How to set CORRECT widescreen resolution for Fallout 2

Discussion in 'Fallout General Modding' started by Magnus, Jun 8, 2017.

  1. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    Hello!

    You've just downloaded Fallout 2 from Steam, and it comes with both sfall and the high resolution patch. What a mess! And they're configured wrong, so the game gets scaled way too far up, people look like ants, the text is unreadable and the windows look all wrong on your widescreen monitor.

    WHAT A MESS!

    So let's fix that. First, open ddraw.ini and set the Graphics mode to 4, and graphicsWidth/Height to 1920x1080. Then open the f2_res_config.exe (the f2res.ini actually does nothing, you need to open this exe), and set the resolution to 960x540. Now start the game, and everything looks as it should.

    See, the reason for all this is that you want to end up with a high-res patch config resolution that's somewhere near the game's original resolution, which is 640x480. Setting the sfall resolution to 1920x1080 means you can safely set the high-res patch resolution to 960x540, and that's basically a widescreen version of 640x480.

    Why can't we have a widescreen resolution for a height of 480 pixels then, so the windows fill the screen completely and you get the experience the developers intended?

    Because 480 * 16/9 is not a whole number! It's 853.3333333, and if you tell the high-res patch to try and render that, you will get what I call the PoopSmear effect, where the text looks horribly smudged and it looks like your monitor is covered in slush ice. Bad. So we need to select a height that has a 16/9 counterpart, and the closest one to 480 is 540.

    Well, technically it's not the closest one, but what's important is that this can be doubled into 1920x1080. Because that 's a resolution your monitor can actually render, and the exact 2x relationship means that the 960x540 image will fit snugly inside your resolution without having to interpolate the pixels. Try with a different Sfall resolution, and you get the PoopSmear effect again. The holy grail is 1920x1080 in ddraw.ini, and 960x540 in the highres-config.
     
    • [Like] [Like] x 2
  2. chieftain486

    chieftain486 War. War never changes...

    Apr 9, 2017
    My personal preference is to set both ddraw.ini and Hi-Res patch to 1280x720. It's exactly 16/9, it shows more space than original, and it looks good enough on 40" screen. :)
     
  3. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    But don't you get annoyed by everything being so small? Personal preference I guess. But yes, that's also an option.
     
  4. Lexx

    Lexx Background Radiant
    Moderator

    Apr 24, 2005
    1280x720px is the best, imo. It still looks true to the original but at the same time... better. I am using 1920x1080px in the mapper, because it makes it easier to create the maps, as you get a better overview of what you're working on.
     
    • [Like] [Like] x 1
  5. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    But the menus are so small! How do you live with that dialogue screen? Is there a mod that scales them up to that size?
     
  6. Lexx

    Lexx Background Radiant
    Moderator

    Apr 24, 2005
    It's not *that* small and it doesn't bother me at all. Scaling it up would just make it more ugly.
     
  7. Graham2077

    Graham2077 It Wandered In From the Wastes

    Sep 16, 2014
    For someone who has a 1366x768 monitor, what would you recommend doing? I've always played 1/2 at that resolution, but I do want to experience them how they were originally intended. I feel like being able to see the entire map at times is not really the way it was supposed to be.
     
  8. gustarballs1983

    gustarballs1983 Look, Ma! Two Heads!

    Oct 28, 2009
    My experience with fallout started on a 15" CRT monitor, and playing HRP 1920x1080 on a monitor with the same resolution just brought back the initial impresion from that time.
    When my 15" monitor burned out, and had to switch to 17" crt, I actually *hated* that pixelated look fallout games had when using biger monitor.


    @Magnus I don't quite understand what do you mean by closest to native resolution. I think You would achive the same with HRP resolution set to monitor native resolution and use separate scaler function to x2 in sfall, although i'm not aware if this function was taken down from most recent sfall, however it was present in RP2.3.3 native (sfall v 3.3).
     
  9. burn

    burn Where'd That 6th Toe Come From?
    Modder

    Apr 22, 2012
    Some screenshots to show the difference might've been helpful.
    I go with 1280x800. Using settings from the first post, the game just dies with application error.
     
  10. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    I always set hi-res patch using windowed mode, so I can resize the window freely.
     
  11. Magnus

    Magnus Weapons Manufacturer Modder

    Dec 6, 2007
    If you use 1280x800 it sounds like you have a 16:10 monitor. In that case it probably can't display the higher 16:9 resolutions. Try these settings instead:

    Sfall - 1920x1200 (and remember graphics mode 4)
    Highres - 960x600

    I'll show you screenshots, but it will have to be in the end of July, I don't have a computer right now.
     
  12. fo2wontwork

    fo2wontwork First time out of the vault

    Oct 16, 2018
    I tried this and it worked great. Then I went and downloaded the restoration pack and I have not been able to get it to work since then. I uninstalled everything and made sure everything was erased completely and tried it again but it will not work.

    I accidentally loaded both the restoration pack and the unofficial patch witch I read later your not supposed to do because the patch is included in the restoration pack.

    Every time I try to put the inputs suggested by OP it says there is an error loading the 960*540. Any other settings and the screen is too small to read anything.

    Also I have my laptop hooked up to a monitor through HDMI which I think causes a lot of sizing problems in general also so not sure if that effects things or not.

    I am running windows 10. I tried messing around with compatibility mode and put it to vista pack 3 but I didn't really know wth I was doing just trying whatever I could but nothing worked.

    Any help would be greatly appreciated I really want to play this game I was just starting to really like it!
     
  13. burn

    burn Where'd That 6th Toe Come From?
    Modder

    Apr 22, 2012
    I think you can leave sfall settings default and just use scale x2 in HRP settings to achieve the same result.
     
  14. Daniel "Dan" Acerbi Rocha

    Daniel "Dan" Acerbi Rocha I AM NOT A SIR! I WORK FOR A LIVING YOU MO-RON!

    Jul 11, 2018
    Does that work for FO1 Fixt as well?
     
  15. miracle.flame

    miracle.flame First time out of the vault

    Oct 26, 2013
    Risen again to provide a short guide to the perfect graphical output deliverable in Fallout 2 nowadays.

    So obviously you need the latest Hi-Res Patch https://falloutmods.fandom.com/wiki/Fallout_2_High_Resolution_Patch
    and the latest Sfall https://sourceforge.net/projects/sfall/
    installed + the custom global shader above.

    edits in ddraw.ini file:
    [Graphics]
    ;Set to 0 for 8 bit fullscreen
    ;Set to 4 for DX9 fullscreen
    ;Set to 5 for DX9 windowed
    ;A DX9 mode is required for any graphics related script extender functions to work (i.e. fullscreen shaders)
    ;Modes 1, 2 and 3 are no longer supported
    Mode=4

    ;If using a DX9 mode, this changes the resolution
    ;The graphics are simply stretched to fit the new window; this does _not_ let you see more of the map
    ;If set to 0, use Fallout's native resolution
    GraphicsWidth=1920
    GraphicsHeight=1080


    edits in f2_res file (be sure to edit the right file, if editing the file within game directory UAC_AWARE=0 must be set in the file):
    GRAPHICS_MODE=2
    SCALE_2X=0
    SCR_WIDTH=960
    SCR_HEIGHT=540


    Edits in Fallout 2\data\shaders\blur.fx
    static const float2 resolution = float2(1920, 1080);

    static const float2 w = float2(1, 0);
    static const float2 h = float2(0, 1);

    static const float blurRadius = 10;
    static const float sigma = blurRadius / 2;
    static const float blurFalloff = 1.0f / (0.1 * sigma * sigma);

    static const float threshold = 0.1f;
    static const float sharpness = 15; (raise this by 5 or 10 if you find the result still too blurry to your tastes)


    The result looks like this (the interface bar is set as IFACE_BAR_MODE=0; IFACE_BAR_SIDE_ART=1; IFACE_BAR_SIDES_ORI=0; IFACE_BAR_WIDTH=680):
     
  16. Buxbaum666

    Buxbaum666 Heterostructured Nanorod oTO Orderite

    Dec 5, 2003
    That looks terrible. Do some people really prefer this smudgy, blurry mess over the original graphics?
     
    • [Rad] [Rad] x 1
  17. miracle.flame

    miracle.flame First time out of the vault

    Oct 26, 2013
    What do you find blurry or smudgy over there? The details are all perfectly sharp, only the strong dithering of the original graphics is cleared out. That's the point of nice picture.
     
  18. Buxbaum666

    Buxbaum666 Heterostructured Nanorod oTO Orderite

    Dec 5, 2003
    Many things look smudgy, which is what happens when you try to filter out dithering - small details will inevitably get lost. It's like trying to remove film grain from movies.
    Some surfaces look like smudges with jagged edges, the blurring makes the aliased edges stand out even more than before.
     
  19. Lexx

    Lexx Background Radiant
    Moderator

    Apr 24, 2005
    I don't find it to be that bad looking. In fact, I'm kinda surprised it isn't the blurry pixelmess that you usually get with them upscaling shader / filter.
     
  20. miracle.flame

    miracle.flame First time out of the vault

    Oct 26, 2013
    So this is the comparison. Raised hand has the shader enabled - sharpness is set to 20.
    Which part do you find more aliased and what is the specific detail you're lacking there? The only detail which is softer is the dither itself which is just a lame way of making impression of detail with limited color pallete. This shader brings more color shades thus no need for the dithered "detail". But please convince me otherwise by referring to specific detail. And what's that nonsense about aliasing? The shader is clearly softening the aliasing as well.

     
    Last edited: Mar 26, 2019