Last Hope mod V1.081

Discussion in 'Fallout General Modding' started by Forgotten Knight, Oct 9, 2006.

What do you like about this mod?

  1. Quests

    0 vote(s)
  2. Locations

    1 vote(s)
  3. Both quests and locations

    7 vote(s)
  4. I'm new to RPG concept, i have no idea what i'm doing but i like it!

    1 vote(s)
  1. Soda_fr

    Soda_fr It Wandered In From the Wastes

    Dec 31, 2009
    Thanks for the tip FK !

    I see what is the problem : on the sublevel, I have killed every gang members as they came out of the barracks :wink: . It results a massive pile
    of corpses in which it's quite difficult to loot.

    I will seek for those dog tags more carefully this evening !

    Again, your mod is very impressive and Im really looking to see more.

  2. Soda_fr

    Soda_fr It Wandered In From the Wastes

    Dec 31, 2009
    Hi Forgotten Knight!

    First, let me tell you that you have done an awesome
    job with this mod. Really. You kept the epic atmosphere
    from the good old fallout and you managed to create interesting
    plot and quests as well as a really good balance game.

    That being said... I went further in your mod and reach Philton /
    Canville, and, well... it seems that many of previous bugs reported on the thread are still there.

    Cubik2k reported on page 9 that he solved the exit grid crash from
    Canville with the "too many items bug". I have experienced it as well.
    I don't know if there is a solution via scripting but if I recall correctly, Killap might have resolved it in the RP. Maybe it would be worth to see if something can be done...

    I have uploaded few screenshots of the bugs I went through and a saved game (as I said, most of them have already
    been reported). I hope it will be of a little help. Screenshots.rar

    Now i'am kinda stuck in Philton / Canville because of the bugs (If I have understood correctly resolving quests improve your reputation and trigger new quests, so bugs in quests = stuck in game? right ?)

    So for now, I will wait for LH1.06 hoping it will be compatible with my saved games. But if they are not, I won't mind begin a new game as soon as LH1.06 will be out (... cause it will be out... someday, right ?)

    Now I have two ingame questions :

    [spoiler:a9a05c841c]in Golden Valley, in military base, im asked to find a water ship (noooo, not again! ;) I have seen nowhere I could find one... Any tip ?[/spoiler:a9a05c841c]

    [spoiler:a9a05c841c]i have reached the shelter location. Scott asked me to return to the prison in wasteland
    forest and find a weak point in security. How would I do that ? Note that the 4 month deadline
    is over (I have tried to speak to the monk in charge and I ended up in jail).[/spoiler:a9a05c841c]

    Anyway, I am *really* looking forward to see your future work ! On that point, you have posted on
    your website new screenshots (in february). Will it be for ... a LH extension pack ? LH2 ? or a new
    project that needs to be kept secret for now ?

  3. NFSlugger13

    NFSlugger13 First time out of the vault

    May 11, 2010
    FK, although you say there is no problem with the prison guard and the forcefield, I'll have to disagree.

    I have received clearance to go to the next town (and return in 4 months), but the force field will not go away. The guard will ask me if I want to leave, and will then go to open the gate. However, no matter how many times I ask, he'll just walk up to the screen and press the buttons -- but nothing will happen. He just goes through the motions while the gate stays in place.
  4. Tihi

    Tihi First time out of the vault

    Jul 4, 2008
    try few times, it will work eventually :D

    i have problem with military base in golden valley

    [spoiler:92075ed079]though i've got the key card from bridge guard i cannot enter the base. is there other way maybe?[/spoiler:92075ed079]
  5. Ardent

    Ardent A Smooth-Skin

    Jul 24, 2009
    I haven't played Last Hope, but from what you described and from my own experience with scripting forcefields, I'm inferring what mechanic could have been used to turn it off. When the guard has finished his motions, try entering PipBoy and turning it off again. This may help :-)
  6. Tihi

    Tihi First time out of the vault

    Jul 4, 2008
    for me it worked fifth or sixth time, you just have to try few times.

    but how can you escape prison... [spoiler:f7011fd8c6]...after you've been captured by patrol? i've killed everyone, have papers from gate guard but cannot get out. pls help[/spoiler:f7011fd8c6]
  7. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    Here it is, version 1.06 is up. :clap:
    List of changes:

    Version 1.06
    -Canville mine entrance guard script fixed, he'll notice if player tries to use the elevator
    -Canville citizen script corrected. "Error" floating messages were caused by another script calling the same text lines 
    -Canville parking Loner script corrected, wrong town rep. GVAR
    -Canville, 3 scavengers on canville traion station caused game to crash when spoken to, corrected
    -Joes store house key, added "use" action flag
    -Philton bulletin board had "Duntown" name written in it, corrected
    -lockers, in north west corner of farmers town residental area, moved to their owners and protected from looting
    -Miners town cave entrance, now possible to clear the pile of rocks blocking the entrance without taking the "mantis raids" mission 
    -when you ask dr.travis "...about the mine...", dialog closes, corrected  
    -reported: infinite xp (+1500 every time) when killing Basil's gang and report back to sheriff, this was possible due to game bug with 0 key, corrected for the current script
    -Bio research base turrets will behave as they should
    -Golden valley meeting now held at local library
    -edited military base guard script (Golden valley), added aditional dialog line so player is not forced to leave the base every second time he talks to the guard, the guard will also remove id card from players inventory if caught stealing 
    -Military base seargent will get "angry" if player doesn't wear any type of metal armor (mark1 or mark2) 
    -after 15 MAR 2322 Arroyo will not appear on the world map and Wasteland Forest will reappear on the same place 
    -Ron will not give you the same job twice. 
    -Greg from Canville will now take the ore from you if you tell him about the job 
    -"coffin guy" has proper script attached to him
    -Robert, "FORM" member can sometimes block the doorway if player decides to go on a killing spree, now "push" procedure added   
    -random encounter Hubologist object_pid name corrected to "Prison patrolman" 
    -Wasteland prison laser gate computer can be used to temporary disable the forcefield
    -Wasteland prison forcefield can be temporary disabled with nearby explosive charge
    -Philton boxing match now possible
    Majority of these changes is compatible with older saved games and most of them are script changes because i also tried to fix some map related errors by scripts (where possible). Some errors were caused by "too many items bug"(i didn't do anything about this yet). :ugly: :zzz:
    I can't be sure about high resolution mod/patch but i've seen bad things happen where player can reach and loot containers which were offscreen in 640x480 res :locked: , awful map edges :freak: , buildings scenery cut on half :wtf: . I could optimize maps for higher resolution in next version but for now i'm firmly focused and only on LH mod :lalala: . So, i wouldn't consider as a bug something(map looks for example) which is related to high resolution mod/patch :spamfromabove: .
    But keep you hands off those shiny footlockers! :mrgreen:


    A short explanation about "Golden valley meeting now held at local library", it's half done because it required some major map editing, but watchable :hide: .
  8. JaW

    JaW Still Mildly Glowing

    Oct 1, 2006
    Wow, it is good to see that you still polishing up this great mod, FK :clap:

    Yes, please do it. High Res Patch is a must have for most of the players in these days.
  9. Soda_fr

    Soda_fr It Wandered In From the Wastes

    Dec 31, 2009
    Wow, FK you work fast and in the shadows!

    I didn't expect a new version so quickly, you really deliver!

    I'm downloading it right now... but won't be able to load my
    save games until 15 days. I might start a new game though :D

    I second JaW about the high res patch, I just can't play without
    it right now... but I promise not to loot the storage footlockers on
    the map edges, I was just pointing them out :wink:

    Anyway thanks and keep up the good work!

  10. Tom9k

    Tom9k Look, Ma! Two Heads!

    Dec 21, 2007
    Uhm, is there any way to get PipBoy?

    Edit: Got it after 10 seconds.... nvm then :)
  11. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Hi, Forgotten Knight,
    this is one of the best mods i have played, thank you. Gameplay is fairly tough and highly addictive!
    After my first steps, i've noticed some small issues (v1.6):

    [spoiler:411b0e6b59]- sheriff in the Golden Valley gave me 1500 XP (for Mr. Basil's quest) repeatedly.
    - bridge guard in the Golden Valley says, so the military base is EAST from town. Man, i'm not good in english, but military base is in the west part of town, isn't? :)
    - in the GV library, if you fiddle with computer, there is dialog: "..after few hours of reading blah blah". But my old PipBoy displays only few minutes passed here. :- )[/spoiler:411b0e6b59]
    Keep your great work up!
  12. Tom9k

    Tom9k Look, Ma! Two Heads!

    Dec 21, 2007
    So, few problem I have got:

    1. Gatekeeper at Wasteland Forest is kinda unreliable - if you ask him to open the gate, he can go there and do nothing OR he can just stay on his place where he was at the time you left map. Then you might have only way back impossible.

    2. Lost City - Can't find the way to open that door. I tried to use TNT (I saw one behind the fence, so that's why), but no use.

    3. About that air purifier in GV - I managed to get that part from the machine but Clark has still only floating text, so he won't send me to FT to repair it.

    4. How can I find some proof that Mr. Basil is holding prisoners?

    5. I am on quest to find who robed Jack - found that holy monk, he gave me location of that small village, but there I have found no more clue about them.

    6. UMB - any way to repair power generator computer? Tried junk, but no effect :(

    That's all for now, this is great mod - very exciting all time.
  13. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Hey Forgotten Knight,
    I just played LH 1.06 few days ago, it's pretty nice as a real TC. Great work! :D

    I got some questions though:
    1. I'd like to know what differences you made are between LH's exe and official 1.02d exe. Is sfall a crucial component for LH? If yes, are you going to upgrade its version? I'm using 2.7 standard version now for LH.
    2. As Tom9k said above, Gatekeeper at Wasteland Forest is pretty unreliable, I have to cheat some dynamites in my inventory to blow the forcefield to get me back in.
    3. Farmer's Community - After I finished Jack's robbery quest, leave the map and come back, I found that I can't talk to Jack anymore, not even a float text.
    4. Golden Valley - I got some random crash when I try "talking" to generic residents.
    5. Golden Valley - The only way I found to solve Mr. Basil's slavery operation is to enter the combat mode to get me down the manhole. Is this the only way?
    6. Still GV - When the exactly time is the meeting held? I wait there for a week (try to sleep till 20:00 every day) but it didn't happen.
    7. GV & UMB - When I entered the locations first time, I found myself in the middle of the maps. I thought I should be near the exit grid/entrance.
    8. After I finished missions in Farmer's, the only new location on my map is UMB, but I can't get any mission in UMB (and can't enter the north building with ladder down). I have to wander in the wasteland to find some new locations like Golden Valley. I think it would be better if you can provide more hints or certain locations via NPCs in early towns.
    9. The sprite of 10mm pistol C67 is as the same as normal 10mm pistol, it should be "10mmap2.frm" I think. And after I asked GV weapon shop owner to "buy" (or upgrade?) C67, I found all normal 10mm pistols in my inventory are gone, he should take only one pistol.
    10. Is it intentional that shops don't restock? BTW, Gas Station owner in Farmer's sell fuel cell controller/regulator for free.
    11. Canville - get trapped in the downtown, everytime I try to leave the map, the game crashes. And I don't see my armored truck near the north exit. :(
    12. Not a gameplay related question, but which real-life region is LH world in? Or is it a purely fictional region?
    Sorry for so many questions. I really enjoyed this mod. :clap:
  14. earthdude

    earthdude First time out of the vault

    May 11, 2008
    I have attempted to play through the new version (1.06).

    1. Clicking on the man in the shop(?) just north of where you appear for the first time in Golden Valley causes my game to crash. This occurred in previous versions as well.
    2. Philton tire quest still cannot be completed.
    3. I like the boxing match[spoiler:2127a752d3], but perhaps a warning as to the consequences of going too far might be in order.[/spoiler:2127a752d3]
    4. My game starts to bog down on entering new maps about halfway through exploring Philton. Initially, saving, quitting and restarting the game worked, but it still got worse. In Canville, I can wait 10 minutes or more for it to load a new map. I don't think this is the too many scripts bug as I've used the fixer program to no avail, but that program wasn't built specifically with LH in mind.
    Anyways, it is now unplayable as a result.

    Thanks for continuing to support this overall excellent mod.
  15. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Alas, i'm trapped in the Canville, due to some gamekiller bug. Game crashes everytime, when i step on the exit grids. (v1.06) :help:

    [spoiler:ab3f1c41aa]..also, small tent is on this map. Loner, who lives here, has exactly same dialog assigned, like one of hospital guards. Both of this dialogues leads to gamecrash.[/spoiler:ab3f1c41aa]
  16. horsedog

    horsedog First time out of the vault

    Jan 5, 2011
    game crashes


    when I finish the "temple of trials" or however you call it, I win the unarmed fight, then the guard gives me the knife and when I try to use it, the game crashes...
    what should I do? am I using wrong version of fallout?
    I downloaded version 1.0 and followed the instructions... :(
  17. horsedog

    horsedog First time out of the vault

    Jan 5, 2011
    I already found the answer to my question in this thread, it happened because I am playing female character...
  18. random1

    random1 First time out of the vault

    Dec 7, 2010
    Hate to be a combo breaker here, but could someone (maybe TK :)) write a paragraph or two about this mod. The first page of this thread has nothing and the same goes for the official website.
    Info on the story and an idea of what the contents are (how many new locations, NPCs, dialogs, etc).
    *hints at falloutmods wikia*
  19. Cerber

    Cerber First time out of the vault

    Dec 30, 2009

    I`m playing v 1.06 strarting from philton game slows down, loading new locations takes few minutes - this is breaking the game :(
  20. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Re: 1.06

    For now this mod is pretty much uncompletable. From Philton the game slows down even hangs up. And Canville is a crash-fest.