Any stuff related to unofficial F2 patches goes in here!

Discussion in 'Fallout General Modding' started by Per, Mar 20, 2005.

Thread Status:
Not open for further replies.
  1. Nikki

    Nikki First time out of the vault

    May 13, 2004
    Nice killap.
    Will you tell us when will be your "new final" FO2 patch released?

    And do you reply PMs?
    Cause I sent you one and you did't answer yet :(
  2. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    When its ready. ;) No seriously...if it isn't done by the end of next week I gonna be mad. With each passing day the bug list diminishes. I hope to cram as much as I can into this release since after this one I highly doubt I shall do another. I know I always claim this but I think I am going to put my foot down this time. 8) If there will be another release after this one it shall ONLY be for critical issues (ie crash bugs, quest bugs, game stopping bugs, or errors on my part.)

    :D Yes, I do and I apologize to everyone who I take forever to respond to. I have a nasty habit of reading pms as soon as I get them (I get an e-mail about it) and putting them aside to respond to later. Of course I always forget to come back to them. In addition I have been busy looking at new housing options for the coming years. I shall get to pms soon enough. :)
  3. boer_kameel

    boer_kameel Still Mildly Glowing

    Apr 2, 2003
    Did you finish school now then? I saw you mention that you're looking for a place to live... Any idea on what job to take?
    "rpg game dev" would sure sound nice ;-)

    Ahh, sounds familiar... Really!
    So many things to do, but time management is a real pain in the ass.
    Quite absurd that you have to juggle with time, to fix a RPG set in an anarchistic setting (with no timeframe), if you come to think of it...

    Good question, that's why I reffed to it by "a fix". Was thinking about looking in to that yesterday, then my gf called for a 2h talk. *sigh* Well, next time I guess ^_^

    The patch itself is no problem! Although I don't have that many posts, well, I've been around here since about 2001 (contrary to what my profile says). I know where the downloads is ;-)

    It's the searching of information that's become hard. Your info is scattered over a few posts. Also, this post doesn't really reveal too much about it's content - but these things usually have a historical reason.

    Seeing that these posts started 3y ago, it's no wonder that it's scattered like this. For the forum regulars this all makes sense (they've been closely watching it all this time), a noob or returnee needs to read for about a week until he knows what's where ;-)

    FYI: This is no rant towards the admins at all, you're already very strict about what to post where around here! And it should be like that. Knowledge is power. Misinformation and unstructured information are violations to our gaining of power ^_^
  4. Good Soup

    Good Soup First time out of the vault

    Jun 4, 2007
    Hello there, I ran across this thread a couple days ago and was pretty exicted to hear Killap's working on very last and final patch. Lots of bugs fixed, there's no doubt about it. I ran across one in particular. at least, I THINK it's a bug.

    It involves Skeeter at Gecko. He is supposed to give me a quest to get his plasma transformer, but I never got it from him. And yes, I already did give him his toolkit. Granted, I stole it back, but I've stolen it before on other games and he's still given me his next quest. Then I exited Gecko and remembered I haven't done that quest yet. So I went back to him, and he won't give me the quest. Just goes on about how I fixed the powerplant.
  5. heodien

    heodien It Wandered In From the Wastes

    May 22, 2006
    You must have some items for upgrade first.
    Like a hunting rifle or a Magnum
  6. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Nah, I still have 2 more years...maybe more depending on how I feel. :D

    Heodien is right. You must have any or all of the following: magnum, desert eagle, hunting rifle, assault rifle, fn fal, or cattle prod in your inventory at the right moment in dialog to get that quest. Seems odd on the part of the programmers but then again those are the only guns he can upgrade and that is how he repays you in the end for doing the quest.

    On another note, completion of the patch is at hand. I have less than 5 minor issues to look into today and then I can do some quick play tests to make sure everything is working as it should. I am hoping to have a release of tomorrow (to coincide with the release of the F3 teaser). If the teaser proves to be a disaster than hopefully an update to F2 will bring a smile to everyone's faces. Once this patch is out the door this means that the expansion is next on my list and I shall be pumping out scripts, etc for that. Stay tuned. 8)

    All issues I plan on fixing are complete. I am compiling the patch and getting ready for a quick playthrough. After this comes the readme file which will take some time to write up. (I have to add the new additions, make some modifications, etc)
  7. Nikki

    Nikki First time out of the vault

    May 13, 2004
    Glad to hear, glad to hear!
    And may I kindly ask you to answer me to my PM?
  8. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Release time everyone!

    Well, it's been months since my previous release but I've still been hacking away at Fallout 2 and the bug reports keep coming in. This is a pretty hefty update and I pushed myself to have it ready on the same day as the F3 teaser. Thus if the video flops, we can always turn back to good ol' Fallout 2.

    In addition to more fixes, I have also decided to make a UK version of my patch. This patch comes with the 1.02 UK exe as well as the Children's patch. The only fix that is not included in the UK version is the sharpshooter perk fix. This is an .exe fix and the patcher I was given my ravachol does not update non US exes. I am not able to fully test this UK version so if someone could confirm it working (or not working) I would appreciate that.

    This looks like it shall be my last F2 patch. I have put a lot of work in this patch and I think I have done all I can. There are several engine bugs which I can never fix without the source code but other than that I really have a hard time finding any other major bugs (sure there will always be minor issues here and there). If there will be another patch, it will only be for critical issues. Thus, if you come across any crash bugs, quests bugs, errors I personally introduced, things I claim that are fixed but still appear broken, or other critical issues, then I shall address them. Other minor issues such as typos will not be addressed. Enjoy everyone!!

    Before I let you all jump to the downloads, I wish to make you aware of the following addition:

    •If you run out of gas on a town circle, entering the town will make make your appear so you can refuel. Thus, no longer should you lose your car by running out of fuel over a town circle. 
    This is a pretty cool fix and I have not noticed any issues with it. I personally never ran into the above issue, but others have so I went ahead and wrote up code to prevent the car from disappearing. Let me know how it works.

    Here are the links for the downloads: (They should also appear in the files section within the next few days)

    US - version A (includes 1.02 fixes)

    US - version B (doesn't include 1.02 fixes)

    UK - version A (includes 1.02 fixes and Children's patch)

    UK - version B (doesn't includes 1.02 fixes but does include Children's patch)

    Full list of fixes:

    Below is a list of fixes since my last release.

    Fixes since Nov 2006.
    Corrections to my personal changes:
    •You can no longer heal the sheriff's leg. It doesn't make sense since it conflicts with his dialog and the purpose of you helping him with tasks. Plus the doctor said all he needed was rest and that the leg was already looked at and all that is needed is time to heal. Since you also cannot heal Cookie in Navarro this change back to the original setting makes sense.
    •Continued to tweak the San Fran fights. I think I got it this time. I played through the matches 3 times and never got stuck.
    •Fire Geckos in the "Toxic Waste" special encounter no longer carry Sam Pritchard's map instead of a fire gecko skin.
    •Chuck is now removed when he is fleeing and you exit the Broken Hills mine.
       *Before he would stay where he last ran to and only continue moving when you re-enter the cave.
    •Randal in the Amenities office no longer forgets he scanned your fake citizenship papers.
    •Completely rewrote Merk's travel code. He never gets stuck, he is always present when he should, and his bodyguards are always there when he is.
    •Digging up Sam Pritchard's grave now yields the map. (before it said you got a map but a map never showed up) 
       *Pritchard's grave can now be looted like all other graves. This was not possible before.
    •The dialog line "Thank you for your help." was incorrectly labeled as a "Bad" response.
    •Buck Dunton no longer gets angry at you when you call him Buck
    •It was impossible to obtain XP for freeing Sulik through Maida's dialogue. This is no longer the case.
       *Also possible to get XP for freeing Sulik through the quest. 
    •After saving Vic, if you talk to him with having a full party, he says that he'll wait for you at Mom's but he would never leave the room. This has been corrected.
    •Unlocked dialog float when Vic enters his house in Klamath (this was unobtainable before due to 1 missing line of code.)
    •After attempting to steal from you the orphans' animations would appear to become stuck. This would cause them to appear to not have death animations if you killed them when they are in this state. This has been corrected.
    •Altered dialog of Caravan "castle" guy to greater clarify when the caravans arrive.
    New Reno
    •Boxing fixes:
      *It no longer says you beat the masticator if you fight and defeat his replacement
      *Camera now centers on the announcer when the match first begins (no longer is the opponent outside of view)
      *Stuart Little no longer disappears when you lose against the Masticator and tell Stuart you want to rest before fighting again.
      *After becoming prize fighter (defeating all the boxers) it now says you become "Heavyweight champion of New Reno" This line of dialog was never being displayed before.
    •If you enter New Reno via Commercial Row you will start in the upper left corner while your car is in the lower right. The same thing happens in the east side of The Den. Both instances have been corrected.
    •Lil Jesus no longer chastises your Melee skill if it is extremely high (295+)
    •Bishop's guards at the bottom of the stairs now recognize you if you are doing quests for Bishop.
    •Tweaked Bishop's safe so it no longer says ("you cannot repair") when you change the combination or ("you find no traps") when you do indeed find and disarm traps.
    •It is no longer possible to tell Mason you solved the Llyod situation before ever speaking with Llyod.
    •Fixed message error when damaging Wright's still. There was a duplicate line which could potentially cause a crash. In addition, the line that you destroyed the Wright still was never being displayed.
    •When digging up the ghoul on Gologotha, there is some grey text which goes by too quickly to read. This text was actually part of the float he gives before you dig him up and thus was not supposed to be displayed anywhere. This has been fixed.
    •Going down Llyod's hole by means other than dialog would cause your NPCs not to follow you down the hole.
    •Talking with a patrolling slaver guard in NCR from behind the fence no longer causes him to think you are trespassing.
    •Threatening Dr. Henry in NCR and failing a speech check now causes guards to come running. This was broken before.
    •The policeman who opens the door to Oswald no longer gets stuck in certain cases.
       *Added dialog for dumb characters to speak with Oswald (dumb characters have the option to speak with him, yet this is impossible since dumb characters can never get dialog with Karl to see Oswald)
       *Fixed bug where dumb character would talk with him and if party members were not present, Karl would refer to them.
    •Doofus in NCR is no longer named Skeeter when you hit the review button.
    •Vortis will no longer get stuck in his room or on the way to his room.
       *Added dialog line when you speak with him when he was on his way to the back room. He would attack you if you talked claiming you are breaking in the back room even though you are talking with him in the main room. Now he will tell you to come back in the morning if you talk with him as he moves to the back room. Once he hits the back room (and you enter it) he will yell at you and call for guards like he did before.
    •The overseer at the Slave place in NCR will no longer attack you when he is in the main room. He will only attack when he is in the back room and you try to enter it.
    Sierra Army Depot
    •If you release one of the viruses in the SAD the game says you have 4 minutes to evacuate but the game kills you after only 1 minute. This is no longer the case. The original intent was that you have a minute per level of the SAD to evacuate. Thus 1 minute to exit level 4 before dieing, 1 minute for level 3, etc.
       *Fixed a message error that caused an incorrect line to be displayed when you hit the end of the timer.
    Vault City
    •The Raider's account book is now removed from your inventory after you show it to Lynette in Vault City.
    •It should no longer be possible to lose the back end of your car by leaving it at the gate, going to another town, saving/loading and returning to Vault City.
    •Lumpy and the dogs in Gecko now evacuate the location after the reactor blows. The lacked the code to do so before.
    Vault 15
    •Fixed glitch with the forcefield in the Vault that made it impossible to disable.
    •Guarding the Brahmin now has a Pipboy entry.
    •Brahmin no longer get stuck in the pen when you let them escape.
    •Fixed bug where Bess would get outside the gates, but not off the map which wouldn't trigger the reputation and karma change.
    •When hanging around the locker, it no longer says you "received the k-9 motivator" when you are carrying the FOB
    •The quartermaster in Navarro, now correctly directs you to the Power Armor locker. Before he would just keep telling you to come back later. A very dumb bug caused this to occur.
    •It was possible to get stuck in combat even when you were not in view of anyone/anything.
    •It was possible for dialog to end with Cookie and then reopen again without the intent of the player.
    •Chris now carries a radio with him. (since he uses it to call for help)
    •If you Super Stim the Navarro Commander to death and then tell the guard outside you're there to clean the commander's room or retrieve the FOB the guard speaks to the dead commander to inform him of this. Some code was added to check that the commander is alive and thus act accordingly.
    •Fixing K-9 as an evil character caused two floating text lines to appear right on top of each other after dialog ended, making both impossible to read. This is no longer the case.
    San Fran
    •There is now a greeting text when you enter.
    •If you happen to have both the quest to kill the Emperor and AHS-9 active, completing one will automatically cause the other to be crossed out (failure - since you become the enemy of the other side now)
    •Slowed down the floating text over AHS-7's head when he gives you a zeta scan. It was almost impossible to read before.
    •Peasants no longer move about (thus use turns) while you fight in the ring.
    •If you get the hardened armor from Crocket but remove it from your inventory and speak with Dr. Jing again, you could reinitiate dialog and get the quest all over again.
    •Bartering is disallowed for Festus in Gecko.
    •Fixed some issues with Marcus and how he goes hostile if attacked.
    •Corrections to even more typo and grammar mistakes
    •If Cassidy dies (before he is recruited) his bar would never close and would continue to operate without him. This is no longer the case.
    •Lone Traveler had a missing dialog line when critter gives directions.
    •When you encounter "Holy People" combat could never end until everyone is dead (even if you were out of view)
       *They now have descriptions when you 'look at' them.
    •If you run out of gas on a town circle, entering the town will make make your appear so you can refuel. Thus, no longer should you lose your car by running out of fuel over a town circle.
    •Slaver and Marauder random encounters will now have NPCs which are able to use the HK Caws that are given to them. Before they used models which could not fire the guns.
    •Wild Brahmin encounters modified: Now wild brahmin scripts will do stuff (ie "mooo", wander around, etc) Before the script for wild brahmin had nothing in it and thus the brahmin would stand around and do absolutely nothing.
    •Merchant Guards from Den Caravan's are no longer acting independent of their master. 
       *Hopefully this should also fix up issues with encounters of Den caravans fighting other caravans.
    •It is no longer possible to slide off the map when the Big Stone head kills you.

    HIPPOPOTAMUS First time out of the vault

    Jun 3, 2007
    I'm assuming it's against the rules to make a new topic about this so here goes..

    This post is for Fallout 2 and using this patch: killap's Fallout 1.02+ US Only Patch - Version A

    Here is my save game:

    This is my first time playing the game and it's pretty much the greatest thing ever but I believe I just owned myself. As you can see in the save game, I lock picked the door in Becky's Bar after waiting for the guard to move and went down. I have two party members, Lenny and Cassidy. The problem is that when I go back up the stairs, I can't go through the door because both NPCs are blocking it. I've tried everything.. including leaving one of them down there and trying to go through just with one. I don't want to lose these guys. I have another save from about 2 game weeks before this one but I've made a lot of progress since then, including finding some sort of Federal Shuttle random encounter that gave me a high-tech 'Phazer' weapon and some injections. Probably some other gear, too. Can anyone help me out here? If there's no way through the door, is there a method to transfer some of the iutems like the Phazer to save game #2?

    I've uploaded save #2 also:

    Thanks for any help
  10. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Have you tried pushing your NPCs? Hold down left mouse button over NPC and use the push command.

    Note to everyone: See above HIPPOPOTAMUS's post for my latest release! :)
  11. Unkillable Cat

    Unkillable Cat Mildly Dipped

    Jan 5, 2004

  12. MoonScar119

    MoonScar119 First time out of the vault

    Sep 14, 2006
    just curious..... but is the "too many items glitch" one of the engine bugs you can't fix without the source?

    and if i have your patch installed (from back on page 70).... can i use the new patch and not lose my games?
  13. Unkillable Cat

    Unkillable Cat Mildly Dipped

    Jan 5, 2004

    killap - do you fix typos in your readme? :P

  14. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Heh, yeah that I do. :D Damn, I hate writing up readme files at 3 am. Oh well, I shall fix those.

    Oh and I forgot to mention that I added a rock to the opening map in the Temple of Trials. The rock is behind Klint and will give information about the version of the patch you are running. If you don't see a rock then something went wrong with installing the patch.

    And all saves from the last version of my patch are fully compatible.
  15. Nikki

    Nikki First time out of the vault

    May 13, 2004
    Brilliant, just perfect.

    I would like to thank you for tremendous job done.
  16. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Thanks for the kind words.

    Patches are currently being uploaded again to fix a few typos in my readme files. They should all be back up in about 5 minutes after the post time of this message.

    EDIT: All files are up again. Enjoy!

    EDIT 2:

    For those curious, here is a list of bugs still present in the game that I am unable to fix. (engine issues)

    1. The too many items bug.  
    2. The Pathfinder perk appears to be slightly bugged: the first level will cut 20% of travelling time (not 25%), while the second level doesn't seem to do anything at all. 
    3. Main computer in Vault City Vault is supposed to raise your electrical damage if you have int. less than 4.  Does not work though. 
    4. Myron - Once you dig up the secret stash at Golgotha, he'll promise to carry more stuff instead (apparently this was supposed to raise his Carry Weight by 10, but it doesn't work). Same issue as the comp in Vault City Vault. 
    5. Chicken coup door in Modoc still shifts off the hinges (only when you blow up the outhouse.) 
    6. Some of the broad shelves still have that bug with picking up half of the shelf itself. 
    7. Some of the special encounter names at first don't show up. You have to revisit them for the name to refresh.
  17. Unkillable Cat

    Unkillable Cat Mildly Dipped

    Jan 5, 2004
    Outstanding. Now Per will have an entirely legit reason to replay the game all over again for the zillionth time.
  18. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Heh, actually I am also going to refer to him in my expansion pack. It will be an easter egg of sort.
  19. Per

    Per Vault Consort Staff Member Admin

    Apr 1, 2004
    ... Or Chuck when you call him Chuck.

    Why not make the limit 100% since that's in line with what he has himself? Or maybe say 125% for vanity.


    Did you fix "site for sore eyes" in Vic's new line?

    If you really wanted to make me happy, you could probably convert my rock hunting map into a special encounter, adding new scripts for the floats and a script to detect when you've put all the Rocks in the box. Hmm... maybe some new special rock item, so you can't just bring them from elsewhere...
  20. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I think that was also something I fixed. I would have to go back and check. I know for sure that Buck had this problem, I don't remember if Chuck did as well.

    Well I chose 295 since I didn't want to remove the opportunity for the player to raise his/her skill in melee. Since the original devs never set a skill max on learning from him I just went ahead and made it 296 since he gives you +5 in Melee.

    Ah, nope missed that. I guess when I read that line I was assuming "site" meant the location. Dumb me.

    Wow, I didn't know you had a rock collecting map. I just downloaded it and quickly tested it out. It's pretty fun. I shall definitely include it in my expansion. It may not be a special encounter (though it could) but rather you find the location through other means.

    Just updated the patch again. If you downloaded it before today, June 6, please do so again. I made some minor corrections as well as fixed a dialog error I found in several scripts. Below are the changes.

    June 6, 2007:
    -Corrected an error in 12 scripts which caused text in the message window to not be displayed. Crashes are also possible (either game crashes or the script goes dead) in these cases, though not guaranteed. The majority of these scripts came from the Vertibird transaction with the Salvatores.
    -Corrected typo in Vic's script when he enters his house in Klamath.
    -Removed debug message (left in by me) when you let Lloyd go (peacefully).
    -Corrected a few more typos in my readme.
Thread Status:
Not open for further replies.