Fallout 2 Restoration Project 2.1.2b (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Sep 18, 2010.

Thread Status:
Not open for further replies.
  1. unacceptable

    unacceptable First time out of the vault

    21
    Sep 19, 2010
    I did include this link in my post, describing my last installation attempt in detail: http://www.nma-fallout.com/forum/viewtopic.php?p=812117#812117

    That did not work out very well. Maybe it was something wrong with one of my discs (tried the older one of my discs this time), but I certainly followed recommended procedure regarding RP. I now have a working game, and noted one (1) persistent bug with the multiple subsequent encounters on world map while traveling by car. This bug have occurred in both of my two recent installations, the one that was done by the book (but did not work) and the one I tried when the recommended way didn't work (which does work a lot better, for reasons currently unknown).

    I am sorry for not being able to determine what went wrong when I followed the recommended procedure.
     
  2. Michi

    Michi First time out of the vault

    60
    Dec 7, 2009
    I noticed a small bug with 2.1.2b

    In the quest chain to clear the village near Vault City of rats....

    I spoke with the Stark, then went to village, then back to VC to speak with Joe, then to councilman, then to Brain, then back to councilman - got xp.

    When I go back to village, the guy there is still asking me when I am bringing the weapons, although all the villagers are saying thank you for saving us.

    Just a small issue...
     
  3. agris

    agris Still Mildly Glowing

    245
    Jul 8, 2004
    Ok, I removed my bug post from the wiki. The combat armor is there. I don't know how / why I missed it my last play through, but that's irrelevant.

    I have noticed, in my current game AND last one, that Kaga never runs away completely. When fleeing, he moves 10 - 15 hexes one direction and just stops, despite my continued attacks. It seems like at least one other person has run into this- anyone else? I just assumed it was how the Kaga encounter was scripted. Even if that is the case, it is less than believable.
     
  4. snaphat

    snaphat First time out of the vault

    5
    Mar 9, 2008
    Yeah, he does that for me also. I didn't care enough to post, but I suppose it is a bug.
     
  5. utunnels

    utunnels First time out of the vault

    74
    Aug 2, 2010
    Kaga and the Mysterious stranger don't need to run out of the map to 'escape'.

    Actually they both try to move outside your sight range (current screen) they disappear. But sometimes if you scroll the screen position or use a higher resolution, strange thing just happen.
     
  6. Dravean

    Dravean Where'd That 6th Toe Come From?

    478
    Mar 6, 2005
    It's always happened to me as well.
     
  7. Glovz

    Glovz Vault Dweller
    Modder

    737
    Sep 16, 2005
    Is it possible via script to have the critters removed from the map upon "escape"?

    Might not be worth the trouble. :shrug:
     
  8. snaphat

    snaphat First time out of the vault

    5
    Mar 9, 2008
    Yeah, it is actually probably that. He doesn't disappear because he never gets out of screen range.
     
  9. ebbpp

    ebbpp First time out of the vault

    53
    Sep 8, 2010
    Got new one-you cannot hit fire gecko with spiked knuckles or the game just missing the animation-I'll send a savegame ASAP.

    Edit: And another one-on one of the encounters I couldn't access my car's trunk-like higher I'll send savegame ASAP.
     
  10. BrecMadak

    BrecMadak First time out of the vault

    93
    Jul 5, 2010
    here is the kaga encounter that most of the players' headache i just countered. There is something doesnt working right as i get the same error every time 100%. I even restarted my pc, but didnt work either. As soon as you want to load this save it throws you out to windows and says;



    and my save.
     
  11. Darek

    Darek is currently unavailable

    Jan 7, 2008
    It's actually very simple, just need to add a little something to the combat procedure. Maybe the whole thing should be tidied up a bit at the same time. I thought the way it was written looked a bit peculiar.

    @ BrecMadak,
    That is one of the reasons why you shouldn't save your game while in combat. It's gotten corrupted and no matter how many times you try it will never load. As far as I could tell it had something to do with critters. Only if I removed all of them (including dead ones) did the map become playable again.

    @ killap,
    From that save I saw that one of Kaga's compadres had a plasma pistol, even though she don't have the art for pistols. It was one of them females in metal armor. Is this something that could be a bigger problem?
     
  12. Dravean

    Dravean Where'd That 6th Toe Come From?

    478
    Mar 6, 2005
    Derek, I heart you and your Fallout detective skills.

    Just saying.
     
  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yeah, I should probably rewrite Kaga. He's one of the first scripts I wrote for the RP 2+ years ago and how he acts now differs greatly from how I initially wrote him. He is much more correct, but his script is riddled with old code which isn't playing well.

    I second this.
     
  14. memetics

    memetics ☢ Mysterious Stranger ☢

    214
    Jan 2, 2009
    Correct: vanilla install with 2.1.2b default windows installer install. I haven't posted this to the bug wiki b/c I didn't have enough specific info. yet, but due to the nature of the bug, it may be necessary for someone to test each encounter map separately, perhaps by temporarily rigging the encounter table to only call one specific encounter map, and testing the maps one at a time. Or something like that. :| [Edit: but please don't waste time testing that until we have more data confirming / localizing the bug.]

    Not sure what you mean; I also posted bug reports on the wiki site. (Maybe you were there right after I posted to NMA but before I posted to wikia ... in which case: patience, Daniel-San!) I put reports and save games on the wiki - for all of the issues I mentioned here except the encounter freeze-up issue, for the reasons mentioned above.

    Anyway, I hope to have more time to test this weekend; for now, I'm too tied up with work. (If only testing and modding could be my paying job!)

    m-
     
  15. DrapiChrust

    DrapiChrust First time out of the vault

    30
    Nov 26, 2009
    A little bug: Highwaymen don't use the jet they are carrying anymore. In the vanilla they were doping themselves at the very beginning of their first turn in combat.

    I read a bit about the bugs on wikia. If I could add:

    1. The problem with disappearing followers in the Bishop's house - they won't disappear if you don't save&load while being upstairs with either of the women. The game remembers them to be waiting on the floor below, but the savegame does only contain the info that there is none of them by you.

    1b. - the problem with skynet disappearing when he stays behind - the same as above, for some reason savegames do not contain any info WHERE are those followers added to the team who are not on the same map as the PC - just don't save&load. I don't believe that something can be done about it

    2. About freezing when having sex with Miria - it's because one of the NPCs stands on the tile in which her father is supposed to spawn. I is usual if you have two or more companions on 'stay close to me'. A vanilla stuff. Just make sure nobody except the PC and Miria is in the room - it will work fine.
     
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Well, since this hasn't been confirmed on the bug wiki, I reckon it hasn't been checked out yet.
    NovaRain, you almost had it. The culprit is not from the blue level but instead it's that single wanamingo from the green level. It's just gotten the wrong script).

    I ♥ you guys too. :wink:
     
  17. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    what?!
    Oh, I never think about that since I only notice the difference in the blue level. I thought all other normal aliens should be as the same as those in random encounters, so I based my assumption on the queen critter. But didn't have time to re-play the EPA part... :oops:
    Thanks so much for the clarification. :D
     
  18. Darek

    Darek is currently unavailable

    Jan 7, 2008
    This is wrong, saving and loading has nothing to do with it. I don't know what the vanilla Bishop's bug was about (something that killap fixed ages ago anyway), but the EPA bug is not the same.
    From epai41.ssl, the script responsible for turning the NPCs invisible:
    Code:
    In procedure use_p_proc there are lines like these for all NPCs not allowed into the EPA.
    
    		add_timer_event(party_member_obj(16777295), game_ticks(1), 40893);
    Now I'm not sure exactly what that is supposed to do, but as it is now it's bugging NPCs out. Remove those lines and they are working properly again.

    This too was fixed long ago but iirc the remade maps from Pixote broke it again. It should be fixed again and if anyone have problems with this it could be that they are running a save from an old RP version or maybe are using some mod that use older scripts (like Miria or unlimited party members). This is just a thought though, nothing I know.
     
  19. lukario

    lukario First time out of the vault

    3
    Oct 8, 2010
    First of all... I love this mod!

    I've been playing it for a week and finally, came to Enclave. I told the scientist to blow up atomic reactor and after that went to kill Frank with Sergeant Granite and the turrets family. After the work is done, I'm trying to use stairs to go to a map with cells, however all I see is an outro (enclave blowing up) and then... outro playing for the second time! After that, game ends and goes to menu (withuot any town outros, or even a screen with my dead body).

    How am I suppose to end the game? :)

    edit:
    I tried the other way - convince scientist to drop fev virus, then blow up a computer with plastic explosives, kill frank - it ends the same way :(.
     
  20. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ lukario,

    You have to leave the oil rig straight away after you have beat Horrigan, if you go anywhere else you will get caught in the explosion.
    The exit is to the north-west, just behind Frank.
     
Thread Status:
Not open for further replies.