Fallout 2 Restoration Project 2.1 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 25, 2010.

Thread Status:
Not open for further replies.
  1. Rune Forumwalker

    Rune Forumwalker First time out of the vault

    Apr 17, 2010
    I recently installed this and started a game, but whenever I leave Arroyo I get a blank random encounter. I figure it's supposed to be a Kaga encounter, but there is literally nothing there.
  2. Felipefpl

    Felipefpl Look, Ma! Two Heads!

    Jun 17, 2010
    Rune - you forgot a few things that could help ya: savegame (before you leave arroyo, maybe killap can find something on it) and specs of your computer like OS and Fallout's version (US, etc), mods installed if any, etc.
  3. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I want to get 2.1.2 out asap, but just haven't found enough time these past two weeks. I really hope this week I can get it out. I'll keep everyone posted.
  4. Radar E 33

    Radar E 33 First time out of the vault

    May 27, 2010
    I think i'm having registry issues with RP and FO2. I can't access some of the new content. Had this issue with RP2.0E, and it appears to have gotten worse with RP 2.1. Halp... :p Thanks.
  5. Ravager69

    Ravager69 Sonny, I Watched the Vault Bein' Built!

    Dec 21, 2007
    Any changes to either Metgzer's, Doc Andy's or the kids from the Den scripts in the upcoming release?
  6. Skynet

    Skynet Mildly Dipped

    Jun 5, 2003
    Why was the talking head for the head monk of abbey removed in new RP?
  7. Dravean

    Dravean Where'd That 6th Toe Come From?

    Mar 6, 2005
    1. it was Morpheus from Fallout 1.
    2. it had no voice.

    At least to me, it feels wrong and "cheap" to reuse a head from Fallout 1. I'd rather picture the Abbot to look a certain way than for the game to tell me that he's a clone of one of the main villains of the first game.

    And since he doesn't have a voice, his talking head sticks out like crazy, since all other talking head's have voices (not counting Cassidy's, which is "optional"). One of the ultimate goals of the Restoration Project is to fit all the additional content into the Fallout 2 world seamlessly, so a person playing through the game for the first time wouldn't be able to tell what was added for the RP and what was already an existing part of the game. The Abbot's talking head would be an obvious feature of a mod and was thus removed.
  8. killap

    killap Bear Dude Moderator Modder

    May 16, 2005

    @Radar E 33
    Please describe your issues.

    What Dravean said.
  9. Radar E 33

    Radar E 33 First time out of the vault

    May 27, 2010
    @Killap: I have them posted on the F2RP bug report page, under misc.
  10. Rune Forumwalker

    Rune Forumwalker First time out of the vault

    Apr 17, 2010
    I use Vista and my copy of FO2 was installed from a Fallout Trilogy disc a while back. It actually gave me two separate game directories of Fallout 1 and Fallout 2, so I left one alone and installed the RP in one. I didn't install any other mods, but I had RP 1.2 installed until I upgraded to RP 2.1.2.

    Of course just the other day I started having problems with 1.2. For some reason whenever I was moving to a different map in a town the game just froze. The screen went dark like it does as it changes maps and the mouse cursor changed to the spinning globe, but the globe didn't spin and the screen didn't change to the new map. This only happened in two areas. The first was leaving Vault City to go to the Courtyard, while the second was going to Chinatown in San Francisco. Both when I was going to Chinatown from the travel map and when running from the tanker down to Chinatown.
  11. Guardian of Nowhere

    Guardian of Nowhere First time out of the vault

    Aug 4, 2010
    I managed to reproduce the bug with Lara's gang war, and whether or not it occurs seems to depend on the number of people following you.

    I guess it bugs out if there is not enough space in the Party Hut (tm) to position all actors correctly. So just leave everyone at the church and pick them up later together with the reward, problem solved.

    Thanks again to everyone involved in making this, it's incredibly good :clap:
  12. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ Rune Forumwalker,
    Your RP 1.2 problem is most likely the "too many items" bug.
    You can get a small program to fix it for you from here: http://teamx.ru/node/361.

    As for your problem with RP 2.1, did you do a fresh install or did you just install it over your old 1.2 folder?
    Also, does the empty encounter happen right away when you leave Arroyo or a bit later?
  13. DForge

    DForge Look, Ma! Two Heads!

    Jul 29, 2006
    In addition to recurring doppelganger bug, I just got an armor bug. All my DR/DT is 0, save for the boxing DT bonus. And my AC is 2. Removing my armor (Combat armor) changes AC to 998. Whee.

    Equipping or removing armor only adds 15% normal DR or 3 DT, don't remember exactly.

    Happened right after EPA. I have before/after saves, if you want.
  14. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Are you by chance playing with the control party members feature turned on in sfall?
    There's a report that it can cause the doppelganger bug, and maybe it's also behind your armor bug.
    Either way, your bugs are pretty much only happening to you and not to other RP players so I would recommend you to look at what you are doing differently (ie sfall settings, mods or other changes you have made).
  15. Rune Forumwalker

    Rune Forumwalker First time out of the vault

    Apr 17, 2010
    I installed it right over the directory in which 1.2 was in. The empty encounter happens leaving Arroyo, and when leaving the encounter I get stopped after a few seconds of travel to return to the same empty encounter.

    I went ahead and traveled to Klamath and probably stopped like ten times. I didn't actually count how many, but it was a lot.

    Ok, I went and loaded the save at Arroyo to test it again. The blank encounter happened seven times on the way to Klamath. Then right outside Klamath I had an eigth encounter, but this time Kaga was there.
  16. UniversalWolf

    UniversalWolf eaten by a grue.

    Aug 28, 2005
    I just started playing the new RP, and all I can saw is wow. Spectacular. Good work, killap. It's like a new game.

    Two things I noticed: after my character had sex with Joey, I still couldn't talk to him about the amulet (I know this is a long-time bug). Also the Modoc mission to protect the brahmin from the wolves was messed up. My followers all attacked the brahmin instead of the wolves. :D
  17. utunnels

    utunnels First time out of the vault

    Aug 2, 2010
    LOL, I tried a stupid character yesterday (in=2, 400+ karma), and that mutant still called him 'scum'. I feel something is not right, but I'm not sure.


    Oh I see, it seems you must be accepted in the town first.
  18. BrecMadak

    BrecMadak First time out of the vault

    Jul 5, 2010
  19. Puokki

    Puokki Where'd That 6th Toe Come From?

    Jun 4, 2008
    Those both are vanilla bugs, but they should be fixed, really. Well, the Modoc brahmin quest isn't exactly a bug, only an AI idiocy; if your teammate hits a brahmin by accident, all of your party will turn against the brahmins. This can be extremely annoying, but it can be avoided by taking away any guns from your party, to prevent accidental hits. Also the fact that the dogs there tend to run away when low HP makes this one of the most annoying tasks in the game, and I would consider changing it more like bug-fixing than changing the game's original content.
  20. matthewfarmery

    matthewfarmery It Wandered In From the Wastes

    Jun 26, 2010
    yeah the guard the brahmin quest is tedious, I also had this problem, I have treied this a few times and unable to save all the brahmin, lost 1 or 2, its very easy to miss turning the brahmin hostile,

    as for the joey sex bug, never encountered this in 2.1 or 2.1.1

    so the issue should be fixed, maybe posting a save may help,
Thread Status:
Not open for further replies.