Fallout 2 mod Fallout 2 Restoration Project 2.2 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 21, 2013.

Thread Status:
Not open for further replies.
  1. Mirak

    Mirak First time out of the vault

    Jul 17, 2010
    Re: Major bug discovered!

    I had a same flicker during molerat fights and no it does not end in a crash.

    ad) walkthrough
    It should be noted that once you win all his money, he won't play again even if you pay him for info later.
  2. hiperborejai

    hiperborejai First time out of the vault

    Jan 8, 2009
    First of all: THANK YOU, KILLAP!!!


    Second: Killap, if you tell me your bitcoin address, I will be more than happy to send you a donation for all your hard work.


    Third. Bugs: https://mega.co.nz/#!V5EkSYKD!bZ-qG3NB2rIsA6NOufQEaQ9HP6kO5nSUQ6TiYIRUhT8 (you'll have to select and copy/paste the link into a browser manually, because it refuses to be recognized as a link by this forum; probably because it contains unusual characters).

    This is a zip file of 34 saves, each with different bug. I will explain each bug, and a slot number of the save, containing the bug:

    SLOT 11: Karl in the Den, won't talk to me, and I can't finish the quest of bringing him back to Modoc, if after delivering the message from "ghost farm" to Jo, I choose to say "that's' not what we agreed on, tell me where the GECK is NOW". That way, the quest of solving the ghost farm problem peacefully becomes impossible to complete, but not crossed out. People in ghost farm still expect me to solve it, but I can't, because Karl won't talk to me.

    SLOT 12: Go to Shark Club in New Reno, talk to pit boss, ask about the "old man near the slot machine". He will answer "that is old man Mcgee. He was sure pissed about you winning his fortune", although I never interacted with McGee at all (nor with "his" slot machine).

    SLOT 13: If you talk to Louis Salvatore while standing behind him, and get him pissed off, he will "sound an alarm", but it is bugged, because it will not activate until you get in from of him. You could potentially get him so "sound an alarm" and still leave the club unattacked.

    SLOT 14: Wrong text. Big Jesus asks "Louis Salvatore lives. Why have you returned?" and Chosen One's answer is "No, I shall return when I have killed him". That was not a "yes" or "no" question, was it? :)

    SLOT 15: In random Yakuza encounter, half of the Yakuza members simply run away without fighting, although unhurt and unharmed in any way. (the same game in from the middle of fight; had no possibility of making a non-combat save).

    SLOT 16: Unreachable bookcase in Vault City (the one I'm closest at).

    SLOT 17: In Vault City courtyard, fix Old'Doc, then talk to Doctor Andrew. Tell him about fixing the doc, and then you have the choice of asking for money/discount or saying you need nothing. If you tell him you need nothing, you get +2 karma, if you tell him any other choice, you get nothing. The problem is, that you can tell him about fixing, ask for money, get nothing, then talk to him again, tell him about fixing again, then tell you need nothing, and still get +2 karma. Getting +2 karma should only be possible if you asked for nothing the FIRST time when informing Andrew about fixing.

    SLOT 18: Tried talking with skeeter for the first time ever (in this playthrough), he sees that I have super-tool kit, and offers to trade it for fuel cell controller. The problem is, that we never talked before, I and need to access his "normal" dialogue, but to do that, I must either to trade him the super-tool kit or to drop it, before talking to him.

    SLOT 19: When talking to the large molerat in Gecko, if I choose "Why don't you tell me about those action you are proposing", the dialogue window simply closes and nothing happens.

    SLOT 20: Wrong text. While talking with the same big molerat, if you choose "I just want your molerats to stop attacking Vault City's patrols", he answers "and here I thought you were concerned for the well being of Vault City". Well, that's exactly what I just said, isn't it? He should only say this text, if I ask him to stop attacks because it hurts the village people, and not Vault.

    SLOT 21: Probably not a bug really. After killing the big molerat, I get -25 karma, and then -10 karma. The logical way, would be to get -35 karma, but maybe that's just the way the engine works.

    SLOT 22: Not sure if bug. I already convinced the Dunton brothers to stop rustling the brahmin, but the quest "find out who is rustling the brahmin" is still not crossed out.

    SLOT 23: Nasty nasty black lines, in Redding, when the rats are fighting in the ring. The fight starts, then follows 5 - 10 seconds of screen flicking and black lines while they "fight" (without any sound effects; that's probably another bug), and then one of the molerat's head explodes and everything goes back to normal. Hilarious, but still a bug. (this was reported before, I know).

    SLOT 24: Talk to woman arranging bets on molerat fights. Choose "I want to make a bet", and then you get 4 choices: "bet on rat 1", "bet on rat 2", "sit the fight out (bet on no one)" and "I've had enough, goodbye". The problem is, that 3 and 4 choices are identical, the fight still happens, and you get to same chat/talk after fight. I think, that choice 4 should simply quit the dialogue, without starting the next ring fight.

    SLOT 25: Arrive to Redding, talk to Morningstar mine owner, agree to search for mining chip, then go talk Kokoweef mine owner, and she will ask "how is the search for the mining chip going", although it is the first time I ever talk to her. If I talk to her without agreeing to search for the chip for the Morningstar mine, then it doesn't happen.

    SLOT 26: Not sure if bug,. Talk to Francis in Broken Hills. He will not speak with you, only will tell you "I do not associate with scum". I have +98 karma, and I am "neutral" status in Broken Hills, how is that considered being "a scum"?

    SLOT 27: The Geiger Counter I have if bugged. I can't sell it, I can't even give it away for free, because the shopkeeper (any shopkeeper) will just say "your offer is not good enough".

    SLOT 28: Wrong text. Talk to mutant guarding jail, he will ask you "You again? What do you want?" and the Chosen One's answer is "Err... no, not really". That was not a "yes" or "no" question. (I believe the mutant should ask "can I help you?" instead).

    SLOT 29: Not sure if bug. When I ask Marcus "What weapons can you use", his answer is not voiced.

    SLOT 30: Not sure if bug. Is the "tag!" perk supposed to be retroactive? Retroactive means that if I "tag" a skill, that I have put some skills point into before, then all those skill points added in the past, get immediately doubled.

    SLOT 31: Not bug, I am sure now. But still, would be nice to know, what is the exact difference between "ranger" and "explorer" perks (besides the +15 outdoorsman). What exactly does this mean: "Higher chance of finding special places and people in random encounters". Higher chance of "finding special people" (if so, then who are these "special people"?)... or, higher change of "finding people in random encounters" (what does that mean, in practice?).

    SLOT 32: Serious bug. In sierra Army Depot, the turrets won't attack your party members. That means, that you can start a fight, run away where turrets can't reach you, and then have Myron destroy all the turrets with his fists (will take a lot of time though, but still...huge exploit potential).

    SLOT 33: In New Reno Cat's Paw, if you ask to buy sex for companions, and choose Skynet (read a book for Skynet), the screen will fade to black (that's normal) and the game will hang (the screen remains black, had to ctrl+atl+del to go back to windows). Very curiously, it seems, as when the screen fades to black, it gets refreshed again and again without limit. After returning to windows, and trying to open the (still running) fallout window again, I briefly was able to see the words "THE END" written on the fallout screen, until it got refreshed to complete blackness again. :shock:

    SLOT 34: With some bookcases (like the one I'm standing nearest to), if you press on the lower right corner of the bookcase, instead of "opening" the bookcase, the Chosen One will instead try to "pick up" the bookcase, and get the message "you can't pick up that item, you are at your maximum weight capacity". Interestingly enough, this bug existed even in the first fallout, so maybe it is unfixable?

    SLOT 35, SLOT 37, SLOT 38: Skynet keeps twitching weirdly and won't move after the combat. The only way to "fix" him, is to tell him to put away his weapon.

    SLOT 36: Not sure of bug, and this is not particular to this save game. Marcus has a plasma rifle, from which he can fire two shots each round. He does that happily, BUT if his first shot kills someone, then he will just end the round and won't fire the second shot. I believe this is relevant not only to Marcus, but other companions too.

    SLOT 39: Not sure if bug. In New Reno, if you try to pick Wright's safe, and trigger the trap, the safe becomes bugged (unopenable) - you can still try to "open it" (obviously, it will still be locked, and you get the message that it is locked), but if you try to "pick" it again, nothing happens (picking animation plays, but no message, no anything).

    SLOT 40: In New Reno Arms, if you stand very close to a wall (from the outside), Eldridge can shoot you through the wall, while being inside (there are no windows in the wall, so this must be a bug).

    SLOT 41: Not sure if bug. Peasant in NCR does not talk or react at all (any other character at least gives you "flying" text, this one does not do absolutely anything).

    SLOT 42: Missing dot. When talking with Saltbeef Bob, one line says "You're a feisty one, old timer" , it should be "You're a feisty one, old timer."

    SLOT 43: Missing dot. When Saltbeef Bob asks you for your name, the answer is without leading dot (it says "Alex" , it should be "Alex.") (of course, "Alex" would be the name you chose for your Chosen One, but the dot is still missing).

    SLOT 44: ....................I completely forgot what the bug was supposed to be here....will edit the post if I remember.

    And, lastly, no save needed, and not a bug per se, but the karma penalty for digging up a grave is way WAY too high. C'mon, -5 karma for digging a grave, and -10 karma for killing an innocent person? Two dug up graves = one murder? This is ridiculous, although I suppose it was in the original game. The penalty should be -1 or 0.
  3. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I actually did, but forgot a > sign in the sentence before it, so the whole line went missing. Oh well. :roll:

    hiperborejai, Nicely done! :clap:
    I'll answer a few of the easy ones.

    SLOT 12 - Fixed allready.
    SLOT 27 - Well known engine bug, not fixable at the moment.
    SLOT 29 - That was never voiced unfortunately.
    SLOT 30 - Perhaps an oversight, perhaps intended. Either way, people tend to look at it as a feature.
    SLOT 34 - Not a bug, but a clumsy fix the original devs made to get around a clipping problem with the bookcases.
    SLOT 36- There is an option in sfall to let them continue their turns. Look for "NPCsTryToSpendExtraAP" in ddraw.ini
  4. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @killap and Mirak too,

    The disarming issue Mirak has been having is a strange one.
    I have checked and confirmed that it goes back to vanilla Fallout 2.
    Almost every critter that has something in item slot 2 will remove it whenever you talk to them or they say a float.
    I'm not sure how big this bug is, but New Reno for one seems to turn into an unintended kleptomaniac paradise.

    Party members seems unaffected by this, haven't checked with others in party.txt.
    Another one who don't suffer this is Mason, who happen to have the no barter flag. Haven't tested with others with that flag.

    Anyway, I believe it's a problem to do with barter. Maybe a side effect of some feature the devs implemented for it.
  5. Kapelinio

    Kapelinio First time out of the vault

    Jul 23, 2013
    OK, now I understand.
    Heh,suit, intelligence and psychopatic brutality :D HE remind my Ted Bundy : 8-)
    By the way, great job and great thanks to You and all others who were involved in creating this, :clap: :clap: :clap:
  6. Glovz

    Glovz Vault Dweller

    Sep 16, 2005
    Just to understand this a bit better, is it a scripting issue or an engine issue?

    IMHO any items that are equipped by a npc should probably not be available for barter.
  7. coldroll

    coldroll Fuck Bethesda

    Jul 4, 2012
    Re: Major bug discovered!

    No crash just the screen flickering until after the mole rat mumbo was over.
  8. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I thought engine, but I had only checked critters around New Reno.
    Checked Arroyo now, and they didn't have the same bug. Took a script from Arroyo and gave it to a guard from Reno and the problem was gone.
    So it seems script based and probably nothing to do with barter anyway. Could be some command being a bit broken, so could still be engine. Haven't had time to compare the scripts yet.
  9. Bakou

    Bakou First time out of the vault

    Aug 12, 2013
    Thank you for all the hard work, I can't stand for re-installing this good old game.
    Very funny to see we've been through some of the same old games (TA, Fallout etc.) :mrgreen:
    Doesn't make me feel younger
  10. Mirak

    Mirak First time out of the vault

    Jul 17, 2010

    Vault Village walkthrough

    - Talking to Joe gets you no xp (But maybe you meant 1200 xp for the whole peaceful solution), but you can get 10mm pistol by initially pretending you know him.
    - You now get 500 xp if you convince Brain to stop the attacks on VC patrols.
    - You now get 1000 xp if you talk to McClure after completing the quest.
  11. Krensada

    Krensada First time out of the vault

    Aug 10, 2013
    I signed up just to tell you that I am having a hard time playing the game now.

    Where once I was able to survive encounters, I am finding it very hard to survive now. And I don't mean its hard, I mean it is unfairly overwhelming.I get killed by every random encounter, and i have to keep saving. even on level 10 I can't find good armor, I can't find good weapons, and my survival rate wherever I go is severely low. I thought this mod would make the game fun, and challenging. but I have to say that it doesn't.
  12. Brunzer

    Brunzer First time out of the vault

    Apr 9, 2010
    The Restoration Project has not, as far I know, made many changes to the original content and gameplay; it merely expanded it. You should be able to get a bit more xp in the towns due to the bugfixes and additional content. The various fixes on the other hand, the trader in vault city used to have much lower prices for example, have made the game a bit more difficult and less exploitable.

    Merchants no longer keep stacking items because of the ‘to many items bug’ (If I recall correctly). So it’s a lot less likely for them to have certain uncommon items like 2mmEC ammo or combat armor in their inventory. Though the good armors are still in their respective places. The combat armor mark2 (good midgame armor) can still be found in the toxic caves, leather and metal armor mark2 in can still be acquired New Reno (the metal armor is only for sale, I think).

    Encounters have always been tricky at lower levels. Sometimes you constantly run into highwaymen and golden gecko’s while you’re at a low level, yet sometimes you get to reap the rewards from a caravan fighting some bandits and snatch a nice H&K Caws. Personally I always save after each encounter that I’ve survived.
  13. Glovz

    Glovz Vault Dweller

    Sep 16, 2005
    There is a way to change the frequency of encounters; unfortunately I cannot recall which file it is, but it's something that can be easy modified with a simple text editor like notepad.

    That should help somewhat.

    I don't believe that killap changed anything about the pricing of items at any vendor. Do you have any other mod install on top of the RP?

    The 'too many items bug' fix did not stop items from stacking, the change was to limit the number of items that had scripts attached to them. Again, this should not affect merchants/vendors in any noticeable way.
  14. Zaxx

    Zaxx First time out of the vault

    Aug 4, 2013
    I tried multiple times and could reproduce the bug yeah. I tried to kill of the Encalve president and the Hubologist in NCR with the bomb method and crashed the game a few times before settling on other methods. I managed to kill off Westin with a bomb but then another bug appeared: when I went back to New Reno to tell Bishop I whacked the guy there was no dialog option to do that so the game simply didn't register I killed Westin.

    The steps I took were always the same: I planted some explosives on the guy with a timer set around 1 minute, then I exited the area and returned to it and the game crashed a few seconds after that.

    Okay, I still have the save so I'll upload it somewhere tomorrow. :)
  15. Brunzer

    Brunzer First time out of the vault

    Apr 9, 2010

    I phrased it poorly, but this is what I meant. Randall, the trader in the amenities office used to have ridiculous low prices. You could easily stack up on books and stims at low level.

    When the shopkeepers didn’t wipe their inventory you had a better chance of obtaining some of the fancy items simply because they’ve restocked several times in between visits. Now you can only buy what they spawn after a single restock.
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ killap

    Looks like the Unequipping problem isn't a bug strictly speaking. But it is rather strange.
    Please have a look at "bismen.ssl and check "inven_unwield", there's one in the talk procedure and two in the timed events procedure.
    Not quite sure exactly what the devs wanted to achieve, and why in that way.

    Also two small bugs in the VC area:

    vcconnar, Node028d
    Tries to use non-existing line 250, should probably be line 174.

    When you rat out Happy Harry to stark and he is sent to the detention center, he is still armed. Should probably remove his whole inventory.

    They've never restocked several times in between, as their scripts don't run if you are not on the map.
    Also, I seem to remember they didn't restock items that they already had, from their restock list. Not sure though.

    Yep, that's what I meant and I thought the pistol wasn't worth mentioning. Missed the xp for Brain and McClure (though that was for the Vault City quest). Thanks. Rewrote much of VC and VVillage sections.
  17. coldroll

    coldroll Fuck Bethesda

    Jul 4, 2012
    I believe it's called ddraw.ini
  18. lostabroad2

    lostabroad2 First time out of the vault

    Apr 2, 2013
    Re: Major bug discovered!

    The problem exists only when the molerats fights and finishes, without crashing, when either molerat dies. There's a similar but much lesser problem with the "Some people in the wrong place at the wrong time" encounter. I thought I was just me since no-one else was mentioning these issues. There's also a screen issue with the maintenance bot in the repair sequence at Gecko. It disappears and reappears at certain places. The crane appears to have an image error which is probably related.
  19. Hayden

    Hayden First time out of the vault

    Dec 27, 2010
    Is the Geiger counter issue even a bug? The Geiger counter has a battery that runs out, right? So after you've used it even once, the battery is now no longer at full capacity. That's why you can't trade it. If you never turn it on, you should be able to trade it fine. Maybe there was no easy way to track the battery and adjust prices accordingly, so the programmers decided to just make it untradable after even a single activation.
  20. kungfujoe

    kungfujoe First time out of the vault

    Sep 28, 2008
    Yep, but that feature appears to have been removed from sfall. Supposedly updates to the program made it unnecessary. I asked about this feature earlier on this thread and got no response, but various web searches suggested that the feature was gone.
Thread Status:
Not open for further replies.