Fallout 2 Restoration Project 2.3.2 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jan 2, 2014.

Thread Status:
Not open for further replies.
  1. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Hey everyone. I'm back from my work travels, etc.

    I still need to catch up on what all I missed over the last 2 weeks here and over at the wiki.

    I'm still planning on releasing another update soon, as well as finally get source files out to everyone.
  2. voodzia

    voodzia It Wandered In From the Wastes

    Jun 27, 2005
    A quick question - is it possible to trigger "Sulik's sister is missing, find her." quest without recruiting Sulik?
  3. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    That's because any game started by reading its manual in the good old times. You really should try it at least once, Chris Taylor would be pleased. :razz:
  4. Mohamed2001

    Mohamed2001 HATE NEWSPAPERS

    Jan 28, 2013
    Sort of.
    You can just go in the slaver camp, waltz in, kill everyone there, free the girl.
    Other than that, non that I know of.
  5. Dux

    Dux First time out of the vault

    Feb 3, 2009

    Both of those ideas are awesome! Any chance they can get implemented in the RP?
  6. lujo

    lujo Look, Ma! Two Heads!

    Jun 14, 2013
    Sad to report EPA is crashing for me in the same way, second playthrough in a row. I only have Nirran's perks per level installed on top of RP 3.2. The first time I enter EPA everything is fine, but if I leave at any point every time I try to come again it crashes. That was in the first playtrough, in this playthrough I decided to stay for the first time, but if I save the game at EPA, the game crashes upon loading. Also, the plant spray canisters don't seem to be working.

    EDIT: I just tried entering the map, leaving, then immediately going back in. Crash. I'll try to sneak into the bottom level, see what happens.

    I also managed to get the card for the red level from the hologram in armor but it crashed as I took the elevetor up.

    EDIT2: I tried it all again, and I could load a game I saved on lvl 4, and while doing the quest for the female hologram I could take the elevator to lvl3 (back up). But after having visited floor 6 or having the red keycard the game crashes when I try to go to floor 3.

    EDIT3: More testing - I managed to do all the hologram quests except the one which gives codes to doors (for the female hologram) by acessing the W wing through the poisonus room. I'll see if another crash happens when I do the female hologram's quest.

    EDIT4: Crashed after I've freed Jules and tried to take the elevator to the 3rd floor. Correction - crashed after I killed the aliens, disabled the force field and found out I need the gel to free Jules. That was enough to get it to crash either elevator.

    EDIT5: Went back up a save game to when I got the password for the seventh floor - crash when trying to go to lvl 3.

    Anyway, the error report I got after turning off the high res patch reads: "The instruction at 10044f61 referenced memory at 0052ff46. The memory could not be written". Sadly that's all I've got...
    Last edited: Feb 6, 2014
  7. IYouI

    IYouI First time out of the vault

    Dec 15, 2013
    Last edited: Feb 7, 2014
  8. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Only the modder's pack (more precisely, the compiler & scripting docs got updated), which has nothing to do with RP.
    Last edited: Feb 7, 2014
  9. fvtb1981

    fvtb1981 First time out of the vault

    Feb 10, 2014
    I just want to say: THANK YOU, KILLAP!!!

    So... that's all: thank you :-)
  10. Heimdall

    Heimdall First time out of the vault

    Feb 11, 2014
    I have problem with running speed of my character on map - it is too fast. Moving from one corner map to second takes only few seconds. I couldn't find option to reduce it in game nor in ddraw.ini. Maybe I missed something and I can slow down this animation ?
  11. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Have you checked the [Speed] section in ddraw.ini? You can set the initial speed with SpeedMultiInitial.
  12. Sduibek

    Sduibek Creator of Fallout Fixt Moderator Modder

    Oct 27, 2010
    killap I'm almost certain this doesn't matter, but I noticed a curiousity that one of the entries in SCRNAME.MSG has a localvars declaration:

    {1089}{}{Door}                          # WILv1Dor.int    ; Locked Door on Level 1 Entrance         # local_vars=8
  13. Geoff

    Geoff First time out of the vault

    Feb 11, 2014
    Hello, 1st time....hopeless at forums BUT.

    Your final instruction
    3. That's it. Don't install anything else, unless you know what you're doing!

    does this mean what it says and will I not need to install the "Fallout2_High_Resolution_Patch_4.1.7" ?

    I apologise if this is an obvious question, but I have been trying to reinstall fallout 2 onto a pc for days correctly now.

    thankyou for any help you can give.


    Ahh answered my own question....installed /updated with above....great and easy
    now to strat games again.....negative is losing previous games
    positive is starting the journey/game again.

    thankyou-thankyou a n d thankyou:clap:
    Last edited: Feb 13, 2014
  14. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    RP 2.3.2 already has hi-res patch 4.1.7 included, no need to re-install it.
  15. Mowgly

    Mowgly First time out of the vault

    Jan 31, 2014
    First, thanks for your great work on this project, i had countless hours of fun with it over the years.
    Also sorry if there's spelling or grammatical errors, english isn't my first language.

    I have a weird issue with the RP, my steam version of Fallout 2 works fine but once the RP is installed i got the "wmAreaInit:: Error loading cities!" message and back to desktop. I made some research and on your wiki page it says that it's an issue found on those using WINE.
    Problem is that i'm on Win XP SP3.
    I tried installing with the .exe and with the manual archive but it doesn't change anything.
    I also tried the "city patch" and with it the game is able to launch but i can't access to the option of the resolution patch nor the customisation of my character on the character creation screen.
    Am i missing something ?
  16. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    I have a feeling that your anti-virus or other security program might be blocking sfall from applying.
    Using city patch won't have any help for the problem. It can only get you to the main menu and that's pretty much about it.
    Last edited: Feb 13, 2014
  17. Mowgly

    Mowgly First time out of the vault

    Jan 31, 2014
    I got rid of my anti-virus, i don't have any other security program that i know of.
    Tried another complete dl/fresh install, didn't change anything, i'm still getting "wmAreaInit:: Error loading cities!".
    Also, there's no sfall.dll or any file named sfall (except for the sfall readme) in my fallout 2 directory.
    Am i supposed to run the .exe without compatibility mode ? Because when i do i get "Could not load DirectX : This program requires Windows 95 with DirectX 3.0 or later".
  18. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    The ddraw.dll in your FO2 folder is sfall. There's no need to run the .exe with compatibility mode.
    Are you sure you have the latest DirectX runtimes (June 2010) installed?
  19. Mowgly

    Mowgly First time out of the vault

    Jan 31, 2014
    That's weird, i installed the DirectX_Jun2010_Redist linked by Killap on another nma topic yesterday.

    Edit: I found a solution, by using the Windows NT-2000 ddraw.dll from the manual RP install files i'm able to launch the game and have now access to the Screen Settings, the "Style" options are available and the rock on the first area tells me that i'm using RP 2.3.2 .
    I don't get it, but since it's working why bother !
    Thanks for your help NovaRain !
    Last edited: Feb 13, 2014
  20. yaiez

    yaiez First time out of the vault

    Feb 13, 2014
    After reading some of the other forums I guess here's the right place to ask for help. I'm experiencing an annoying error when I try to exit Sierra Military Base, walking out worked perfectly before I've done what I wanted to do in the base. After I looted everything I wanted to loot and killed everything I wanted to farm XP on I'm getting this two errors when walking on the green exit field:

    I've tried reinstalling the game & Restoration Project. I'm using the newest version.
    If there isn't any way to fix this maybe there's an editor that I'm not familiar with that could change my character's location? (along with followers)

    Thanks in advance for any help.
Thread Status:
Not open for further replies.