Fallout 2 mod Fallout et tu - Release v1.5

Discussion in 'Fallout General Modding' started by Lexx, Aug 23, 2019.

  1. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    I don't know. Could be anything, really. Did you update the game files mid-game?

    I tried to reproduce the issue in a new game, but the bike works fine. No visible trunk following me around. So whatever caused this for you broke some condition checks.

    /Edit: if you upload your savegame somewhere I could try checking it out and maybe fixing the issue.
  2. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    Nov 8, 2019
    It only happened in necropolis, havent seen it anywhere else, it's not an issue but im worried there could be something underlying
  3. Cerebro

    Cerebro First time out of the vault

    May 6, 2007
    The TMA function got broken somehow during the last couple of updates. The TMA box appears, but no keyboard commands are recognized. It's not possible to type anything...
  4. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Yes, we are working on stuff. One being that keys are fetched from a new *.ini file, which is in the mod folder right now (and not in /config/). I'm assuming you didn't copy that / updated?
    But even with that file, it's still partially broken, because the script isn't 100% complete right now.
  5. Cerebro

    Cerebro First time out of the vault

    May 6, 2007
    Ah, I see. Yes, the new gui_char_sets.ini got under my radar somwhow. Thanks for the info.
  6. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Can anyone test the following?

    1. Go to the Hub Downtown and talk to either Mitch, Mrs. Stapleton or Beth.
    2. Activate the TMA interface (it should work).
    3. Close TMA interface.
    4. Enter barter-mode *in dialog*
    5. Return to the dialog screen.
    6. Try to open the TMA-interface again (should not work anymore).

    It's about this bug.

    @Cerebro maybe?
  7. Cerebro

    Cerebro First time out of the vault

    May 6, 2007
    Yes, I can confirm this bug, tested all three of the mentioned NPCs. Funny thing: When I tried Mitch, the TMA button at least had the click animation and sound. With the other two, the TMA button wasn't even clickable.
    • [Rad] [Rad] x 1
  8. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Alright, Mr. Stalin fixed it (was an Sfall issue). Mechanic-wise I consider TMA to be fully working now. I've also did a first pass on all generic keywords. What's now left to do is just fine-tuning, fixing my shitty english, adding more catchy keywords, etc. This is something that can be done from time to time. For me it's just important to know what folks want to ask NPCs (because I can't read minds).

    I'm considering a new beta package release soon-ish. Just have to play through the game one more time to check that everything is still working.
    • [Rad] [Rad] x 1
  9. bloodaxis

    bloodaxis First time out of the vault

    Nov 28, 2019
    I've been replaying Fallout 1 with this for a while now, and either I'm blind or I fucked something up, but where exactly is the motorcycle supposed to be, trying to find it is driving me insane.

    Edit: I have GVAR_ENABLE_MOTORCYCLE set to 1 in the config file at least.
    Last edited: Nov 28, 2019
  10. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Follow the mainquest. You'll run into it
    in Necropolis.
  11. Cerebro

    Cerebro First time out of the vault

    May 6, 2007
    The bike is...
    at the Watershed in Necropolis. There is a new ghoul (Griffith) who can be talked into selling it for 2000 caps.
  12. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    There's multiple ways to get the bike, btw. You actually don't have to pay anything. :>
  13. Cerebro

    Cerebro First time out of the vault

    May 6, 2007
    I'm for the most part a Goody Two-Shoes type of RPG character, so killing this poor fella and stealing his fuel cell controller is not my way... If this is what you hint at... I never tried anything other than buying the bike. One time I helped him to use the bike himself and leave Necropolis and was like O_o *lol*
  14. bloodaxis

    bloodaxis First time out of the vault

    Nov 28, 2019
    Could've sworn I've looked there before and couldn't see it, well, thanks for the help!
  15. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    If you give him any energy cell(s), he will use them to leave. However, he still needs the Controller, which he has hidden nearby. Now you have three options: 1. you wait for him to pick it up, then kill him, 2. wait for him to pick it up and then steal it while he walks back, or 3. you find the Controller yourself (perception check / binocular) and steal it.

    You can also combine 2 and 3 ... Find the Controller, drop it somewhere else, then give energy cells to him so he leaves the bike alone. Pick up the Controller again and make ways before Griffith has returned. In any case, you're an ass, because you likely took part in his future death in the city. :>
  16. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    We just released Beta v0.1225 - The download link in the first post of this thread has been updated accordingly.

    • Added: Fallout 1 "Tell Me About" function (TMA).
      Brought back from Fallout 1, it is now possible to ask keywords to most NPCs in the game. Our script comes with a few improvements that make it easier to use, such as multiple keywords (ex. Shady Sands -> Shady -> Sands), and an increased set of generic keywords (Help, Buy, Sell, Direction, ...).
      The function is easy to use and can even be ported over to other Fallout 2 modifications if so desired.
    • Added: Robodog!
      Optional mod that replaces Dogmeat with a robodog. \o/
      Simple script + dialog replacer. Check the readme for more information on that.
    • Note: undat.exe (used to extract needed assets from Fallout 1 *.dat files) now should work under WinXP.
    • Note: release package can now be correctly unpacked using Windows unpack tool
    • Added: Holodisks now have custom inventory icons to make them stand out better.
    • Added: The option to change the Water Chip time limit.
    • Added: Invasion and water timer values now can't be changed mid-game anymore.
    • Added: After killing Gizmo, his body will now correctly turn into a corpse container and then empty desk.
    • Added: Ian won't comment on Killian's store / Gizmo's casino anymore if either is dead.
    • Added: After giving the Water Chip to the Overseer, the whole party gets teleported into the library, not just the player.
    • Added: Necropolis invading Super Mutants will only spawn with weapons now if Fixt has been enabled (gamebalance!!!1).
    • Added: "Magic Hands"-animation when repairing the Glow power generator and the BoS Power Armor.
    • Added: It is now possible to use the Mariposa door code holodisk directly on the door to unlock it.
    • Added: Experience-messages in the log window should now correctly take the Swift Learning perk bonus into account. ("You earn 100 experience." -> "You earn 105 experience." etc.)
    • Added: It is now possible to *actually* destroy the Military Base force field emitters (yellow and red). They will also visually change.
    • Added: Force Fields now work via timed_event and not map_update anymore (ex. opening the PipBoy would re-enable disabled force fields).
    • Added: Stealing the urn in the Skum Pitt is now a tad harder, because Neal will react to noises at night.
    • Fixed: "Rescue Tandi" quest pipboy entry only showing up after talking to Aradesh.
    • Fixed: It was possible to hire Ian "for free" (circumventing dialog checks) under certain conditions.
    • Fixed: Deathclaw encounter still happening at all times.
    • Fixed: Typo in Trent (Deathclaw encounter survivor) dialog.
    • Fixed: Reactivated invasion timer reduction by the Military Base Vats Control computer terminal.
    • Fixed: Vinnie dropping leather jacket even with "armor destroy mod" enabled.
    • Fixed: Caravan-jobs - Now setting exit grids on *all* elevation, to trigger the correct follow-up map.
    • Fixed: Caravan-jobs - Also fixed spawn position of Small Ghouls group (would end up on hex 0).
    • Fixed: Hub "Captors" will now reset to their home tile when the player enters Old Town.
    • Fixed: Deathclaws in the Boneyard don't have magic vision anymore.
    • Fixed: Super Mutant Invaders (Necropolis, etc.) would spawn new weaponry on every map_enter.
    • Fixed: Can't rest in Hub / Heights anymore.
    • Fixed: Can't rest in Adytum underground anymore.
    • Fixed: Gun Runner's map exit grid partially transported the player to the Blades, and not Rippers map.
    • Fixed: Disabled Glow Robobrains should not "stand up" anymore in combat.
    • Fixed: BOS Power Armor on the table can now *actually* be repaired with the multi-tool.
    • Fixed: Michael can be asked about the Power Armor motivator at all times now, not just the first time the message appears.
    • Fixed: Irwin will correctly appear on his farm after the raiders were killed (only if satellite quest locations have been enabled).
    • Fixed: Dead bodies will disappear now in the farm quest location.
    • Fixed: Armor destroy mod would remove armor from party members.
    • Fixed: Wrong spawn hex when using the Cathedral tower stairs from elevation 1 to 2.
    • Tweaked: Reverted merchant prices back to Fo2 barter formula. It'll be changed to something better once I find the motivation to dive back into it.
    • Tweaked: Vault 13 vault door won't close anymore right behind the Overseer (will only close on next map enter).
    • Tweaked: Generic Junktown guards will instantly rotate to their home rotation after returning to their home tile.
    • Tweaked: Water/Invasion timer settings overhaul.
    • Tweaked: Improved the "shut-down" Gizmo casino sign graphic.
    • Tweaked: Using the sewer holes in Necropolis without opening the cover first will now open the cover instead of spawning a log message.
    • Tweaked: Tycho's primary skill isn't melee anymore.
    • Tweaked: Increased money respawn time for certain merchants.
    • Tweaked: Increased worldmap encounter rates.
    • Some fo1_settings.ini restructuring has been done.
    • Lots of generic codecleanup has been done. Too much to listen all of that in here.

    Here is a video of Fallout 1's "Tell Me About" in Fallout 2's engine for anyone curious enough to check it out, but not curious enough to check out the latest release of Fallout et Tu.
    The addition of TMA means that now the only "crucial" difference between our version and the original is the lack of red dots while traveling on the worldmap (well, and the shown location names only when moving the mouse cursor over location circles, but that would be more a setback than an improvement, imo).
    We have a couple ideas about how to tackle the red dots, but sadly nobody mad (and skilled) enough to actually do it.
    Last edited: Dec 2, 2019
    • [Rad] [Rad] x 6
  17. drunkboris1

    drunkboris1 First time out of the vault

    Dec 2, 2019
    This is incredibly impressive.

    I've reinstalled it twice now, and I cannot get any music to play at any point for any maps in Fallout 1. Any ideas?

    I put the Mod folder inside of the Fallout 2 Directory, should I move it?

    EDIT Finally got it working, not sure what was wrong
    Last edited: Dec 3, 2019
  18. Cerebro

    Cerebro First time out of the vault

    May 6, 2007
    Bug report: Seems like the Vault Dweller got a little lost on his way to bust Gizmo with Killian and gang. ;) (Warning: Large screenshot)

  19. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Great. I've moved the "Gizmo desk code" to the wrong position in script, which now results in the player being teleported to the wrong hex.
    Fixed it on repo... dunno when i'll push a new release package.
    Last edited: Dec 4, 2019
  20. khai9999

    khai9999 First time out of the vault

    Nov 16, 2016
    Is there any benefit packaging hero appearances into .dat format than losses files? Asked this because after barter screen or loot screen, my appearance will change to default generic hero sometime. To fix this, open and close inventory screen which somewhat annoying process.