Fallout 2 mod Fallout et tu - Release v1.5

Discussion in 'Fallout General Modding' started by Lexx, Aug 23, 2019.

  1. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    @gustarballs1983 @PxHCx I've just committed a new experimental sfall build with changes to the AI weapon pick calculation to git. With my tests, the LE gun is now chosen correctly. AIBestWeaponFix needs to be set to 1 for it to run.

    NOTE: This is not an official release, so there could be issues of whatever kind. This is just for testing.
  2. gustarballs1983

    gustarballs1983 Water Chip? Been There, Done That

    Oct 28, 2009
    will it require a new game, or would it work with old savegames?

    NVM.. tried with an old save game. seemes to work. tried with assault rifle, combat shotgun, and LE BB Gun. Always chooses LE BB Gun now. don't have an access to sniper rifle yet.
    Last edited: Apr 30, 2021
  3. Tomfoolerly

    Tomfoolerly First time out of the vault

    Apr 30, 2021
    Hey sorry if this has been posted before but I searched around and couldn't find anything about this.

    I've been playing through et tu and LOVE the qol changes, but I'm having some problems

    1 A lot of text has been replaced by error messages https://www.dropbox.com/sh/hl2pb5s4447x7bq/AAAu-uxnUTp5p4k3AIvpRARTa?dl=0

    2 some of the quests don't work, namely the Decker quest in Hub, I kill decker and his groupies but then the quest just, doesn't end and I'm stuck in the basement. When I try to do the kill Gizmo quest it just teleports me to north Junktown and then nothing happens.

    3 I also can't talk to Mrs Stapleton, minor complaint but I like the books lol

    Does anyone know if there's any fixes for these? I googled a lot, but there doesn't seem to be anything anywhere on this. I followed the installation instructions and double checked them but maybe I missed something

    Again love everything about the mod just having some issues
  4. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Lots of error messages is a huge red flag already. Not being able to talk to Mrs Stapleton is a huge red flag as well. Something is obviously wrong with your installation that should be fixed first. The Hub and Junktown stuff is very likely related to that issue as well.

    Need more information:
    - did you follow the install instructions correctly?
    - what language version of Fo2 are you using?
    - what OS are you using?
    - what ettu version are you using?

    /Edit: Spotted that random floating error in the Hub. This clearly means files are missing / can't be found. Yet apparently you were able to play till reaching the Hub. Based on that I'm assuming that not all files were installed correctly and you have to download and reinstall the mod again.
    Last edited: Apr 30, 2021
  5. Tomfoolerly

    Tomfoolerly First time out of the vault

    Apr 30, 2021
    Yep, that was it, I remember when first I installed it not all the files extracted for some reason so I manually copy and pasted them and figured it was no big deal lol

    Thanks for the response!
    Last edited: Apr 30, 2021
    • [Rad] [Rad] x 1
  6. GuyManBot

    GuyManBot First time out of the vault

    Nov 26, 2017
    Hello. I have installed everything correctly, although I do have a general question. Keep in mind I am a bit of a newbie when it comes to Classic Fallout modding. But whenever I encounter a talking head, I just have the talk screen surrounded by a black void. IIRC it's supposed to just go over the map and pause everything. Not sure if this is just a limitation of the mod itself, or if this is something that can be fixed. Either way, great work on everything.
  7. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    Set DIALOG_SCRN_BACKGROUND=0 in f2_res.ini.
  8. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    That's just the default setting for other mods that came before, so people got used to it. Also the game does not pause in dialog - critters, etc. keep moving around when hoovering over the dialog options (which is why I enabled the black screen - looked more vanilla to me).

    /edit: Turns out critters only keep moving in dialog interface if the dialog gets started from outside the talk_p_proc. Learned something new today.
    Last edited: May 5, 2021 at 7:50 AM