Fallout 2 mod Fallout et tu - Release v1.9

Discussion in 'Fallout General Modding' started by Lexx, Aug 23, 2019.

  1. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Alpha 2 / Revision .713 is now available for download here. The first post has been updated accordingly.

    • Added: FoA good ending can be achieved with keeping Nicole and Laura alive.
    • Added: offset parameter to define PipBoy water timer post-it position from .ini file. Used to fix its position when running odd / unsupported resolutions.
    • Added: When joining traveling NPCs on the worldmap, the game time will now advance correctly based on distance to the target location (as example, via Harry from Necropolis to Mariposa takes ~22 days).
    • Added: Fo2 styled merchant inventory restocking (optional!).
    • Added: Resting timer now behaves like in Fo1 (06:00 instead 08:00)
    • Added: If wearing power armor, radscorpions won't poison the player anymore.
    • Added: Quick Pockets perk now acts like in Fo1 (3 ranks, -1 AP / rank).
    • Added: Using binocular on owned bike now returns the battery power in %.
    • Added: Custom ai packages for Mr. Handy robot.
    • Added: Converted Ian, Katja, and Tycho party dialog to Fo2 style.
    • Added: Door sfx to Glow doors (correct key / incorrect key).
    • Added: power on / off sfx to Glow power management.
    • Added: Animated power generator.
    • Added: Glow robots now play getup/falldown animation depending on current power status.
    • Added: Junktown casino now uses loaded dices.
    • Added: "dice girl tamper timeout" - if the player tampers with the dices and the house noticed, the table will not not be locked forever.
    • Added: More location related dialog to Ian (Junktown, Hub, Raiders, Necropolis).
    • Added: Scrapheap / Fo1 demo map and location data (not available ingame yet).
    • Added: Boneyard quest log entries.
    • Added: V15 questlog entries are back, but only appear when entering the V15 location.
    • Added: Destroying the rats tunnel in V15 now has visible feedback. As a bonus, rats on this level will respawn over time, unless the tunnel gets closed by the player. This will have barely any influence on any player, but still nice to know it exists.
    • Added: Custom item proto for Boneyard farm quest.
    • Added: Custom script and graphic for Gizmo's casino sign, to swap it out once Gizmo is no more.
    • Added: Critter proto templates for small radscorpion, gecko, golden gecko, fire gecko, spore plant, and sentry bot (This is primarily for modders right now).
    • Added: Geckos and small scorpions to encounter tables (rare chance only).
    • Added: Geckos are only lootable with gecko skinning perk (currently not available).
    • Added: The player now also receives a small dose of radiation while traveling on the worldmap around the Glow. So be sure to throw in rad-x a bit earlier than 2px in front of the green circle!
    • Added: Alternative path for obtaining the motorcycle fuel cell controller.
    • Added: Fo2 toe mutation code for lolz. :>
    • Fixed: Cathedral tower staircase (teleport)
    • Fixed: Unlimited XP exploit in Master's Vault computer terminal script.
    • Fixed: Flip in Vats map won't bring the player to Lou if he attacks with the Brotherhood. Same for the gate and door mutants.
    • Fixed: About a trillion bugs related to the vehicle. It should now be far more stable than it ever was in Fo2 vanilla.
    • Fixed: Night Person trait now works correctly. Player receives the correct amount of skill points on levelup, and the trait can be removed via the Mutate!-perk.
    • Fixed: "Destroy Armor Mod" wasn't removing armors in special cases.
    • Fixed: Removed duplicated critters (cook, etc) in Shady Sands.
    • Fixed: Party members can't run through the 2nd V13 door anymore.
    • Fixed: Garl shouldn't drop his metal armor anymore if Armor Destroy Mod is active (untested).
    • Fixed: Powered Armor and Hardened Power Armor weight adjusted to Fo1 values (had to double the weight, because Fo2 sets / 2).
    • Fixed: Party member combat control settings are working now.
    • Fixed: Junktown guards will now appear correctly when ambushing the Skullz.
    • Fixed: Skills description changed from Fo2 to Fo1 version.
    • Fixed: Marcelle won't leave the map anymore if NumPathNodes is > 6.
    • Fixed: Neal in the Skum Pitt killing the Skulz ganger will now play the correct death animation.
    • Fixed: Potential money stealing exploit (primarily in the Boneyard).
    • Fixed: ai package for deathclaw eggs.
    • Fixed: MacRae will not call female dude "lad" anymore.
    • Fixed: Loxley now has the same team ID as everyone else in the thieves circle.
    • Fixed: The BOS high elder is male now, as the dialog suggests (very likely protos swapped back in the days).
    • Fixed: "Gain access to the Glow"-quest now appears correctly when entering the location.
    • Fixed: "Restore power"-quest in the Glow now starting and ticking off correctly.
    • Fixed: Video titles in PipBoy archive.
    • Fixed: Can't steal from floating eye bots anymore. They also won't drop items.
    • Fixed: Boneyard gangwar (Kill Razor) questlog entry and NPC reactions.
    • Fixed: Rats would stop moving around after returning to a map.
    • Fixed: Cutscene subtitles / color .pal files.
    • Tweaked: If the player kills Garl in the fighting ring, Garl's items should be added to the beginning of the inventory now, and not the end.
    • Tweaked: Added the V13 medial locker back into the game, but changed it's position and adjusted NPC dialog accordingly. The "original" position was shit and won't return under no circumstances.
    • Tweaked: Increased big bike size by 1. Doesn't make much sense, but is better for gameplay I guess.
    • Tweaked: The Deathclaw from the missing caravan quest can now be encountered on the worldmap again (only if missing caravans quest has been started, though).
    • Tweaked: Armor stats to Fo1 vanilla.

    Other than that, the usual code fixes, redefines, cleanup, etc... didn't mention that in the changelog, because that would be blowing it out of proportions.

    Delete the alpha r548 folder first before installing the new alpha! Savegames won't be compatible anyway. Players have to start a new game otherwise stuff will be bugging out.
    Last edited: Sep 7, 2019
    • [Rad] [Rad] x 3
  2. Cerebro

    Cerebro It Wandered In From the Wastes

    May 6, 2007
    Thanks for the update, but there seems to be some issues with this release. I deleted the mod folder completely and did a fresh install. After starting the game, the intro of FO2 plays and the Vault cave walls are brown instead of blueish etc... Some files missing here?
  3. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Of course you still have to follow the installation instructions from the readme.

    1. Install FALLOUT 1 anywhere.
    The game is required to play the Fallout 1 in 2 engine conversion!

    2. Install FALLOUT ET TU into your Fallout 2 folder. The folder structure must look like this:

    3. Start the undat.exe and select the master.dat file from your FALLOUT 1 installation.

    4. Select the Fallout1in2 mod folder as extraction target.

    5. Extract the files.

    That's it. The game can now be played!
    • [Rad] [Rad] x 1
  4. Cerebro

    Cerebro It Wandered In From the Wastes

    May 6, 2007
    Ah, I'm stupid. Completely forgot about the Undat-stuff. Sorry. :oops:

    One thing that's happening to me though (since the first release) and maybe could be fixed: When leaving the Vault cave for the very first time after starting the game, it crashes to Windows. When I restart the game and load my save file from right before the cave exit, it works fine and I get to the world map.

    Error message has something to do with memory access violation. I tried to reproduce it to get the exact error code, but even though I started a fresh game without loading any save, it did not happen again, so it's inconsistent. Will write the full error code once I get it...
    Last edited: Sep 6, 2019
    • [Rad] [Rad] x 1
  5. Cerebro

    Cerebro It Wandered In From the Wastes

    May 6, 2007
    I just did a caravan run for the Crimson Caravan. First route (Hub to Boneyard) went normal, but after I decided to head back to the Hub immediately, the caravan encountered a group of raiders who exploded spontaneously for 999 damage without me ever doing anything.
  6. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Do you have the debug mode activated? That's just my cheat to get through it quickly.
    /Edit: Oh well, looks like the condition failed and now they are exploding even outside of the debug mode. I'll fix it..

    /Edit2: New version is up. Download link in the first post has been updated accordingly. Just download and overwrite version r713. Savegames are compatible.

    Changelog, because I didn't want to sort through stuff now:
    • Added: "classic worldmap" mod to primary files. Activate via ddraw.ini / check the Readme.txt
    • Added: The dead body of Kenji now gets deleted on map_exit if Killian is alive.
    • Added: If Kenji gets killed and player doesn't loot his inventory, it will be moved into Killian's store.
    • Fixed: Quick Pockets perk now reduces the correct amount of APs.
    • Fixed: More Glow tweaks. Polished "welded door" script that accidentally slipped in... now it stays.
    • Fixed: Caravan critters exploding on their combat turn.
    • Tweaked: Worldmap circle area at V13 and Necropolis looks a bit better now.
    Last edited: Sep 7, 2019
  7. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    playing rev.729

    Are there any particular reasons why:

    -Seth in Shady Sands now has a Leather Jacket in his inventory, in addition to the stuff he normally has?

    -Tandi and Aredash don't play their spoken lines nor moove lips?

    Pipboy Glow quest displays gain entry to glow quest despite player not knowing where it is, nor having the Brotherhood of Steel quest to go there? (still in Shady Sands)

    Night Vision perk is reverted to 1lvl +20% brightness level instead of 3xlvl +10% brightness? if it's hardcoded and can't be fixed than I'm absolutely ok with it.

    Seemes most of those changes were made when switching from Fallout1port to Fallout1in2 directory.
  8. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    I went back to revision 5 and it seems Seth always had a leather jacket in his inventory. I'm assuming this is a Fixt addition that somehow wasn't spotted since day 1. Interestingly, Seth is even wearing a leather armor.

    I haven't touched Night Vision perk except reverting it to Fo2 default. Pretty sure this perk can be fixed with Sfall, but I honest to god never used that perk ever since the game existed, and I don't really want to dig into it either. If someone else wants to adjust / fix the perk, go for it.

    About Tandi, Aradesh, the Glow, etc. this means your mod installation is broken. I just tried it directly from latest repo and everything worked. At this point I guess it's best to delete the files and redownload them, even as slow and painful as xp-dev is.
    Due to me testing that stuff and reverting to an earlier version... I've also broken my repo and are now downloading everything again. Very painful.
    Last edited: Sep 8, 2019
  9. jvs3

    jvs3 First time out of the vault

    Aug 24, 2019
    In the raider base there are still 3 raiders which drop leather armor (savegame attached).

    I also had the problem with Tandi (and Killian) having no spoken lines. Aradesh however did have spoken lines. What fixed it for me was rerunning undat.exe

    Edit: v0.724

    Attached Files:

  10. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    That's really damn weird. I have no idea why the armor wasn't deleted and so far in all of my tests the armors were correctly deleted. Ugh... will check it out again later.
  11. Cerebro

    Cerebro It Wandered In From the Wastes

    May 6, 2007
    By the way: That's the error I was talking about earlier. Happens when I install a fresh version and leave the Vault cave for the first time:

    When I load a save before leaving an THEN leave the cave, it doesn't happen again. Very strange...
  12. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Sadly these memory errors can mean anything. I have no idea why it is or could be crashing. For me it runs fine and I never have to reload right after game start. Something Sfall related could be causing this, but there is nothing that runs on map exit of V13. Could be related to our worldmap script, but then it would crash more often than just once at game start. actually no, the worldmap script starts right after you enter the v13 cave, so it can't be the issue here.
    Last edited: Sep 9, 2019
  13. Cerebro

    Cerebro It Wandered In From the Wastes

    May 6, 2007
    Just a small update, even if it doesn't help in tracking down this bug: I just found out that the memory error can happen everywhere. I downloaded the newest repo and loaded a save from the Hub. Switched city maps without problems but the error happened when leaving the Hub and entering the world map. So I guess it has something to to with the world map itself. (Loading the very same save file after the crash and exiting the Hub again didn't reproduce this issue. The game just crashes a single time after installing/updating new files - which is a good thing, I guess. :))

    Edit: Oh yeah, and another small thing: Too much information. ;)

  14. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Repo / dev branch needs to be taken with a grain of salt, because every update could require to start a new game. Most of the time this isn't the case (anymore), but it can still happen.

    The debug messages should be gone with the next commit.
    • [Rad] [Rad] x 1
  15. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    I have another Bug this time Fo2 engine related. Darek proposed a fix for this long ago for RP however it never were succesfull.
    the deal is:
    this is a party NPC that has armor equipped first time you encounter him/her on it's *base* proto:

    this is IAN on base proto thing is that proto has armor stats written into the proto (which is ok but only for base proto.) (also one could see that not all armor stats are back to vanilla. it wuld appear that base Leather Jacket explosion damage resistance was 20% instead now is 10% hence the bug with 10% there when no armor worn).

    Now the tricky part:


    This is IAN after first level up with no armor same armor bonnus backed in proto however this time is visible.

    and now the finale OP part:


    this is IAN after first level up with armor stats baked-in proto *and* wearing the leather jacket.
    those bonuses addup on anything else than basic proto.
    Additionally explosion resistance is 30 because there's 20% from proto (which was vanilla Leather Jacket explosion resistance plus 10% from what it is now).

    This is vanilla FO2 engine bug so called famous CASSIDY too weak on base level bug.
    Cassidy has no resistances baked-in to proto so on base level he has 0/0% on all resistances. to make things worse when giving him metal armor on base proto he changes thresholds and resistances only slightly ( for example normal to 2/10% ) as if His base Leather armor would count as base 0/0% and metal is only upgrade on top of it.
    this changes to display correctly when he levels up to level 1 and on all subsequent levels up to His final level.

    My proposal to fix this issue for Fo1in2 would be leave base protos of all armor wearing npc's (Katja,Ian,Tycho) as is. However change all the armor thresholds and resistances values of proto of leveled up Level1,2,3,4 for Katja,Ian and Tycho to 0/0% on everything except EMP since they're sepose to be immune to it.

    Additionally to fix Ian and Katja base proto no armor worn issue of 10% explosion resistance change Leather Jacket explosion resistance back to vanilla 0/20% and start a new game. This would fix it.

    As of right now when wearing any armor they're tougher than they're sepose to be on all levels besiedes the base one.


    Although this potentially would screw up the PartyNpcArmorEquip=0 option


    Next Bug:
    IN Fallout1in2 the sfall-mos.ini option enables to share player given perks to NPCs. It works for FO2 and Fo:Resurrection but it does not function for Fo1in2.

    for a look inside i took Awareness Perk and it isn't shown up in Ian's perk list scr00003.jpg
    Last edited: Sep 10, 2019
    • [Rad] [Rad] x 1
  16. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Shouldn't *all* (party member) protos be set to 0/0 because the armor is dealing with the resistances (unlike generic critters, where the armor is ignored)? I mean, if no armor is equipped... it should be 0/0 for them... and usually party members always wear some armor.

    If it's an engine bug, I guess it would be the best to let Sfall folks decide what to do about it? Don't really want to touch something that potentially could be fixed in better ways.
  17. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Problem with setting basic protos to 0/0% would cause all armor claded NPCs on their basic level (basic proto) to have 0/0% on all resistances while wearing their basic armor type and only get the difference between what they wear as basic armor to what they wear currently for example when cassidy switched from Leather Armor to Metal Armor His normal resistances went from 0/0% to 2/5% which is exactly what remains from metal armor decremented by Leather armor stats. the probelem is when cassidy drops Leather armor his stats show 0/0% as well as when wearing leather armor but it seemes the game does not show negative resistances values. Hence the bug and cassidy without armor takes 25% extra damage as in -25% damage resistances and -2 damage threshold for normal damage.

    I think the same will be the case with Fo1 party members in FO2 engine, as 0/0% for their base protos will be treated as if they wear their base armor. but It's easy to check. Change base protos with MrStalin's editor to have 0/0% on everything start a new game, go to Shady Sands and see for Yourself. this get's fixed once they reach a new level. Same as with Cassidy.

    and do not matter what i said earlier about breaking the game for people with out armor change mod. It will work just fine as loong as *base* proto remains with the baked in buffs and subsequent level protos will have the baked-in bonus removed.

    This on the other hand begs the question for easier acces to PA/HPA for whole team.
    Because after the fix it will be nessecary for the party to be of any kind of help.

    I mean the whole fixt iea of sneakiness and nimble fingers to acces armory is sort of silly. Wouldn't it be wiser to switch this acces for a legit one as a reward for quests (like disposing of jackals and vipers), or when wearing Power Armor simply to bullsht the guards that you are a Palladin and that you've returned from outside escapade with stuff to donate to the armory, or simply a way to trade with armory crates to exchange stuff that you have for those extra 2 Power Armors.

    Without baked-in bonus and no Hardened Power Armor Katja Ian and Tycho are shit weak aginst super mutants with miniguns. so there has to be a way to give them HPA. Miles on the other hand shouldn't hesitate to do the upgrade more than once. Perhaps some cash (i mean some caps) would make him consider to do it agin, and agin,and agin. 4HPA is all that's needed. Perhaps some more tinkering with party NPC critical chance and better criticals stats.
    I'd try 30% better criticals and 40% crit chance total for all of them to be end game viable.
    Tycho 40% crit chance base + 60% bonus from eye targetting would yeald 100% crit chance and a 35% insta kill chance. It's not something I'd set in stone, but rather just a loose disscusion.
    Last edited: Sep 11, 2019
  18. Mr.Stalin

    Mr.Stalin Mildly Dipped

    Oct 29, 2015
    You must first make sure that everything is good with the files, and then blame the engine for this. :)
  19. Darek

    Darek is currently unavailable

    Jan 7, 2008
    What? How was it not successful?
    I have admittedly not played the game in ages, so I haven't tested it much in-game, but looking at Cassidy's first proto in F2se it seems like it is working. The only thing I saw was that the EMP value for the base proto was wrong. Killap must have missed that if you stamp an armor on a critter that already has 500 EMP protection, the extra 500 does not get added. You must do that manually.

    It's obviously easier to just not equip the armors on the companions in the first place, and jut leave them in their inventory (like with Sulik), though that may not be desirable. Would probably work equip them with dcript on first map enter or something.
  20. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    Truth told, I'm not exactly sure how this works. Does a companion jump to stage 1 when you enter the map / meet him the first time? Or does that happen on first level up?

    Making them wear the armor on first map enter isn't a big issue.
    Then, base proto keeps armor values, stage protos will get 0/0 and then it will / should work correctly?