Fallout 1 mod Fallout Fixt - next release will be some time in Jan 2020

Discussion in 'Fallout General Modding' started by Sduibek, Dec 15, 2010.

  1. Mr. Deathclaw

    Mr. Deathclaw First time out of the vault

    Aug 19, 2017
    Alright, I'll give it a shot. I'll play it safe first and just wait by Thomas for awhile and wait to see if he'll start it. Thanks for the help!

    Edit: Waiting around for him to start the session did not work, I even left to grab a bite and came back, no messages in the message box. I may try that area save method you mentioned, of course I'll back up all my original files before replacing anything. I think the cause of this may be that I had to go stand in front of the mat IMMEDIETELY upon entering the BOS bunker for the FIRST time, so I probably just need a save file where the player has just entered the bunker for the first time. Hopefully this works, haha.
    Last edited: Aug 19, 2017
    • [Like] [Like] x 1
  2. Pwener

    Pwener FEV is the equivalent of a chest x-ray.

    Aug 15, 2017
    So I'm posting a follow-up on the bug I encountered where Overseer Jacoren would not initiate his ending dialogue where he justifies kicking you out (spoiler fools!).

    I'm posting it here in case it may be Fixt related. I originally brought the issue up in page 46 of the Restoration Project's official thread.

    So I was right, it was the speed of the game, or more especifically, the speed at which the Overseer walked towards you. I don't know if this was a Fixt issue having to do with the non-optional ENDGAME mod but after uninstalling Fallout 1 and Fixt and reinstalling everything again the dialogue initiates and the Overseer walks towards me at intended speed.

    Before he either started walking out of the vault from farther away than he should initially spawn or he walked slightly slower and this created a soft lock that prevented the game to end and the only option was to force close the game which I don't like doing.

    The issue happened to me while playing the game on Android (ExaGear) initially and very rarely the dialogue initiated. ExaGear does not run Sfall so game speed is the default 100 value. I moved the save to the PC and in 110 speed (FIXT default) it worked every time. I moved the speed down to 100 in ddraw.ini and it soft locked the very first time like it did in ExGear.

    Again, I think this was a bad installation of either the game or FIXT and I can't test it no longer because I have not been able to recreate the issue as now on ExaGear with speed at default the dialogue has triggered as it should in the last seven or so speedruns I've done.

    So in the future if anyone has this issue know that it is the Overseer's walking speed that causes the issue. You will know if his speed is messed if the Vault Door closes right under his sprite and he takes a few seconds longer to appear on screen from inside the Vault as well.
    Last edited: Aug 20, 2017
  3. Schezza

    Schezza First time out of the vault

    Sep 7, 2013
    @Mr. Deathclaw

    apparently I cannot seem to get the training to work as well.

    Admittedly last time I played F1 was 2014-2015, definitely not version 0.81. So either it's a newly introduced bug or it's bugged because I'm a bad boy and have smoking enabled - which should be default if memory serves.

    Yeah it still works in 6.7.3. even with smoking enabled. 0.81 is fucked up somehow, or I managed to bug out my game. Which I doubt. The fault always lies with the latest dev :P
    Last edited: Aug 21, 2017
    • [Like] [Like] x 2
  4. Pagan

    Pagan First time out of the vault

    Jun 21, 2017

    Great to hear your work on Fixt 0.90 is progressing well.

    I was hoping it would be the one last version with the original FO1 engine, though...before hitting the big 1.0 with the new FO2 engine.

    Keep up the good work!
    • [Like] [Like] x 1
  5. Sduibek

    Sduibek Creator of Fallout Fixt Moderator Modder

    Oct 27, 2010
    Various things, lol. I will be in touch as it gets closer to release time so I can have some folks test stuff before release. :) Right now the big one I could use testing on is the newest version of Sfall/ddraw -- I'd like to make sure it's as stable as the version that came with Fixt v.81 and doesn't introduce new bugs. Another one is trying to narrow down what causes those worldmap crashes.

    The resolution stuff is out of my hands, Mash would be the one for that, but he's been MIA for a while now :(

    @Schezza @Mr. Deathclaw @Pwener Thanks for the testing of bugs! Can you each add the details you've provided about your respective bugs to http://falloutmods.wikia.com/wiki/Fallout_Fixt_bug_reports please, that would be awesome. Especially if it's confirmed to work in a previous version like @Schezza mentioned.
    • [Like] [Like] x 1
  6. .Pixote.

    .Pixote. Antediluvian as Feck

    Sep 14, 2009
    This might be crazy conspiracy stuff, but Mash might not be walking amongst the living any more. I know he was moving to Tasmania/Australia a few years back, and I had his email contact and true name - but my email account has been lost with his details. Anyway after doing a Google search someone with his name came back, but that person had been killed in a car crash in Tasmania. I hope this isn't true, and I hope someone knows how to get into contact with him and alleviate my fears.
  7. Schezza

    Schezza First time out of the vault

    Sep 7, 2013
    Btw, you "scared" me when you've decided to put Fixt in its own folder. Looks and "functions" (not much use being able to open the original Fallout, is there? :P) cleaner now, just looks a bit weirder :P

    oh btw, was it always that Fallout doesnt have an uuh active window, not accessible through alt tab? Having it in the task bar, doesn't help either. Doubt it, since this is my first time that I had to create a WinActive Fallout script in my ahk :o What's worse, I set it to ctrl F4. Hope I don't get used to it and my brain screws up so hard that I press alt f4 at another game hahaha.

    You just had to mention worldmap crashes. You've just ruined my day. Had twice of those and I was like "oh shit, this shit is still here? Think that was the reason I stopped playing F1 last time."
    Only fixable by going to the menu and loading the game anew. Weirdest shit ever. I strongly suspect you'll only ever find out the origin if you record the game. And even then it might not be enough ^^

    But maybe since Quickloading and probably normal loading doesn't work as well, maybe it starts with a condition happening when you quickload before leaving the map? Is there even any technical difference between normal- and quickloading?

    Wiki Bug created. I would have liked to post the link here and ask people to try it out first, but as I've said, I trust in my and Fallout's engine and the blame will always be put on the latest dev :P Sorry mate ^^

    *rant start*
    Also, dropbox sucks. Registration mail doesn't go through like always ^^ but main thing that disappointed me was that right click doesn't work. Jesus, it's year 2017! Also error when resending the share mail. Two big fails... For some reason I can share stuff now. But you cannot share entire folders with everyone. Also you cannot share comments with everyone - not much point to it then... It's a comment, not a chat! Dropbox sucks big.

    I've spent 3 minutes and found 3 things that don't work like they are crystal-clearly supposed to. And that with a 500m company. Maybe I'm just a little spoiled brat, but every single Dev out there does so many stupid little things. And nobody seems to notice that with just a little editing, you could make it so much better. *rant end*

    Btw, do you remember ever fixing a price difference between clicking trading and asking someone to trade? It was a vanilla? bug, don't remember which npc. Maybe only one where you get a discount? Even after all those years, I'm still paranoid enough to double check those values :D And sadly, this round I'm doing atm - not even resetting the area helped - this son of a bitch, Jacob, in the Hub, wouldn't sell me his "brotherhood hammer". I only had one chance to buy it and I didn't take it, because I failed to predict the possibility that I had to use 2nd my last resort and get it as a quest reward. ^^

    What's wrong in the first place is, he has it equipped. And once you click Trading (not talk?), he unequipps it after you close the dialogue. And then, somehow, some way, if you either talk or click, you can somehow buy his hammer. First and last chance I had, I asked him some questions about himself first. I tried to duplicate this but it was impossible. It was like a global value in my exe file was edited and I can no longer buy that hammer, no matter what I do. Hilarious shit ^^

    It doesn't really need addressing, I'm just asking if you've ever dived down into these sort of trading bugs...
    • [Like] [Like] x 1
  8. Schezza

    Schezza First time out of the vault

    Sep 7, 2013
    @Sduibek - Nova said that just replacing the ini file should update sfall? Nothing else?

    Then explain to me:
    ;Set to 1 to speed up the hp/ac counter animations, set to 2 to update hp/ac counter instantly
    SpeedInterfaceCounterAnims=0 (2 is a new option/description?)
    How can it be that Crafty can add another option here? He must have edited another file for that somewhere, or he went over the source code again and was like, hey, there's another option available?!?

    Anyway, I compared 0.81a - sfall v1.19 with Crafty's sfall1 v1.7.27

    You probably did that already and I can shoot myself now, for making myself tired and eyehurting. But, at least I remembered to always check the config files for sweet options before doing a new playthrough ^^
    In any case, I urge everyone to do that before playing F1 or F2!

    There's some nice stuff to try out:
    • RELOAD WPN CHANGE Reloadreserve + AutoReloadWeapon=0
    • DISPLAY KARMA CHANGES - gosh, theres a reload wpn change, or a display karma changes? damn. this is "useful" for killing the ghouls in Necropolis.
    • ;Russian language encoding for character names and savegame descriptions. (for science)
    • AutoQuickSave=0 - runs all 10 slots through (for science)
    • [Debugging] (for science)

    Anyway, Crafty only changed some things and added some new things, so when you say "I could use testing on the newest version of Sfall/ddraw" - you do realize, that in order to test his changes, you actually would have to go through the list like I did and manually check, edit, change and test everything? :P

    Basically, everything where I didn't comment something, is completely new. Except maybe if I asked a question. In any case, I didn't include the [titles] which could be important. So, if I were to update my sfall, I'd have to search which category everything belongs to, again. Not to mention the new options that weren't turned on by default. If there was only a list comparer as good as Wikipedias???..... someone know something? Also, he's moved like 3-4 things around.

    Anyway, ignoring all the new comments(options) that Crafty added, the only FIX CHANGES (compared to my custom installation!) are as follows:
    ;Set to 1 to speed up the hp/ac counter animations, set to 2 to update hp/ac counter instantly
    SpeedInterfaceCounterAnims=0 (2 is a new option/description?)

    ;The initial speed at game startup
    SpeedMultiInitial=100 (was 110)

    ;The speed of flow of time in the game (higher - faster; valid range: 1..10; Default is 1)

    ;The modifier key you have to hold down to change any speed settings
    ;If set to 0 if you don't want to use a modifier key, or a DX scancode otherwise
    ;Set to -1 for either ctrl key, -2 for either alt key or -3 for either shift key
    SpeedModKey=-1 (was 0)

    10 speed slots changes, Numpad 0-6, whatever.

    ;A key (LShift) to press to toggle the highlighting of all items on the ground on the current map
    TurnHighlightContainers=0 (was 1 - very nice, I used that in F1 for the first time and actually found a never seen before hidden alien in the Crater :D )

    ;Time limit in years. Must be between -3 and 13
    ;Set to -1 to remove the time limit, and automatically reset the date back to 2161 each time you would have reached it
    ;Set to -3 (or -2) to remove the time limit, automatically reset the date and override fallouts function to return the correct year
    TimeLimit=-3 (isn't that in your custom install somewhere?)

    ;Prevents you from using 0 to escape from dialogue at any time.
    DialogueFix=0 (was 1)

    ;Choose the damage formula used to calculate combat damage.
    ;0 - Fallout 1 default
    ;3 - Fallout 2 default (checks for all ammo stats; require modified pro-files/use AmmoFile with a configured ini-file)
    ;5 - Haenlomal's Yet Another Ammo Mod (require modified pro-files/use AmmoFile with a configured ini-file)

    ;Set to 1 to prevent you from saving in combat except at the start of your turn
    ;Set to 2 to block all saving in combat
    SaveInCombatFix=0 (doh, haven't saved in combat in quite a while, but I haven't gotten to the dangerous parts yet, Followers vs Mutants, where you have to sniff out the dangerous ones ^^ - this is new as well, despite me commenting on it!)

    ;Set to 1 to force the player to play the idle animation when reloading their weapon
    PlayIdleAnimOnReload=0 (was 1)

    ;Set a number of milliseconds to idle each input loop
    ;Set to -1 to disable
    ;Set to 0 to idle only if other processes are waiting for processor time
    ;Set to 1 (or some higher number if needed, max 100) to prevent 100% cpu use
    ProcessorIdle=10 (was 1)

    ;Set to 1 if using the hero appearance mod

    ;Set to 1 to add additional pages of save slots

    ;Set to 1 to speed up the hp/ac counter animations, set to 2 to update hp/ac counter instantly
    SpeedInterfaceCounterAnims=0 (2 is a new option/description?)

    ;Modify the maximum number of animations allowed to run on a map. (Default is 21, and the maximum is 127)

    ;Set to 1 to remove the limits that stop the player rolling critical successes/misses in the first
    ;few days of game time
    RemoveCriticalTimelimits=0 (was 1)

    ;Prevents you from using super stims on a critter who is at full health.
    SuperStimExploitFix=0 (what exloit is this? as far as I know super stims only kill in F2? I suppose it's a "don't uselessly use resources "exploit"?" - but you can waste stims as well?...)

    ;Turns off the effects of drug abuse to prevent skill, books and perk gain exploits
    DrugExploitFix=0 (was 1 - yet I had no problem getting my stats down to 1?? bug?? However, I couldn't get perks with stat points from drugs. First time for everything, huh? :P)

    ;To set highlight color of NPCs not in your line of sight
    ;0=disable, 2=red, 4=gray, 16=yellow, 32=pink
    ;ColorLOS=16 (was 1 -> ;1= animated red (FALLOUT DEFAULT) -> apparently he forgot to include this)

    ;To set highlight color of NPCs not in your line of sight
    ;Set to 1 to remove "Friendly Foe" perk, but have the effect active
    RemoveFriendlyFoe=0 (was 1)

    ;Set to 1 to enable sale of earlier used Geiger Counter/Stealth Boy
    CanSellUsedGeiger=0 (OMGZ, HYPEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE - ofc this is new as well! Scanner???)

    ;Controls the speed of animation of time in pipboy (lower - faster; valid range: 0..127)

    ;Set to 1 to displaying reply numbers instead of dots in dialogue options
    NumbersInDialogue=0 (wut? - whatever this is, this is new as well. wait, do we only have dots? In any case, numbers would remind me of like Baldur's Gate. And the answers right now are beautiful. Dots are beautiful. Simple is beautiful.)

    ;Set to 1 for additional checks on a blindness and direct visibility in the engine function is_within_perception_.

    ;Disable internal credits


    ;Set to 1 to disable weapon animation (put away/take out) when searching containers and doing other stuff
    InstantWeaponEquip=0 (is in your customs; but yeah, if you haven't compared yet, you should probably know that it's active by default now. Or not. There's really no point in someone other than you comparing the lists :D)

    ;Russian language encoding for character names and savegame descriptions.
    ;1251 (1C)
    ;866 (Fargus)

    ;Assigns a keyboard button to switch russian language encoding in-game
    ;4 = Scroll Lock, 2 = Caps Lock, 1 = Num Lock


    ;Set to 1 to fix the issue with doors being able to dodge bullets.

    ;Set to 1 to skip the executable file size check

    ;If you're testing changes to the falloutw.exe, you can override the crc that sfall looks for here
    ;Sduibek testing version: 0xf43d208c
    ;Public release version: 0xf0fd4d53

    ;These option control what output is saved in the sfall-log.txt, the debugging version is required
    ;Prints messages duing sfall initialization

    + Keycodes​

    • [Like] [Like] x 1
  9. Sduibek

    Sduibek Creator of Fallout Fixt Moderator Modder

    Oct 27, 2010
    @.Pixote. That is very sad news if true :(

    @Schezza Thanks for all that info! I'm not aware of a way to fix the barter pricemod discrepancy between dialog vs Barter button in FO1, probably can be fixed in FO2 engine though. Other bugs please add to bugs wiki. :)

    You are mentioning Dropbox I assume because you tried to share a savegame with me? ( https://www.dropbox.com/request/G3k5A5dL65ZMD0jKNjoC )
    That is strange, the way I shared that folder it should be pretty much hands-free and not require registration. You should be able to just drop your savegame(s) in there and that's that.
  10. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Added some comments on old unfixable bugs as sfall 1.7.6 does resolve them also in ideas section added the freedom issue about opening some doors and lockers as fo1 only allows lockpick for that Fo2 allowed shooting the lock busting them with a penetrating kick and using crowbar from backpack to force the door to open... unfortuneatly no such option in fo1.

    Those are pesky ones especially in doc morbid's basement locker and doors behind wich is the BoS initiate in the Hub only lockpick works wich is annoying

    If You did not recive response to Pm You sent me write here this forum has a pesky habbit of eating up my sent pm's and never delivering them. I used to have this issue with Sduibek back in 2010 at least out of like a zillion PM's to Him only one reached Him and i got a response after like 1 year. However it did reach Him and that's why I'm listed as Brainstorming in credits :p yay :D
    Last edited: Aug 23, 2017
  11. Schezza

    Schezza First time out of the vault

    Sep 7, 2013
    aren't you a lucky guy. It will have taken me approximately five years to get listed. But not like I did much to deserve it. Also, nobody will ever give a shit about who is on that list. That's just how the world works ^^

    Anyway, I found that version here

    And despite knowing his name, I cannot seem to find a reliable source without google translate, where is 1.7.6?

    ddraw.dll.. the "new" one for 1.7.27 is 100 kb smaller than 0.81a. So, how the hell can I replace that without seriously damaging something else? :P

    And to view dlls you need a special program, which I don't just download for fun. So I have no idea what will be missing, but 100 kb, that's pretty game breaking I'd say.
  12. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    That was not to express my hapieness from beeing in credits but my anger from forum engine eating up my private messages in the past. It delayed some messages by 1/2 to 1 year back in 2010 and 2011. but it's not an issue now i sepose. Anyway I compared ddraw.ini from what You've provided and v1.7.6.

    Your version is definetly newer version i got 1.7.6 from dobrovik's archive : here

    Crafty removed some crc checks and version checksum swapping from the .ini so probably that's why new .dll version is slimmer in size.

    As for the difference between 1.7.6 vs 1.7.27:
    ;Choose the damage formula used to calculate combat damage.
    ;0 - Fallout 1 default
    ;3 - Fallout 2 default (checks for all ammo stats; require modified pro-files/use AmmoFile with a configured ini-file)
    ;5 - Haenlomal's Yet Another Ammo Mod (require modified pro-files/use AmmoFile with a configured ini-file)

    ;Allows you to edit the ammo data for DamageFormula, point at an ini file containing the replacement ammo data

    so AP ammo fix and YAAM support.
    I'll test today wether v1.7.27 works or not
    above all else:

    it seemes that @Schezza found even newer version of Crafty's Sfall for Fo1
    1.7.27 it's changelog hasn't been updated, however .ini file indicates some new functions like ammo modifier support and ammo mods support (YAAM). crc check and checksums swapping have been removed from .ini (and probably from .dll too so it's smaller) [it seemes it's a fresh piece of code properties say it's from 24.08.2017 from aroud midnight GMT 0].
  13. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    Crafty rewrote his sfall1/2 builds in pure ASM early this year, that's why their file size that small and support Win98.
  14. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Ok.. So i tried YAAM for Fo1 sfall v1.7.27

    The modifiers do get taken under account YAAM style but the ammofile does not replace pro-files seemes the pro-files only get to be used i ran a quickie to raiders and did some tests there 10mm pistol was a havoc with JHP ammo scoring 60-70 damage each shot. deagle did massive damage with jhp ammo and absolutely zero damage with FMJ no damage criticals to the eyes one by one were observed that's because JHP has DR modifier of 25 and FMJ has a DR modifier of -25. However YAAM treats DR modifier as DT modifier and reduces DR by 10% for every point of threshold that excedes oponent's armor. so the mechanic is working as intended but pro-files have wrong values -25 DR modifier turns in +25 to damage threshold for the enemy.This way no wonder i do no damage.
    Somebody would need to tweak those numbers
  15. Crafty

    Crafty First time out of the vault

    Apr 30, 2015
    Probably a silly question, but you copied AmmoYAAM.ini from config_files\ to the directory of Fallout and enabled it in ddraw.ini? :-p

    Btw, there is no advantage in using YAMM (or Glovz's Damage Fix for F2) in comparison with the original F2 damage formula (it's excellent) with good ammo data. The problem is that the ammo data (especially for AP) in the original pro-files is incorrect.

    Might have to prove that F2 damage formula with the good ammo data in pro-files (or via AmmoFile) works fine, but too lazy to describe it even in russian (and no one is interested).

    In general, I advise to use F2 damage formula with good ammo data (AmmoF2balance.ini, for both F1 and F2).
    Of course, talking about pure F1 or F2 (can be with RP). With mods/conversions (F2WR/Olympus2207/etc), which change or use their pro-files of the ammo it doesn't work (using AmmoF2balance.ini, but you can create your ini version).
    Last edited: Aug 25, 2017
  16. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Yes I have AmmoFile.ini both in copied folder inside fixt directory and file only in Fixt's root directory.

    However when playing this way, I did tons of damage with jhp ammo and none damage with criticals to eyes one by one using FMJ ammo 10mm AP ammo worked because previously I've set it to work the same way as 10mm JHP ammo (for testing purposes) within pro-files. BTW damage formula was set, and semicollon that is before AmmoFile.ini for coresponding formulae was removed.

    I have no idea why but it seemes that YAAM in Your Sfall 1.7.27 reads only pro-files but not the ini.
    That is not a big issue since I've already plowed through them and edited them properly using Cubik's tool F1wEdit or something like that.

    Anyway a eternal Thank You to You Crafty for doing this work.

    Also Could ou tell me wether this version of Sfall wil work in ExaGearRPG on Android?

    Exagear is software Binary translator arm<=>x86 + windows API emulation, in order to run windows programs on Android. However it does not support command line, so there is no way to tell ExaGearRPG to use additional .dll file for the Fallout1w.exe . Do You have an idea how to overcome this?
  17. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    This is how F 1.5 Resurrection rolls, custom proto files for ammo on top of original damage formula. Many unsuspecting dudes got shocked how brutally effective a solid burst of 14mm armor piercing bullets could be against power armor in Res..
  18. Crafty

    Crafty First time out of the vault

    Apr 30, 2015
    It's weird, I compiled the version with the test messages in sfall1-log.txt:
    pid=111, ac_adjust=0, dr_adjust=-20, dam_mult=1, dam_div=1
    0,44 Магнум об. (pid=111), ac_adjust=0
    The first line confirms that the used ini with ammo, and the second is that these data are processed in DamageFormula (3 or 5).

    You are welcome :)

    It works with Win98 after you edit the .exe file - look in Windows98.txt from the archive. Perhaps this will help in this matter.
  19. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009

    If that is the case than weird, i remembr AmmoFile.ini for .44 magnum FMJ had dr_adjust of 4 or 5 for Yaam.

    it can't be -20 or no damge will be done based on the formulae. it treats dr_adjust as dt_reduction so a positive number reduces damage threshold (and negative adds to damage threshold) [at least for YAAM] dr_adjust of -20 would add 20 damage threshold on to what critter already has per bullet. rendering damage threshold of APAmk.II providing that enemy wears leather armor wich has 2 DT on normal damage. the total DT would yeald 22 and .223 FMJ from hunting rifle nor .44 magnum FMJ from deagle could do any damage aginst it. However using Fo2 native formulae could work in this case.

    As for Win98 support I was aware of it at the time of writing previous post. The question is wether it will work in ExaGearRPG. I sepose I'd have to check it out by myself. Is there any Hex editor preferred for the job? AFAIR Hex editors won't show ddraw.dll nowhere, only everything in hexadecimals. Or did You mean ASM? Sorry but if You ment ASM than I'm not *that* experienced to perform such stunts.

    Best Regards
  20. Crafty

    Crafty First time out of the vault

    Apr 30, 2015
    This is just an example of how the strings will look like (with values from the AmmoFile that was used at the time of copying).
    For AmmoYAAM.ini it should look like:
    pid=14, ac_adjust=0, dr_adjust=0, dam_mult=3, dam_div=2
    pid=29, ac_adjust=0, dr_adjust=0, dam_mult=3, dam_div=2
    pid=30, ac_adjust=0, dr_adjust=4, dam_mult=1, dam_div=1
    pid=31, ac_adjust=0, dr_adjust=0, dam_mult=3, dam_div=2
    pid=32, ac_adjust=-20, dr_adjust=0, dam_mult=3, dam_div=4
    pid=33, ac_adjust=0, dr_adjust=8, dam_mult=1, dam_div=1
    pid=34, ac_adjust=-20, dr_adjust=5, dam_mult=1, dam_div=1
    pid=35, ac_adjust=0, dr_adjust=0, dam_mult=3, dam_div=2
    pid=36, ac_adjust=0, dr_adjust=4, dam_mult=1, dam_div=1
    pid=37, ac_adjust=-15, dr_adjust=20, dam_mult=1, dam_div=1
    pid=38, ac_adjust=0, dr_adjust=0, dam_mult=1, dam_div=1
    pid=39, ac_adjust=0, dr_adjust=0, dam_mult=1, dam_div=1
    pid=95, ac_adjust=-10, dr_adjust=0, dam_mult=1, dam_div=1
    pid=111, ac_adjust=0, dr_adjust=5, dam_mult=1, dam_div=1
    pid=121, ac_adjust=0, dr_adjust=2, dam_mult=3, dam_div=2
    pid=163, ac_adjust=0, dr_adjust=0, dam_mult=1, dam_div=1

    Any, i prefer hiew.