Fallout 2 mod Last Hope mod V1.082

Discussion in 'Fallout General Modding' started by Forgotten Knight, Oct 9, 2006.

What do you like about this mod?

  1. Quests

    0 vote(s)
  2. Locations

    2 vote(s)
  3. Both quests and locations

    14 vote(s)
  4. I'm new to RPG concept, i have no idea what i'm doing but i like it!

    3 vote(s)
  1. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    Thanks for bringing this topic back to life. I think i did map edges on more than one occasion or i guess i should say spent more time than i want to remember. Anyway, thanks for having fun with this little sidequest so people can have more resources to choose from and find what's more useful for them in game.:ok:
    • [Rad] [Rad] x 1
  2. Muttie

    Muttie It Wandered In From the Wastes

    Oct 9, 2017
    I actually think this mod deserves more attention. It's just so hard to find the time. I only managed to play the first two hours yet. As with any mod, really. Playing Fo usually starts as a break and then ends up in work (aka bug reports, notes, guides, opening files etc.), lol. Well, that's fun, too ;).

    However, regarding map edges I found one that was rather weird:

    - Bug: On the second map in Wasteland Forest (station), I can enter the mountain-wall in the east. Either by clicking on the mountain or the space behind the door in the mountain surface (if close enough). In addition, the south-east part (that's east of the well) is oddly inaccessible.

    I also found some other bugs:

    - Bug: In the building of the prison administrator is a kitchen table with a food ration pack and an iguana (whole). When I select “take all” the items disappear. At first I thought this is Hunger. However, apparently Iguanas can't be eaten, plus Hunger seems to work differently (i.e. it checks every 30 minutes). So I retried. And the items appear to be bugged. When I try to select them individually, it says “maximum weight capacity”, although I should have plenty of room (175 lbs).

    - Bug: Whenever I encounter a WP patrol & Radscorpions, the patrol attacks me. In any other case they don't (i.e. they fight the rats, geckos or bandits). Only with rad-scorpions they'll ignore the critters and target me. Happened every time so far. (Confirmed, http://www.filedropper.com/slot202scorpion, this one is unfortunately in combat. However, I did nothing, but save once I had a chance. The WP patrol attacks me, and the scorpions are passive). Anyway, this should be easy to reproduce as it happened always so far.
  3. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    That's an understatement. This mod stand shoulder by shoulder with Resurrection 1.5 and Fallout:Nevada, (although, harder and buggier) but it doesn't have 10% of their coverage.

    I wish i could write a walkthrought, but i sadly won't have much time for at least the next 18 months.
  4. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    Sweet, more radroaches(bugs) for dinner! Ate all of them and uploading the remains asap:mrgreen:
    Bug 1&2 required map changes, these should work for new game or if area has not been visited yet. WP patrol & Radscorpions should fight each other now, no need to start a new game for this change to take effect.
  5. _Pyran_

    _Pyran_ Still Mildly Glowing

    Jan 31, 2017
    - bug?
    Canvill's Dead Claws Cave:
    How to complete this quest? There is no exit grid.
    All the claws of death are killed. Jerry is alive and dynamite appears in the inventory.
    (from text) Dynamite should be given only at Jerry's death?
    (from mapper) But I do not see the script responsible for the ability to exit.

    And edge & maps fix for LH 1.082
    Last edited: Apr 7, 2019
  6. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    There's one detail you missed, message displayed if you decide to kill deathclaws and enter the cave:
    "As you enter... suddenly the cave roof collapses behind you. Tons and tons of rocks are now blocking what appears to be the only way out. If could take days or much more to dig through... if you survive that long." Exit grid is now blocked and there's no other way out. Sure it would be convenient to have an easy way out for every situation but not this time :cool:
    :deal: Thanks for updates.
  7. Muttie

    Muttie It Wandered In From the Wastes

    Oct 9, 2017
    I found two more rather minor ones in my notes:

    - Bug: The Wasteland Forest overlay map has an error. First it's spelled “repear” not “repair” and second the map description for “Station” and “Car Repair” are swapped (i.e. clicking on station takes to car repair and vice versa). So it needs to swap the names around.

    - Bug: See http://www.filedropper.com/holyquestion. When I select the highlighted question (Can I ask...) it just ends dialogue. I guess, it skips a reply like: “No, child, just bring me those flowers.” which then ends dialogue. Or it's because I already received the books, and the dialogue just stops. Either way it's oddly abrupt.

    The rest I have is more esoteric, and I need to play it more first once I find the time.
  8. _Pyran_

    _Pyran_ Still Mildly Glowing

    Jan 31, 2017
    Thanks for answer.
    • I saw this message.
    • I killed all the claws.
    • And almost the entire squad survived.
    • No exit?)
    If I understand correctly: This trap is a dead end; The author's idea. But maybe make an opportunity to get out?
    Why then need dynamite in the cave?
    And this text #a078.msg
    {102}{}{Those fucking deathclaws... (Coughs) They heard us while we were going into the cave... Made an ambush. (Cough)
    The whole damn place is full of them... Our guns were too weak. I tried... (Cough) Couldn't run for it, the bastard
    was too fast... (he's still alive but his breath becomes shallow. He struggles to speak)}
    {103}{}{Wait, stay with me Jerry! What can i do?}
    {104}{}{You... (Cough) must stop them... uh, take my backpack... one explosive charge should be enough... place it ghhh...
    (Coughs, he passes out...)}
    {105}{}{Hang on Jerry, don't you fucking die... shit!}

    {110}{}{(Exit.)} replace on {110}{}{(Let's go)}
    And ... with permission, I want try to redesign maps "fermers town".
    Last edited: Apr 7, 2019
  9. Muttie

    Muttie It Wandered In From the Wastes

    Oct 9, 2017
    I decided to post everything I've written down so far, however, I'm not particularly comfortable with this as I played for only a few hours and my comments are probably not always on point. However, I don't know when I find the time to continue, and rather than letting several months pass I thought it better to mention the few things I've noted down now. So I spend two days editing my notes (to make them more comprehensible (and not just longer), I hope), tested a few points a little more and played a bit further.

    The document, plus a few save-games: http://www.filedropper.com/lhfeedback
  10. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    Did you installed the mod in a subfolder of a VANILLA version of Fallout 2 ?
    Most mods have issues with the restoration project.

    About food\water, they are consumed automatically in this mod.
  11. kbear

    kbear First time out of the vault

    Apr 22, 2019
    -get alert about cave in
    -killed all the claws
    -got dynamite from wanderer
    -dropped dynamite at every beam and pile of rock but nothing
    -tried to "use on" with dynamite on every beam but nothing
    at this point i don't know if im missing something or its just the game messing up.
    there needs to be some form of alert or hint because now im just dropping dynamite anywhere.
    if you have done this quest can you tell me exactly what to do. like exactly where to plant the dynamite or which wall to punch 24 times.
  12. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    Hello, please don't hurt yourself:smile:
    It's a dead end. You need to let Jerry go by himself. Later you'll find him lying on the ground, badly injured, just outside the cave entrance. You need to attach the explosive charge on the support beam outside. So far this is the only solution for this quest.
    killjoy for sure.
  13. kbear

    kbear First time out of the vault

    Apr 22, 2019
    So i came across a bug with Philton and finding Reds girl i explored the areas and talked to a lot of people before taking taking the quest to find her. i searched her shelves and there was only a flower. i checked with previous saves with no interaction with the town that it does appear, but just not sure why it hasn't after doing some stuff. i talk to red after taking the quest and the quest to get money off him and i only have two dialog options.
    one asking about money and saying i haven't found her. asking for money and then not starting a fight and talking to Eric leaves me no option to tell him red cannot pay. so i cant finish Reds quest or Erics . . . . should i load a much earlier game or can i still finish the game without finishing these quests?
  14. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    Red's (former) bartender Jackie left a note, in the same wooden bookcase where you find a flower, which you need to hand over to Red personally.
  15. kbear

    kbear First time out of the vault

    Apr 22, 2019
    I know that it is supposed to happen but it doesn't. after taking the quest from red it doesn't spawn the note in for some reason. like i said only the flower is there once the quest is active no note. i have completed the quest in a first time visit to the town.
    also i get a crash when my mouse goes over the eye scanner and the door of the building out the back of matthews place (i have tried on first visit with no steps walked in town)

  16. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    I did some testing with your save file, note shows up every time:
    1.First time visit, quest active:
    2. Second time visit, quest active after first visit:
    3. Retinal Scanner is actually fine, but the door itself had an old piece of code that doesn't get recognized by new compiler. Attached script Door1.int should fix the problem.

    Edit: Uploaded new Door1 script, this one should work better. No crash when used in a "regular" way.

    Attached Files:

    Last edited: Apr 29, 2019
  17. kbear

    kbear First time out of the vault

    Apr 22, 2019

    thanks for the quick reply. no matter how many times i tried it it didnt work so i gave up and just started from a previous save.
    -where do i put that script. . . . (sorry no idea about this haha)

    also any hint as to how to find Scott (quick go here then here do this and that talk to this person). . I read that if you get to canville that you can find Scott, but i've done all i can do in canville (part that causes explosions, deathclaws, the farm problem even though no one gave me that quest and could talk to anyone about it) i have no idea what quests progress the story line and those that just waste time. how important is it to get Scott before the time runs out.
    also with so many important things costing so much money and killing robbers results in no items dropping, how does someone make enough money to pay for all the stuff.
    also if possible hint to the circuit board locations?
    also where can i find the shovel for the old dude in farmers?

    thank you so much for this.
    also not sure if i have said already but seriously good mod! i was a little unsure but i do really like this game!
    Last edited: Apr 27, 2019
    • [Rad] [Rad] x 1
  18. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    Unpack it in your fallout2 mod folder e.g. ...\fallout2\data\scripts overwrite/Y
    You have to at least visit these locations:
    - Miners Town
    - Farmers Town
    - UMB
    - Golden Valley
    - Duntown
    - Philton
    - Abandoned Base
    - Silting
    - Canville

    When all areas have been visited, this guy in Canville will take you to Scott, but first you help him:
    find scott.jpg

    shovel for oldie small.jpg
    Cornfield just outside his house.
  19. kbear

    kbear First time out of the vault

    Apr 22, 2019
    It no longer crashes when the cursor goes over the door anymore but it does crash when you try to open the door with he hand icon.

    Also come across another bug/glitch in Golden valley with the sheriff and being able to claim the 1500xp after the basil quest and if you do that quest before the drunk guy, after putting him in jail the sheriffs dialog and reply options are what the drunk guy says and cannot finish the quest.

    I cant steal the slaver inventory book even with a skill level of 95, it just says you have failed to use your steal skill. ( tried over 30 times )

    Struggling to find Dunton, is it a location i can find or do i have to be told about it? ( i have already been asked to get uranium and i'm guessing i get it from that location)

    The quest for the chip for Canvile mine: is there the one chip that causes the machine to explode or is there another one to get?

    Am i supposed to let the 4 months pass to progress the story line or is it recommended to find him by that date?

    Billys book: i know its in the cave with the rats but i cant see a book? is it really small or well hidden but still a normal image for books?

    is it possible to add the item highlighter mod with your mod?

    Just curious if you are still working on future updates for this mod or if i'm just annoying you with questions on an old project. . if so i'm sorry haha

    How did you learn to mod fallout?

    Sorry for the long recurring questions, its just when i start a game and like it i want to be able to finish it and i don't want to give up on this game
    • [Rad] [Rad] x 1
  20. Forgotten Knight

    Forgotten Knight Time traveler stuck in time... Modder

    May 24, 2006
    I uploaded new script, earlier reply, this should work at least longer :)

    I did both quests in the same order and checked the script, i can't find what's wrong. If you have a save game with that bug, that may help, other than that must be a glitch in the matrix.

    At your current skill, you have a slight chance of success.

    It's the power plant
    just north of Golden Valley, Eddie from Philton marks this location on your map when you do this quest: Deliver data disc to Leonard to provide Philton with more power.

    Have to check this one later.

    Administrator gives you 4 months to find escaped prisoners. Be sure to return before to reset the timer.

    It's down in the mine, behind the trash can.

    New versions of sfall support this feature. Older version, such as v4.0.1 requires separate script file gl_highlighting inside mod scripts folder. I will update sfall with next mod update. I don't recommend updating sfall in the middle of game play, it may corrupt save game files or cause other errors.

    Yes i'm still in modding business. I have unreleased content for two other mods i started working on years ago, atm they's collecting dust on the shelf.

    Did some coding for fun... had the time and will to fix game developer mistakes, that's how modders are being born.

    You'll finish it, or start modding and then we'll fight them bugs together:mrgreen:
    • [Rad] [Rad] x 1