Fallout 2 mod Megamod version 2.46 Bug Reports and Suggestions - Closed

Discussion in 'Fallout General Modding' started by MIB88, Jun 25, 2014.

  1. alatari

    alatari First time out of the vault

    90
    Sep 4, 2007
    Questions about the Masticator bout

    So it seems that if you go below 0 HP in the boxing matches you actually die so Mega Mod boxing are death matches. No rematch if you lose.

    I beat the first 3 opponents by knockouts but I knocked out the Masticator 13 times (he was laying face down when the ring announcer declared my victory by 120 points to 108 points after round 12) and I killed him with a blow to the face 6 times. He always got back up and came after me on his 2 crippled legs and 2 crippled arms.

    I was using the regular boxing gloves and not the steel plated ones. It was an 90 minute long match in real time.

    Is this the way the match was intended to go in the Mega Mod?
     
  2. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Got it! Thank you very much. Yeah, something I had known but forgotten: anything that is in the city.txt must be in maps.txt or the game will crash... but the rule does not work in reverse. In order to add a number of new locations from the RP, I had to take out location names from maps.txt that were planned for my future inclusion of the Dominion mod. All good now. :ok:

    @alatari
    I never specifically changed anything in the MM regarding how boxing works. I've only included fixes from @killap. But... I wonder if one of the global scripts (hs_combatdamage) may be preventing boxing from working as it should? I've never seen an error like that, since I always use the plated gloves and go for the knockout.
     
    Last edited: Mar 6, 2016
  3. France

    France First time out of the vault

    6
    Mar 1, 2016
    Hello guys i have problems with car. When im bringing to Smitty fuel cell controller and tell him to put it in. Apperas black screen and nothing happens after. I can her music and effects but black screen keeps standing.
     
  4. ravenbober

    ravenbober First time out of the vault

    9
    Jun 26, 2014
    So, I little bit not understand about fresh actually version. Is it 45.3 or 45.4?
     
  5. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @MIB88
    Good. :cool:

    @alatari

    OK I'll try to explain it again as simple as I can.

    When you have sex with someone the game rates how good you were by using the obj_sex_rating formula.

    That formula is (Ch*50 + En*25 + AG*13 + St*12)/100 + (2 if Karma Sutra master) + (1 if Sex Appeal) + (2 if sex god), and will give you a score between 1 and 15.

    That score is added to the global_var 194 (GVAR_PLAYER_SEX_LEVEL) every time you have sex, and once the sum reaches 100 or you get the porn star reputation (whatever happens first), you are considered a sex God. The sex level is hidden so you will not know what it is unless you use a save game editor to check what value global variable 194 has. Sex God is not a reputation or perk, nor is it ever mentioned in the game. It is just a term the developers used when they were working on the scripts, as it is shorter to write "is_sex_god" than "((global_var(GVAR_PLAYER_SEX_LEVEL)>=100) or (dude_has_porn_star_rep))".


    The score you get from the sex rating formula can be categorized as follows:

    sex_rating_great (9)
    sex_rating_good (7)
    sex_rating_normal (5)
    sex_rating_bad (3)
    sex_rating_horrible (2)


    To pass the porn star audition and to become a Gigolo, both requires that you get a great sex rating (>=9).
    Passing the audition should automatically make you a Gigolo, as the requirements are the same.
    Being a Gigolo does not give any extra points to the sex rating formula, nor does it guarantee that you pass the audition, as you could have used stat enhancing drugs while becoming a Gigolo and not using it for the audition.

    The sex rating system that goes from horrible to great was meant to be used in connection with the people you have sex with, as in they would comment on how good or bad your performance was. This is sadly not used much at all. Billy, Sheila and Franki (can't sleep with him because of a bug) in the Den, and then Mrs Bishop in New Reno are the only ones that uses this as far as I'm aware. Billy in particular is funny because if a female has bad sex with him, he will throw her out of the room and lay down on a mattress and finish it off by himself. :lol:

    One thing I'm not sure you are aware of is that after having sex in the Cat's Paw, you can get temporary Agility and Strength stat boosts (lasts for 1-2 hours iirc). That could have screwed up your test results a bit if you didn't pay attention.

    Another thing to consider, the added sexual encounters in the Megamod may or may not have included the sex rating and sex tracking code.
    I don't know and can't be bothered to check, but it is possible that sleeping with some people just don't count.
     
    • [Like] [Like] x 1
  6. phobos2077

    phobos2077 Mildly Dipped
    Modder

    596
    Apr 24, 2010
    What's the issue about checking item in the active hand? Sfall function active_hand returns the active hand for PC, and all NPCs ALWAYS use one hand slot (right hand, AFAIK).
     
  7. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    @phobos2077
    No, the issue was regarding the inactive hand.

    @ravenbober
    I repack everything from time to time. And then I release smaller patches as things get worked on so that people are not having to download everything each time.
    The latest full version was 2.45.3. Add those files first. Then add the 2.45.4 patch after that.
     
    Last edited: Mar 8, 2016
  8. alatari

    alatari First time out of the vault

    90
    Sep 4, 2007
    I'm grateful that you explained it "as simple as you can" cause ya know mister, I ain't too bright. My poppa paid for my physics and math degrees. I didn't do a lick of work. Just bought all them answers and paid someone to take the Quantum Electrodynamics and Partial Differential Equations tests fer me.

    The character rested until any stat changes from the Cat's Paw wore off before taking the audition with only 1 Buffout after getting Gigolo. Before getting Gigolo it took something like 3 Buffout and 2 Psycho and that led me to the incorrect conclusion. (Now that I have the +1 CH shades it should be a snap).

    So you are saying it's incidental that the character had the Gigolo perk as what really changed is that he gained the 100 level of GVAR_PLAYER_SEX_LEVEL after several sex instances that actually used the formula and added to the global variable. He had already broken 100 sometime previous to getting the Gigolo perk. This would explain the random amount of attempts that it took to get Gigolo on different saves as it would happen once the character got a sex session that ended with +1 AG AND +1 ST after the GVAR_PLAYER_SEX_LEVEL had broken 100.

    (Ch*50 + En*25 + AG*13 + St*12)/100 + (2 if Karma Sutra master) + (1 if Sex Appeal) + (2 if is_sex_god).

    So on the Wiki the Gigolo article needs the above obj_sex_rating formula with an explanation that every time the character has sex they are checked against the formula and they break 9 they gain the Gigolo perk. And that the formula and test is the same as the porn audition. Also, that the GVAR_PLAYER_SEX_LEVEL is a constantly being added to with a value of 1 to 15 and eventually adds a +2 to the formula from a sex_god status.

    Leslie Anne Bishop's responses did change and the last time she said it was wonderful from the previous of something about "it wasn't great but it relieved the stress of daily life". Never noticed Shiela's comments. I'll check it out in a save game and when the character heads back north to the Abbey.

    My guess would also be that sleeping with the Widow in Arroyo, Emily in Klamath or Liela in Colly are probably not adding to the hidden counter.

    What save game editor is preferable?

    Your explanation is appreciated and I'll modify the appropriate Wiki pages.

    EDIT:
    OK I modified three pages at the Wiki. Would you please check to see if the new information is correct?

    Leslie Ann Bishop
    Gigolo
    Golden Globes
     
    Last edited: Mar 11, 2016
  9. alatari

    alatari First time out of the vault

    90
    Sep 4, 2007
    Keep trying from a couple of save games and eventually it works.
     
    • [Like] [Like] x 1
  10. alatari

    alatari First time out of the vault

    90
    Sep 4, 2007
    That's the thing. I knocked the Masticator out so many times I lost track. If I clicked the end combat button then he would just stand back up and the fight would continue. It worked on the previous 3 fights so it's just scripts dealing with his fight. If I'd used the plated gloves the knockout wouldn't be any different but I might have been able to deal 150 HP needed to eventually kill him by points.

    New Reno
    --------

    Encountered this week was in a dialog with Wrights' son in the train station who wears black leather jacket. The middle response just says "ERROR" and clicking it leads to two choices that both read "ERROR". This is after a discussion with his mother who is going to meet my character in front of Tully's chapel in the morning and having just accepted the Richard's death quest but before talking to Renesco or Jagged Jimmy.

    NCR
    ------
    If you say "Bite me" to Hoss in the Cantina on the first dialog then the game crashes with error "The instruction at 00455bc8 reference memory at 00000215. The memory could not be read from. Press OK to terminate" I'm on Windows 8.1 now and a different laptop.
    If you don't start the fight till the second dialog options then no crash.
    Hurting him, knocking him out, nor pulling a gun doesn't end the fight where he concedes but if you cripple an arm he'll run away. When you talk to him again it just starts from the beginning with him insulting you and if you refuse to fight you just lose 10 karma over and over again.
    Tandi isn't likely to say anything about taking care of her son. I'll see if I can get past that and still do her mission.
     
    Last edited: Mar 11, 2016
  11. Tocotron

    Tocotron First time out of the vault

    5
    May 12, 2010
    Hey guys,
    i'm unfortunately also stuck with the temple of trials crash. Whenever i finish the temple/am a pussy and skip it by saying "sorry Klint", the game freezes & crashes during the video (or shortly after, if i skip it.) I also had the "unable to save game"-error, which i fixed by moving the files from Fallout2/data/Data up to Fallout2/data.

    I'm running Win7, got a clean GOG-installation, copied the 45.3 files, copied the 45.4 files, deleted patch000.dat, ran process2.bat, ran RunMe, double checked the read only at the proto files.
    All to no avail :(

    Any suggestions? I'd really like to play the megamod because it offers more new content than the restoration project - and i've been playing fallout 2 for 15 years, so i really want the new stuff!!

    Greets :)


    EDIT:
    Okay guys, just fixed it by doing a fresh installation and placing the missing (why the heck is it missing anyway?) msvcr71.dll file (which i downloaded from a .dll-site prior) in the Fallout2 folder BEFORE running the process2.bat.

    Maybe this is helpful to someone.
     
    Last edited: Mar 11, 2016
  12. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Hehe, yeah that is totally how I meant it :wink:

    Yup, that was what I was saying. Your Wiki modifications looks good to me. There's just one minor thing that I'm not sure is worth changing, Leslie Ann Bishop only reacts to great, good and bad sex. There are no checks for normal and horrible sex in her script, so there will be no specific dialog about those two.

    The best editor is the Fallout 1 and 2 save game editor (F12se), though I prefer the older version (F2se) because it has a hex editor built in. You can get them from here.
     
  13. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    @alatari
    My continuing thanks for the bug reports.

    Still unsure what is the deal with the boxing, though...

    I will make sure to add these new encounters to the hidden counter.

    EDIT: I checked these scripts. The variable was being set with Emily and Shania, but not with Leyla in Colly. I will add it to Leyla's script.

    I will include it in the readme file and the next update. Thank you.

    And, speaking of the next update:
    It is almost ready to go. I really wanted to fix the issue with Marcus not joining your party before I release it. I needed to add a critter and a script to the Broken1 map in order to make sure the quest regarding Chad can be completed. However, I have run into another snag. If anyone has any ideas then I am all ears. I have a few maps that just refuse to be opened in the mapper. I'm just not sure what is going on. I've had issues opening up maps from other mods. That makes sense to me, since I may not have the scenery added in the MM. But, these are my maps. I have modified proto files before, and have still been able to open up maps. So I really am really just stuck. Broken2 opens for me. In fact, I can't get my Broken1 map to open, the one from the RP using another configuration for the mapper, or even the original unmodded one.

    @NovaRain's suggestion to change this line "art_cache_size=256" in mapper2.cfg in another post did not fix the issue.

    Any ideas?

    EDIT:
    @alatari
    I looked at the dialog and script for Chris Wright in the train station. I can't find anything wrong. Just out of curiosity, what is the date for ncchrwri.msg in the dialog folder?
    I'm starting to think that version 2.46 is going to have to be a full repack...
     
    Last edited: Mar 12, 2016
  14. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @MIB88 and @alatari

    I've fought the Masticator several times now (using normal gloves), with many insta kills and knock outs, and every time I have won the fight when my turn is finished. It seems strange to me that there would be any script problems here, hook scripts or otherwise, as then it should happen to everyone, or at least to more than one. Just speculating here, but maybe this is a freak accident with some improperly set death flag and the Masticator's critter_state_states refusing to be updated.

    // critter_state States //
    #define CRITTER_IS_NORMAL (0)
    #define CRITTER_IS_DEAD (1)
    #define CRITTER_IS_PRONE (2)

    The game normally ends the fights when a critter is prone (or destroyed in procedure destroy_p_proc if dead). But what if the critter state got set to critter is dead while some other flag didn't get properly set, thus leaving him in Limbo as half dead instead of killing him. Maybe he can't be killed or change his critter state under those conditions. I mean the Dude can get flagged as half dead and I seem to remember it also happening to companions, but not sure about that. If the bug can't be reproduced it's as good an explanation as any...


    I also looked at Hoss and I had no errors from his dialog, but it does crash every time I pull a gun and then pass a turn.
    It's because of a Lvar mixup in "procedure dude_pulls_gun"

    if (obj_item_subtype(LVar0) == 3) then begin should be if (obj_item_subtype(LVar1) == 3) then begin
    and
    if (obj_item_subtype(LVar3) == 3) then begin should be if (obj_item_subtype(LVar2) == 3) then begin

    I'm not sure what changing this code tried to achieve.
    Anyway he does surrender when his health goes down to 1/3 of his starting health or you pull a gun.
    It's a bit silly that he can flee without surrendering, so I would recommend adding a critter_is_fleeing check in a combat_p procedure.
    I would also make a critter_is_prone check so he surrenders when knocked out. killap did the last part iirc.

    Also, the bartender gives you a free booze for beating up Hoss every time you talk to him, need a check there.


    About Chris Wright, ncchrwri.msg is missing from the MM and there are no 500 - 505 lines in the vanilla .msg file, hence the ERROR.


    MIBB88, when you say you can't open Broken1 from RP and vanilla, what game files (master.dat and protos) are the Mapper using then?
    I mean if you are using the appropriate sources for the map in the mapper, it should open just fine, right?
    So if you would install a clean Megamod 2.45.4 and link the mapper to that and then start to add updated files (checking modified date may be helpful) to that installation a few at a time, it shouldn't be too hard to find out what's breaking the map. I know you know this already, but saying it anyway as I don't believe you will find an easier and faster way to fix your problem.
     
  15. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    @Darek

    Thanks for all your help. I'll make those changes and/or additions from Killap's files. Not sure how Chris Wright's dialog went missing.

    Maybe I wasn't clear about opening Broken1.map. I meant that I can open NO Broken1 maps. If I remove all data files, I can't open the vanilla map. I keep multiple mapper.cfg files and different folders for the MM, RP, and others (mostly previous versions of the MM). I just rename the .cfg file when I want to tinker with a specific folder. So, the maps and protos are all different and use whichever data files were for that mod/iteration. I can't open any version of Broken1.map from whichever configuration I use. It's like all Broken1 maps are corrupted across my entire hard drive. And, it isn't just Broken1. There are a few others. But, for the most part, most of the other maps open without any issues.

    But, who knows what corruptions have snuck in over the years? I haven't "installed" the mapper or the game in ages. I just copied all the files to an external hard drive and play and modify from there, taking it to whatever computer I have accessible. Been doing that for... a while. Seriously, I don't think I've done a clean install since the Megamod was version 2.0. I'll try a fresh install of the mapper on this new machine.
     
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Yeah that does sound like an odd one. I was thinking that you perhaps shared a master.dat file between several mods and had somehow injected a bad proto into it. I have the same kind of setup by the way, minus an external hard drive.
    Reinstalling the Mapper sounds like the logical thing to try, though I'd find it odd if that had gotten corrupted. I mean what files are there that even can be?
    You say you've got a new machine, is that when the problems started? Could running the Mapper in compatibility mode make it work?
    Other than that could it be that the Mapper is unhappy with some setting in mapper2.cfg?
     
  17. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    No, I remember this problem occurring on one of my other machines, as well. And nothing jumps out at me from the mapper settings as being wrong. I did modify the size of the art cache as was mentioned in another thread when someone had this problem, but that didn't help me.
    But I did a little testing based off something you said. I swapped out my master.dat file for an earlier version from 2009 and Broken1 will now open for me. Odd, as I thought the only things that were modified in the newer master.dat files was first level party NPC information.
     
    Last edited: Mar 13, 2016
  18. Darek

    Darek is currently unavailable

    Jan 7, 2008
    So if I got you correctly, when installing the RP and other mods, you made manual fallout installs and just grabbed any old master.dat file laying around, without thinking it had been modified. Done that mistake myself. :lol:
    Anyway, the most obvious suspect would be Marcus. His proto in Megamod 2.45.4 has a modified date from 2010 and I can open the Mapper just fine. Maybe you've updated him later and something went wrong?
    By the way, if you haven't added the modified protos to your working master.dat yet, you probably should, just to make sure they work.
     
  19. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @MIB88
    I tried to look at Smitty to see what's up with the black screen problem, but I can't decompile the script. Get an "Error: Index of node out of range" when using int2ssl, and when using sfall script editor it comes out blank. Care to share the .ssl file?
     
  20. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    I guess so! I'll be more mindful of that in the future. I'll definitely check over Marcus. But, the latest proto files were in the master.dat file I was using. I ended up having to use a master.dat from 2009 to finally get the map to open.

    So, I will add the Chad Skimming Quest components to the Broken1 map and wrap up this version of the MM. However, I have added a lot of things. I think I might as well make it a full repack. It's going to be big, though, given the size of the MM already and the fact that the latest version includes all the new Talking head dialog files. Still, it'll be out before the end of the week.

    As for Smitty, you can grab him here. Thanks.
    http://www.mediafire.com/download/k54hoa5ll0yuaa2/dcsmitty.ssl