MIB88 MegaMod - opinions, technical issues, etc.

Discussion in 'Fallout General Modding' started by Lil Mordino, Dec 19, 2005.

Thread Status:
Not open for further replies.
  1. Misteryo

    Misteryo Still Mildly Glowing

    Feb 15, 2007
    That would be very cool. Thanks.

    And another (I find these things in spurts, due to my own schedule): Vault City 2nd Floor Vault doors behaving badly.

    ST: 5. Use buffout. Use crowbar on stuck doors. Receive message: "With the help of the crowbar you have forced open the door." HOWEVER, the graphic still shows a closed door, and I can't walk through it. When I "use" the door, I receive message: "This door won't shut. It is stuck open."

    So, part of the game thinks it IS open, and part of the game thinks it is still closed.

    This happens for all stuck doors on this level.

  2. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    This too was a problem in the original version. Killap fixed this, and I thought I had included that fix. I will have to go back and check this code too. Thanks.

    Edit: Testing the merchant fix to prevent him from charging into battle is gonna take a while. The AI.txt file is another one of those that, if changed, renders all previously saved games unusable.

    Also took another look at Sulik, both his script and my game. I could not find a reason for his 'amnesia.' I wonder if anyone else out there can reproduce this bug that Misteryo has encountered...
  3. heodien

    heodien It Wandered In From the Wastes

    May 22, 2006
    Im using US versino
    General Adressed bugs already (at least i think so)
    Vic doesnt level up
    Cant have Shooting Marriage

    Not adressed bug.
    Almost every time that i try to blow the underground rocks in modoc, game crashes.
    Skeeter didnt asked me to get 3 plasma transformer(dont remember correctly the name now) for him.
    Bessie disappeared after following me for a while(even being in my party)
    Farrel doesnt recognizes that i have the watch in my inventory
    Cant collect the iron ore from the modoc caves (strangely, one piece appeared, anda after that, save bugged)
    In Klamath, in The Den and in Modoc sometimes i try to save it says : Error, unable to save game ; so i have to reload an older save game.

    Im right now going to Broken Hills, i will let you know if i find more bugs.
  4. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Thanks for the report. Now:

    Which side are you trying to blow up: the regular side, or the side where the mole rat is after having come in from the mine?

    Did you have a gun in your inventory that he could work on? He won't ask you if you don't have something he can modify.

    Where exactly did she disappear?

    My initial guess is that Farrell's script checks to see if the toilet is blown up and that you you have the watch in your inventory. I will check this out and modify it.

    How are you trying to collect it?

    Not sure what this is about. I know you are tired of seeing me type it, but it's true: I only see that error when there is a problem with the proto files/folders.
  5. heodien

    heodien It Wandered In From the Wastes

    May 22, 2006
    The regular side, the one that you reach by climbing down the ladder

    Strange, i had a sniper rifle on my inv.

    Dont know exactly, but when i entered a random encounter she wasnt there (i think it was some robbers), and i never seen her again hehehe

    Strange, i did blowed the toilet.

    Just clicking on it and clicking on the wall with the "use on" button.

    It might be, and still i have that problem with the protos recently generated disapearing when i close the game.
  6. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Sniper rifles can't be improved.

    The code for Bess probable needs to be added to a few scripts...easy enough.

    You weren't clear: You are using tools to get the ore, right?

    Those protos are supposed to disappear when you exit the game. It is the ones that stay around that are not part of the Megamod that are the problem.
  7. heodien

    heodien It Wandered In From the Wastes

    May 22, 2006
    Oh ok, then im not having any problems with protos anymore.

    As for the tool, yes im using the mining tool that the blacksmith gave me

    As for the rifle, i tiped it wrong, it is a hunting rifle
  8. Stg Granite

    Stg Granite Look, Ma! Two Heads!

    May 8, 2007
    Man, great work!
    I had never installed any mod, then, all this ones together was awesome!
    I already finished the game and have found many bugs. Reading through the other pages, i didn't found any mention about them, then...

    - New recipes for itens' creation (i know they're in the Vault City's vault's Library's eastern corner's computer). After learn from Vic how to make the Eletronic Lockpick, when i click on the computer, a message comes saying that i gained 250xp (or 350), but my character yet can't make any item except Electronic Lockpick and Electronic Lockpick MKII. I had 100% in both Repair and Science. Later, i tried again, with a new game, this time with Science 140% and Repair 116%. The same thing.
    - In Klamath, is the Master Trader, in Vic's house, supposed to do some thing? When i click on him, nothing happens.
    - In the Special Postman Encouter, my car disapears.
    - In Salvatore's Gun Stash, the same thing, my car disapears.
    - In Modoc, after the explosion of the well, the forges in Smithy's home disapear.
    - I can not reload the Sniper Rifle (yes, i have its bullets).

    Hm... i know that some locations aren't immediately on the wolrd map, but, after complete the game, i haven't found any reference about Abbey, Scraptown and Collyweb. Could someone tell me how i can find some of them?

    And... i noticed that, in data\Data\CITY.txt, there are some locations that doesn't apear in the mod, like Necropolis. Are there any plans for that city?

    Well, if this was of any help, and i find some more thing, i'll tell you. And i'm sorry if i bothered you.
  9. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    I doubt you really read through this whole thing. It's very big. But you could have used the search feature to get some answers.

    I modified your message to address things easier.

    1. What you KNOW about item creation is wrong. Talk to people. You learned from Vic one thing. Why would you think everything else is in the computer?

    2. I addressed this before. It is part of the next add on. No script yet.

    3. Mentioned and corrected for next release.

    4. Same as #3.

    5. This is new. I will check this out. Thanks.
    Edit: I have corrected this.

    6. You have bullets, eh? The right bullets? This is also addressed.

    7. Scraptown: addressed. Abbey: hidden until you talk to someone. Colly: Not implemented yet.

    8. There are many locations that are part of other mods not fully implemented yet.
  10. zeller

    zeller First time out of the vault

    Apr 30, 2006
    hi there,

    I also encountered some problems:
    the locations on the nem world map parts are dead, if I enter any of them, the last location screen turns up and moving the cursor causes the arroyo temple "f*ck you it's your fault" crash.
    f*ck me it's my fault?
    also the same thing happens when I enter the new areas near new reno

    ow everything else is working and the mod is cool.
  11. heodien

    heodien It Wandered In From the Wastes

    May 22, 2006
    First of all, are you using UK or US?
    Did you set all the proto folder to read-me only?
    Do not install with any other patches or mods as well.

    Are there any new proto files in the critter folder?After 02 march
  12. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    I blew up the rocks several times and the game didn't crash once.

    I was able to get Farrel to acknowledge that I got the watch (by blowing up the toile and by not blowing up the toilet).

    I also checked mining the ore. That part is also working as it should be.

    Again, not sure why these aren't working right for you.
  13. zeller

    zeller First time out of the vault

    Apr 30, 2006
    1 i don't know...(how to check it?), the patch is US 1.02d (have no patch.dat in the folder), so it must be the US version...

    2 i've might messed up sth, but since the arroyo crash haven't occured this time i thought everything is ok now

    3 it's the only mod i installed.

    i'll reinstall it doing the proto/critter part carefully, if you think this causes the problem.
  14. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Yes, that is best. Uncheck everything in the proto\cirtter and proto\items folders. Then check them again as read only. For some reason, when extracting the files with certain programs, even though it says the files are read-only, they really aren't.
  15. Stg Granite

    Stg Granite Look, Ma! Two Heads!

    May 8, 2007
    - I can't fix the computer in Vault 13. I have the Voice Recognition Module, but when i use it on the computer, it opens dialogue screen. The same thing if i try Science, Repair or Lockpick (yeah) skills.
    - When i "sleep" with Miria or Davin, the game pauses, my screen goes black and i have to hit Ctrl+Alt+Del.
    - In Vault City, Courtyard, when i talk to Ed, Vic's friend, there's a line "Error" in the options of dialogue.
    - In my wolrd map, there is a large area, to the east, all filled with water (or with what i think that is water).
    - Talking to Tony, in Broken Hills, i can discover that he is Anthony Fassard even before to have the localization of Navarro.
    - Allright, sorry for the Sniper Rifle. It actually reloads. But its description says it uses .223 ammunition, instead of 7.62mm.

    Then it is supposed to teach me SOMETHING, right? But it doesn't.
  16. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    1. Ed was modified slightly to account for a new option with Bess. I will fix this.

    2. the map has been expanded...a lot. The area to the east looks like water, but just consider it an area where you are not supposed to go. I don't really work with graphics, and don't really know how to change this, as it is implemented from another mod.

    3. True, but you can't access all dialogs until you have been to Navarro and learn more of the story.

    4. Thanks for pointing that out. I have changed the description to show the proper ammo.
  17. zeller

    zeller First time out of the vault

    Apr 30, 2006
    I uninstalled it, ran a registry cleaner, and then: installed the game, copied the mod files into the game folder, unchecked then checked again the proto items critter folders, then started a new game. still the same bug occured.
    I can access without problem: collyweb, farm, truck crash(or what), the new modoc areas, but the southern places are not working: the unknown areas under new reno and those under the NCR line.

    also if I try tell Miria to "sleep with me and remove my clothes", the game stops after the blackening(of the screen) and I can't do anything(else than killing the process in task manager).
  18. Skyrage

    Skyrage First time out of the vault

    May 8, 2007
    So - just to check up on things (the readme files in this mod didn't really tell me much) - I've got the U.K version of Fallout 2 - do I have to install any patches (including no-children patch + U.S patch) before installing this mod or should I skip those?

    I tried installing this mod once, but I must've borked it cause it crashed as soon as I tried to enter the temple of trials.
  19. joker-

    joker- First time out of the vault

    Feb 8, 2007
    I have kinda same problem here too.. I can't go even inside of the Temple, game crashes straight and says: "Application error C:\...\Fallout2.exe" .

    I did like that too, but didn't worked me as well. 1st Megamod worked greatly, but 2nd won't cooperate with me at all. All the files (2.0, 2.1, 2.1.1) i've downloaded from nma:s download section, so reason won't be corrupted files etc.

    So, where is a problem and how to fix it?
  20. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Didn't tell you much!? From the readme:

    1. Install version of Fallout 2 that takes up the largest amount of space (Humongous).
    2. Make sure you do not have a patch000.dat file in your main Fallout 2 directory. Either delete or rename it.
    3. Make sure the entire proto folder is set to read-only
    4. Make sure the individual items and critters inside the proto folder
    are set to read-only
    5. Install the game and mod to a new location. Do not use the location you usually use. Pick a new folder entirely or, better yet, a different partition of your hard drive.
    6. If you are going to uninstall a Fallout 2 game, you should also
    restart your computer after doing so, before reinstalling the game again and adding the Megamod.
    7. If you have installed the game many times on your computer and removed them, it might be a good idea to also run a registry cleaner.
    8. If you are using Winrar, when you check your proto files to see if they are read only, they will say read only. Don't believe them. Uncheck all the read only boxes. Then, check them again.
    9. You should not have any files in any folder that were modified after any other file from the Megamod. Another thing to check is their read-only status. I keep all necessary files on read only. If I see a file and I don't remember if I had intentionally modified it or not, I check this. If it is not read only, I assume it was made by the game and then delete it.

    And from the next readme file:
    It should go without saying that you first need to have the Megamod version 2.0 installed on your computer. Next you must have update 2.1 files added to Finally, the files from this patch need to be added. Just copy the folders included here into your main data folder. In some cases files are being added. In other cases, old files need to be overwritten. When prompted, answer yes to questions regarding whether you want to overwrite the existing files. Make sure you check the placement of these folders. They should overwrite info in the same folders already in your data folder. Do not simply copy them out without paying attention to their placement.

    These are the things that have worked for people. Some of them don't really make any sense as to why they work, like using a totally different directory, but that is one I discovered and that works for me.

    US or or UK version might have some differences, but I don't think so. I know others using the UK version got it working fine.

    Don't use any other patches or mods, except the children's patch, as it only adds graphics files and is safe to use.

    And don't forget to copy the .exe file included in the mod. If the game crashes immediately after the Interplay logo, that is usually the problem.
Thread Status:
Not open for further replies.