Random FPS Stuttering Issue **FIXED**

Discussion in 'General Gaming and Hardware Forum' started by Phil the Nuka-Cola Dude, Oct 1, 2005.

  1. Phil the Nuka-Cola Dude

    Phil the Nuka-Cola Dude Sonny, I Watched the Vault Bein' Built!

    Jul 9, 2004
    After popping in my ATi X800 XL, I installed Battlefield: Vietnam (already owned it, but my GeForce 5200 FX couldent handle it in the lowest res for higher then 20 fps).

    With max settings/lighting/1280x1024 res, I was getting between 120-300 FPS (300 when not alot was going on, 120 when there was 30+ people on the screen at once).

    I noticed the FPS randomly dropping to 9-16 for about .25 seconds every few seconds. I load up Doom 3, same problem. America's Army? Ditto. HL:1? Yes. HL:2 uh-huh.

    I had tried EVERYTHING. From custom drivers, to tweaks, to formatting, when I fixed it...

    It appears ALOT of people are having this problem. It seems that by default, cable internet network adapters (im not sure if DSL uses the same principle, but then again, DSL is just a glorified phone line) are set to auto-detect your bandwidth. This is very bad, as it attempts to auto-detect every few seconds, using precious system resources, and basically causing a CPU usage spike (not really noticable when surfing the internet, or at the desktop, but when games use 300+ megs of ram, and 40% of your cpu... It gets bad quick).

    I've taken a bit of time (30 minutes) to put together a quick walkthrough to fix this.

    **NOTE** - Some of these options may have slightly different names, depending on your windows version, and network adapter, but they all lead to the same place. For you kiddies out there, dont mess around in the Computer management section, as you can inadvertantly fuck your (?parents?) comp up big time. Lets begin!


    Step 1: Start/ Settings/ Network Connections. Open up your "Local Area Connection". See where it says SPEED? Remember that number.



    Step 2: Right click My Computer, then click Manage.



    Step 3: Device Manager/ Network Adapters/ Click your primary NIC Adapter. Click the Advanced tab. Click "Link Speed/Duplex Mode". Still remember your LAC speed? Where it says auto-detect, select your default internet speed in FULL.



    Step 4: Restart and be happy.
     
  2. aegis

    aegis It Wandered In From the Wastes

    147
    Sep 1, 2004
    yeah it improves, the jitters are less harsh and less frequent..its a pain to get a 2003 game like G2 to work smoothly on a 2004 machine..