Restoration Project Question

Discussion in 'Fallout General Modding' started by Hellbane, Mar 14, 2010.

  1. chiquita

    chiquita First time out of the vault

    28
    Mar 11, 2010
    Download this file:

    Code:
    http://www.dll-files.com/pop.php?dll=d3dx9_42
    Put it into your Windows\system directory and you should be fine. Sometimes you have to download dll libraries separately for older games, I had to do the same for Neverwinter Nights 2.

    EDIT: Ninja'd by Nirran, sort of.
     
  2. Hellbane

    Hellbane First time out of the vault

    37
    Nov 11, 2007
    FINALLY!!! :D :clap: :rofl: :dance: :drunk: :whistle:

    After several error messages concerning input devices & cities I AM INTO THE GAME!!!!!

    TYTYTYTYTYTY everyone who has been so patient & helpful!!!!!

    BLESS YOU!!!!
     
  3. chiquita

    chiquita First time out of the vault

    28
    Mar 11, 2010
    No problem, glad to see your problem solved :wink:
     
  4. mare6600

    mare6600 First time out of the vault

    10
    May 29, 2007
    Can I ask one question? I couldn't find what I have to change in that .ini file when I want to put sfall over RP 1.2? When I copy that .dll and .ini file, and start the game I get the message Error loading cities. Yes, I have read that FAQ file and I could change City limit in .ini file to 1, but I want to know all what I have to do with that .ini file so the RP 1.2 and sfall would work properly.
     
  5. SHADOW-XIII

    SHADOW-XIII First time out of the vault

    98
    Nov 19, 2007
    you have to edit INI file so that number of cities is correct
    (RP got more cities/locations, that's why)
    check original RP ini file
     
  6. chiquita

    chiquita First time out of the vault

    28
    Mar 11, 2010
    Are you using sfall that comes with the RP? It's already set up. If you still get the "Error loading cities" message, you might want to try changing "times_run=#" from 1 to 0 in fallout2.cfg, then mark the file as Read-only.

    EDIT: Actually, wait - this helps if you get the "Error initializing input devices" message... oh, never mind.

    EDIT2: Damn it, I didn't even read mare6600's post properly. Let's just forget I said anything, shall we? Basically, do what SHADOW-XIII said.
     
  7. mare6600

    mare6600 First time out of the vault

    10
    May 29, 2007
    I have put those .ini and .dll files from sfall over the game with the patched RP 1.2, because Killap said that you should download the new(2.5.7 I think) sfall for RP 1.2.
    When I did that first I got the message Error loading cities, so I went to that .ini file and changed CityLimitFix to 1, and then the game started. I have also changed that Mode to 4 in Graphics section( I had to put that dll file that chiquita has mentioned into windows/system - thank you chiquita for that tip).
    I have put some lines that were in older .ini file ( file that was before putting those files from sfall) like DefaultEnvironment=1 in Sound section and BonusMoveFix=1 in Misc section, and also have changed WorldMapEncounterFix=1WorldMapSlots to 21, DamageFormula to 2(in RP 1.2 .ini file it was 1 for Grovz's AP ammo tweak but here it says 2 in comment), NPCAutoLevel=1 in Misc section and some other things that are irrelevant and I think wont affect the game working properly.

    Can someone tell me if sfall could work with RP 1.2 properly or not? And if I have to change or change back to somethings in that .ini file? In its readme file it says that is only compatible with US 1.02 patch.
     
  8. mare6600

    mare6600 First time out of the vault

    10
    May 29, 2007
    I have noticed that when I click new game in game menu the black screen shows up and I have to wait sometime before Narg's face bumps in.
    And also my mouse pointer is very inaccurate in the game menu. When I have to move mouse pointer for a small distance it's not responding very well. I changed mouse sensitivity in option menu and in .ini file but it's not good (it can be fast but not accurate). When I have to create a new character it's like I'm fighting with it (I want to change my intelligence but I can't).
     
  9. Darek

    Darek is currently unavailable

    Jan 7, 2008
    You might want to set "OverrideArtCacheSize=1"
    This fixes the elevator crashes in EPA, but depending on your setup you may or may not be affected.

    Also I wouldn't use Glov's AP Ammo tweak, since it don't work correctly (unless it's been fixed?).
     
  10. chiquita

    chiquita First time out of the vault

    28
    Mar 11, 2010
    I've been using sfall that comes with RP until now, your post actually encouraged me to try the latest version. You may want to try setting

    ;CityRepsCount=## (19 by default)

    to any higher number - 21 worked for me.
     
  11. Timeslip

    Timeslip Water Chip? Been There, Done That
    Modder

    921
    Aug 15, 2007
    These are obsolete, and no longer do anything. There's no point in re-adding them. The bonus move fix was replaced by the save in combat fix, and the default environment setting was a part of the eax code which was removed. (And which wasn't used by the RP anyway.)

    No, leave that at 0. (1 is useable, but tends to lead to an invincible horrigan at the end.) The comment is referring to a different mod.

    And why on earth would you want to change that for the RP? :?

    Sure you aren't confusing it with WorldMapSlots?
     
  12. mare6600

    mare6600 First time out of the vault

    10
    May 29, 2007
    Thank you guys for everything.
     
  13. chiquita

    chiquita First time out of the vault

    28
    Mar 11, 2010
    Yeah, I guess I am :D Well, as long as it doesn't screw up my game, I don't mind.

    So, does it work now? I'd like to help you, but it seems to be working fine with my game - I just replaced the two files. And if CityRepsCount have nothing to do with your problem, I don't know what could be wrong.
     
  14. mare6600

    mare6600 First time out of the vault

    10
    May 29, 2007
    Just few more questions.
    SingleCore=1 Why would I like to fallout uses just one core when I have 4(or 8 I'm not sure)?
    AllowLargeTiles=0? I don't understand what this to. Do I have to? :)
     
  15. Timeslip

    Timeslip Water Chip? Been There, Done That
    Modder

    921
    Aug 15, 2007
    Fallout is single threaded (sort of; windows spawns extra threads, so it's a bit complicated. Just pretend it's single threaded.) anyway, so it won't run faster with more cores however many you have. The reason you might want to confine it to one core is that these old games often contain race conditions (yes, I know you can't have a race condition in a single thread. It's to do with those other windows threads. Like I said; complicated. :P)which will never occur on a single core processor, but which can do on a multicore machine. (Thief 2 is the best example I've seen. On a machine with more than one core it'll lock up within seconds of starting a mission, always. On a single core machine it's completely stable.) There's not any confirmed crashes in fallout due to the problem, but that option exists just in case. I advise setting it to 1 for safeties sake, unless something else is already pinned to that core.

    If you don't know what it does, you don't need it. (It's only required for mods which include maps with oversized tiles. The RP doesn't.)