Sfall win98 backport

Discussion in 'Fallout General Modding' started by kokeeby, Aug 20, 2023.

  1. FatMerc

    FatMerc First time out of the vault

    Feb 18, 2020
    I could have swore Dx9 did work, maybe I’m tripping. It’s also emulating a voodoo 1/2, if that matters.
  2. kokeeby

    kokeeby It Wandered In From the Wastes

    Jul 4, 2019
    BTW, if you don't mind, what kind of an error is it giving you on the built-in HRP? Is it just a crash or is there some error message? If you set in ddraw.ini in the [Debug] section

    ;These options control what output is saved in the debug log (sfall-log.txt)
    ;Prints messages during sfall initialization
    ;Prints messages relating to hook scripts
    ;Prints messages relating to scripting
    ;Prints messages relating to the critical table
    ;Prints messages relating to engine fixes
    it should create a sfall-log.txt file in the Fallout directory on startup. Could you post it on pastebin or someplace else? Also the error message... :) I wouldn't normally ask, just curious where it crashes. I noticed, that if you have desktop color depth set to 8-bit, built-in HRP exits with a message of 8-bit mode being not supported - have to switch the Win98 desktop color depth to 16-bit. I always set color-depth in my Win98 VMs to 16-bit, so I didn't even notice... have to update repo instructions.
    Last edited: Oct 25, 2023
  3. FatMerc

    FatMerc First time out of the vault

    Feb 18, 2020
    @kokeeby Ok, I’ve got a couple crash logs that I saved, one of these I’m unable to extract because dosbox saves any file you export to a .sav file. I tried to extract with iRAR but maybe you can get it out (I also tried renaming to .zip, no dice). And I have win98 screenshots of crash on kernel32. The dosbox zip is not zip its .sav; had to change name for upload. Also if you can tell me how to fix maps for non-HR I can help do the work. Noticed your message about desktop 8-bit and yeah that is my setting, so I’ll try that. Thought that might be an issue, but with so many possibilities I got frazzled. Another thought I had was integrating Ddraw 7 as option in stall?

    IMG_0145.png IMG_0146.png

    Attached Files:

    Last edited: Oct 26, 2023
  4. kokeeby

    kokeeby It Wandered In From the Wastes

    Jul 4, 2019
    That particular error is not related to hrp; the access violation happens in the c runtime after the game has ended and the runtime is deallocated. The game starts, checks for the current desktop color depth, exits because it's 8-bit. Anyway, I uploaded a newer version, so use that one (it also has the fix for a recent bug in the talking head mod - https://github.com/BGforgeNet/Fallout2_Restoration_Project/issues/246).

    I think the built-in HRP should work fine once you switch desktop color depth to 16-bit.

    If you still want to play without the HRP, I updated the maps -> https://mega.nz/folder/ypVwwCQb#2AjZq6kGnoJs2z0FGw-zSQ

    Extract into your FO2 folder. (you can rename the original mods\elevators.ini to something else so it doesn't get overwritten). You need to start a new game to have those maps working.
    Last edited: Oct 28, 2023
  5. FatMerc

    FatMerc First time out of the vault

    Feb 18, 2020
    @kokeeby Hey it works now! It was indeed the desktop res needed to be set to 16bit. It plays and runs good, the only difference is non-res is a bit more snappy, but I ain’t complaining. Nice to see this working in all its glory. All the mods work too; no crashes yet (I’m about to do Rat God quest).

    I imagine those maps will be popular (maybe) with mobile players.
  6. fanboy

    fanboy First time out of the vault

    Sep 3, 2013
    Hi! Could you please remind me which app you are using under iOS?
    I have iDOS 2 but standard Fallout 2 (without sfall) is always crashing while loading, so no use to try it with sfall, I guess.
  7. FatMerc

    FatMerc First time out of the vault

    Feb 18, 2020
    @fanboy I’m using RetroArch Dosbox-Pure. You have to install win98 or win98 SE.