Ascorti/Ace Casino guards hostile

Discussion in 'Fallout RPG Gameplay & Tech' started by BruceInCola, Oct 7, 2015.

  1. BruceInCola

    BruceInCola First time out of the vault

    3
    Oct 7, 2015
    After a loooong trip down to NCR, New Reno and environs, I am back in Redding to finish up the mine quests. However, when I go into the Ace Casino, the guards in front of the door at the back room are immediately hostile to me! WHAT HAVE I DONE?! Way too far along to load an earlier save (esp since I don't even know what triggered this reaction). Any suggestions? When I try to engage the guards (from front, OR from behind, when I open the metal door), the Mayor gets involved and quickly gets roasted by my companions.

    Any way to salvage this situation?

    Thanks!
     
  2. Dead Guy

    Dead Guy Senate Board Director oTO Moderator Orderite

    Nov 9, 2008
    Do you get any floating text before they turn hostile? The first things that come to mind would be bringing Marcus in if they aren't fans of mutants, but most NPCs like that will tell you about it before attacking. That should also be the case if you run in with your weapon drawn.

    Other than that, I guess there could be some kind of relation if you've worked some of the quests related to who controls New Reno and how that family treats Redding? Far fetched maybe, the only one in redding I remember is openly pro-Reno is the guy that runs the morningstar mine, I think.
     
  3. BruceInCola

    BruceInCola First time out of the vault

    3
    Oct 7, 2015
    Thanks, Dead Guy. I did do a lot in New Reno before coming back and finding this nasty surprise (because I had not finished Redding quests), but I actually gave the chip to the pro-Reno guy, so I don't think that's it. Also no mutants in tow, just Sulik and Vic. I have a feeling I looted something I should not have, but again, I was here so many game hours (and real hours!) ago, I have no idea what it was, and even if I did, I would not want to lose all this progress just to save that quest.

    I also tried entering with guns stowed, same result. And there was some text spoken by the guards before they turned hostile. Usually something like "Ok, we told you this would happen!" or something to that effect. "That's it! You're going down!" Wildly paraphrasing, but obviously they had warned me before (or someone that LOOKED like me! :P )

    I guess my options at this point are
    1. Abandon quest and that sweet, sweet loot - don't ever go into the Ace Casino again
    2. Go Mad Dog and engage the guards, kill them, resulting in a city wide death match (I assume)

    Any other options or suggestions, I am open to!

    Thanks
     
  4. Dead Guy

    Dead Guy Senate Board Director oTO Moderator Orderite

    Nov 9, 2008
    It might be possible to sneak along the southern wall and up to Ascorti I guess? Would probably require rather high sneak though since the place is lit.

    Very strange problem, I've never heard of it before. Did you go in his office from the caves and loot anything? IIRC they still shouldn't be hostile unless you go out the door between them.

    Have you tried entering without companions or after telling them to put their weapons away? I guess you're aware of the fact that companions sometimes need to holster as well after visiting NCR.
     
  5. BruceInCola

    BruceInCola First time out of the vault

    3
    Oct 7, 2015
    Thanks again. Yeah, tried sneaking along the South wall by myself (holstered of course), but no dice...my sneak skill is awful. I DID enter the office from the Caves on a previous visit, but did not enter the "money" vault, or exit through that door. And since I pretty much yoink anything not nailed down, I am sure I looted whatever was available back there. I guess that did it.
     
  6. afd04587sd

    afd04587sd First time out of the vault

    1
    Aug 5, 2018
    Yes this an old topic, yes this is a disposable account, but if anyone ever comes across this thread, here is the solution:

    It's the damn door. If you try to open the closed door 3 times, the guards will get hostile the next time they see you.
    To fix this issue, use a savegame editor and change the value "MVAR_Using_Locked_Door" in reddown.sav from 3 to 0, 1 or 2
     
    • [Like] [Like] x 1
  7. Wipowil

    Wipowil First time out of the vault

    1
    Nov 17, 2019
    Thanks.