Fallout 2 mod BIS Mapper error initializing video

Discussion in 'Fallout General Modding' started by jacksnapes21, Nov 12, 2019.

  1. jacksnapes21

    jacksnapes21 First time out of the vault

    3
    Jul 15, 2019
    hey friend, nice to meet you,

    I just played playing with Mod Fallout 2, after searching on Google and I got BIS Mapper, it's really cool!, because I can edit the map myself like GECK for FoNV / 3 or Creation kit for Fo4 ... after I download and settings, critter_dat =c:\GOG\Fallout2\ critter.dat etc ...
    I'm having a problem, I get a popup error "error initializing video mode 640x480" I don't know
    and I searched Google again, but I got people who were having problems"error initializing video when opening games". but my Fallout 2 game really works.
    they say the settings in f2_res_Config, but my BIS Mapper can't work

    I use Windows 10 Home.

    help please.. :(
     
  2. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    try this
     

    Attached Files:

  3. jacksnapes21

    jacksnapes21 First time out of the vault

    3
    Jul 15, 2019
    Thanks for fast respon friend, but still not work :( , upload_2019-11-12_9-21-42.png
     
  4. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
    did u unzip in mapper folder then run m2_res_patcher.exe to activate it?

    also this may fix it :
     

    Attached Files:

  5. jacksnapes21

    jacksnapes21 First time out of the vault

    3
    Jul 15, 2019
    I've patched, well, it's still the same error...I really do not understand my computer ... my PC is like refusing to run a classic application, and.. I gave up making a map.. so I'm now interested in making/editing sprites for Fallout 2... this is cool too :D thanks for help
     
  6. arroyoman

    arroyoman First time out of the vault

    26
    Jun 11, 2019
    Hey, this reply may be a couple of months late, but I am currently running Windows 10 and faced the same exact problem too. However, I was able to resolve the issue. Here is what I did :

    1) After patching mapper2.exe, right click mapper2.exe
    2) select properties
    3) go to the Compatibility tab
    4) You should see 'settings'
    5) tick the box 'Reduced color mode'
    6) tick the box 'Run in 640x480 screen resolution'

    That fixed the issue for me.