Black map instead of The Den - GOG+RPU_v26+fo2tweaks_12.10

Discussion in 'Fallout RPG Gameplay & Tech' started by rzulf_blotny, Jan 11, 2023.

  1. rzulf_blotny

    rzulf_blotny First time out of the vault

    Jan 11, 2023
    Den is fixed (info near the end), but black map appeared now instead of Stables (without mapper.. so I have no idea what could be the cause). If anyone here has an idea, do share, if not, F2 will need to wait for future, maybe I will try again in a year or two, when I will be swiching laptop.


    I am getting a clear black map instead of The Den (sometimes there are grey hexes here and there, on that black map). I tried reinstalling game from scratch quite a few times already.. .

    It started after I tried editing temple, arroyo and klamath with BIS mapper patched (+complementary ressources). Results were not the best, so I gave it up, but now, even after clean installation, I still keep getting the same black map intead of old, stinking and full of jetheads Den.
    Saves from when game was working - stopped working (those before Den load, but lead to the same black map; and those from after or inside of Den give some memory errors and game gets closed).

    Each time game was reinstalled (e:\ - and i tried to different folders) and I was starting a new run (game folder was deleted while uninstalling): GOG version + RPU_v26 + fo2tweaks_1210 - in that order, overwriting everything). Windows 10, dx9, 1366x768 res, which is native for laptops screen.



    ;Set to 0 for 8 bit fullscreen
    ;Set to 4 for DX9 fullscreen
    ;Set to 5 for DX9 windowed
    ;Set to 6 for DX9 fullscreen windowed (the resolution in f2_res.ini should be set to the same aspect ratio as your desktop resolution)
    ;A DX9 mode is required for any graphics related script extender functions to work (i.e. fullscreen shaders)
    ;Modes 1, 2 and 3 are no longer supported

    ;If using a DX9 mode, this changes the resolution
    ;The graphics are simply stretched to fit the new window; this does _not_ let you see more of the map
    ;If set to 0, use Fallout's native resolution

    i set molotov to do fire dmg and to have unlimited weight limit (or maybe that was originall setting..) - well I was just copying those files from "back up folder - for those two files and saves folder)


    ; Set the Fullscreen resolution here.

    then setting same resolution in "f2_res_config.exe"

    when starting game 1st time I was asked to turn off some resolution patch made by... someone whose name i forgot:P, and each time I agreed.

    Restarting windows did not help.

    Any idea what heppened and/or how to fix it?


    Sooo... I uninstalled it once again, restarted laptop, installed gog version...:
    - played untill Den (it loaded normally), saved, closed game;
    - installed RPU_v26, played untill Den (loaded normally), saved, closed game;
    - unpacked fo2tweaks_1210, manually set what I wanted (instead of copy/paste from backup),
    - downloaded new sfall ( and exchanged "old" one ( - line by line edited it to match and by the end of it I coud tell that as far as ddraw.ini file goes, there was no need to do that at all (** added below) - i mean updating sfall, played untill Den - even moved back to Klamath and back to Den (loaded both times), closed game, logged here, wrote this update.

    In the end I am not sure what helped:
    - restarting after uninstallation?
    - quick playthru untill Den and saving (i believe this creates some files in map folder), each time?
    - manually setting ddraw.ini and fo2tweaks.ini again (maybe got somehow corrupted)?
    - that new sfall changed something?
    - Hakunin prayers so that I could finally set off on my quest? (... I have a feeling it was this one tho...)

    ehh.... now i feel like trying that mapper again. ^^

    this is missing in new ddraw.ini
    ;Set to 1 to enable fade effects for background music when stopping and starting the playback
    FadeBackgroundMusic=1 (i dont really care about it)

    ;Set to 1 to enable the balanced bullet distribution formula for burst attacks
    ComputeSprayMod=0 (was set to 0 by rpu either way)

    ;Set to 1 to fix the issue with the division operator treating negative integers as unsigned
    ;Note: To perform the unsigned integer division, use the new 'div' operator
    DivisionOperatorFix=1 (this was the only thing that could matter... I will see in the future:P)

    and this.. was "0" in the old one, but I left it at "1" coz of the info about it being always enabled:
    ;Set to 1 to boost the maximum number of tile FRMs from 4096 to 16383
    ;This option is always enabled in 4.3.7/3.8.37 or later. The information is left for reference only

    PS. While looking at those settings, I wondered, why there is no option about not letting game show aim chance % in values below 0. I went back to game, just to check it. I had -26% when trying to throw spear at ant. ;) IMO, there should always be a chance for that... (as long as character has enough STR to actually throw it).

    I tried to open newrst map (Stables) in mapper (from original files - master.dat i think) and could not! Got a message "error reading ocjects while loading map".
    I will try now with "newrst" files from rpu.dat
    - i will copy "" from rpu.dat into master.dat (RPUs file is bigger).
    again the same message.
    - copied original master.dat from backup - mapper loaded '' from backup master.dat!
    Now time to try it out in game.... (come on Hakunin - pray!) - map is black, but character started in other spot this time. So maybe not only master.dat, but also something with rpu.dat is wrong.
    - while reentering Stables and before on the way there got error with message:
    "Error!: partyMemberItemSave: Can't fing script!" - game closes after that.
    - I will download that file from github. - did not help.
    - I will try reinstalling RPU again (only that, but not from .exe but unpacking it from .zip) - did not help
    Last edited: Jan 13, 2023