Black screen on mods

Discussion in 'Fallout General Modding' started by Alex Broughton, Jan 9, 2021.

  1. Alex Broughton

    Alex Broughton First time out of the vault

    8
    Jan 9, 2021
    So I have played through all of fallout 2 restoration project mod/addon and worked like a charm so I wanted to try megamod v2.46 and no matter what I do following all the instructions and troubleshooting once I load the game, create a new game after the character creation I end up in the pre-temple of trials I go into the temple and its a black room with no exits. I can move around but the room is just pure black nothing I tried to also load and play last hope mod 1.082 I get the exact same problem! Please help! Attached is a screenshot

    Here are the steps im taking.

    1. Through steam downloading fresh game files.
    2. Moving the folder to C:/fallout2
    3. Copy pasting the mod files from the unzipped files directly to the game files.
    4. Hitting yes to all (replace files)
    5. Run the game (having deleted the patch.000 file also tried leaving the file. I have tried unchecking read only on the files/folders and leaving it checked (repeating steps 1-4 with each fresh go at it)
     

    Attached Files:

    Last edited: Jan 9, 2021
  2. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    So, I put suggestions in a readme file for a reason. I would suggest you look it over and try the things mentioned there. Pay special attention to #4.

    A lot of times, people get the black screen because of missing proto files. Maybe the files get copied over, then they get deleted because they weren't set to read only. So, after you have copied all the files, open the data/proto/critter and data/proto/items folders and set the files to read only to keep them from being deleted. Then, run your game.
     
  3. Lexx

    Lexx Testament to the ghoul lifespan
    Moderator Modder

    Apr 24, 2005
    You could change the folder setup and move everything to /mods/, then the game wont delete the protos anymore.
     
    • [Rad] [Rad] x 1
  4. Alex Broughton

    Alex Broughton First time out of the vault

    8
    Jan 9, 2021
    Excellent suggestions gentleman as when I inspected the mod in its folder in that directory and compared to the game there was a huge difference in the file counts. The NEW problem I am having is I

    1. Right click folder > properties
    2. Uncheck "read-only" and hit apply.
    3. Computer does some stuff. I click ok.
    4. I then right click on the folder again and go to properties AND THE FACKING READ ONLY IS CHECKED AGAIN.

    So why isnt it saving (in the Mod folder before I move it to game folder)
    Lexx would it be possible to give you remote access and see if you can fix it? No pressure though, im just a scrub
    Thanks again!
     

    Attached Files:

  5. Alex Broughton

    Alex Broughton First time out of the vault

    8
    Jan 9, 2021
    Problem solved! I called an IT friend of mine and unknowingly I figured out that the version of the mod I was using wasn't correct. Can we update the downloads page to the actual correct download (the external download site is down and what I found wasn't the right version until now). Thanks again!
     
  6. BillyTheMountain

    BillyTheMountain First time out of the vault

    1
    Mar 8, 2021
    What version do I use then? I am getting the black screen right after the Intro video... which plays fine. Black screen... I can still hear music. but the game does nothing.

    I downloaded this one.... That is linked in this post by Dionis.

    https://www.nma-fallout.com/threads/fallout-of-nevada-Фаллаут-Невада.207311/

    Installed as instructed. Not sure what im doing wrong.

    HELP!?

    I just want to play this great mod.