Changing Volume Increases FPS in FO2?

Discussion in 'Fallout RPG Gameplay & Tech' started by charlie6gun, Apr 8, 2019.

  1. charlie6gun

    charlie6gun First time out of the vault

    Apr 8, 2019
    So I've been trying to get FO2 to run correctly for a really long time (this is the steam version btw). I didn't have any problems with FO1, but with FO2 the fps is horrible. Its so bad, you would think FO2 is the most demanding game on the planet. The steam version comes bundled with sfall and res patch and I've tried messing around with the .ini files and all that. I've tried installing other mods and patches as well and nothing changes. The only thing that increases the FPS is changing the volume and brightness?? It seems to be connected with the windows 10 popup that shows up when you change those settings and not the actual change in volume or brightness itself. As soon as the popup leaves, the fps dives back down. This is what broke me. Does anyone have any clue what is going on and what would cause such a thing? Not sure if this helps, I'm trying to play this on laptop with an i7 integrated graphics.
     
  2. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Make sure CPU idle options in sfall and HR patch are not enabled simultaneously, or try disabling both of them for a while.
     
  3. gustarballs1983

    gustarballs1983 Where'd That 6th Toe Come From?

    Oct 28, 2009
    You may also try to disable affinity by setting SingleCore=0 in ddraw.ini this will cause all processor cores to run fallout 2 i know that on some systems affinity tied to first core is problematic, AMD CPU's mostly. Secondly try to run the game on dedicated graphic's card instead of the integrated one. Fallout 2 while using DirectX 9, 32 bit graphics mode and a custom resolution (FHD epecially) is a lot more demanding than the basic requiremets placed on steam, still it should run smoothly on any recent better-than-a-potato machine.
     
  4. charlie6gun

    charlie6gun First time out of the vault

    Apr 8, 2019
    Well thank you for your replies. I tried everything with no luck. I also don't have access to a graphics card so that's a no go. I do wonder if it has something to do with using intergrated, sometimes games just don't like it even if they are old. I sort of found a a solution in using windowed mode and turning my computer resolution to match it. Its not ideal, but I've been through worse as a low spec gamer. Thanks again.