Fallout 2 mod Classic Fallout engine videos playable ingame in HD resolutions

Discussion in 'Fallout General Modding' started by gustarballs1983, Oct 18, 2022.

  1. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    New alternative official source to get Upscale videos. any further upscales will be available only throught this new method:
    How to watch or obtain the files:
    #1 get a way to operate on ftp protocol. so either FileZilla or get a webbrowser that supports ftp, for example pale moon still supports ftp, while firefox and chrome have long gone dropped the support.
    #2 enter adress ftp://tarballs-stuff.servebeer.com


    If using FileZilla You'll only have read permissions, no write permission is allowed.

    #1 720p Last Hope videos added, nessecary .MVE videos to enable upscale playback are bundled with _Pyran_'s releases ( look in his signature for Last Hope 1.082.3 or similar they contain the videos that Forgotten Knight did not include copy them over along with the upscales to 1.085 by Forgotten Knight).
    #2 CATHEXP the utterly hardest one to get good looking in hi res is now available in 1080p as well.
    #3 Fo:Sonora cinematics added spoken ones by Ron P. plus Russian original and alternative expliosion all in 720p
    #4 Fo2 vids added all in 720p

    thread title changed due to no longer beeing tied to EtTu only.

    More to come.

    BOIL1 720p:
    BOIL2 720p:
    BOIL3 720p:
    CATHEXP 720p:
    DIPED 720p:
    INTRO 720p:
    IPLOGO 720p:
    MPLOGO 720p:
    OVRINTRO 720p:
    OVRRUN 720p:
    VEXPLD 720p:
    WALKM 720p:
    WALKW 720p:

    1.in uper right corner within the link click download to aquire video to the drive.
    2. copy the videos to <FoEtTu folder>\data\ART\CUTS\
    3. in your root Fo:EtTu folder look for a file called ddraw.ini and edit it like below:
    4. make sure your .mve files are in the same folder. copy them from a corresponding folder in mods\fo1_base\art\cuts

    Mode=4 *or* Mode=6

    change resolution from zero ( ot doesn't have to be fullHD just not zero ,make surethat the subtitles will be visible )
    For example:
    GraphicsWidth=1920 just make it your game resolution most important >0
    GraphicsHeight=1080 just make it your game resolution most important >0




    If You haven't already install a codec pack (k-lite codec pack with default settings is recommended)
    1. keep only one codeck pack installed at all times
    2. codec pack is nessecary for sfall in order to be able to view Xvid cinematics in game
    3. be prepared for slightly longer video loading times
    4. You may still use Mash's HRP with GRAPHICS_MODE=2 and use the same resolution as in ddraw.ini if You use Mode=4 or Mode=6 and SingleCore=0 in ddraw.ini and some form of CPU FIX provided either in f2res.ini or ddraw.ini. also the option to strech movie size in HRP =1

    Built-in HRP is not compatible with the subtitles on some machines ( same goes for sfall5 by Mr.Stallin that totally dropped support for Mash's HRP not to mention sfall5 has an unfixed bug and tears the image of other video formats than .mve in lower 1/3 of the screen. vannilla sfall had it fixed long time ago).

    also make sure th path to videos and subtitles from the drive letter is not too big, since that may cause trouble viewing the subtitles.

    Don't complain if the video lags for you and you play on a potato or other hand calculator

    HD resolution images without hardware acceleration ( Xvid codec beeing one) require strong cpu and a decently fast drive.
    So for middle ground I've settled for SATAIII SSD and 4 core 2.8GHz processor to be a minimum requirement to have before whining that video lags behind audio. This is for 720p further higer resolutions may require more powerful hardware to be smooth. Frankly nobody in their right mind thought about putting anything in 4k resolution in a Xvid codec and .avi container. 4k without GPU acceleration is pure madness and an overkill for CPU.

    Have fun
    Last edited: Apr 2, 2024
    • [Rad] [Rad] x 8
  2. MagicHp

    MagicHp First time out of the vault

    Oct 27, 2022
    Thanks a lot for this!

    Just a question: It seems subtitles (playing in French here) won't display using these. Are they embedded in the video or is it another fixable issue?
  3. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Subtitles work independant of original videos, they are not a part of original video, the videos were converted to avi. upscaled to 4k h.264 .mp4 then downsized and converted to 720p Xvid .avi . As for why subtitles don't play with the .avi extension it's a question not up to me but to the sfall team. Go to their github and make an issue for it.
  4. MagicHp

    MagicHp First time out of the vault

    Oct 27, 2022
    Ok that's good to know ^^

    Thanks for the info.
  5. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    no problemo.. and just so you know. Fo2 vids coming up next, however, i need to scratch up some free time, and motivate my lazy ass to do it. they need to be cut apart, downsized to 720p, and converted to xvid .avi.
    I mean they could've been 4k or 1080p but sfall team hesitates to implement .h264 .mp4 playback into sfall. I already tried to convince them. but they say sfall has got xvid and it's enaugh.
    the problem is, Xvid is low compression codec 4k Xvid movies are like 8-10 GB in size each, and CPU can't handle the playback ingame ( no hardware acceleration for Xvid out there anyway like for .h264 .mp4 and .h264 has better compression, so the files are a lot smaller which further reduces strain on CPU). But no, sfall team says nay.
  6. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    No need to edit MovieX options. AVI movies will be played instead of MVE when found.
    AVI itself is just a container, I don't know why mpeg4 video stream in AVI container doesn't work on your side.
  7. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    well mainly because mpeg4 is container not format the format is either vp9 for classic mpeg4 or .h264 for the common standard, either way nor vp9 nor .h264 works in sfall. .avi only combines with vp9 there's no such thing as .h264 .avi

    And the proper output support for sfall should be .h264 .mp4 , since that's the standard DVB format uses, and that's the video Topaz Labs spews out, sorry but it would appear only Xvid works as format. tried vp9 .avi but it doesn't work, I don't know about others but i assume Xvid is the common ground that works for everybody.. You haven't finished ironing out that discussion over at github, as of why vp9 .avi doesn't work (as I assume that's what you mean by "mpeg4" in .avi container).

    well as it turns out Mpeg4 has various implementations and two format implementations Mpeg4 part2 supports DiviX, XviD, 3vix, and libavcodec so called Mpeg-4 ASP, and Mpeg-4 h264 implementation known as Mpeg4-part10, and called Mpeg-4 AVC

    I now understand wgy sfall team hesitates to implement h264 codec, as a decoder for this type of codec has to pay for a license at least until 29Nov2027. So how about .WebM and Theora? could this be done? unfortuneatly xvid has too low compression to be taken seriously for a 1080p or higher video resolution. On the other hand theora is capable of high res vieos and has very good compression, so bitrate wouldn't be as extreme as Xvid 4k video. So whaddya say @NovaRain
    Last edited: Oct 27, 2022
  8. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Hey Frenchman You still here? I managed to solve the missing subtitles for me, try to go over the changes I've made to original post, and see if it fixed something for you..

    If not write about it here, I'll try to help with what i know.. truth is subtitles do work, and it's not an sfall issue, it's just configuration.
  9. Obsti

    Obsti First time out of the vault

    Nov 29, 2022
    I am not him but I installed Fo1in2 today (English language) and found these upscaled videos as recommended links, so I installed them. They play properly with AllowDShowMovies=1, but the subtitles are missing for me a well. I followed the instructions in the OP, ignored what was crossed out.

    In ddraw.ini I tried these three variants:
    GraphicsWidth=1920 / 1280 / 0
    GraphicsHeight=1080 / 720 / 0
    Nothing changed.

    If I disable the avis with AllowDShowMovies=0 I get the old videos with subtitles without an issue.

    Any further ideas?
    Last edited: Nov 29, 2022
  10. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    Hey there..
    the fact it doesn't work is simply by bad FoEtTu design decision of keeping Fo1 related stuf inside "Fallout2\<EtTu_main folder>\mods\fo1_base" folder instead of "Fallout2\<EtTu_main folder>\data\"

    both videos the original .mve ones and the upscaled .avi ones must be in the same folder that is <your path to et to EtTu>\data\art\cuts. the corresponding .sve subtitle files must be in \data\text\english\cuts , instead of somewhere in mods\fo1_base..

    Also make sure the path to the game is less than 63 characters long, has no spaces in folder names, and all folder names are 8 characters max. this engine still has some limitations of it's predecessor. The Predecesseor was ran in MS-DOS actually, so all of theese ms-dos limitations might apply to stuff within Fo2 engine too..

    As for me, I actually managed to unlock subtitleas after going through one additional step after the above, i had to launch the videos ingame with resolution 1280x960. after that the subtitles were enabled after changing to any resolution. i don't know why, but it worked for me.
  11. Obsti

    Obsti First time out of the vault

    Nov 29, 2022
    The subtitles work on the normal videos, just not on the upscaled ones. I copied the .sve's to the base data path to no avail.

    Steam created the Fallout 2 folder with a space in it, but since the subtitles work normally on the standard cutscenes, can that even be the issue?

    I tried the resolution workaround you mentioned, it changed nothing, neither in that resolution nor another afterwards. Any further ideas?
  12. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    the .mve videos ( the native Fo1 ones) need to be placed in the same folder as .avi videos and that is data\art\cuts..
    don't ask me why I'm not sfall dev, but i asked one about this same issue, and that's the conclusion He made when testing to check why subtitles don't work.

    Long story short. Both, .sve's need to be copied to data\text\english\cuts, *and* .mve's need to be present next to .avi's in data\art\cuts, the rest os just a fali-safe check, but the first two are a must. ,mve's need to be pesent because sve subtitles make a check for current frame to display the subtitles, and sfall doesn't check other folders for .mve's when .avi's are in data\art\cuts, .sve's do not check .avi's for specific frames. it is a good thing since some of the avi's used are nearly 60fps ( with added frames compared to the .mve's which are usually below 25fps.).

    sorry for such a late reply. I'm busy today, and headache kills me..
  13. Obsti

    Obsti First time out of the vault

    Nov 29, 2022
    Everything is placed where you say it should be placed.

    AllowDShowMovies=0 results in low-res videos with subtitles.
    AllowDShowMovies=1 results in high-res videos without subtitles.

    I am testing with the Main Intro and the Overseer introduction. I suspect there to be some other parameter playing into this, but reading their descriptions throught all .ini's , I cannot put my finger on one.

    No worries, I am down with a real influenca and temporarily almost deaf due to it (which is why subtitles are nice), I know that feeling. No hurry.
    Last edited: Nov 29, 2022
  14. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    I've checked quickly ddraw ini for possible incompatibility settings.. have you set graphics mode to =4 or =6? it is nessecary too y'know... ( natively it's probably mode=0 )
  15. Obsti

    Obsti First time out of the vault

    Nov 29, 2022
    It is 4. When I got the hi-res videos I checked as per the OP, but it was already set per default in the recently released et tu.
  16. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    so which files doid you copy exactly to data\text\english\cuts ?
    if yoou copied only the .sve's than You're probably missing narrate.txt and ovrintro.txt..

    Just so You know I copied all of the game content from \mods\fo1_base to \data as i was desperate to make it work back then.. I'm still not entirely sure which files need to be present where in order for the subtitles to work.. so far only et tu poses problems with the upscales. other mods I've made test upscales for seem to work fine.

    if it's not this than, frankly i have no idea..
  17. Obsti

    Obsti First time out of the vault

    Nov 29, 2022
    I copied the complete folder content.
  18. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    ok Now I've narrowed it down..

    tell me what install version are You using the release or from github app?
    what sfall version are You using?
    and what High resolution patch type are You using the sfall's built-in or the Mash version?

    the problem is in sfall built-in HRP version subtitles for .avi's don't work. You need to be using Mash's HRP the original one ( with patched fallout2 executable) or else it won't work tested on sfall 4.3.6 and

    The mash's HRP is f2_res.dll which requires a patching fallout2.exe this is the old method and the patcher isn't even bundled with releases anymore. to make it worse Built in Sfall HRP is set to work out of the box. it throws a warning message on first run, and if you click "Yes" it depatches the exe and uses built in sfall.. and in this case you're screwed, as You'd require a old HRP patched game executable, so your best bet would be to either find a patcher or reinstal the game, as fallout2.exe for EtTu still comes patched ( luckily).

    once you have the patched version in order for the stupid warning message to go away and keep old HRP you need to open ddraw.ini and set:
    and save the file
    or simply click "no" everytime you launch the game.

    oh yeah don't use sfall-extended from Mr.Stalin He severed the compatibility with Mash's HRP ( he says only built in HRP works with his sfall) so presumably You won't get subtitles at all with Sfall-Extended ad least in and earlier
  19. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    Well, I got subtitles in both Mash's HRP or sfall's built-in HRP in your issue report.
  20. gustarballs1983

    gustarballs1983 Vault Senior Citizen

    Oct 28, 2009
    nah.. this is definetly a thing, i checked throughly this time, it doesn't matter 63 chars in adress bar or the movie file beeing 8th or lower segment in a subfolder, however when i switched to built in HRP the subtitles in OVRINTRO.avi always ceased to work.. i was lazy and didn't bother to check INTRO.avi each time since it takes considerable amount of time b4 subs start rollin', checking OVRINTRO.avi was waaay faster, since i just skipped the intro and went straight into new game, an simply took max from the get go, so only two button clicks.