Fallout 2 ending bug

Discussion in 'Fallout General Modding' started by Constantine, Sep 26, 2019.

  1. Constantine

    Constantine First time out of the vault

    Jun 18, 2019
    Hey guys :)

    The problem is that my game goes back to main menu after the oil rig explosion. No endings.

    I've tried various solutions with no effect. Leaving the door while in combat mode. Taking the elevator up to vertipad. Disabling sound acceleration. Increased game speed over 100..

    I was wondering if somehow my save "forgot" that I arrived at the oil rig with the tanker and if, somehow, can I fix it through the save editor.

    (No save present before oil rig -_-)
  2. _Pyran_

    _Pyran_ First time out of the vault

    Jan 31, 2017
    You have not written, installed mods or not. I assume - this is RP (+ newest sfall 4.1.9\4.2.0).
    Replace sfall (ddraw.dll only) to an earlier version (4.1.7 or belove).
  3. Constantine

    Constantine First time out of the vault

    Jun 18, 2019
    Wow Pyran! It worked like a charm. Thank you very much.

    I had the 4.1.8 version.
  4. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    It's because a change in sfall 4.1.8+ triggered a flaw in UP/RP's edited ENCFITE.int script (vanilla doesn't have the problem). Technically the player is considered "dead" right after leaving the oil rig, as if you stay on the oil rig till the countdown ends.
    Here's a fixed script that works for both UP/RP.

    Attached Files:

  5. Constantine

    Constantine First time out of the vault

    Jun 18, 2019
    Thanx for the reply NovaRain!

    Now, before I leave, besides thanking all the community here and especially all those responsible for the fixes, I need to report an annoying bug.

    (I know this is not the place but just in case it's new..)

    Those 2 repair robots in epa brought my framerate into a crawl. As long as they were on my screen, my game was unplayable. Something was wrong with their script cause they were stationary and shaky. More like possessed than depressed :p.

    In combat mode there wasn't any issue. Destroying them fixes it completely.
  6. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    I saw that report on other forums before, but didn't find the root cause, and not all my saves can reproduce the issue.
    For some reason it seems the timed event in Mr.Handy's script is run rapidly, causing its anim sequence (moving to one point) never being executed completely before a new command. On some system it can cause serious lag.
    The way I "solve" it is changing Mr.Handy's wandering mechanism to like Arroyo villagers rather than brahmins. This would make it wander less frequently, but it's better than shaky/laggy I suppose. The one in alt_fix is a less modified version of the script, Mr.Handy would probably move around non-stop but at least it's really moving rather than stuck at one point, I'm not sure if the alt fix would solve the system lag.

    Attached Files:

    Last edited: Sep 29, 2019
  7. _Pyran_

    _Pyran_ First time out of the vault

    Jan 31, 2017
    Fixes were made a few years ago by Foxx for EPA, SAD, Gecko and NCR
    > Fixed robot on the 3rd level of EPA (fixed framerate error.).
    > Fixed robots in the Sierra (now of them drop out and normal motors for Skynet).
    > Fixed dialogue Skeeter (free weapons repair options)
    > Fixed Duppi NCR (now he can not steal money immediately after purchase).
    > Fixed NCR map entrance (added blockers, it was impossible to get into the city - bypassing protection).
    > Fixed Krom from Umbra Tribe (now he does not jump Health).
    > Fixed animation in biological armor.