Fallout 2 Restoration Project 1.1 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jan 13, 2008.

Thread Status:
Not open for further replies.
  1. Cubik2k

    Cubik2k Where'd That 6th Toe Come From?
    Modder

    Nov 22, 2005
    Hi killap, thanks for your Great Mod, which refreshing the playing the Fallout.
    however, there is a bug with Mynoc/Morlis/Flint-Sharpened Spear.

    When I talk first time to Mynoc, then go to Morlis for a flint, and back to Mynoc and start to talk to him then game always crashes and freezes.

    Sometimes dialog freezes on the line:
    "{308}{}{Here you go.}"
    then game crashes.

    I have standard options in ddraw.ini
     
  2. Lord Danath

    Lord Danath It Wandered In From the Wastes

    Jan 14, 2008

    Try removing the file acmorlis.int from the scripts folder and try again.

    Let me know if it worked.
     
  3. Cubik2k

    Cubik2k Where'd That 6th Toe Come From?
    Modder

    Nov 22, 2005
    Yeah, it is working, thanks.

    @killap:
    so there is a bug in acmorlis.int

    EDIT:
    In one of first random encounters with few pigrats and one molerat, molerat is not attacking me.
     
  4. wastelandhero

    wastelandhero First time out of the vault

    Jul 5, 2007
    I run XP installer version, only b-team and cassidy talking head. Did not have this problem. Stole flint, went to Mynoc, asked about spear, exit dialog, talk again, get upgrade, exit dialog. No crash.

    Although I am having a lot of critters being knocked unconcious after doing trials. Melee at 70% after training, luck 7. First release melee was 80% and this never happened. Actually none of my many previous games did this before the rest. pack install. Wierd.

    Fisrt Kaga encounter, he hits me for 14 points. I hit back for 7, second hit 8 points and knocks him out. Combat ends and he gets up screams his little taunt at me then runs off. Seems to be working fine on my system.
     
  5. puszki

    puszki First time out of the vault

    Aug 11, 2007
    @killap

    well, let's see... i've tried to get the location of the primitive tribe in many ways (making different games for each way) and every single crashes....
    i've tried:
    -Talking Sulik about his village and hiring him
    -idem, but without hiring him
    -Hiring Sulik without asking the location
    -Not even talking to him and going straight to the Primitive tribe
    -Rescuing Sulik's sister

    In all the cases the game crashes the same way i've told you... it just closes without any error dialog

    Thank you very much for the help
     
  6. mcm

    mcm First time out of the vault

    Jan 14, 2008
    If I save in the first encounter with kaga after he has hit me and reload again. The dialogue starts from beginning. Just a note.
     
  7. Polynikes

    Polynikes It Wandered In From the Wastes

    Jun 19, 2007
    Well, I tried a fresh install of Fallout 2 (I made sure to empty the folder of all files before reinstalling) and the mod v1.1, but unfortunately the entering Primitive Tribe bug still plagues me. I tried entering Primitive Tribe both with the car and on foot, not that it should make any difference, but every time for some reason the game crashes. Same with Sulik's sister. I'm guessing it must be something specific to my setup causing the problem, but I haven't a clue what. So far this is the only crash I've had; entering other locations has been perfectly fine. Has timeslip had any problems with Primitive Tribe playing in Win98 on a VM? This is a bummer, I really want to see what Primitive Tribe is like.
     
  8. puszki

    puszki First time out of the vault

    Aug 11, 2007
    @Polynikes

    Hey man, i've exactly the same problem... i'm talking about that with killap... take a look on my replies

    see ya
     
  9. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I don't understand what could cause this, but I will see what I can do. It has always worked for me and many others have made it there just fine. I'll let you know if I come up with anything.

    So, my patch/expansion includes all the files that come with the official 1.02 patch. Most of those proto/art files I did not modify in any way but I include them since they came with the official patch. Are you perhaps referring to these?
     
  10. ElectricSheep

    ElectricSheep First time out of the vault

    Jan 13, 2008
    No problems with Kaga or the Primitive Tribe village here.

    I did wonder at the fact that there doesn't seem to be any City Rep increase for helping the Den create an orphanage. You get xp and a 10 karma reward if you talk to Johnny, thats it. Seems a bit on the low side for helping a group of kids (and squatters, incidentially) to get a better life.
    Hardly call it a bug though, but if you have a list for things you'll fine-tune later, you may want to add this
     
  11. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    No, Den town rep should go up 5 points depending on the outcome you choose.
     
  12. tomten

    tomten It Wandered In From the Wastes

    Jan 6, 2008
    Is there a way to extract the original data as files in the same format as the manual restoration project? That way it would be easy to see exactly what the differences are (using some sort of directory compare) between the original and the restoration project.
     
  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    You can use a dat extractor and take apart the master.dat file. From there you can binary compare each file and see if it was modified in anyway.


    @Those who had crashes with the flint. Please try this updated file: flint crash fix
    Just save/copy it over to your Fallout2/data/scripts folder and overwrite the file that is already there.
     
  14. Glovz

    Glovz Vault Dweller
    Modder

    Sep 16, 2005
    Well I have been trying to help in identifying where the ammo/weapon problems have been coming from in regards to aimed shots. I am fairly certain my mod is not to blame as some people who have encountered the issue have no used my mod.

    Of course if people are using old saved games with Restoration Project then ...
     
  15. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I appreciate it and I don't blame your latest mod. Any help in getting to the bottom of this matter is appreciated since I don't have as much time now as I did during my break.
     
  16. JaW

    JaW Still Mildly Glowing

    Oct 1, 2006
    Hi Killap, could you copy updated files to this folder (like acmorlis.int ) instead of silent updating whole install file with the same version number? It's very confusing.

    P.S. Thanks for great job you are doing. It is just unbelievable :clap:
     
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Of course. I only did that in version 1.0 because there were some nasty bugs and NMA wasn't hosting the file at the time so the main source was my link. I wanted those who hadn't gotten it yet to not be plagued by the first round of bugs. I won't be doing any more silent updating anymore, so don't worry. :D Do (or others) let me know if the updated file I put out fixes the crash.
     
  18. Cyclis

    Cyclis First time out of the vault

    Jan 14, 2008
    First killap, let me say that I'm extremely grateful that you've put this much effort into something that only the small core of Fallout fans will appreciate. I haven't gotten far enough on my new game to see any of the new areas, but the additional content in Klamath and the Den was great. I've been playing this game over and over again so many times that anything new is just fantastic to see.

    Now one thing I'm little unclear on - is this addon intended to change the balance of the game in any way, or is it strictly new content? I've noticed a few things, such as Flick no longer having the .44 Magnum, but I was wondering more about pure combat balance as opposed to market balance.

    Basically, Sulik knocks people out with literally every other swing of his sledgehammer. Sometimes all I have to do is follow him around and loot the unconscious people in his wake. This seems to be the case for pretty much any melee attack. The knockout chance is extremely high, it almost certainly seems higher than fifty percent.

    I'm also having problems with encounter rates, too. Prior to this patch I used a separate encounter fix that replaced the worldmap.dat, and it seemed to be pretty balanced on all the computers I've applied it to (I did a clean install before applying your expansion, so that's not the issue). Right now with just your addon, I'm getting an average of five to six encounters per square. I literally can't move out of the Den without getting chopped to pieces by hordes of bandits with SMGs that I can't possibly handle at this point in the game. I understand and absolutely agree that moving across the wastes needs some element of risk, but it's not really so much a risk as it is a certainty that I'll be dead within two squares. The only way I've progressed even a fourth of the way to Vault City is by flagrant abuse of the save system.

    I know that I can turn off the encounter fix but then I'm certain with my Dual Core processor that I'll go back to flying around the map and running into maybe one encounter every few towns. That kind of sucks a lot of the danger out of the game, and I'm hoping there's an alternative.
     
  19. gracul

    gracul It Wandered In From the Wastes

    Jun 6, 2007
    Hey!

    Well, i've started a totally new game, seeing as this version shouldn't have any nasty bugs.
    However, i've found some minor ones.
    * Looting Elder's items still not making a karma drop.
    * I lockpicked Hakunins chest and got a message "you deftly steal the shamans things", so i check inventory and there is nothing inside, so i use the steal skill, and get the same message, still nothing inside, then i open the box and there is nothing inside anyway :P
    * Empty encounter after Kaga 1 - maybe because my game was at 10x speed.
    * Kaga encounter 1, after he close combat the 2 last dialogs just show up on each other and Kaga disappears, instead of running away.
    * Was fighting with keeng rat, i fire the pistol, suddenly game error... so i am like "wow, first time i get an error while using Glovz ammo script", i check the .ini file and nope, i forgot to turn it on, so im 99% sure its something else not Glovz ammo script.

    Killap, what would you say if the beggining of this topic would contain a "current bug list", seeing as you won't have as much time as you did before? That way the bugs wouldn't need to be reported all over and over again... everyone then would know that the bug he found is acknowledged by you, and every bug that you fix, could be marked with like a "+" sign, so in like a month or two when you release 1.2 then the corrections list is obvious.

    Edit: A possible bug in Klamath, as in Per's walkthrough - "If you're stupid, conversation with the simpleton Torr takes on a most interesting character. He can put the Den on your map if you ask him about Vic before accepting quest 3. He'll also offer free accomodation (same effect as described above), but not until after you've accepted or declined the quest, and since Torr doesn't return to the town map if you finish quest 3 properly a stupid character wouldn't normally get that option anyway."
    Guess Torr was meant to come back to the town map after quest "Guard the Brahmin"
     
  20. raif the mad

    raif the mad First time out of the vault

    Jan 11, 2008
    funny thing happened just now, was exploring the surroundings of primitive village, to get the knives for the quest, had an encounter with molerats, ran away from them and when I was back on world map I had been teleported to a few squares southwest of den, so far has happened just the one time so no idea how that happened though.
     
Thread Status:
Not open for further replies.