Fallout 2 Restoration Project 1.2 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Jun 9, 2008.

Thread Status:
Not open for further replies.
  1. Wamphyri

    Wamphyri First time out of the vault

    13
    Jun 10, 2008
    FINALLY! i made the discovery about my problem ^^



    The original fallout setup on my computer got rigged .... some of the list files were not overwritten during the rp setup
    i don't know why but they just were the original files thank godness i still had my old computer to compare files :)



    i thank everyone for the great help ... but .. erhh... the phazer is a new weapon ? i never found it on the federation shuttle PLUS the
    holy handgrenade is somewhat of a killer frank horrigan in one shot :P

    the phazer and the bozar seem to be rigged for me ... i encounter an enclave patrol and i have 10 ap
    i need 2 shots each 5ap out of the bozar to kill the 4 men so i usually kill them within the first round O_O

    and the phazer kills everything with a critical for me whenever i shoot at the eyes O_O
    good i got the sniper perk but still o_O i have not encountered a single enemy to survive the first shot i did the following locations with that killer thing :P
    -san fran tanker everything 1 shot
    -holy handgrenade encounter 1 shot for each knight and for the rat (is there a way to be nice to the knights`? marcus fired at them in the first round before i even did something)
    -navarro killed everyone (i kinda don't like them ...)
    -miliary base even the pet deathclaws got hit for 500+damage in the eyes!

    i downloaded the item editor to downgrade the phazor did anyone else have same happenings?

    ah yes and the village close to vault city... how do i end that quest? i got the ankh and i talked to the people in the council but i dont seem to get it solved




    aaand another thing (sorry for ma chaotic posts)

    can you look at two things for me?
    i LOVE the slayer and sniper perks so ... i always got them ... that kinda made new reno boxing impossible for me :( i sometimes kill the enemy with my first punch to the head ....(critical 5hp damage and killed instantly :P)
    then the game gets stuck ... anyway of solving that?


    aand
    is there a way to later on add the "lootable armor" mod as an option during setup?
    i would like to have some armor since i kill most of my enemys with headshots (so why not get their armor after they bit the dust)


    thanks again for reading my scribbles :P
     
  2. encinodude

    encinodude It Wandered In From the Wastes

    174
    Jun 3, 2008
    Update on the NPC leveling issue: Not working, deleting the NPC base files in the proto folder. Sulik and Vic are still de-leveling.

    Also, Slaver's Camp: I got the ring of keys diplomatically from Don (by tricking him) and he agrees affably that I can go get the slaves for Metzger. The two guards guarding the pen, however, aren't as agreeable. They'll attack if I try and open the gate, unlocked or not.
     
  3. TeijoLavuaari

    TeijoLavuaari First time out of the vault

    2
    Jun 19, 2008
    It worked.

    Many thanks!
     
  4. ZiggyMeister

    ZiggyMeister It Wandered In From the Wastes

    126
    Apr 7, 2008
    Yeah killap, can you give us a estimate for the release date of RP 1.3?

    And can you tell me if the save games from RP 1.2 will work with the RP 1.3?



    Because I just started playing with your RP 1.2 and I'm still in the early, early beginning... i.e: As of now, I just created my character.

    Thanks a lot :D
     
  5. Bofast

    Bofast Look, Ma! Two Heads!

    325
    Jan 26, 2006
    @Killap
    In the Abbey, when you have obtained the botany info for the library monk and he asks you to upload it to the computer, the first answer is something like "I'll do that right now", and the other just read "Error".

    Also... when I had killed all the rats in the Abbey basement caves I had to end combat to get the "beast" to turn hostile. When I then tried to shoot it I got the sound and the animations, and the proper amount of action points were subtracted, but no text was displayed down in the message window at the bottom left of the screen, no damage was caused and no ammo was used. :shock:
    My companions could hurt it as usual, though. I reloaded a save in the basement, went to the caves once again and this time I fired at the "beast" before I had killed all the rats, and everything worked normally. Engine glitch, perhaps? :?

    Edit: When I returned the stolen body to the Shi, the phrase "Hold on there. No one said I did this for free." appeared down in the message window at the bottom left of the screen. That was when I finished the "returning-the-body" conversation with Dr Wong by using the line where I did not request a reward.
     
  6. Minigun Jim

    Minigun Jim It Wandered In From the Wastes

    157
    May 12, 2008
    It's not a bug, you're going to the wrong place :P . Don refers to the shed with Sulik's sister, NOT the compound to the south. You can bluff the sledgehammer guard and use the key on the shed's cage door fine.
     
  7. Yeugs

    Yeugs First time out of the vault

    6
    May 24, 2008
    hi, i've just found the metal armor which will replace the leather armor mk2 i've been using since ages. problem is the ac of the metal armor is just 10 whereas the leather one is 20. is this normal ? thanks in advance !
    nick

    edit: well i guess this is normal according to http://fallout.wikia.com/wiki/Metal_Armor it's just strange that the leather armor provides more armor class than it's metal counterpart...
     
  8. abc12345abc

    abc12345abc First time out of the vault

    1
    Apr 11, 2008
    Help...I can't figure out how to get in and fly the vertibird. Besides, there are 2 in Navaro base, which one is flyable? And is it possible to fly back to Navaro from Enclave? Thank you.
     
  9. Kanhef

    Kanhef Vault Dweller

    793
    Sep 2, 2007
    @ Wamphyri:
    If you have Sniper, Better Criticals, and are making aimed shots at the eyes, you'll get a lot of instant-kill criticals with any weapon. You could probably take down the Enclave with a BB gun.
     
  10. BR4ZIL

    BR4ZIL Still Mildly Glowing

    215
    Feb 22, 2008
    killap,about my problem (revert to old NPC appearance) i found this archive npc_appearances_killap.rar i uziped the contents on my SCRIPTS inside fallout's data overwriting the new archives.
    the game is working fine and the npcs got the old look(i really dont like vic's armor)so i asking if these changes will affect the gameplay?
     
  11. encinodude

    encinodude It Wandered In From the Wastes

    174
    Jun 3, 2008
    I went to that shed and I don't remember there being anyone inside unless there was another shed... I'll look again.
     
  12. ogreb

    ogreb First time out of the vault

    75
    Jul 30, 2005
    I like the idea of having to fight at least one of the brothers in PA.( vaniila FO2 RP 1.2 )
    The rest of the fights with them are pretty wimpy...
    I still took him out easily enough though...

    And Kaga should stay evil...I like the idea of having to look out for some crazy guy. Gives the game more tension...
    I know I don't have to choose the speech path and just continue to fight him....but it shouldn't be there in the first place.
    Maybe the last fight you can talk him out of it or something...but not the second.

    Does 10mm JHP just not work anymore ? The turrets at SAD did 0 damage to me....metal armor. I just walked up to them and punched them with a MPF.
    And with combat armor it's the same way..???

    Is it because of the AP fix..so if they had AP ammo they would be causing damage? probably..
    Need to give those turrets Bozars or something....too easy now...its too easy anyway.
    Need to give critters more AP ammo....


    Oh ...!!!!!

    At the EPA ( RP 1.1) you would simply fix the computer in the room where you see the magnetic field message. ( In order to talk to the holograms)
    Now you click the computer and you get a message about a loose wire....but it doesn't say where ....I tried to repair all computers on that floor and nothing happened. Repair 90 with Super tool kit

    Is it on another floor ? I know there is another hologram/computer quest ( binary hologram...unless thats changed also) on another floor.

    I'm going to reload to an earlier save and try the computer again....make sure I read it right...
     
  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    You'll probably have some bugs with Sulik. And some new fixes with Vic will be missing as well.

    Umm...Sulik's sister is in the shed to the right of the main building.


    As for 1.3 of the RP....1.2 did come out like a week ago you know? 8-) But, 1.3 is scheduled for the 2nd week of August. Whether it will contain bugs fixes and and some new content or bugs fixes and a lot of new content is up to graphic artists aiding me in my ventures.

    @ogreb
    Turrets doing 0 damage is because of the AP ammo mod. Disable it in the ddraw.ini file.

    EDIT:
    What do others think about changing the diplomatic path to the final Kaga encounter? I know many of the diplomatic characters were slaughtered during this one but was it also very difficult to handle the other 3 encounters before it? (1st one doesn't count since anyone can survive it)
     
  14. BR4ZIL

    BR4ZIL Still Mildly Glowing

    215
    Feb 22, 2008
    ok thx killap, that conviced me to use the new npc appearance :| (i still think that vic's armor is weird).

    i was thinking, since fallout is full of easter egg why dont you make your own easter egg when you release v1.3 (i know that you want to make the game as most original as possible) but that could be real cool
     
  15. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    The one that can be flown is the one in front of the hanger (not the one inside) See the RP Guide for details. You are able to fly back to Navarro from the Enclave, but there is a restriction here.
     
  16. Slowhand

    Slowhand First time out of the vault

    55
    Apr 23, 2008
    Meaning we're officially back to square one on that issue? Bummer.
     
  17. JayJay

    JayJay First time out of the vault

    1
    Jun 19, 2008
    When I leave Klamath to the upper left exit the game crashes with an application error. Any solution for that?
     
  18. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Send me a save game please. Also, details on your setup (ie installation method, OS, etc)
     
  19. Morticia

    Morticia Look, Ma! Two Heads!

    372
    Mar 9, 2008
    Is there any way to add a dialogue option? One choice to continue to fight and one to scare him away? I don't know.

    We get a dialogue window to talk to that stupid Hermit in a random encounter, (that never has anything to say or sell,) but no options with a much more meaningful encounter like Kaga.

    ***
    One other thing I am wondering about is NPC carry weight. With only the Armor mod installed and Glovs ammo fix on, I seem to remember overloading NPCs in version 1.1 with far less ammo than this.

    - Sulik: 2x SMG, ~1770 10mm, Leather Armor = 95/200 lbs.

    - Cassidy: 2x CAWS, 773 shells, Leather Armor = 63/175 lbs.

    - Vic: 2x Assault Rifle, ~1600 5mm, Leather Armor = 56/150 lbs.
     
  20. zebani

    zebani First time out of the vault

    3
    Jun 19, 2008
    target function not working

    Hello
    First of all, killap thanks for the restoration project.
    Now i am having a problem. I started fresh with 1.2. Played a while then realized that the target icon don't appear on the lower right corner on weapon box. Right click does nothing! But If i start a new game its working fine. What can i do to fix this. I don't want to start a new game again.
     
Thread Status:
Not open for further replies.