Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I did not change anything to do with confronting Francis, only what happens after you have told him you've found the letter.
    Could you please provide a savegame of this?

    killap, in Francis procedure talk_p_proc...
    Code:
    if (54 < 5) then begin
    	  start_gdialog(594, self_obj, 4, -1, -1);
    	  gsay_start;
    	  call Node018;
    	  gsay_end;
         end_dialogue;
    end 
    
    Shouldn't that be...
    
    if (global_var(54) < 5) then begin
    	  start_gdialog(594, self_obj, 4, -1, -1);
    	  gsay_start;
    	  call Node018;
    	  gsay_end;
    	  end_dialogue;
    end
    Or does it mean something I'm not familiar with?
     
  2. Jerico

    Jerico First time out of the vault

    15
    Nov 30, 2006
    I'm having a similar problem with Francis as spukrian.

    I'm trying to finish the "missing people" quest and now only thing Francis says to me is "Hello Hero" and [DONE] is the only dialog option(Trying to confront him about the letter). I think it's because I exposed the "anti-mutant" skeem and I think it was the first quest I finished in BH. Is there away "reboot" Francis to his original dialog options, he doens't even let me arm wrestle anymore.
     
  3. maglalosus

    maglalosus First time out of the vault

    5
    Apr 13, 2010
    Yes - thank you that fixed the problem!
     
  4. spukrian

    spukrian First time out of the vault

    30
    Apr 1, 2010
    Well, the thing is I also told Marcus about the missing people before confronting Francis. Could that have something to do with it?

    Anyway, here´s a save:
    http://rapidshare.com/files/375421391/SLOT61.rar
     
  5. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Nope, you are right. This is an original 1.02 (probably even 1.0) bug. YAY more vanilla bugs! Basically a bug with macro usage.

    EDIT: It seems several scripts at Broken Hills also have this issue. Looking through all the scripts in the game, there also appears to be one at NCR as well.

    Sounds good.

    Awesome news!
     
  6. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Alright guys, the issue with Francis (no arm wrestling or confrontation about his letter) is no bug, but the way it's always been. It happens after you expose the Anti mutant scheme.
    You just noticed it now since you held off with confronting Francis.
    But hey, it's not all bad. You get a free beer. :drunk:

    It's a bit odd though, if not both, then at least the arm wrestling should still be available. killap, could you take a look at Node019 and see what you think.

    To "reboot" Francis, get F2se and set GVAR 301 to =0. Don't forget to set it back to =5 after you've talked with him.

    Also...
    What does this mean? They won't be sent to jail for finishing this quest? If so, this is no longer the case. The do go to jail for it.
     
  7. YujiTFD

    YujiTFD First time out of the vault

    7
    Apr 13, 2010
    Klamath, rustling brahmins' troubles' evidence

    Hello!

    I'm sorry if problem has been already explained. I'm having troubles delivering evidence for who's been rustling the brahmins in Klamath. I realised brahmins has been "rebranded", I got claws, I spoke to Duntons' - no outcome, still impossible to deliver the quest. I tried different ways with no luck. Can anybody hint me with solution, please?

    Update: also accepting quest for Anna's locket, reading the diary and stuff doesn't provide me with quest item from Anna's grave. using fresh F2 install with RP2.0.2d.
     
  8. spukrian

    spukrian First time out of the vault

    30
    Apr 1, 2010
    Thanks Darek, I guess my memory of vanilla FO2 ain´t that good as I thought.

    Hey, I noticed another thing in Broken Hills: if you talk to Phil, the bartender, order a drink, tip him, ask him if there is anything to do, click "-more-", and then "anything else?" leads to a number being printed in the infobox. It is a different number depending on some unknown variable. In the save I link to earlier, it is "11".
     
  9. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Re: Klamath, rustling brahmins' troubles' evidence

    You need speech 51 % to get the correct dialog option with the Duntons.

    What is "quest item from Anna's grave"?

    [spoiler:60903626f0]Have you talked to Mom? Joe?[/spoiler:60903626f0]

    Heh, I didn't know about it either. :)

    That number Phil gives is just a debug message to keep track of the status of the missing peoples quest. It was accidentally left in.
     
  10. drizzt561

    drizzt561 First time out of the vault

    38
    Mar 30, 2010
    Re: Klamath, rustling brahmins' troubles' evidence

    [spoiler:e739020e1e]You also have to talk to Anna's ghost before mom has any dialog about it.[/spoiler:e739020e1e]
     
  11. Voduar

    Voduar First time out of the vault

    7
    Jul 2, 2008
    Bad news, everyone. I found another issue for you guys, though I am not sure if this counts as a bug. When Cat goes from his third level to fourth, he significantly downgrades for me. He loses 1 strength and 2 action points. Also he only gains 7 hit points as opposed to the 10 he gained the previous 2 tries.

    Otherwise, I've found this RP to be excellent.

    P.S. Are the Abbey fixes going to come out anytime soon, or are they being saved for the big release? I want to know if I should wait on that or simply run this version of it.
     
  12. YujiTFD

    YujiTFD First time out of the vault

    7
    Apr 13, 2010
    Thank you, everybody, you were right ! I guess I was playing too much new games recently and completely forgot about old-school RPGs' awesomeness, it's been over 10 years now :?
     
  13. Unkillable Cat

    Unkillable Cat Mildly Dipped

    562
    Jan 5, 2004
    A question: What's the status on the fight with Lenny in NCR? Is that still bugged or have they all been squashed?

    Because I've come across some problems there. They, along with some other bugs, can be found below:

    The Den:

    # If you try to interact with the door leading to the slaves, one of the guards will say a float text ordering you not to touch it. One of those floats is something like "Touch that again and you'll loose a limb." That's a typo and should be "lose".

    Raiders:

    # In the scorpion lair in the Raider caves, near where the "big" scorpion is, there's a knife on the ground that cannot be picked up as it's location is obscured by scenery.

    (There's another item like this somewhere in the game. I think it's down the toilet in Modoc. Scenery prevents it from being picked up.)

    # In the westernmost minefield in the Raider caves (if you entered the map from the "Cliff" map, it's the mines on the leftmost path) there is at least one trap that cannot be disarmed because its location is obstructed by scenery. From the searchable bones, count 2 squares straight down, and then 1 square down to the left. (There may be other traps nearby that cannot be disarmed because they're actually inside scenery and/or walls, but they don't pose a threat unless you set off the whole minefield.)

    # The "Cliff" entrance appears on the Town overview map as long as you've entered the map with the mercenaries on it, but not the cave entrance itself. This is most likely due to the fact that the two maps are loaded together. Propably cannot be fixed.

    NCR:

    # Typo. Gond's float text when he likes you is "Take heart! Our brother's hit a slave camp last week." It should be "brothers".

    # Combat with Lenny is (still) bugged.

    Bug 1: If I kill him normally and end combat, Merk won't talk to me, meaning I'm trapped in the ring.

    Bug 2: If I use the Mutagenic Serum to kill Lenny, but do not make any further attacks against him, he'll fight as normal for the next round, but the round after that he'll drop dead but it will still be his turn, and the game will hang there forever, with Lenny's corpse having the red outline around it.

    Currently, the only way for me to finish the Lenny fight is to use the Mutagenic Serum on him, and attack him at least once in the round before he dies. Even then, at least once did the corpse get up to hit me once before dying.

    # A good portion of the Bazaar maps "reset" after the Lenny fight.

    Doofus starts asking me again if I need to have my car watched. I can talk to him, but I can't pay him to watch the car.

    I used Steal to clean out everyone in the Malamute Saloon. Everybody in there have gotten their stuff again somehow. The only exceptions are Merk and his bodyguards.

    The slavers, whom I killed earlier, are still dead, and the slaves I freed are still free.


    Misc:

    # The NCR Ranger Safe House outside of Klamath has an Assault Rifle in one of the lockers. This Assault Rifle has (none) ammo in it, so it can't be unloaded.


    And I've forgotten to mention this before, I'm playing on a WinXP machine (SP3), and I'm not using the Hi-Res patch. Fresh humongous install followed directly by RP 2.0.

    EDIT: New bug added.
     
  14. Endocore

    Endocore Look, Ma! Two Heads!
    Modder

    365
    Mar 14, 2010
    @Darek
    On the Bess issue I reported (she wouldn't stand up), you could be right. I've been noticing frozen/stalled animations in other places on occassion (although they don't seem to be in places one would expect, namely places with lots of animated tiles and scenery). For example I encountered a party of scavenger ghouls around Gecko, and when I killed one of them he remained in a "standing" animation even though he was quite dead and I looted his corpse; I don't believe I've ever seen that happen before on my many playthroughs of FO2 and various mod versions of FO2.

    I see now what you're saying on the Balthas thing, I didn't notice that while looking at it myself. Thanks. I'm thinking of jumping back to before entering Modoc and replaying onward from there, so I'll make a change to RP 2.0 Balthas and see what happens.

    @all
    I went to Vault City and did many of the Vault City/Gecko quests, but haven't quite finished. The updated maps continue to impress me, and Vault City (all areas) had some particularly nice touches. I didn't encounter any major problems or bugs in either city (apart from the Brain, but what's a game of Fallout 2 without a bugged megalomanical rat?), but did notice a few minor issues as well as some old vanilla FO2 bugs:

    --Vanilla FO2 bug: Lydia the bartender's "look" description says

    Val (Vic's daughter) has the same description, yet Val is indeed wearing metal armor while Lydia uses the peasant outift sprite. Either Lydia's description or her sprite should be changed.

    --In Gecko, in the cornfield right by the entrance to the town, a ghoul is "packed" too tightly in the corn. He can't move around, and the player can't talk to him.

    --Line 122 of gclenny.msg

    should end in a question mark.

    --Vanilla FO2 bug: The guard at the front desk of the power plant, when asked about door access keycards, very clearly states (gcrdesk.msg, line 140)

    yet only the last part is true and the player is forced to resort to that grand old ridiculous tradition of crpgs--randomly rummaging through shelves in other people's homes--to find the keys. Perhaps this shouldn't bother me so much, but I make it a point to not participate in the tradition and refuse to rummage around shelves in peoples homes while they stand idly by watching me unless there's no other way to get a required item (such as the colored keys at the plant). Unfortunately, though, neither Jeremy nor the guards at the doors (gcrguard.msg) have dialogue lines to facilitate a conversation about keys. On the issue of keys and doors in the plant, the door to the small "computer room" area on the way to the reactor is colored yellow but doesn't require a yellow key. Perhaps it should be switched to a regular sliding door.

    --I found a small lockpick set somewhere along the line, but it doesn't work on the locked doors in the Vault City vault from the active item slot (i.e. click on the lockpicks, the cursor turns to a circle with a tiny dot, click on door, "That does nothing" appears in message box).

    --Vanilla FO2 bug: Line 208 of gcharold.msg needs something...

    Either a "Uh, well, I uh, that is... Goodbye" or a "Uh, well, I uh, that's all. Goodbye." would do nicely here.

    --While leaving Vault City at night I picked up the raider's trail and followed them on a lark. I didn't actually do anything after arriving at the Raider base as my party isn't strong enough to tackle them yet (I reloaded a save game and played on from Vault City), but I noticed that one of my party members seemed to spawn "in" the water truck at the cityscape entrance to the raider base and wasn't able to move. I tried it a second time (left Vault City at night, followed the raiders) and the same thing happened again. I tried going down the ladder and all the party members appeared with me, so it wasn't a permanent problem. However, perhaps the truck should be moved a few hexes south on the topside map. Although I said I wouldn't mention them anymore, the scroll blockers on the cityscape entrance map to the Raider base aren't set properly, but in an opposite way--they're too far out. If I can see lots of blank/black areas outside the tiled area without using the hi-res mod, then it probably looks like a sea of blackness with hi-res installed.

    --Poor Brain. Instead of taking over the world, his true ambition seems to be to beat T-Ray in a contest to be the buggiest FO2 character ever. In my initial conversation with him he tersely mourned the loss of Keeng Rat and grew quiet to mourn as usual, and then when I clicked on him again the chat started as follows:

    I looked at his script and actually didn't see the problem Darek mentioned in talk_p_proc (it looks like all the procedure calls are carefully framed within open and close dialog commands), but I didn't follow all the dialogue nodes through to their respective ends so perhaps the problem is in those, or is something else.

    --There's still the old issue with Lumpy saying "Skeeter's right here" when Lumpy is somewhere other than Skeeter's workshop.

    --In the past there have always been issues about scripted items contributing to the "too many items bug" and so forth, but now that these problems are supposedly fixed--why not add a simple script with a timer to make a Vault City "Day Pass" live up to its name? I've always thought it's sort of silly that a single one-day pass allows one access to Vault City until the end of time. When the timer runs out at the end of the day the Day Pass item is destroyed and replaced with an "Expired Day Pass" item. The player would then be required to obtain a new valid Day Pass from the Customs Office. I guess whether this is a vanilla FO2 bug or a feature begging to be implemented is debatable.
     
  15. ocelot

    ocelot It Wandered In From the Wastes

    109
    Sep 17, 2003
    My game crashes immediately after I return to Primitive Tribe after negotiating the stimpak deal.
     
  16. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    What dialogue options did you choose?
     
  17. Dravean

    Dravean Where'd That 6th Toe Come From?

    478
    Mar 6, 2005
    I like this idea. It gets my vote.
     
  18. NielsK

    NielsK First time out of the vault

    10
    Sep 12, 2008
    Just to support Darek, here is my saves from Modoc and Broken Hill.

    http://www.megaupload.com/?d=3RLPKA6U

    Balthas has almost the same problem as reported before. But I believe that he somehow gets assigned the same speech responses, as Jo. Until Johhny is brought back or as long the player is doing the slag quests.

    Francis does reply, but the game crashes when it is making the area transition after the conversation.

    The Den:

    Anna's diary doesn't have a description when you hover over it at the npc trade dialog.
     
  19. Iguana Bob

    Iguana Bob First time out of the vault

    10
    Nov 8, 2008
    Sorry to bother again, but I did what you suggested me (uninstall, reinstall from scrap, and then RP) but the result is the same...
     
  20. SilverM

    SilverM It Wandered In From the Wastes

    103
    Feb 16, 2008
    I don't think it's supposed to be a One-Day Pass that expires. It's a pass that grants the holder the access to Vault City ONLY AT DAY TIME, during which (s)he can conduct business. In the evening the person is escorted out of the city and can return the following day. more info: http://fallout.wikia.com/wiki/Day_Pass
     
Thread Status:
Not open for further replies.