Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. Endocore

    Endocore Look, Ma! Two Heads!
    Modder

    365
    Mar 14, 2010
    I went back and did everything there is to do in Modoc all over again (starting from before I entered the town for the first time), and learned a little more about the problems I had there last time:

    a) The problem I had before with Bess standing up is actually a vanilla FO2 bug, and a complex one at that. If the player uses a Doctor's Bag to heal Bess, her crippled leg is healed but the process interferes with setting the variable (mcbess.int local variable 0 bit 512) that determines whether she should stand up or not. Per's Guide to Fallout 2 mentions that the doctor skill rather than a bag must be used, but not that a strange bug is behind the whole thing; in fact it looks like whoever wrote the script at BIS intended the player to use a doctor's bag as the preferred method of fixing Bess' leg. Use_obj_on in mcbess is buggy as it currently exists, but even after rewriting and fixing that (and very prominently placing a "script overrides" command there), the Doctor's Bag itself still overrides Bess' script anyway and fouls her up. The moral of the story is, heal Bess with the skilldex doctor skill if you're going to try at all (which we knew before thanks to Per, but at least we now we know why) unless there's some way around the issue of script interference from the Doctor's Bag.

    b) The problem with Balthas' weird dialogues after going to the Ghost Farm is indeed completely fixed by moving the call for a float text ("Please save my boy") to the end of his talk_p_proc (after everything else there has been processed), as Darek suggested.

    c) There are bugs with both Cornelius and Farrel surrounding the watch quest--but these bugs were also present in RP 1.2 (in which I replayed Modoc as well during my search for answers--sometimes those backed up savegames come in handy). After asking around town about the watch situation and then returning the watch to Farrel immediately after retrieving it from the outhouse (in either RP 1.2 or RP 2.0), the player can still ask him about where he got the money for new tools and what's in his wall safe; both of these lines of conversation lead to the ability to demand he confess to stealing the watch or provide proof of his innocence. Since the player just gave him the watch moments earlier, obviously this is all wrong. After returning the watch to Farrel, the player can still tell Cornelius about Farrel's wall safe prompting a fight between the men. Even if one were to insist that Cornelius is senile and it's funny to instigate a fight even after the watch has been returned, looking at this in terms of the Farrel problem says to me it's a bug as well; once the quest is done it should be done. I can only guess the reason no one else reported this before even in RP 1.2 (as far as I can tell) is that nobody else ever talks to Cornelius or Farrel again after solving the quest (as there's really no reason to).

    Another vanilla FO2 bug I noticed but had forgotten about: in the area around Modoc there's a random encounter called "Mantis fighting Brahmin." In all the times I've gotten this encounter, there has never been a brahmin in sight. In worldmap.txt it's in Encounter Table 22 ((6-8) DVMV_Mantis_Swarm FIGHTING (5-8) MOD_Wild_Brahmin), and everything there looks fine (correct monster pids called, etc) so I don't know what the problem is.
     
  2. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    The RP will not function correctly if you use vanilla maps for the main locations. You should be fine copying over random encounter maps though.

    However, don't fret. We are going over the maps and fixing things. Random changes like the Geck by the Arroyo bridge (which is unreachable, btw) and the gate in Klamath are being removed. I'm not sure why they were added other than for a rofl, but whatever. Other maps glitches are to be expected with so many changes. They are all being fixed up though.

    In other news, many bugs squashed today. See the wiki for comments on unconfirmed bugs. RP 2.1 will definitely be a hefty bug fix update. Some vanilla bugs are being squashed too (it never ends!).
     
  3. Grunter

    Grunter First time out of the vault

    19
    Jun 11, 2008
    Thanks Killap

    I was not trying to be unconstructively critical of the additions. Plenty of other people like them :) That's good. I just felt that some of them detracted from the spirit of the RP.

    I fully understand that there will be bugs and issues in any substantial application (I am a software engineer). Everyone who plays a game makes a decision based on whether the bugs outweigh the pleasure derived from playing a game or not. Up till now the pleasure has always outweighed the problems. I am looking forward to that balance being restored in 2.1

    Once again, many thanks to everyone involved in improving this game.
     
  4. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I didn't see your post as being critical at all. I appreciate all feedback, no matter what.

    Bug squashing is first priority, balancing/tweaking then follows.
     
  5. GlowHound

    GlowHound Look, Ma! Two Heads!

    311
    Jun 12, 2008
    Apologies.
    Concerning Francis. I've applied both of Darek's fixes, but the quest still isn't working. I'm past actually talking to Francis and letting him go, it worked after I dropped the note. But I've gone back to the tunnels and looked at the bodies after getting the second fix, but I still can only tell Marcus that there are tunnels under the city.

    Do I need to start a new game, or...?
     
  6. wastrelwink

    wastrelwink First time out of the vault

    6
    Apr 15, 2010
    Hi, having fun with the restoration project, thanks a ton for all the work you put into it. Running into the following problem, twice now.

    First, things were going great, until I got to the EPA. When I arrived, the entire visual map was black, just me and my npc's (including the trunk of the car). After scanning online help faqs, I reinstalled and re-updated, and then modified the ddraw file. Now, the fuschia and purple highlights are gone, but sadly I'm running into the same problem, only in the DEn this time. Just me, my GUI, and Sulik in a field of black. I can run around and everything, there's just nothing there. No exit hexes, just me and my mottled shadow.

    This seems dissimilar to the other 'black screen' problems. Any idea what is wrong?

    Edit: Before, I also tried updating Sfall. which led to a problem in which the game wouldn't start, with some error about cities. Which is why I reinstalled, and lost my save game :( )
     
  7. Tuxi

    Tuxi First time out of the vault

    4
    Apr 10, 2010
    So I have played Fallout 2 almost through. I am at the Oil rig mission and Im getting so frustrated. I know I should arm the bomb and free my people but the president doesnt have any "Presidential Access Keycards". So Im pretty stuck, Im level 30 and I stand no threat to the dozens of Enclave guards there. In need of help, really want to finish this game as I have literally played it dozens of times all the way to san francisco but then got frustrated and stopped. Now I decided to finish the game but ran to a bug... :|
     
  8. ufo_hunter

    ufo_hunter First time out of the vault

    59
    Feb 29, 2008
    @Tuxi

    I believe that has been mentioned in the technical wiki (see page 1 of this thread). The key is missing by accident and will be fixed later on. Maybe you can add it to your inventory with an editor.
     
  9. Tuxi

    Tuxi First time out of the vault

    4
    Apr 10, 2010
    Meh, got so frustrated that I watched the ending scene and shift+deleted the game. The final level was very annoying even without the bug though.
     
  10. Lexx

    Lexx Background Radiant
    Moderator Modder

    Apr 24, 2005
    Huh, I finished the game with level 23. You should have no problems with the enclave people. Especially because you don't really have to kill everyone.
     
  11. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Good you try to get to the bottom of it, and an interesting find. :)

    The use "doctors bag" is not BIS code but killap (or Seraph) code. As for the problem itself, the engine seems hardcoded to not run ANY code in the "use_obj_on_p_proc" procedure for the doctors bag and the medkit. So a script override will obviously have no effect.

    The way to make it work would be to put the code in "procedure critter_p_proc" and have a check for when Bess is no longer crippled. " if not (critter_state(self_obj) bwand 8)" or whatever it would be.
     
  12. Endocore

    Endocore Look, Ma! Two Heads!
    Modder

    365
    Mar 14, 2010
    @Darek
    This is actually a lot of fun, sort of like a Fallout 2 metagame. By trying to fix (or at least looking into) RP 2 bugs for myself as I run across them, I think my knowledge/skill level has increased by a few hundred percentage points just in the last two weeks since RP 2 was released. Although I'm sure killap doesn't want a lot of backseat drivers running amok with his mod (or at least not until he's done with it), I would encourage everyone to try this if they have the time. The things you'll learn will provide a big benefit later if you want to make some original modifications of your own, whether they're just for yourself or to share with others.
     
  13. Jerico

    Jerico First time out of the vault

    15
    Nov 30, 2006
    Just wanted to report a bug(s).

    1. In Abbey there was a monk who wanted to leave so I agreed, but asked for him to wait. Now he is M.I.A nowhere to be found. I guess he dissapeared when I left the map to seek for the water pump parts.

    2. In New Reno Mrs. Wright is supposed to meet you in the church where Father Tully is when you talk to her about the her husband selling alcohol, and according to a walkthourgh she's supposed to show up at 6 a.m. Well I waited and she didn't show up. I tried leaving the map and returning, but nothing and when I doubleback to the Wright mansion she's M.I.A too.

    Sorry for reporting here, but there was no mention of the 'transport a monk' quest in Abbey in the walkthrough in wiki, so either it hasn't been updated yet or it isn't a quest(little bit confused about this). And according to the walkthrough I read the quest about 'alcohol still' should be working as there several mentions about other quests that don't work. So either Mrs.Wright missing is avanilla bug or something is wrong with my game.
     
  14. Tagaziel

    Tagaziel Panzerkatze Staff Member Admin Orderite

    Dec 10, 2003
    One more bug: when in the EPA and using the repair skill so that Vic would run up and fix stuff, the game doesn't check his skill but mine, forcing me to go out and level it up to explore it.

    Why diminish the usefulness of our favourite fatass?
     
  15. minvader

    minvader First time out of the vault

    7
    Apr 6, 2010
    has anybody get the robbers cave in a random encounter? i've entered LOTS of caves and no luck. (not even empty cave).

    also in new reno after being made man for Mordinos, if you become made man for another family, you can do all Mordinos quest again.
     
  16. spukrian

    spukrian First time out of the vault

    30
    Apr 1, 2010
    I had a weird crash. A vagrant in the tanker was blocking the exit and when I wanted to push her, that action wasn´t available, I ended up doing an examine instead and the game crashed.

    This is no big issue though.
     
  17. Voduar

    Voduar First time out of the vault

    7
    Jul 2, 2008
    @minvader Yes, but its taken forever. I've had one cave full of robbers and 2 empty caves. The empties were very early, and the robbers were after I was already lev35

    EDIT:Just managed to get a second one. Both times when there were actual robbers I was in the mountains west of Redding. I don't know if that's relevant
     
  18. SHADOW-XIII

    SHADOW-XIII First time out of the vault

    98
    Nov 19, 2007
    actually I was playing that part in RP 1.2 and had to wait few days till she came, don't remember exactly but I was frustrated waiting for her so long ... just get few days, few in/outs from that part of city or city itself
     
  19. DGT

    DGT It Wandered In From the Wastes

    148
    Apr 7, 2006
    Has Jinxed been altered in the UP/RP? It seems like I'm seeing a lot more misses and less critical misses than I used to with Jinxed in vanilla. Missing 3 times in a row (not rarely, either) with 110%-120% unarmed and a 90% chance displayed isn't making sense.
     
  20. Luigibacsi

    Luigibacsi First time out of the vault

    12
    Jan 18, 2009
    Excellent work killap, love the new version! Is it possible to add the karma pictures that were disabled by BIS(scourge of the wastes, shield of hope ect..)? Also do you have a list that notes the new/changed dialog files(it would haste the translation greatly)?
     
Thread Status:
Not open for further replies.