Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. mobucks

    mobucks As a goof Orderite

    May 22, 2010
    Kaga is the other "chosen one" right?

    I never had encounters with him this playthrough, i thought the first was on the way from arroyo to klamath, but i did the min/max game opening where you dont kill anything/get exp till you pick up sulik/vic/cassidey and got the car really early as well.

    I am playing as a female, but updated to 2.0.e after starting this game. (Which was vanilla 2.0 installer)

    Could the fact that i skipped all the arroyo quests after the TOT have something to do with it?

    anyway, thanks so much for all the hard work, all of the people who made/contributed to this mod/expansion.
     
  2. The Regular One

    The Regular One First time out of the vault

    56
    Mar 25, 2009
    @Rodneyh37

    That problem has already been entered into the technical wiki by me.
     
  3. Rodneyh37

    Rodneyh37 First time out of the vault

    16
    May 21, 2010
    Ok, cool.
     
  4. bojanh66

    bojanh66 First time out of the vault

    6
    Apr 3, 2010
    How should we install RP 2.1 ?

    Is this the right way:
    -first RP 2.0,then 2.0.2e update,then RP 2.1
    or
    -first RP 2.0,then RP 2.1,then 2.0.2e ?

    thanks.


    --------------------------------------
    i know that,but i mean are there some other way?
    something like this:
    -
    -
    is this true or not?
     
  5. Mirr

    Mirr First time out of the vault

    48
    May 1, 2010
    @bojanh66 RP 2.1 is not out yet.See page 1 for information.
     
  6. Vic Ious

    Vic Ious First time out of the vault

    24
    Feb 7, 2010
    Tried it various times now. Some of the slavers who are protecting Metzger don't take damage from firearms. Even Marcus with his gatling doesn't do a scratch on these guys.
    HtH on the other side hurts them from 2 to 4 damage points.

    Is this a known bug?
     
  7. mobucks

    mobucks As a goof Orderite

    May 22, 2010
    [EDIT] -Solved, awnser on page 65, thanks Darek


    Sorry about the dumb Kaga question, i read the release notes fully.

    I have a problem though i just want to see if anyone else has it.

    My NPCs do not follow their "custom" combat behaviors. I had Vic, Sulik, and Cassidy, all had only melee weapons, and they would use them, however they wouldnt "close distance" to engage, only attacking if a critter was lead to them within 1-2 hexes. I have pleanty of times started a fight and see all my men just standing there not helping me, skipping their turns, or moving one hex towards me but not fighing.

    Thing is, i think they act like that only in certain situations. I havent tested it fully,(not alot of combat in my game yet, and i restarted) but the whole issue was happening inside a random encounter cave filled with mutated mole rats i walked into when i ran into a hermit. Inside the cave the issue was there, but i went outside to talk to/ throw knife at head of/ the hermit, and after i attacked all my NPCs closed to engage him in melee.

    Maybe the party NPCs are "blind" inside certain caves?
     
  8. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ mobucks,
    Check out my posts on page 65 of this thread for the answer to your NPC problems (the one with the picture and the next one). No fix yet though.
     
  9. Magnus

    Magnus Water Chip? Been There, Done That
    Modder

    953
    Dec 6, 2007
    Some of those guards carry Psycho, which increases DR by 50. If they're wearing a bit of armor and you're using JHP ammo, DR might go up to 90, which I believe is max, and then there's DT to worry about. Not a bug, just overpowered drugs. With some kind of AP ammo mod active (like mine) you should be fine using AP ammo against those guards, or you could try a hunting rifle with FMJ.
     
  10. Rodneyh37

    Rodneyh37 First time out of the vault

    16
    May 21, 2010
    I found a bug in using the Brotherhood bunker computer in San Francisco.

    I started off the game with 7 STR, i reached the computer with a Power Armor, meaning i had 10 STR because the armor added 3 points.

    I couldn't get the "i want to get stronger" option while been with the Armor because well... i am already at 10 STR but i said i want to add the STR anyway, so i took the Armor off and then went to the computer who did have the add STR option... now i took it but when i got back to the INV and added the Power Armor again i think the game counted me as only having 8 or 9 STR instead of 10 because the size limit of my INV was lower then before i used the computer [when i had the Power Armor]

    If it matters, i never took a perk to add size to my INV.
     
  11. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    A save game would be helpful, preferably right before you increase your strength.
     
  12. Rodneyh37

    Rodneyh37 First time out of the vault

    16
    May 21, 2010
    Of course:

    http://www.2shared.com/file/nJBhh20H/SLOT04.html

    I also found a much bigger bug, i was doing the hand-to-hand combat quest for the Dragon and Cassidy and Sulik [not others] are shooting at the people I'm fighting with during the combat and every time they kill one i "win" the round and the town doesn't get mad, they act as if i won by myself without the use of weapons.
     
  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Alright, grab this file for a (hopefully) fixed brotherhood computer. Save it to your Fallout2\data\scripts directory, overwriting the file already there. This will also fix problems with the other stat upgrades (charisma, perception, intelligence). The underlying problem has to do with all the various perks, traits, armor stats, etc that were not all being accounted for correctly.
     
  14. legionarius

    legionarius First time out of the vault

    3
    May 24, 2010
    First of all really thanks to Killap "The Bear" :)
    I have windows 7 64 bit, and I have a problem: the colors are messed up.
    I have tried first installing the clean version of fallout 2 (and I noticed the color problem). Searching on the web, I found that some people solved the color problem simply copying ddraw.dll from Fallout 1 to 2.
    I've made it and the game worked well.
    Searching for patches I decided to try some F2 mods. I uninstalled fallout 2. I reisntalled it. I applied F2_Restoration_Project_2.0, and after I upgraded to "2.0_update2e".
    The game runs, but once again I got the colors problem :( I tried changing ddraw.dll, but the game crashes. So I have left the ddraw.dll of the res. pack, and the game works but the colors are messed up :(
    Someone else has got windows 7 64 bit? How have you solved
    the colors problem? Killap i know you are a good Bear, have you got some ideas about this problem?
    Thank you :)
     
  15. RangerKarl

    RangerKarl First time out of the vault

    22
    Apr 7, 2003
    Hey killap, nice to see you're still working on this. Unfortunately got a problem entering Den for the first time, from the world map.

    Clean Fallout 2 install, then installed 2.0 installer version, then pasted in the 2.02e updates after that. Looked through the wiki and part of this thread for solution but did not find any.

    Mediafire of save: http://www.mediafire.com/?nzk3mhiyz2i

    Also, I can't recruit sulik. I did the Torr bug hunt line, and asked for maida to waive his debts, but the option to ask him to join up just has him say his "resting here with grampy bone" line.


    EDIT: Argh! I just noticed I neglected to check my copy of FO2 and assumed it was US, when in fact it was UK. Reinstalling the ResPack with child FRMs let it load. Sorry for clutter, but this may help others to check if they're suffering from the same thing.
     
  16. BuxnaMan

    BuxnaMan First time out of the vault

    61
    Mar 26, 2010

    Go to options -> scrn and change color to 16-bit. If after restart you get "failute to initialize input devices" error edit ddraw.ini and find and change to 1:

    ;Set these to 1 if you want fallout to access the keyboard or mouse in background mode
    ;Try these if you get the 'Failure initializing input devices' error
    BackgroundKeyboard=0
    BackgroundMouse=0
     
  17. legionarius

    legionarius First time out of the vault

    3
    May 24, 2010
    BuxnaMan thank you very very very very much!!! I have changed to 16-bit colors and now I see everything well. The color problem seems to be disappeared! I have just tried to enter in the game and everything seems to work fine :) Now I will start playing the game hoping to do not have problems^^

    BuxnaMan I tried before to change to 16 bit, but I changed even something else in scrn, I clicked restart, and the game didn't start anymore. But now I've reinstalled everything, and I've changed only the colors to 16 bit and everything seems to work :)

    Thank you very much BuxnaMan, and of course to the good Bear that created this mode :)

    Guys with the restoration pproject i installed even Miria F2RPv20. I think I should be ok now, or there is something else I need/would be good to install before starting the game? :)

    Thank you again guys:)) I didn't think that so many people liked fallout II :) I am very happy I can play again this beautiful game :)
     
  18. TaapLuup

    TaapLuup First time out of the vault

    50
    May 11, 2010
    Any word on when 2.1 will be ready?
    I've been holding off playing this mod till its release. (can't wait!)
     
  19. Darek

    Darek is currently unavailable

    Jan 7, 2008
    When the beta testers are done and the bugs they found are fixed. I would guess around one more week or so. It depends on how much time everyone involved have.
     
  20. TaapLuup

    TaapLuup First time out of the vault

    50
    May 11, 2010
    I was hoping Killap would give us a more firm date.
     
Thread Status:
Not open for further replies.