Fallout 2 Restoration Project 2.0 (Unofficial FO2 Expansion)

Discussion in 'Fallout General Modding' started by killap, Apr 1, 2010.

Thread Status:
Not open for further replies.
  1. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Wait, in vanilla F2 you only get six shots with the gun at night? Really? I totally thought you can shoot at night as much as you could shoot during the day... I actually rarely use that gun, so can you provide details in how it actually operated before?
  2. Drelm287

    Drelm287 First time out of the vault

    Jan 21, 2010
    But if I just tell him to change the armor, nothing weird happens, right? If I can't ask to Cassidy to change his armor, I better uninstall npc mod.

    Thanks for the first "emergency" update. :wink:
  3. Darek

    Darek is currently unavailable

    Jan 7, 2008
  4. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yes, if you just have him switch armor, he will be fine. The problem is if you have him run around without any armor. A fix for this will be out shortly.

    Ah, okay. The reason I modified it was because I thought you could use it at night. You can, but you cannot recharge it. That is essentially what I want. Alright, I shall remove the change I made from the RP installer/manual install.
  5. carpediem99

    carpediem99 First time out of the vault

    Apr 2, 2010
    Thanks Killap for your hard work and thanks to the team for working on this project. I've been following the main post for the last 2.5 years and so happy for the release.

    I have a question regarding this:

    There is now another way of killing Keeng Ra'at. Be observant of the scenery.

    Any hints I can get? I have been looking and can't find a thing.

  6. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Update 2 (2.0.2)
    -Already includes all changes in update 1
    -Fixed several maps where the rug under a critter would prevent the player from speaking to the critter.
    -Mom would give "Error" as her response after you help her setup the orphanage. This has been fixed.
    -Cassidy would disappear if you asked him to remove his armor and had him run around unarmored. This has been fixed.
    -Harry in Vault City had no inventory. This has been fixed.
    -It was possible that AHS-7, Suze, and a table at one of the gun merchants in San Fran would not operate correctly due to the map changes in this release. This shouldn't be a problem now.

    Download and extract it to your main Fallout 2 directory. Overwrite the files already there. You know it is updated if the rock at the start of the game says 2.0.2.

    Look at the wood supports.
  7. x'il

    x'il Water Chip? Been There, Done That

    Mar 3, 2009
    Hey, killap, i don't know if you already knew this and included it as part of the npc armor mod in the current RP or not, but some time ago i uploaded an un-armored cassidy critter in the animations thread.

    Here: http://www.nma-fallout.com/forum/viewtopic.php?p=730434#730434

    (Just thought of that when i read your post above, because i've noticed in some discussions before that critters can dissapear if there's no animations for a particular armor or weapon).
  8. DGT

    DGT It Wandered In From the Wastes

    Apr 7, 2006
    killap, sorry to not post this on the wiki, but I'm failing to use it properly and don't have the time to figure it out at the moment.

    Anyway, I'm having a problem with being pulled out of the worldmap every few seconds into an encounter screen that's empty except for what may be a random number of Broc Flowers and Xander Roots. I am then forced to run to the exit grid for another few seconds of world map travel.
  9. Harold

    Harold First time out of the vault

    Feb 21, 2010
    I found a bug in Modoc, using the 2.0.2 version. When you try to talk to Farrel you can't reach him (you get a "can't reach" message). I'm guessing this is the same as the earlier rug issue since he's standing on one of the new rugs. Still I didn't enter Modoc earlier with that save, I reloaded from an earlier save and entered for the first time with 2.0.2.

    (I added it to the technical wiki too but since it's behaving extremely oddly for me I'm posting it here too.)

    I too am having problems with that page. For me it's not updating properly. When I view it I see the old version for RP 1.2 but when I click edit I see the new version for RP 2.0 (tried purging the cache, restart browser et c several times). I hope I didn't screw anything up editing it.
  10. Tony Brasco

    Tony Brasco First time out of the vault

    Mar 11, 2010
    It appears that the installer does not work entirely correct if the user does not have english (United States) as their regional settings in Windows. This is possibly due to differences in the way different countries write dates and times or use a different decimal separator. It may be due to the addelay-script, which assumes the date or time is in United States format. The script uses at least %TIME% variable.

    Changing regional settings in Control Panel to English (United States) seems to allow normal installation. My Windows XP is English Professional, but I live in Finland and use Finnish regional settings.

    Also, I noticed that in ddraw.ini, DamageFormula is set to 0 even though I checked the Glovz's ammo tweak in the installer.
  11. joochian

    joochian It Wandered In From the Wastes

    Apr 1, 2010
    guys i am having problems:

    -going to den residential, is ok, but leaving it becomes blank and program quit..

    -ask metzger about slaver camp, he gives direction, when i reach there, 2 rangers arrive together and slavers start shooting.. rangers like to burst and vic was killed...

    :previously on RP1.2, i killed metzger and ask his slaves about sulik's siter to get slavers camp, and reaching there without being shot.. still able to chat/bluff my way thru the guards.. eventhouhg metzger was dead

    -having a car, did not help my continuos xander-broc encounters.. the xander+broc from wasteland cannot be stacked as the same items with xander+broc from towns..

    any comment? the xander-broc encounter is getting tiresome like bad april fool joke..
  12. joochian

    joochian It Wandered In From the Wastes

    Apr 1, 2010
    DGT... you are not alone... even after getting a car, you still have to meet the endless/repeating xander root + broc encounters.. haha
  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I am using just that for Cassidy's unarmored appearance. Great job with it!

    Does it display any specific message in the message window? Also, a save game would be useful. Did you install this on a fresh install of the game?

    Damn, knew I missed one. Alright, fixing it up now.

    I'm working on a solution to this.

    Good to know.

    That is totally different. DO NOT change the setting in the ini file. I repeat, DO NOT. The ammo mod is contained in other files now.

    Save game, please.

    Uh, Rangers were there? Did you ever talk to the Ranger in NCR? Save game, please.

    What are you asking here? Are you saying you cannot ask the slaves about the camp anymore?

    You had sent me a save game earlier with Cassidy and Harry in VC. I did not experience the random encounter issue that you and others are describing. Did you install RP 2.0 on a fresh install?
  14. Jerico

    Jerico First time out of the vault

    Nov 30, 2006
    Having a strange problem.

    I mentioned earlier in this topic that Kaga doesn't take any damage(first encounter), ok I might have broken it by saving in the middle of combat(my bad), but now that I updated to 2.0.2 I don't get any encounters at all.....walked around map for along time.
  15. BuxnaMan

    BuxnaMan First time out of the vault

    Mar 26, 2010


    Ok I have fixed my error by updating directx. It seems some of the files from older versions are not included in dx 11 from windows 7. I used directx web setup to download missing files.

    I tried posting on technical wiki but I thing I actually messed up something. My problem is that when I try to use Sfall in SCRN options and restart game after usual "failure to initialize input devices" which I fixed editing ddraw.ini I encounter another error.

    The instruction at 00379ae4 referenced memory at 00000000
    The memory could not be read from

    Click OK to terminate application

    I am using RP 2.0.2 on clean install of Fallout 2 from my old disc without any other mods. I have Windows 7 in English with English version of the game. I have installed Fallout in C:\Fallout 2\ rather than in Program Files. I have also tried running it as an administrator but same thing happens.

    I should note that everything works fine when editing back ddraw.ini and just using high resolution without directx9 rendering.

    Another note I do not seem to encounter endless empty encounters everybody is posting about. I have tried traveling a lot around world map and haven't got one. I am not much into game I just went straight from my village to traveling so I could check if this happens to me.

    Again thank you Killap and all people that worked on this. I am glad you released it even thou it is not perfect yet.[/b]
  16. Ervik

    Ervik First time out of the vault

    Apr 1, 2010
    What I'm looking for are these:


    Images for each specific karma level. Maybe they were in 1.2, but I've never seen them atleast.
    The only one that shows up is the "Savior of the Damned" one. Which seems to be the default.
    So did I really miss them? Been looking all over on the character screen...
  17. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Wow, did not see those before...or maybe I have. Not sure, I haven't slept much recently.

    No, those are not in RP 2.0 (or any previous version). I'll consider adding those to 2.1 though.

    This is probably due to the resolution you are setting it to. Have you tried a lower resolution? Like 800x600?

    EDIT: Also, try setting SAFER_DISPLAY_LIST to 1 in f2_res.ini in your main Fallout 2 directory.

    I think I got a new batch file for the installer. Those of you with non English versions of Windows should no longer have a problem. I'm packing everything up so that future people don't have to download all the updates.


    Okay, for those of you with empty random encounters popping up all the time, I assume you did not uninstall 1.2 or a previous version of the RP. It is highly recommended to do a fresh install. However, I want those with this problem to go to Fallout2\data\scripts and look for a file called: glkagaen.int If it is there DELETE IT!
  18. BuxnaMan

    BuxnaMan First time out of the vault

    Mar 26, 2010
    Ok I have fixed my error by updating directx. It seems some of the files from older versions are not included in dx 11 from windows 7. I used directx web setup to download missing files.

    But another error/bug (maybe not?) comes up. When I die I can hear narrator saying his text but the screen is just plane white (no image of dead body wearing vault 13 suit).

    I would also like to know if not being able to walk too far is fixable. This is pain in the ass on high resolutions since I cannot move from top of the screen to the bottom in one click but rather have to move several smaller distances. Especially if while moving I click too far Chosen One just stops walking.
  19. Endocore

    Endocore Look, Ma! Two Heads!

    Mar 14, 2010
    Congratulations, killap, on this major new release of your project.

    Apart of course from the need to place all the files oneself, are there major differences in the file content or other differences for the end user's experience between the Windows auto-installer version and the manual install version?
  20. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    There is a difference. You don't get any of the extras (ie npc armor mod, Cassidy head, etc). All you get in the manual install is the RP, sfall, appearance mod, and resolution patch.
Thread Status:
Not open for further replies.