Fallout 2 Restoration Project 2.1.2 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Sep 5, 2010.

Thread Status:
Not open for further replies.
  1. Asmodan

    Asmodan First time out of the vault

    Sep 2, 2009
  2. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Found the problem. Vanilla bug. The description of the encounter is not accurate with what is actually happening. It says mantis/scorpions and brahmin, when in fact the brahmin are not spawned. Which is correct? The description or the coding? Thoughts on this? I believe in the past we've sided with what the text files say and assume coding error.
  3. Haenlomal

    Haenlomal It Wandered In From the Wastes

    Sep 25, 2003
    I would say go with the text, and make the random encounter spawn brahmin...can never have too many brahmins to kill, I say. :P Anyone want steak? :)

    -- The Haen.
  4. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Hmm, so the only instance I found of this was one entry in the encounters table with mantis. This encounter happens near Modoc. All other brahmin vs critter entries in the table appear correct to me. I've corrected the one issue, but I guess I'll have to test in game and see if the problem persists for other brahmin encounters.
  5. agris

    agris Still Mildly Glowing

    Jul 8, 2004
    (RP 2.1.2) north of Modoc, I got a "you encounter a herd of brahmin" encounter and it was totally empty. No mention of mantis. I had sold Bess to the jerkey guy in Modoc, but then let her out so I was expecting the special encounter detailed in Per's walkthrough and never got it. Maybe this was supposed to be it? Either way, no mention of mantis.

    savegame: http://www.mediafire.com/?pekk0qcmic12gbs
  6. willooi

    willooi It Wandered In From the Wastes

    Aug 23, 2010
    Hey Killap, just finished this version of the RP, great work :D

    The bugs I encountered were the Shi still saying 'Now for the Hubologists' even though I'd already slaughtered them all, and occasional times in random encounters when critters would be shooting but their animation frames would remain static. There have also been times on the new encounter maps where my party and I can seemingly walk straight through the car.

    My party and I also managed to kill Kaga pretty easily on my second encounter with him as he spawned on the entrance to a cave. He was critically hit and fell to the ground, and upon getting up he wouldn't move and just got gunned down.

    And just a minor little thing when, upon returning to San Francisco after the credits, accessing the inventory and exiting would cause the Kiss To Build A Dream On song to start replaying until exiting the map. Apart from these, no other issues.

    One suggestion I'd make would be for the elevator buttons in the EPA to be changed from 'G, 1, 2' to '3, 4, 5', etc. Just to better reflect the actual levels... or even corresponding colour-coded buttons to rid any confusion?

    It really has been such a fresh new experience[spoiler:3969477f72] and I love the special encounter after completing the game too, awesome! Gonna now go try out that new weapon[/spoiler:3969477f72] :D :D :D
  7. kitovyj

    kitovyj First time out of the vault

    May 1, 2008
    Hi guys,

    Playing RP 2.1.2 I've found two bugs. Both of them exist in previous version too.

    First bug is related to the vault city bring-the-ten-bottles-of-bear quest.

    Then giving quest to the player, bartender notices what player may not bring any of "that radoactive stuff, that comes from Gecko"

    In vanilla version, this quest was at least a little bit challenging - player had have to go to Klamath, New Reno to get the real booze, because Gecko bartender could offer only radioactive stuff, here is the screenshot showing barter dialog with Gecko bartender(vanilla version) :

    There is nothing he can offer, but you can buy radioactive drinks using the dialog options.

    But in restoration project version, Gecko bartender can offer you a lot of beer and booze:

    So, the alcohol quest becomes simple and almost illogical... Player now can get needed amount of bear and booze in Gecko. I think it is a bug that brokes the original developers intentions.

    Second bug I've encountered is an issue with caravans going from Broken Hills to the Vault City. Every time I try to go with the caravan, caravan have one empty encounter and after that caravan master dissapears. I arrive in the Vault City alone. I have a set of saved games, I will post them as soon as I get home.

    And third - not sure it was not due to the lack of my attention - I could not install the RP 2.1.2 without Pixote mod. I unchecked the related check box, but installer showed a message box saying what "Pixote mod already installed anyway, and can't be uninstalled". But I definitely deleted entire previous fallout installation folder before updating. And then I launched the game I saw rugs and pots... :) (Aren't there too many pots in the Pixote's maps ? :))))

    Thank you for doing the great work guys, and sorry for the long post and bad english...


    Here are the promised saved games in one zip archive. There are three of them : before hiring as caravan guard, empty encounter and arriving alone in the Vault City.

  8. zearro

    zearro First time out of the vault

    Sep 14, 2010
    This is my first time on this forum as I just found the restoration project mod and I am excited to get it to work. I am gonna report a save game problem on rp 2.1.1, But I can save on a vanilla install. I am working on win 7 64bit and a steam version of fo2 that i just purchased.

    Thank you killap for taking the time to modify and expand a game that I loved to play years ago.

    I am gonna do a reinstall and try rp 2.1.2 only.
    EDIT: It saved when I created new after install.
  9. Gaspard

    Gaspard Kasparov

    May 7, 2009
    I've had saving issues before. just gives an error when I try to save, but that has not been exclusive to just RP. That's why I've never thought of reporting it...

    Usually what fixes that for me is if you load a savegame, then you should be able to save normally again.
  10. glouter

    glouter First time out of the vault

    Sep 5, 2010
    so I posted in the gameplay thread, arguing some business with fast shot (I didn't think it was a bug at the time). Supposedly, it will become a part of Sfall, and now I'm wondering why Sfall will field the bug. Are the Unofficial Patch and RP not changing the engine at all? (the fast shot thing being an engine fix, I assume)
  11. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    That is correct. All engine fixes/changes are part of sfall.
  12. Wolfz

    Wolfz First time out of the vault

    Mar 18, 2004
    hi! I have a technical question for killap.
    I have these weird rainbow-effects. I tried to change the graphicmode to 4, but i get an error-message that says "install dx9".
    System is Win7 (64bit) dx11 (was already installed)
    Did i just miss something in the settings?


    PS: Fallout2 Vanilla german installation and your patch (incl all submods)
  13. willooi

    willooi It Wandered In From the Wastes

    Aug 23, 2010
    Hi Killap,

    (1) Just started a new game as a dumb character and recruited Sulik, and on a couple of occasions now after ending combat when I go to 'talk' to him, instead of there being a Talk icon it's instead the Hand, and I can take away all the stuff I gave him like he was a corpse! Also, he no longer follows and just stays in the same spot when I enter a new map or grid. Strange.

    (2) Also met Kaga for the first time but he had a rifle (hunting, I believe) instead of the standard spear vs spear early on in the game, and then the game crashes shortly after.

    Edit: Save game files in case you need them

    (1) http://willooi.com/wp-content/uploads/2010/09/SLOT14.zip

    (2) http://willooi.com/wp-content/uploads/2010/09/SLOT11.zip
  14. utunnels

    utunnels First time out of the vault

    Aug 2, 2010
    That happened to me sometimes before.
    For example, an NPC critical misses and loses his next turn then you leave the map, he will stay 'floored' though he's in the standing pose. You can pick up his equipments like a corpse.

    I doubt it is an old bug.
  15. Darek

    Darek is currently unavailable

    Jan 7, 2008
    @ Wolfz
    Just because you have dx11 doesn't mean that you have the full dx9 baked into it. You can safely update only that part from here.
    Or if you don't want to do that you can set graphics mode to 0 and instead set the high-res patch to 16 bit (that also works to fix the funky colors issue).

    @ willooi
    If an NPC is still knocked out when combat ends this can happen. What happens is that the game forgets to clear Sulik's unconscious status, and outside of combat mode he cannot wake up (as he's unconscious for a certain number of turns, and there are no turns unless you are fighting).
    Simply start combat mode, push next turn. Repeat as many times as needed until he comes around again.
  16. willooi

    willooi It Wandered In From the Wastes

    Aug 23, 2010

    Thank you, it's all good now =)
  17. Wolfz

    Wolfz First time out of the vault

    Mar 18, 2004

    Thank you. I had already tryed the 16bit setting, but i get a white screen.
    For Dx9 i have some issues with the certificate of .cab files...

    I think i have to play it in rainbowcolors...

    PS: Got it! Had a litte bugfile... Dx complete wipe and reinstallation solved it.
  18. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    I've noticed small issue: with more than one lighter in his pocket, "generic dude" can't smoke cigarettes.
    (It was already reported and hopefuly fixed for long hair dude too.)
    RP 2.1.2; clean FO2
  19. Psihotik

    Psihotik It Wandered In From the Wastes

    Sep 22, 2009
    Can we expect some new talking heads in the upcoming release?
  20. ufo_hunter

    ufo_hunter First time out of the vault

    Feb 29, 2008
    A small bug I believe. When boxing in Reno I scored a critical hit at the very end of round 1. Something like
    "xxx was critically hit to the head crushing the temple good night gracie" "xxx was hit for 3 hit points"
    The boxer collapses and turn ends, but instead of victory round two starts. The boxer gets up in his own corner and comes at me again. After a few turns I manage the same critical hit again and now the boxer stays down and I win by means of knockout.
    Not a big deal, but just thought to report it.
    I have no save since boxing is in combat mode. I have a save just prior to the match, but it is kind of hard to replicate. It was the third match against "steel" mark torres or something...
Thread Status:
Not open for further replies.