Fallout 2 Restoration Project 2.1.2b (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Sep 18, 2010.

Thread Status:
Not open for further replies.
  1. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I'm pretty certain it's in a locker on the wall. He should tell you to get it from there.
     
  2. Dravean

    Dravean Where'd That 6th Toe Come From?

    478
    Mar 6, 2005
    I just noticed that in the installer, it still describes the Talking head for Cassidy as being "from Mutants Rising, modified by Pixote"

    You also might want to note that that particular talking head doesn't actually talk, as the description is misleading to anyone that isn't in the know.
     
  3. .Pixote.

    .Pixote. Carbon Dated and Proud
    Modder

    Sep 14, 2009
    Delete the previous talking head from Mutants Rising Killap...Conti's version is so much more superior - if you haven't done already. :look:
     
  4. x'il

    x'il Water Chip? Been There, Done That

    980
    Mar 3, 2009
    What happened with the attempts to voice it? didn't fly?
     
  5. unacceptable

    unacceptable First time out of the vault

    21
    Sep 19, 2010
    First of all I'd like to thank killap for making Fallout 2 an even greater game through the RP. I haven't played Fallout 2 in a little while, but I have used RP 1.2 (liked it too!), and was quite happy to find out that even more "lost" content has been restored.

    There are a few possible bugs I would like to report, possibly related to the Restoration Project.

    Since I had RP 1.2 before, I uninstalled and completely removed anything related to the old Fallout 2 installation. I then installed a North American version of Fallout 2, resulting in a clean 1.0 installation (placed at E:\Fallout2\). Nothing else was added beside the new RP 2.1.2 installation. I chose to install all of the additional content except Missing Children FRMs, 14mm/.223 pistol sounds from Fallout 1 and YAAM.

    I loaded character stats from a .GCD-file, and started a new game (no old savegame used). I decided to travel around a bit, to check out the new world map and visit places (i.e. San Francisco) that has been changed. I found what is possibly a minor graphical glitch in San Francisco, outside the Hubologist compound.


    Direct link: http://img684.imageshack.us/img684/7458/hubolostrip.png

    Check the tarmac along the right edge of the screenshot, and the sidewalks above and below the fold in the driveway. Maybe this is a way to add the view of the bridge? I don't think that there is something wrong with my installation. I normally run at 640x480 resolution, and this looks the same in 640x480 as it does in 1280x960. I tried several graphics modes with the same result.

    My next find is a bit more complicated. After walking around the world map I eventually ended up in Vault City. There I recruited Cassidy, and headed off for The Den. Between Modoc and The Den I ran into a caravan attacked by highwaymen. I stepped aside and patiently waited for them to fight each other, to be able to loot the corpses afterwards.

    I am aware that saving while in a fight is discouraged by some, but this occurred without any save or load. The caravan consisted of one caravan master, one guard, and two slaves. The highwaymen were four in total. One of the highwaymen is wielding a 10 mm pistol, and is shooting at the caravan master (constantly missing, hitting another highwayman instead). She suddenly hits the female slave, the female slave walks up and starts attacking with her fists, but the highwayman does not fight back and instead run to the left edge of the map.

    This is a screenshot from the savegame I did after observing this strangeness:

    Direct link: http://img684.imageshack.us/img684/9936/strangez.png

    Far left is the female highwayman (with a crosshair and -43% hit chance marker). To the right of her is the attacking female slave. The highwayman was completely unharmed (as far as I remember) before the female slave started attacking her. I downloaded F2se and added Awareness to my character, revealing that the highwayman currently have 37/55 HP in this savegame. She also have two rounds left in her 10 mm pistol, but she will just stand there being slowly beaten to death 1-2 HP's at a time. If I go any closer the highwayman will run south, but will not fight back against the pursuing, unarmed, female slave. Neither will she attack me if I start shooting at her.

    Another strange thing about this fight is that I can hit the leftmost female highwayman every time, armed with the HK P90c, firing single shots. With a -43% hit chance I'd expect critical failures rather than scoring two hits each turn. The other targets (with hit chances -22%, -28% and -34%) are virtually impossible to hit. Burst firing with the P90c does not generate hits, neither am I able to score hits with the combat shotgun in the given conditions. Only single shots from the P90c work for those highly unlikely hits.

    I tried killing off the other two highwaymen, the female slave, ended combat and walked up to the formerly malfunctioning highwayman. She now fired her last two rounds at me, and switched to unarmed attack afterwards. She did not run away this time, and bit the dust soon afterwards.

    I can provide the savegame, it's about 1 Mb in size. I'm just not sure where I could publish the ZIP-archive.

    If I load this game, and do not attack anyone (just choose to end my turn), Cassidy will start attacking me within a turn or so. These "companion attacks" have happened to me before when saving in a fight and not starting to attack someone after loading, possibly also in unmodified Fallout 2, can't really remember. Not a huge problem, but still a bug I think.

    There seems to be lots of different kind of pots everywhere! I am absolutely sure that several of them wasn't there before.

    The formerly inaccessible table (in the lower right corner, by a window) in Red 888 Guns in San Francisco now seems to be completely gone.
     
  6. kitovyj

    kitovyj First time out of the vault

    17
    May 1, 2008
  7. NovaRain

    NovaRain Casual Modder Modder

    Mar 10, 2007
    The option says "Visually enhanced world map", not normal maps.
     
  8. kitovyj

    kitovyj First time out of the vault

    17
    May 1, 2008
    Sorry, my fault... So there is no way to not install map modifications? (just tooooo many pots and nude pictures...)
     
  9. Skiewolf

    Skiewolf First time out of the vault

    24
    Mar 31, 2010
    Are there any progress reports or eta for the new pc type - red haired woman? :look:
     
  10. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Nope, sorry the maps are a mandatory install. However, the number of pots and nude posters (these are only found in a few locations) has been greatly reduced in the 2.1.x line.

    Really? I definitely remember changing that text. Or at least some text that referred to the talking head. I'm not in front of my modding machine at the moment so I can't check the installer script.

    Yeah, good point. I have limited space for text in the installer though, so I can't be as verbose as I would like.

    These were added for atmosphere. The number of them was reduced in the 2.1.x line.

    It seems that people are still a bit displeased with the enhanced maps. I'm still open to suggestions for improving them. While all the new pots, posters, etc won't be removed entirely, I am willing to hear areas where there are too many and some should be removed.

    The table never had anything on it, so I removed it.

    Not for a long time. We don't want to burn out our critter modders.
     
  11. kitovyj

    kitovyj First time out of the vault

    17
    May 1, 2008
  12. Lightwolf84

    Lightwolf84 First time out of the vault

    30
    Sep 19, 2010
    Fallout 2 Restoration Project 2.1.2b
    +
    F2_HiRes_Patch_v2.3


    Do those work together?
     
  13. MutantDwarf

    MutantDwarf First time out of the vault

    21
    Aug 5, 2009
    The HiRes Patch is integrated into the restoration project.
     
  14. unacceptable

    unacceptable First time out of the vault

    21
    Sep 19, 2010
    I see. I've only played this recent mod for about two hours, and just noticed some new pots and was unsure if something was wrong with my installation. I am looking forward to discover the posters and other stuff you are mentioning! Nice to hear that you are open for suggestions, since I suppose it's a bit of work changing stuff like that. Are there any newly added pots that function as containers?

    Why not just turn it around and leave it, like the one in the back of Valeries "shop" in Vault City? :)

    Do you have an opinion about the oddities in NPC behavior I described above? I could probably work on finding out more about possible triggering events. I will gladly spend time with such tasks if it helps RP along in any way.
     
  15. Goweigus

    Goweigus Mildly Dipped

    566
    Jan 18, 2007
    Not sure if this has been mentioned before...

    There seems to be a problem with some quests appearing on the quest list for The Den. Ex: I got a quest for finding out where Becky gets her booze and another quest for finding Smittys car part. I died and had to reload before I did either of these things, and then that play through I never got those quests added to the list. Sorry I didn't notice it at first, so I don't have any save files for it.

    PS: What was the world traveling stuff set to in previous versions? I rather like the way it used to be but I do not know what it has ever been set to in the past.

    PS: Whats the highest resolution supposed to be? I seem to recall achieving a higher res via a mod in the past that let my go pretty dang high (but it had that crap around the sides on certain maps). I can't seem to get it over 1024x768

    PS: Is there any fix for moving down the list of locations in the world map? Any amount of clicking shoots one way down or up the list, forcing me to scroll the map looking for the locations myself some of the time.
     
  16. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Unless you can reproduce this I'd say random fluke.

    I haven't changed this. I'm not sure when you last played the RP, but there is a different implementation this time around. Look in ddraw.ini for the various setings you can play with. I mention all this in the readme that comes with the mod. The readme is in the main F2 directory.

    I'm pretty certain it depends upon your system. I do have the res patch set to safe mode (or whatever the safe list thing is called) to ensure the most stability. You could try turning that off and seeing if you get more in the list. Honestly, going higher than 1024x768 is not worth it. Things just get way too tiny.

    I don't recall behavior like that with the map list. Did it always act this way? Can anyone confirm?

    I don't believe any of the the new pots act as containers. No harm in checking though. The game's all about exploring ya know. :P

    Because I got too many e-mails saying that table doesn't have anything on it. Game is b0rked! But yeah, I could do just that.

    If you can consistently reproduce an error then I can try and get it fixed. The combat system and AI in F2 can be finicky.
     
  17. Meep

    Meep First time out of the vault

    2
    Jun 10, 2010
    Definitely way too tiny ! Anyway, if you really want to, another way to increase the resolution is to type in your desired resolution yourself under custom.
     
  18. Lightwolf84

    Lightwolf84 First time out of the vault

    30
    Sep 19, 2010
    Will bigger resolutions than normal cause movement problems in the game like it did in Fallout 1?

    Can get stuck etc?
     
  19. Rogue Hex

    Rogue Hex Look, Ma! Two Heads!

    353
    Apr 10, 2003
    Hi Killap, I just wanted to stop by and say thank you for all the great work you and others have put into the RP and in making Fallout an even better game. After a brief 5 year absence from the series, discovering this has motivated me to hunt down my once lost F2 game, dust off the cobwebs and start a fresh character.
    I thank you, sir, for rekindling my lost romance with Fallout. I cannot wait to get started!
     
  20. Guardian of Nowhere

    Guardian of Nowhere First time out of the vault

    6
    Aug 4, 2010
    Today I noticed something odd in 2.1.2b.
    Because of the NPC appearance mod I always play with several companions (three power-armored gentlemen and an armored super mutant go into a shop, buy gauss guns and a vindicator, bid the shopkeeper farewell and just go. Gotta love it :lol: )

    In the ddraw.ini I found a line that said "Set to one to directly control party members in combat". I had to try that of course, and it works well, 4 guys that act like the PC in combat is pretty cool.

    The problem is, they apparently have some perks only my PC should have: Awareness (not really a problem), Bonus Move and Bonus Rate of Fire. Feels like cheating somehow :oops:
    I can also access their character screens during their turn in combat mode. They all have my tag skills, with their values, apparently. And my name.
    Does this option work like it's supposed to? (and was it always there? Never noticed it before.) Had some crashes while it's enabled, too.

    Apart from that, no bugs yet. Great job @ all involved with the RP :clap:
     
Thread Status:
Not open for further replies.