Fallout 2 Restoration Project 2.3.2 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jan 2, 2014.

Thread Status:
Not open for further replies.
  1. Matthews

    Matthews It Wandered In From the Wastes

    Aug 29, 2012
    From what I recall from another such report and its reply, it is something to do with too many spawning critters on that map. Think the reply basically was: Pull Melchior back towards the elevator, fight a bit, go up the elevator, go down said elevator and repeat until he's dead.

    (Tried finding that reply I mentioned, but it is past midnight and I'm rather tired already).
  2. ETPC1

    ETPC1 First time out of the vault

    Aug 14, 2013

    Ooo! I'll try that :D

    Edit: worked like a charm! also helped to put my followers one level up and off the screen.
    Last edited: Jan 22, 2014
  3. ETPC1

    ETPC1 First time out of the vault

    Aug 14, 2013
    Is there a way to get into the Sierra Army Depot without talking to the wrights? I accidentally pissed them off :P
  4. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    Try checking Sam Pritchard's grave.
  5. ETPC1

    ETPC1 First time out of the vault

    Aug 14, 2013
  6. ETPC1

    ETPC1 First time out of the vault

    Aug 14, 2013
    So, I know I'm doubleposting but I just want to thank Killap, Timeslip and everyone who busted their ass working on this project. What a fantastic ride that was. Just finished the game and everything, including the addons felt....right, y'know? If you told me this was what shipped at retail, I would totally believe you.

    I think my favorite area was the Abbey for the music alone but the EPA was totally fantastic and so was Sulik's Tribe (FINALLY SOME CLOSURE).

    Kudos. To everyone!
  7. Dravean

    Dravean Where'd That 6th Toe Come From?

    Mar 6, 2005
    Thats the best kind of review. Thanks, and I'm glad you enjoyed it.
  8. voodzia

    voodzia It Wandered In From the Wastes

    Jun 27, 2005
    I'm sorry for this noob question but how do I enable the smoking animations?

    I'm playing as LHD and already have the lighter in my inventory.

    Solved - looks like I'll need a pack of fags too.
    Last edited: Jan 27, 2014
  9. OhNoes

    OhNoes First time out of the vault

    Jan 29, 2014
    Got some bug here:
    1. got the quest in the abbey where i got to repair their water pump.
    2. got to vc Happy Harry for the motor for the pump.
    3. Everytime i speak with Happy Harry, the dialoge window pop ups and i choose any option in the dialoge the game crashes with this info:
    "The instruction at 0046dd39 referenced memory at 00000038"...
    if i reload save and try talking again crash repeats

    I have 2 OS on my machine - windows 7 64 and windows xp 32 - crash happens on both machines.

    Sorry couldnt attach savegame now, because keep getting "database error" to my archive.
  10. CPL

    CPL Still Mildly Glowing

    Mar 16, 2013
    Ah yes, "the instruction at" crash. That's a buddy of mine from the past. I think that has something to do with PRO files, does it not?
  11. Endocore

    Endocore Look, Ma! Two Heads!

    Mar 14, 2010

    1) For years now I wanted add a "bell" sound before each round when boxing in New Reno. I finally got around to it-- only to find the game already has a sound in place, but it never plays due to a simple bug! In ncanounc.int, the line:


    should say:


    What's more, a two-ding bell is supposed to play at the end of each round but can never happen due to a similar bug. In ncprzftr.int, two lines that say:


    should instead say:


    There are two ambiguous sections in critter_p_proc of obj_dude.int for candy calamities.

    A) In clause if global variable 692 > 0, is next check meant to say:

    if (((game_time - soda_timer) >= 36000) and ((soda_timer != 0) or (((game_time - rocks_timer) >= 36000) and (rocks_timer != 0)))) then

    or instead:

    if ((((game_time - soda_timer) >= 36000) and (soda_timer != 0)) or (((game_time - rocks_timer) >= 36000) and (rocks_timer != 0))) then

    In other words, is it

    (1 and 2) or (3 and 4)


    1 and (2 or (3 and 4))

    because currently it reads

    1 and 2 or (3 and 4)

    which seems rather brash to me. :wink:

    B) A few lines down is an empty clause if gvar 692 equals 0, 1, or 2. This calls into question what is intended for the three following else clauses. Are they meant as alternatives to cases where gvar 692 > 2, or meant as alternatives in the context of the entire critter_p_proc procedure? In other words, it seems to me the last lines of critter_p_proc should perhaps be rewritten as:

    procedure critter_p_proc
     [other stuff]
     if (op_global_var(692) > 2) then
      if ((op_global_var(692) == 3) and (gave_warning != 1)) then
       gave_warning := 1;
       op_display_msg(op_message_str(1, 600));
       warning_timer := op_game_time() + op_game_ticks(10);
      else if ((op_game_time() >= warning_timer) and (gave_warning2 != 1)) then
       gave_warning2 := 1;
       warning_timer := op_game_time() + op_game_ticks(3);
       op_display_msg(op_message_str(1, 601));
      else if ((op_game_time() >= warning_timer) and (gave_warning2 == 1)) then
       op_explosion(op_tile_num(op_dude_obj()), op_elevation(op_dude_obj()), 999999);
    or should they? We can't really tell in its current form.
  12. .Pixote.

    .Pixote. Antediluvian as Feck

    Sep 14, 2009
    That reminds me, I always wanted to adjust the animation of the lady walking around the ring, and give her a number board that she holds above her head...each round will have its own number. How many rounds does the game allow?
  13. Oppen

    Oppen FIXT n°1 fan

    Dec 26, 2011
    Looks like it should be (1 and 2) or (3 and 4) to me.
  14. Janardag

    Janardag First time out of the vault

    Jan 30, 2014
    Hi, I have a problem with the Rustling the Brahmin quest. Whenever i want to examine brahmin's behind Danton's house nothing happens. I have perception of 9.
  15. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Ask Mrs. Buckner about it, she'll send you to find another clues.
  16. Janardag

    Janardag First time out of the vault

    Jan 30, 2014
    i've already done this but nothing happens either, when i confront Duntons with that 51% speech option i go to Aida Buckaner which point's me to her mom , and, it would be cool but of course it's not because thers'e no option to talk about Brahmins with her.
  17. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Hm, I didn't confront Duntons at all last time. Here's my quick guide:
    1. Get quest from Mrs. Buckner
    2. Help Torr, grab radscorp claws from shack
    3. Show the claws to Mrs. Buckner, she'll send you for some more clues at this point
    4. Check the Dunton's brahmins (my PE 6 + Speech 40% dude haven't had any troubles here)
    If everything fails, perhaps you should add your report here:
  18. Janardag

    Janardag First time out of the vault

    Jan 30, 2014
    Ehh, it look like some sort of fatum, last time i played this game with an olde RP version of the mod after days literally of thinking i gave up and it looks like ill have to give up this time also.... I just fell like a rag abandoning this quest again.

    I've done this:
    1 Defended Brahmins for Torr
    2. Spoked to Ms. Buckaner about recent event and started rustling the brahmin quest
    3. Showed her those radscorpion pincers right away and then she pointed me to look for more clues, now Im stuck with this quest because i cannot check those two brahmins behind Dunton's house . It only say that its an domesticated brahmin.....

    I have an option to tell them to leave Torr using my speech check on them gaining some exp, next when i go to Aida Buckaner to tell her about that i finished the investigation she then points me to her mom but her mom only worries about that pesky Smiley of hers and nothing more....
    Last edited: Jan 31, 2014
  19. Mohamed2001

    Mohamed2001 HATE NEWSPAPERS

    Jan 28, 2013
    Check the Brahmin with the binoculars. If not, try the science skill. I am not sure, I forgot which one. Gonna start RP now.
    • [Like] [Like] x 3
  20. Janardag

    Janardag First time out of the vault

    Jan 30, 2014
    It actually works! :clap:

    Why there is not a single walkthrough of this mission that points out that you must use binoculars?! Lol i didn't even know i can use one... after all this years i finally finished this quest. Thanks Mohamed!
Thread Status:
Not open for further replies.