Fallout 2 Restoration Project 2.3.2 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jan 2, 2014.

Thread Status:
Not open for further replies.
  1. CPL

    CPL Still Mildly Glowing

    Mar 16, 2013
    Well this is rather amusing, at least to me. I'm in the Klamath Rat Caves right now and Sulik has Lenny's battle dialog, or whatever that's called. So he's saying things like "I'll give you such a pinch!" Maybe he could have a career as a hair dresser when the quest is done. :razz: I have no clue how that came about, or if anyone else noticed this, so I thought I'd give it a mention. It doesn't effect any other dialog with him, but it does rather make him amusing when you imagine how his character usually is.
  2. MisterCrit

    MisterCrit First time out of the vault

    Dec 3, 2011
    You thought they were a bit over the top? Who are you to decide? Even though you're powerful and can do just about anything you want, that doesn't mean you should. I think your actions represent a gross abuse of power and are thoroughly unwarranted. This kind of thing is totally anathema to anyone who respects the goals and ideals of the Restoration Project. These objects were clearly created by the original developers and should not have been tinkered with. :violent:
  3. iLikeDirt

    iLikeDirt First time out of the vault

    Dec 29, 2013
    Jeez, it's just a video screen.
  4. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    Uh, in vanilla maps (VC & MBase) there's no video screens. And AFAIR those animated video screens are made by modders not original devs. So Pixote is free to remove those scenery objects that he added in previous builds.
  5. Dravean

    Dravean Where'd That 6th Toe Come From?

    Mar 6, 2005
    As pointed out above me, Pixote isn't removing art assets placed by the original developers. You see, several RP releases ago, he gave the game's maps a makeover, mostly adding detail and making the world feel more alive and lived in. In just about every RP release since then, he's tweaked his additions. This is nothing new.
  6. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    Heh, still the same story, poor Pixote is being punished on a daily basis. No matter if he adds or remove his own artwork, angrered fans just keep lynching him! The good news is that some people can't recognize the original Fallout's artwork from those new eye candies created by Pixote's skillful hands, that's what I call a compliment! :razz:
  7. Ale

    Ale First time out of the vault

    Jan 1, 2014
    Found some issues:

    1) There is "op_display_msg("There is a low humming noise in the air, like a magnetic field is somewhere nearby.")" in epas6 script file. Could you please edit the script so it uses text from epas6.msg? It would be much easier for us translators to handle it. Also, if any other scripts have texts inside (I haven't noticed any other), please consider editing it as well. Thank you

    2) EPA: The floor numbers does not match the elevator numbers. IE: You're in level 3 according to the elevator, but the sign says you're in level 5. AFAIR, this was correct in RP 2.2

    3) Gecko: This may not be actually a bug, but I just thought it's weird. You can get the gecko holodisc from Gordon even if you didn't talk to the Brain about optimizing the power plant and got the Ankh. Shouldn't this item be necessary to get that holodisc from Gordon? Not to mention that he talks about optimizing the power plant before it has been even fixed :) This is actually a "bug" from vanilla Fallout.

    All of these have been reported to bug-wiki including saves.
  8. kabadesu

    kabadesu First time out of the vault

    Jan 14, 2014
    I've posted this on the wiki but wanted to post it here too to see if anybody had any ideas about this one.

    Mavericks 10.9.1. GOG.com fallout_2_1.0.0.14 for Mac. F2_Restoration_Project_2.3.2. Just playing Fallout 2 for the first time. Whenever I enter The Den the map is completely blank. Things I’ve tried that do not help: Quitting to desktop, Using Legacy/Modern graphics patch, Uninstalling reinstalling, Starting a game on windows and copying the working savegame file where I can get to The Den… Nothing works. I can get there without Restoration Project but I don’t want that.

    Hopefully dropbox is alright for the savegame https://www.dropbox.com/s/6717gfdvpg04tpa/SLOT01.zip

    Edited to update my dropbox link.
    Last edited: Jan 15, 2014
  9. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    In the end, nobody could blame you from removing your own content, but it is also true that some of us were fond of some of those.
    But you can't make every content that you don't like optional, it would be a pain in the ass to code the installation...
    So we can cry or learn to mod. (the second option is too hard for me, i think...)
  10. iLikeDirt

    iLikeDirt First time out of the vault

    Dec 29, 2013
    I have exactly the same problem (Same OS, same version of the game, same version of RP). Current thinking is that it appears to be some sort of issue involving the high-res patch and the new maps, but people are still scratching their heads about it.
    Last edited: Jan 14, 2014
  11. oldskool

    oldskool First time out of the vault

    Jan 15, 2014
    Hi All, I can't get any of the patches to work *AT ALL*. I've tried both the F2RP and the UP.

    Using the Mac GOG version, I followed the instructions on Wikia 3 times (removed the whole Fallout 2.app folder between each run). After installed I can get the front screen, see the intro, but can't load any screens after clicking on the menu items (New Game, Load, Settings, etc).

    Anyone have any ideas as to what I'm doing wrong?
  12. Sduibek

    Sduibek Creator of Fallout Fixt Moderator Modder

    Oct 27, 2010
    Last edited by a moderator: Jan 9, 2016
  13. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Poking back in after a week away from Fallout. I hope the issues reported in the last few pages have made it to the wiki - I haven't looked there recently.

    Promised source code to the RP and UP is still upcoming. I'll maybe try and have things wrapped up by the end of the month, which also means minor update to the RP to clear off the wiki.
  14. iLikeDirt

    iLikeDirt First time out of the vault

    Dec 29, 2013
  15. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Yeah, there are sadly 2-3 scripts in the game that have hardcoded text. They are all at the EPA. For some reason if you point to those scripts' message files, the game displays "ERROR". This issue has been there since the EPA was first introduced in the RP and I've looked into it on more than one occasion. I always end up baffled with why it's happening. I feel like at this point the only hope is to just create new scripts and consider those old ones bugged.
  16. Sduibek

    Sduibek Creator of Fallout Fixt Moderator Modder

    Oct 27, 2010
    Perhaps a naive assumption/suggestion, but would it work to use script_overrides; command in these cases to force your message? The important thing is to override before AND after the situation, I've found in some cases that a pre-and-post override is necessary. Doesn't hurt to try if you haven't tried that already. (Which you probably have :D)

    procedure HardCoded_Display_Situation
        display_msg("killap rox");
    Last edited: Jan 16, 2014
  17. Oppen

    Oppen FIXT n°1 fan

    Dec 26, 2011
    Did you personally create those files? As a wild shot, I'd check the encoding of those msg files, as well as the presence of BOM, the line break style, etc. The engine probably makes some assumptions that weren't respected in those files.
  18. Ale

    Ale First time out of the vault

    Jan 1, 2014
    Do you know which scripts use this hardcoded text?
  19. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    I did indeed create them.

    Hmm, I don't recall whether I tried deleting and recreating them. It's more like the engine is trying to reference a non-existent entry. I'm suspicious because the first script with this problem is the next script entry that is allowable thanks to sfall extending the number of usable scripts. But who knows, perhaps that's just a coincidence and a red herring.

    Of course. The three are: epas6.int epai30.int epai31.int

    Are you doing a translation?
  20. Ale

    Ale First time out of the vault

    Jan 1, 2014
    Yeah, I do. If you won't be able to fix it in the next patch, I'll have to compile the scripts myself (shouldn't be a problem hopefully). Thanks anyway.
Thread Status:
Not open for further replies.