Fallout 2 Restoration Project 2.3.2 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jan 2, 2014.

Thread Status:
Not open for further replies.
  1. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Uh, I just tested and all three work just fine. No Errors at all.
    I just added the string and msg file values to the decompiled scripts and it worked.
    Maybe something is wrong in the source, or goes wrong when it gets compiled?
  2. jessemonster

    jessemonster First time out of the vault

    Jan 16, 2014
    I'm having the same problems as oldskool here and have no idea what to do. Have followed http://falloutmods.wikia.com/wiki/F2RP_Technical_Info to the t 3 times also.

    Installing Fallout 2 - works fine.
    Delete 256 entry in the registry - fine.
    Installed RP with the legacy option - still works but now is all funky colours.
    Updated Sfall (to 3.2) per the wiki, only copy over the dll - same as above, works, but in funky colours.
    Updated HiResolution patch to latest (4.1.7) - Now, stops working.

    The wiki goes on to say edit the ddraw.ini and the f2_res.ini but the changes they say to make are redundant (i.e. the changes are already made).
    Also locking the critter folders etc. don't affect the problem but assuming no problem.

    What happens after opening Fallout 2 RP (installed per wiki) is this: There is a windows window in the middle of the screen with the title "Fallout 2 @640x465x1" enclosing Fallout 2. The loading screens and intro vids are gone, it goes straight into the main menu. Clicking on Intro, New Game and Load Game have no effect. Clicking on Preferences brings up the option of Screen Settings or Game options but clicking either of these has no effect. The only button that works is the exit button.

    I'm on OSX Mavericks 10.9.1 with a 2.5 GHz late 2011 Macbook Pro with 8GB RAM. Not too sure if you need any other information.

    Any help anyone can give would be great. Cheers.
  3. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I don't use Mac myself, but if I understood what I've read on these board correctly, the answer is something like this...

    As far as I can tell that wiki is not up to date (just an edited RP version number but the text itself has not been updated). There should be no need to update sfall, the latest version is the one included in the RP (I think).
    Also the HiRes update is just stupid. The reason you are told to install with the legacy option is that the later versions of the HiRes patch don't seem to work too well with Macs. So stay with the legacy option and forget about updating the HiRes patch until someone figures it out.
    Last edited: Jan 16, 2014
  4. CPL

    CPL Still Mildly Glowing

    Mar 16, 2013
    Hmm, now Vic has Myron's combat dialog along with Sulik having Lenny's (although the Vic/Myron one isn't as amusing.) I did install a newer version of the Miria mod catered to the new version of the RP and new version of the Unlimited Party mod catered to the same thing, so perhaps one of those had the combat dialog swapped around? It hasn't crashed or messed up the game otherwise. I can play it with no issue, including non-combat interaction with them. I guess it's something in the COMBATAI.MSG file that's not in order? I'll have to look into this.
  5. cruton

    cruton First time out of the vault

    Jan 17, 2014
    Don't mean to derail anything, but quick question.

    I remember that in the orriginal version of F2, in Gecko, you could talk to Skeeter, a ghoul mechanic, while holding certain weapons in your inventory, and he would offer to upgrade a weapon in exchange for a 3-step plasma transformer. I know that you could find at least three of these, and after giving Skeeter the first, he would tell you, that he could always use more and would offer to upgrade more weapons for free as long as you bring him more 3SPTs, each of which would earn you 350 XP in addition to the upgrade.
    On my current play through (with 2.3.2 mod) I can only seem to find a single 3SPT and skeeter only ever seems to offer a single free weapon upgrade. I did my best to check the patch notes, but did not see anything referencing that this was ever changed. Does anyone know if this is a bug or was this done on purpose for a particular reason?
  6. NovaRain

    NovaRain Casual Modder Modder Moderator

    Mar 10, 2007
    Because it's considered as a bug and got fixed.
    In UP changelog:
    EDIT: From his dialogs (gcskeetr.msg) I didn't find any about "he could always use more (transformers)". And he only says "Well, ya see, I need a darn 3-Step Plasma Transformer", looks like he only needs one.
    Last edited: Jan 17, 2014
  7. chrisboote

    chrisboote First time out of the vault

    Oct 5, 2004
    I have a strange bug
    Lara vs Tyler
    I did Lara steps 1-3 (check church, ask Metzger find out Tyler's weakness)but nowhere in sight are any of t
    Then I went to Tyler and grassed up Lara
    Then in the church fight, I double crossed Tyler, shot him and Marc, killed all the other guards and none of Lara's mob took a scratch
    Lara came up and says 'now let's get them at the party'
    I said 'Yes', teleported to Den Residential, but nowhere in sight is anyone from Tyler's gang (well, I had just killed them all) and Lara hasn't come with me
    Now Lara is vanished, not on any map, and I can't end the church quest :(

    I have a save from AFTER I tell Tyler about Lara but before the church fight
    Happens every time :(

    Any hints as to what I could do?
  8. Matthews

    Matthews It Wandered In From the Wastes

    Aug 29, 2012
    Well, I never tend to do things outside of how the quests are supposed to get done, so if that specific case happened to me I'd reload and do it all over.
  9. chrisboote

    chrisboote First time out of the vault

    Oct 5, 2004
    Well, yes, but now I've gone back to an earlier save (when first arriving at The Den) and there is no character "Tyler's friend" or similar anywhere in Den Residential :(
    So I think the same problem may persist
  10. Matthews

    Matthews It Wandered In From the Wastes

    Aug 29, 2012
    Hmm (No clue how to make "spoiler-thingies", so I apologize for this little part).

    Lets see if I remember the order correctly here:
    1. Lara tells you to scout the church and its crates.
    2. Lara tells of you to ask Metzger for permission.
    3. Lara tells you to find out a potential weakness in Tyler's crew (the party).
    4. Lara wants you along for the deed to be done, you attack the church while Tyler is away in the Den Residential area.
    5. Lara wants you to help her finish off the job, thus you get "automatically" to the Den Residential area outside Tyler's friend's (Tyler's pal only shows up for this part of the questchain) house and the fighting follows with Tyler and his pals dead.
    6. Quests completed far as I know, collect reward.
  11. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    Reeeeally? ... I'm out of town for a week but when I return I'll need to have speaks with you about this.
  12. chrisboote

    chrisboote First time out of the vault

    Oct 5, 2004
    Talk toTyler, tell him you have information, grass up Lara
    Tyler ISN'T away in the den, he and his whole gang get killed at the church
    Actually get teleported to just by the exit grid
    No way to complete quest, no more Lara, no reward :(
  13. naossano

    naossano So Old I'm Losing Radiation Signs

    Oct 19, 2006
    Everyone is in the church in the vanilla game. But in RP, the Residential area is back ingame, and the quest is extented as it was originally intended by the develloppers.
  14. Mahlay

    Mahlay First time out of the vault

    Jan 19, 2014

    i played the restoration mod many times in different versions. Always a good experience. Killap, you are a genius.

    Begging your pardon, i wonder if its possible to make the RP mod anyhow compatible with the miria mod.
    Though maybe not especially intended by the developers that your spouse makes any progress, it would be quite necessary to give them the ability to at least level-up and wear armor.

    At their current state their companionship is not viable at all if you want to keep them alive till the very end.

    A change like giving them a proper level-system would grant players the freedom to decide on their own if they give into marriage in modoc or not. Right now, it is just not a good idea to have any of them around.
  15. Darek

    Darek is currently unavailable

    Jan 7, 2008
    Well you are kind of going outside of what was intended here. Lara did not reward you when doing the quest like this in the vanilla game either.
    But yeah I think its an omission in the RP, or at least a hole that should be plugged. Either make Lara angry/hostile to the player after the fight or reset the trap variable and set gangwar to 11 when Tyler is killed on the church map and gangwar variable is 9. What do you say killap?

    chrisboote, you can sort of fix this yourself with the fallout savegame editor. After the church fight, but before going to the residential area, save the game and then set Gvar 454 to 11 and Gvar 471 to 0. When you load the save Lara will reward you and walk into the church.
  16. Mahlay

    Mahlay First time out of the vault

    Jan 19, 2014
  17. phobos2077

    phobos2077 Mildly Dipped

    Apr 24, 2010
    I have this question. Not sure if it's related to RP, sfall or hi-res patch... There is this floor traps in S.A.D entrance map, which normally explode when you step on them. The thing is, I can safelly "disarm" them by going to combat mode and walking over. No explosion, nothing. Was it always like that and I just had too much modding lately to notice such exploits? %)

    Edit: looking at mine code, I see it uses:
    which does not work in combat mode (I learned it while modding).
    If there is an interest, I can provide instructions on how to make unavoidable explosions using sfall features (for sake of "bug" fixing; if you consider it as such).
    Last edited: Jan 20, 2014
  18. valcik

    valcik So Old I'm Losing Radiation Signs

    Dec 20, 2008
    I'm sticking with the sfall's ProcessorIdle parameter set to 1. It takes a little more of CPU time than with the Hi-Res patch built in fix enabled, but the game runs considerably smoother. Et vice versa, Hi-Res patch's fix gives better results in terms of CPU time usage, but the game runs less smoothly than with the sfall's CPU idle function enabled. (Tested on Intel C2D E4500@2.2GHz + GTS250; Windows 7 Ultimate 64; June 2010 redist DX9.0)
  19. ETPC1

    ETPC1 First time out of the vault

    Aug 14, 2013
    So, I still get that stupid crash when fighting Melchior. This is with 2.3.2, same system as my last reports.

    Should I just uninstall, reinstall, install latest RP and restart my game?
Thread Status:
Not open for further replies.