Fallout 2 mod Fallout 2 Restoration Project 2.3.3 (Unofficial Expansion)

Discussion in 'Fallout General Modding' started by killap, Jul 5, 2014.

  1. gustarballs1983

    gustarballs1983 Mildly Dipped

    572
    Oct 28, 2009

    Boxing Fights in new reno in RP doo give bonus. but you can't loose.
    +5% to normal damage resistance is all you het from Prizefighter title, considering you did not loose.

    Besides Jinxed is an ocasional triat ment for hardcore players not for an everyday playthrough. as you get over 55% chance to crit fail on a missed attack. and even with 95% hit chance you're going to miss like 1/20 of attacks. so going with something below 95% chance to hit on a jinxed build is plain loonacy. not to mention you play with low Lk, which is even more penalizing with jinxed, since you get more severe penalties from crit fails, with implication on the worst ones from crit fali list more often.

    As for the reno boxing ring than yes crit fail couts as a self knockout and you do loose. Jinxed is generally not a good triat to go with. But for some reason you are hell bent on playing with it, and keep complaining about it.
     
  2. laclongquan

    laclongquan Boned Hunter of Sister

    421
    Jan 11, 2008
    I am not complaining. It's honest feedback about an unique build that few people play. We've played normal luck, high luck/crit build to death already. It's boring to repeat them. Luckily luck2 jinxed provide an unique way of playing.
     
    Last edited: Mar 27, 2020
  3. .Pixote.

    .Pixote. Carbon Dated and Proud
    Modder

    Sep 14, 2009
    I played a similar character once...Vic had a critical failure and killed himself, it was so funny. I support crazy character builds.
     
  4. laclongquan

    laclongquan Boned Hunter of Sister

    421
    Jan 11, 2008
    Luck2 Jinxed is crazy as march hare~ With unarmed tag you can play it, but playing with guns/melee weapons and you are looking at dropping weapons every other turn at the very least, if not destroying outright.

    The effect it spread to enemies too, and because enemies always outnumber us, we have a slight advantage in absolute number of events, which balance out the bad things happen to us.
    [blog]
    ===========

    Because it's been a long time Miria still not upgrade... I mess around with partytxt, change proto/critter to not read only (according to endocore miria mod article) and other things, and viola, before I know it: unable to load savegame

    reinstall the RP, replace the sfall 3823 ... now I am unable to save game~

    FFS! Okay, add the enable=1 in [Debugging] section, then set the Savegame folder to NOT read only, and it's saved alright. It's something to do with the way savegame folder is set during moving I think [/blog]
     
    Last edited: Mar 28, 2020
  5. laclongquan

    laclongquan Boned Hunter of Sister

    421
    Jan 11, 2008
    Question: does anyone has any luck with Better Miria mod in RP recently? As in a few months back.

    Better Miria mod from Endocore doesnt seem to work. She doesnt level up.

    The state is: F2, then RP, then better miria mod. WHich is current state and doesnt work.

    I reextract miria mod, copy replace into folder... and now it cant load.

    If I reinstall RP then I can load the game, but miria doesnt level up.

    Checking: the article say proto files are 545, 546, 547, 548, 549, and 550. And so
    level_pids=16777761,16777762,16777763,16777764,16777765,16777766

    But inside the better miria mod files are proto files 550-555. With the party.txt coming with level_pids=16777766,16777767,16777768,16777769,16777770,16777771

    So yeah, I am puzzled~

    EDIT: a halfway workaround is that deleting the miria mod scripts, leaving the original scripts in place. So Miria can now start level up and chat. I am uncertain what will break and when, but for now Miria can do normal work and that is enough.
     
    Last edited: Mar 29, 2020
  6. Dux

    Dux First time out of the vault

    52
    Feb 3, 2009
  7. laclongquan

    laclongquan Boned Hunter of Sister

    421
    Jan 11, 2008
    Suggestion: more hint about EPA in other area. Possibly in ABBEY, Vault City and Vault 15 computers. For such a huge area, it deserves some more hints. Hell, MYRON and Dr Sheng know about it. No reason Vault City doesnt have any clue, or Abbey.
    EPA is now bloody hard to find thanks to my aversion of Myron. I keep telling myself:
    "--Boyo, we need to get that sucker just so we can make superstim!!!
    ---It's Myron, baby, Myron~"
    And I keep delaying him.
    Thus the only clue left is at San Fran, which is waaaaaay late game for EPA level of quest reward.

    I would grit my teeth and do a detour to San Fran before Vault 13 if I remember EPA exist~ No clue remind me of that hidden area thus chance lost~

    And before you said Look! "A traveller"! I was Luck 2 so no chance of that~

    Luck 2 equal no special encounter. It's after NCR I raise it to Luck 4 that I can find Bridge and Pariah Dog~
     
    Last edited: Apr 4, 2020
  8. laclongquan

    laclongquan Boned Hunter of Sister

    421
    Jan 11, 2008
    On another weird note:

    In my current Luck2 (and now Luck4) Jinxed run, I can not find any Combat Armor in store. I even buy 2 suits of Power armor in SF, but not seeing any CA for sale, not for love or money. I find the 1st Combat Armor in store after 3 suits of Power armor in SF, but not seeing any CA for sale in other towns.

    Luck definitely affect how nice a shop can restock their inventory. With Luck 2, you can have loots out of your ears but you wont find good items to spend the gold.
     
    Last edited: Apr 5, 2020
  9. laclongquan

    laclongquan Boned Hunter of Sister

    421
    Jan 11, 2008
    Vault Village quest discrepancy

    Isnt that VV ended with open a trade route through the village? At least, that's what darek guide told me.

    Yet I find no trace of it.

    1. I accept to buy weapon. Meet Joe. meet McClure. Return to Connar.
    2. Meet Brain to persuade to stop attacking VC patrol with the rats stationed in VV.
    3. Return to Connar to see things alright.
    4. Return to Connar to see things changed in the village (house but no wall). Definitely not trade route quest yet because not one month later.
    5. Return after a long while: village got surrounded by wall. Connar say everything alright now. No one else has anything new to say. See no one mark as Connar wife.
    5.
     
  10. SaciDePatinete

    SaciDePatinete First time out of the vault

    2
    Apr 30, 2020
    I'm not sure if people are still having this issue (I'm almost sure I didn't, when I last played the game years ago), but I decided to go on a Fallout 1 - 4 marathon (for story) and when I finally reached San Francisco, I got the infamous bug with the Dragon's quest, where you get stuck with the first of his disciples (Zurak). I tried rolling back an earlier save and going to San Francisco again, making sure to watch the fight between him and Lo Pan and then going straigth to Dragon to talk to him and initiate the quest. No luck there. Right after the "Fight!" is annouced, Zurak just stands there without doing anything and if I beat the crap out of him and he either dies or get knocked unconscious, nothing happens and I remain stuck in the ring. Anyone knows a way to circumvent this problem? It's very frustrating to get this quest locked, after over 30+ hours trying to squeeze the most out of the gameplay. Any help is really appeciated. Thank you very much for your attention.

    PS: I'm using the GOG version, with RP version 2.3.3 and burn's v12 update.
     
  11. laclongquan

    laclongquan Boned Hunter of Sister

    421
    Jan 11, 2008
    1. Suggest you try to learn Unarmed from him first.
    2. As an emergency way around, you can try using Super Stimpack to kill most of the Shi guards in downtown. Reduce the demand on search path, which I suspect it affect the script firing.
    3. Also try to leave your companion on other maps, like Shi Palace or the Dock. Their moving to surround the ring might also increase demand on search path.

    When I fight in New Reno, the ring fights are pretty slow due to the high number of NPC affecting computing. Same as in SF. Though it's rare to see such scripts refuse to fire up like that.
     
  12. SaciDePatinete

    SaciDePatinete First time out of the vault

    2
    Apr 30, 2020
    Thank you for your input, laclongquan!
    1. I did try that. Repeated the training until I couldn't learn more from him, but then, he refuses to give me the quest, because apparently I am too weak yet (I'm level 22 -_- ). As a test, I used the save editor to Tag unarmed, so it would spike its level a bit higher to take the challenge and still, the problem occurs.

    2. Never thought of this one... might work

    3. I left my companions on NCR along with the car with my zillion items and walked to SF, thinking that less data to compute would solve the matter. Still no luck =/
     
  13. Darek

    Darek is currently unavailable

    Jan 7, 2008
    The reason for the San fran fight bugging out is to do with brahmin Bess in Modoc. If you heal her she becomes a party member (only visible on the Modoc maps, but she is still with you on other maps even if you can't see her).
    Unless you sell her to get butchered or get the random encounter where she dies, she will be with you inside the boxing ring (invisible). The two fight scripts searches the ring for any critter to set as your next opponent, and sometimes that will become Bess, even though there is another boxer in the ring with you. Since you can't fight what you can't see, you will become stuck.

    So before the fights, go to Modoc and kill Bess. Or go bug the dude doing the latest patch to finally fix it. It's very simple to exclude Bess from the opponent search.
     
    • [Rad] [Rad] x 1
  14. Matt Drax

    Matt Drax Smart Ass

    128
    Sep 4, 2010
    It even can still happen when you completely ignore Bess/Modoc though...
     
    Last edited: May 2, 2020
  15. laclongquan

    laclongquan Boned Hunter of Sister

    421
    Jan 11, 2008
    That would be strange because last run I did rescue bess without doing the slaughterhouse portion. So by all sign she should be with me in the ring. Yet I do NR and SF ring fights without problem.
     
  16. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I'm not making this shit up. :lol: I saw it twice in other peoples save games just last year. Here is a link to one save game I fixed if you want to read about it.
    As far as New Reno, it's never been a problem there, only in San Fran (differently scripted).
    I'm not claiming it happens every time, just that I know it can happen sometime. Maybe it has to do with when the NPCs gets placed on the map, they may get put in different hexes depending on how many party members you have, or maybe in what order they got recruited. Or maybe there is a randomness factor to what hex they get placed in and sometimes Bess is closer to you than the boxer and get set as your opponent, and sometimes she's further away, and there is no problem. I just don't know enough about how the engine treats this stuff.

    Can it really? I know there was a problem with not letting the dragon and LoPan fight play out completely, but that just got them stuck in the ring not you. Or am I remembering that wrong?
    Anyway, I'd be happy to look into any save game you may have of this happening, to see what the problem is.
     
  17. laclongquan

    laclongquan Boned Hunter of Sister

    421
    Jan 11, 2008
    And here I was, thinking that bess bug was fixed.
     
  18. laclongquan

    laclongquan Boned Hunter of Sister

    421
    Jan 11, 2008
    Note: Chad skimming quest in Broken Hills

    Darek guide doesnt mention this but Max, when telling us about the complex system of lock in Chad's house, up our lockpick 5% (non tag).

    Second note: as long as we havent delivered Jet antidote to Doctor in Redding, SF shops dont sell antidote.
     
  19. Silver-Lambda

    Silver-Lambda First time out of the vault

    47
    Feb 2, 2020
    Hey guys how can i find the npc armor mod for the vanilla version for the game not RP
     
  20. Foxx

    Foxx Russian Modder

    210
    Oct 31, 2017
    Hi, everybody. Tell me the original song names prmtribe.acm and abbey1.acm