Getting the official mapper to recognize my fallout 2

Discussion in 'Fallout General Modding' started by P2, Jul 25, 2009.

  1. P2

    P2 First time out of the vault

    5
    Jul 25, 2009
    I use windows vista and the official mapper doesn't recognize my fallout 2 as being installed. I installed it anyway and when I try to open it, it says couldn't find/load text fonts.

    Any help would be greatly appreciated.

    Thanks!
     
  2. brother_soifran

    brother_soifran Look, Ma! Two Heads!

    396
    Oct 14, 2008
    Gronichonha P2.
    Haaaaaa :)
    This failure message :)
    "couldn't find/load text font" :)
    When it happens to me it wants to say one thing.
    The path of the fallout2 master.dat is bad declared in the mapper2.CFG
    Just open it and check if on the bottom the config file has the good adress.
    Exemple for me:

    I've installed my fallout in:
    F:\fallout2\
    My mapper is on this directory (but it's not necessary)
    so the config file says:

    • [system]
      art_cache_size=512
      cdlock=I:\cdlock.dat
      color_cycling=1
      critter_dat=F:\Fallout2\critter.dat
      critter_patches=F:\Fallout2\data
      cycle_speed_factor=1
      executable=mapper
      free_space=0
      hashing=1
      interrupt_walk=1
      language=french
      master_dat=F:\Fallout2\master.dat
      master_patches=F:\Fallout2\data
      scroll_lock=0
      splash=1
      times_run=1

    And we will win some time, don't forget to replace
    librarian=0 by
    librarian=1

    in the [mapper] part:
    • [mapper]
      default_f8_as_game=1
      fix_map_inventory=0
      fix_map_objects=0
      ignore_rebuild_errors=0
      librarian=1
      override_librarian=0
      rebuild_protos=0
      run_mapper_as_game=0
      save_text_maps=0
      show_pid_numbers=0
      sort_script_list=1
      use_art_not_protos=0

    if not, you won't be able to create and save new stuff in the mapper.
    But don't forget too to create a directory cal:
    X:\fallout2\dev\proto\items
    ..................................\critters
    ..................................\scenery
    ..................................\tiles
    ..................................\walls
    ..................................\misc
    Where X is the letter of the disk where you have installed your mapper.
    You absolutly must respect this path if not, if not you won't be able to save your new proto in the mapper and you will have this fabulous message:
    "error saving prototype"
    Remember you can install your fallout2 and mapper where you want in your hard disk, but you haven't the right to create the directory above elsewhere I have written it.
    Hoping it'll help you.
    Schuusss

    Brother Soifran
     
  3. P2

    P2 First time out of the vault

    5
    Jul 25, 2009
    Thanks!

    That worked perfectly!

    Thanks a lot!
     
  4. brother_soifran

    brother_soifran Look, Ma! Two Heads!

    396
    Oct 14, 2008
  5. P2

    P2 First time out of the vault

    5
    Jul 25, 2009
    I can't seem to make any of the modifications I have made to the protos stick.

    As soon as the game starts it seems to write over the protos instead of using them.

    How do I fix that?

    :irked: :irked: :irked:
     
  6. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    You need to set protos to read only (right click the file, properties, attributes section) before you go into game mode.
     
  7. P2

    P2 First time out of the vault

    5
    Jul 25, 2009
    I did. I even have the folder set to read only. It still isn't working.
     
  8. killap

    killap Bear Dude Moderator Modder

    May 16, 2005
    First off, don't make the folder read only.

    The protos must *not* be set to read only when you are modifying them. As soon as you are done making any changes, go back to the proto directory and set them to read only. If you plan on making new protos, then the .lst file must *not* be set to read only when you are saving them. It is actually safe to leave all .lst files in the proto directories with the read only setting unchecked and to never touch them again.
     
  9. P2

    P2 First time out of the vault

    5
    Jul 25, 2009
    yeah....

    I understand that part, though not making the folder read only is interesting, but the program is writing over them, even after I have successfully modded them and then set them to read only.

    P2
     
  10. Nirran

    Nirran Vault Senior Citizen
    Modder

    Apr 15, 2007
  11. Touquet

    Touquet Look, Ma! Two Heads!

    328
    Apr 20, 2007
    Hi,
    I have an error with the mapper, when I launch it I got : "wmAreaInit::Error loading cities!"...

    I've the Restoration Project 1.2 installed and high res patch installed on F...G Windows Vista 32 bit.

    Here the .cfg files:

    [debug]
    mode=environment
    output_map_data_info=0
    show_load_info=0
    show_script_messages=0
    show_tile_num=0

    [mapper]
    default_f8_as_game=1
    fix_map_inventory=0
    fix_map_objects=0
    ignore_rebuild_errors=0
    librarian=1
    override_librarian=0
    rebuild_protos=0
    run_mapper_as_game=0
    save_text_maps=0
    show_pid_numbers=0
    sort_script_list=1
    use_art_not_protos=0

    [preferences]
    brightness=1.000000
    combat_difficulty=1
    combat_looks=0
    combat_messages=1
    combat_speed=0
    combat_taunts=1
    game_difficulty=1
    item_highlight=1
    language_filter=0
    mouse_sensitivity=1.000000
    player_speedup=0
    running=0
    subtitles=0
    target_highlight=2
    text_base_delay=3.500000
    text_line_delay=1.399994
    violence_level=3

    [sound]
    cache_size=448
    device=-1
    dma=-1
    initialize=1
    irq=-1
    master_volume=22281
    music=1
    music_path1=E:\Fallout\Fallout2\data\sound\music\
    music_path2=E:\Fallout\Fallout2\data\sound\music\
    music_volume=22281
    port=-1
    sndfx_volume=22281
    sounds=1
    speech=1
    speech_volume=22281

    [system]
    art_cache_size=261
    cdlock=H:\cdlock.dat
    color_cycling=1
    critter_dat=E:\Fallout\Fallout2\critter.dat
    critter_patches=E:\Fallout\Fallout2\data
    cycle_speed_factor=1
    executable=mapper
    free_space=0
    hashing=1
    interrupt_walk=1
    language=english
    master_dat=E:\Fallout\Fallout2\master.dat
    master_patches=E:\Fallout\Fallout2\data
    scroll_lock=0
    splash=1
    times_run=1


    Need help please..
     
  12. Ohaimerk

    Ohaimerk modoc, den, grave Orderite

    Mar 30, 2009
    Could it have to do with too many cities? The FO2 exe might be patched, but the mapper might not be. Though I've never used the restoration project, so it might be something different.

    You might also try moving, renaming, or deleting your patch000.dat file if it's still in the fallout2 folder(unless it's needed by the mods you're running)
     
  13. Touquet

    Touquet Look, Ma! Two Heads!

    328
    Apr 20, 2007
    Ok I try but I've already use the mapper with RP 1.2 install and is was working well but I was on Win XP ... :?

    Thx