GOTY Steam edition - DLCs won't work. PROBLEM SOLVED

Discussion in 'Fallout 3 Gameplay & Tech' started by Antikeen, Feb 4, 2010.

  1. Antikeen

    Antikeen First time out of the vault

    1
    Feb 4, 2010
    ---SOLVED---
    Ahrg, i just had to patch it to 1.7!! Damn, i thought Steam would keep the game up to date!!

    Btw i just found out it only works, if i start the game with Fallout3ng.exe
    If i start with Fallout3.exe, Steam or FalloutLauncher.exe i get the same problems as discribed above...
    just in case anyone else has the same problem...
    ---SOLVED---

    This is really starting to piss me off, im trying to get the DLCs running for 3 days now, nothing works.

    Here is the problem: Downloaded the game form steam, aktivated the DLCs in the menu and played the game.
    As i left the vault i got a msg that the broken steel DLC was loaded and the level limit was raised to 30. But thats all, no radio signal from the other DLCs.
    So i traveled to the point lookout ferryplace and found just many red <!> where the ferry should be. i could talk to the ferrycaptain, but without sound.
    Similar situation at the "the pitt" radiotower and train tunnel, missing meshes etc, no pump cart i could use to reach the pitt.

    So the DLCs seem to load just partly.

    What i tried:
    - redownloaded an installed the game 3 times, DLC *.bsa files in the datafolder seem to have the correct size
    - used ArchiveInvalidation Invalidated.exe (although the ArchiveInvalidationInvalidated!.bsa in the data folder is empty ...?)
    - started the game with FOMM

    I don't know what to do anymore...