[Help]fallout 2 with restoration project mod crashes at vault city.

Discussion in 'Fallout General Modding' started by Farix, Jul 4, 2019.

  1. Farix

    Farix First time out of the vault

    1
    Jul 4, 2019
    Hello thank you for trying to help.
    first play through of fallout 2 im trying to get to vault city for the first time but it crashes every time i get to it from the map, im moving from the haunted farm to vault city directly.
    the error that only sometimes shows up is a "memory could not be read" error, most of the times i just get my desktop.
    I've already deleted the entire folder of the game and reinstalled everything, with the .exe on full installation countless times, tried compatibility mode on every windows possible and with all the extra options on and off with different combinations and the legacy option on the RP installer,
    its not a save problem since the game works fine on a different, much less powerful machine, it doesn't even manage a stable fps but gets me to vault city no problem, also the screen is too small...
    i'm lost, please help.
     
  2. burn

    burn Mildly Dipped
    Modder

    506
    Apr 22, 2012
    Try updating sfall for starters.
     
  3. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    48
    Nov 8, 2019
    You cant use any other sfall versions with the RP only the one that comes with that version of the RP.

    Having same issue, have done multiple reinstallations and still have numerous bugs, cant finish the sulik mission because the Umbra tribe is just a black screen with no exit grids, constantly get random encounters which also have this issue which flash and disappear, the den was a black screen at one point but i removed a map file and that fixed it.

    This mod is one of the worst most conflicting mods ive ever installed, it conflicts with the fucking VANILLA GAME, the only mods i have installed other than RP is the Unofficial Patch by Killap and Sfall.
     
  4. Lexx

    Lexx Background Radiant
    Moderator Modder

    Apr 24, 2005
    The RP is *stand alone*. If I remember right, it should say in the readme not to install any other mods. If you install the unofficial patch after the RP, you overwrote RP files and fucked the game.

    Besides, the RP is based on the unofficial patch, so there is no point in installing both.
    Also, Sfall is integrated in the RP - copy&pasting a different version over it works, but only if you do not overwrite the ddraw.ini of the RP (unless you know what you are doing, then you can just copy&paste the old ddraw.ini values into the new).

    Tbh, if the RP "conflicts with your vanilla game", then the problem is on your side.
     
    Last edited: Nov 9, 2019
    • [Rad] [Rad] x 1
  5. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    48
    Nov 8, 2019
    Yeah looks like i kinda fucked up a bit, i reinstalled the game *again* with only the RP instead of the UP as i didn't know i couldn't have both and it's working fine now, sorry about that i'm used to modding the new fallouts and even i haven't done that for quite some time.

    Edit: I still dont know how to update to newest sfall release but is it even really necessary
     
  6. Lexx

    Lexx Background Radiant
    Moderator Modder

    Apr 24, 2005
    Not really, unless you want to use one of the newer mods like inventory filter buttons, etc. Even then I think you only have to replace the ddraw.dll to make it work.
     
    • [Rad] [Rad] x 1