Improved Scripting Tools (SSL+ and Script Editor)

Discussion in 'Fallout General Modding' started by phobos2077, Feb 7, 2015.

  1. burn

    burn Mildly Dipped

    Apr 22, 2012
    Compiling works fine for me without mcpp or any command line editing, see attachment.

    I don't really have crashes, but exceptions, hover and hidpi issues are really getting me on edge... I got a proof of concept vscode extension and if it works out well enough, will probably switch from SFSE.

    Attached Files:

  2. VonZorch

    VonZorch First time out of the vault

    Jan 1, 2012
    Burn, thank you for the tip.
  3. VonZorch

    VonZorch First time out of the vault

    Jan 1, 2012
    Never mind, Burn told me how to fix my problem.

    One other thing, supporting .txt files would allow opening documentation inside the editor.
  4. Muttie

    Muttie It Wandered In From the Wastes

    Oct 9, 2017
    I have a problem with Fallout sFall Script Editor_v4.1.4
    In the previous version (4.1.3) I was able to click on a “node” on the right side and it would jump to that part of the script. This worked under the (Procedure and Variables tab). Only when I clicked on a command in the (Functions) tab would it add that command to the script.
    Now, in 4.1.4 all three tabs (Procedure, Variables and Functions) add to the script when clicking on them.
    However, this only happens in 4.1.4 when I click on anything in the script first. Only then does a click on “procedure or variables” insert whatever I clicked on to the script.
    Consequently this “issue” is kind of avoidable (don't click on anything), until I use (ctrl+f) because searching for anything in the script “selects” the part I searched for. And from then on instead of navigating the script it will insert any command from the right tab I click on. I don't know how to get out of this (deselect script) so that I can continue to navigate (i.e. jump from node to node)?

    Am I missing something? I tried double-click, right-click and looking through the options I can't find anything that switches this “command” on/off. I also tried a few buttons (ctrl) in addition to left-click, but zippo.
    Currently I have to search, note down the line, close, reopen and then navigate. Rinse & repeat each time I use the search function.

    I'm not a modder I only look at scripts to figure out rules or bugs (grunt). But for both cases navigating the script was very useful (nodes are not always in order). In fact I had to switch back to 4.1.3 as checking scripts has been a pain with 4.1.4.

    4.1.3 was better in this regard (i.e. I can click on anything in the script itself, use ctrl+f, and a single click on anything in the right tab took me to the node clicked on. Which was handy.)
    Is it possible to make this an option (i.e. to switch from 4.1.4 (scripting style) to 4.1.3 (navigating style)?)
    Or the search function can't select what it searches for when used (which is probably inconvenient).
    Or an ability to deselect the script by clicking somewhere (like the top), although that is probably inconvenient, too.

    Anyway, it's probably a bug that ctrl+f basically disables that “navigate option”.
    • [Rad] [Rad] x 1
  5. Mr.Stalin

    Mr.Stalin Agent of Enclave Modder

    Oct 29, 2015
    Now jump occurs by double-clicking.
    With searh by ctrl+f - this of bug, I'll fix it.
    • [Rad] [Rad] x 1
  6. Sauron462

    Sauron462 First time out of the vault

    Dec 6, 2019
    When I open .int files with this, or I try to open the exe. It just says that it will now associate .ssl and .int files with the program. How do I use the script editor?
  7. Lexx

    Lexx Background Radiant
    Moderator Modder

    Apr 24, 2005
    *.int files are compiled scripts. What you want to open and edit are .ssl files which are uncompiled scripts.