Megamod 2.3 technical issues and suggestions

Discussion in 'Fallout General Modding' started by MIB88, Dec 6, 2007.

  1. jackass888

    jackass888 First time out of the vault

    Jun 5, 2004
    thanks... didnt delete anything yet :) and yes it happened in the map where the vault entrance is. Thats really good news that we might see a even more complete MegaMod so soon.
    edit: deleting and/or didnt work
    editagain:deleted data folder,copied the untouched data folder from 2.32,started new game... still the same
  2. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    I'm at work now and can't test this. But, two of the files that may have problems are and These are in the data/scripts folder. If you could, please delete first and then try to enter that map. If the game still crashes, then try deleting the file.
  3. yghern

    yghern First time out of the vault

    Aug 7, 2007
    Is there only me, who got this bug?
    Its about Toxic Caves. Driving there results in car disappearing, but its not worst, because exiting TC (by feet) cause the game to crash with no excuse - just black screen, windows' sound of "critical error", ctrl-alt-del-solutiuon required.
    Maybe this will help: I got the quest for rescuing Smiley from Adrin, then went to Klamath Canyon and found a "map of toxic caves near Klamath" searching crashed Vertbird.
    Also, Smiley after few meters of escaping, becomes hostile and attacks me BUT he is still green-bordered, not red.
  4. sonarone

    sonarone First time out of the vault

    Jan 15, 2008
    Is this compatible with killaps restoration pack mod ? What are the differences between this and killaps mod?
  5. Solon

    Solon First time out of the vault

    Dec 8, 2007

    If you look at the page JUST before this one you will find the answer to your first question.

    The differences? Killap's puts in what was cut from original content before release. MIB88 Megamod blends many other mods that MIB88 likes into one all encompassing package.

    EDIT: clarity
  6. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Sorry, I didn't see that you had updated this. When I first entered that map, it crashed on me, too. Then, I renamed those two files, and the crash didn't occur. However, I don't think it was those files anymore, because, I renamed each of those files to their original names and I haven't had the crash since. Just that one crash. I don't know what to make of this.
    Just to check something: did you delete the data folder that was in your Fallout 2 directory, and then copy over the files from the 2.32 download? Or did you just overwrite the files without deleting that data folder?
  7. sonarone

    sonarone First time out of the vault

    Jan 15, 2008
    I can't wait when it will be merged with killaps restoration mod. It will be the greatest day for fallout
  8. jackass888

    jackass888 First time out of the vault

    Jun 5, 2004
    i deleted the data folder first so i didnt overwrite anything, then stared a new game. and i just checked.. vanilla 1.02 vault city works.
  9. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    I really can't explain what is going on then. If you decide to reinstall the mod, please let me know if you encounter this error again. Also, be sure to follow all of those installation tips in the readme. Sometimes crazy errors do occur just because something is carried over from a previous installation.
  10. yghern

    yghern First time out of the vault

    Aug 7, 2007
    Finally, I started new game cause I love that extra ammo, armor & weapon from Toxic Caves. Still, going to main map from TC keeps crashing my game. Do I need to wait for another relase, or it is just problem with my installation?
  11. jackass888

    jackass888 First time out of the vault

    Jun 5, 2004
    thamn brain error... my previous working version was 2.3 , not 3.21. And i tested with 2.11 files now that the error is somewhere in data\scripts... in the files beginning with "vc" ofcourse. Or atleast some script leads to the error. I will try to narrow it down further.
    edit: the problem should be deleting it doesnt seem to break anything
  12. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Another problem I am not experiencing. Sorry, but I can't diagnose it if I am not experiencing it myself. I'll give it some thought, to see if I can come up with a possible explanation. However, you might have to delete everything and reinstall everything from the beginning.

    No, the reason why I thought the problem was in one of those two scripts mentioned earlier is because those are the only Vault City scripts I have changed in a while that had changes in their critter_p_proc procedure. That is a part of the script that is active all the time, unlike dialog. But, I will try to figure something out.
  13. btreehugger

    btreehugger First time out of the vault

    Jan 11, 2008
    Until you make the decision, here's a quick fix for dcmetzge.ssl and his dialog file (because I know how tedious it is to deal with minor bugs like this).

    procedure Node025
    	if (item_caps_total(dude_obj) >= party_price) then begin
    		item_caps_adjust(dude_obj, -party_price);
    		set_global_var(457, 2);
    		if (global_var(100) < 2) then begin
    			set_global_var(100, 2);
    		set_global_var(445, global_var(445) bwor 134217728);
    		gsay_reply(46, 510);
    		giq_option(4, 46, 511, Node004, 50);
    		giq_option(4, 46, 512, Node999, 50);
    		prev_node := 25;
    		gsay_reply(46, 515);
    		giq_option(1, 46, 516, Node999, 50);
    # 25.5. Not enough money for Vic (from 25)
    {515}{}{Don't try my patience. If you don't have the money, then fuck off until you do.}
    {516}{}{Uh.. ok.}
  14. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    @btreehugger: Thank you very much. I do appreciate any help with these things and I will make sure to incorporate this tonight when I finish work.

    Just as a status update for everyone: I am still working on including Killap's restoration. I really can't make any promises, though, as I'll be...leaving in a couple of weeks and modding time will be uncertain. I may not finish. I will still have a minor update, at least. Killap's additions are pretty significant. Also, I might have two other additions, including a rough Colly/Sokil mod as well as Vault 23.
  15. Robert Czarwolski

    Robert Czarwolski It Wandered In From the Wastes

    Feb 5, 2007
    BOS Bunker

    Here is where the BOS Bunker is on my worldmap:
    How i post images? I tried to post it with my C: diretory and it didn't worked... I have to upload it in any site?
  16. Brother None

    Brother None This ghoul has seen it all
    Staff Member Admin Orderite

    Apr 3, 2003
    Re: BOS Bunker

    Yes, you have to upload them.

    Registration not required, quick 'n easy
  17. Robert Czarwolski

    Robert Czarwolski It Wandered In From the Wastes

    Feb 5, 2007
    BOS Bunker (yes, again...)

    Well, finnaly i managed to do it :D
    :( I've resized it to small... Altrought, the location is seen, don't?
  18. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Re: BOS Bunker (yes, again...)

    Ah, crap! I thought I fixed this. I typed the wrong number into the location in the city.txt file. It is supposed to be on the coast. Ugh. This will be fixed, and reachable by land, in the next update.
  19. Boosta

    Boosta First time out of the vault

    Jan 5, 2008
    More fun finding faults guaranteed! Or your money back...

    Hi MIB88.

    I'm new to this, so please bear with me.

    Got some errors for ya.
    #1 is a random encounter with bounty hunters. (Yes, I killed some children. By accident, but that started me down the 'dark' path))
    When they spout their random taunts at me, sometimes they say "You see a bounty hunter"
    Have a savegame with this if it helps.

    #2 is also a bit weird. When entering Klamath for the first time, I ran to the town square where the dog with the key is. Then I went up to the bathhouse, where suddenly the master trader comes running after me, hellbent on my death.
    I dropped him like a bad case of the munchies, went out of combat and that was that. Everything else went well.
    This was during my first install with your mod. Going to see if I can get this to happen again.

    #3 is a also a random encounter, this time with a bunch of raiders.
    After killing all but one female, she's dropped by a nice shot and is unconcious. If I walk a few paces upward and leave combat status, she still lies on the ground, but spout her taunts at an....amazing pace.
    Got a save on this one too.

    #4 is some lout in the holding 'cell' in the 'open' part of vault city.
    I've unlocked and opened the door, but he doesn't care. Still yells that the door is locked. And the guards (#1 and #2...maybe give them a name perhaps, with a sidequest to let you open the door ?)don't talk, or even care if I touched the door they 'guarded'.
    I have a savegame of this as well. Just hope I'm wrong in thinking it might already have been mentioned in the wiki...

    #5 is the encounter with the vertiassault squad after tomfooling around with the enclave quard via the computer in Gecko's reactor core. Are their corpses supposed to disappear ?
    Mine did.

    Then we have our man Klint. Is he SUPPOSED to be a walking tank ?
    Not that I'm complaining, but my character feels a little weak compared to his 275 HP and 575 (!) carrying capacity...even if she is a woman.
    Sure am glad I reloaded that time I shot him in the back in the sewers of klamath....

    Finally, we have a suggestion. I accidentally (hrm) shot one of the sons in the firefight over the Ghost farm ONCE (I had agreed to help them) and they turned their guns on me!
    Other friendly npc's allow you to shoot them once or twice I think, before they go psychotic on your ass...maytbe this could be done here too ?

    I've just gotten around to find the abbey and bunker 21, and I'm looking forward expecially to the EPA...thanks for a great mod! :clap:

    EDIT: I have a problem with Panda antivirus that won't let me play Fallout 2 without turning the protection off! If I do, the game works like it always has...
    Maybe you've heard of someone else having this problem ?
  20. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Re: More fun finding faults guaranteed! Or your money back.

    I will check this one out. I won't need a save. This one is easy enough to find and correct.

    The master trader is part of another mod to be finished adding later, and I moved him off to the side, not realizing he had a psychotic script attached to him. Anyway, I think you are using the 2.31 version. I fixed this in 2.32, which was released a couple of weeks ago.

    On a fast computer, those taunts will go that fast if you aren't in combat. Can't be fixed. Well, it can be, but it means correcting A LOT of scripts to add code to only say those taunts if the critter is conscious.

    This is what I was referring to in the wiki. Just part of the Alternative Life mod that I had to pull out for now because it was leading to other problems.

    Never saw that before. I'll check it out.

    His creator did make him extremely powerful. I will change this in a future version. But, he does help me to test out certain areas for now, as I don't use character or inventory editors to test the mod.

    You know, I have no idea how to change this. I don't even know if it can be changed. You don't always get a free shot, though. I know in random encounters if someone accidentally hits you or your party once, your party will turn on them. The only way to guarantee that they will not turn on you is to temporarily assign them to your party. But, to do this here just raises the question of doing this for so many other encounters. A lot of work for so little payoff. Guess you better not shoot anybody by accident! :D

    Yes, they are cool locations. But these versions are going to be modified. I'll end up using Killap's version of the Abbey, which means I will have to develop a story for the existing Abbey and move it to another location on the worldmap.

    I believe you when you say your antivirus wants you to disable it before running the game. I think I read something like this in a thread a long time ago (regarding the game, not necessarily this mod, I think). But, no. Sorry, I have no suggestions for this.