Megamod 2.44 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. diggerzz

    diggerzz First time out of the vault

    Feb 2, 2012
    This bug appear if you have "Bag" in inventory. When create "Healing Powder" (may be and all other item) with Mr.Fixit - game hang. Only helps Ctrl Alt Del.
  2. nad02s

    nad02s It Wandered In From the Wastes

    Jan 31, 2008
    Some more bugs to report:

    1. I finally got my hands on a gasmask, I headed straight to the Destroyed Lab then to the Ghost town, in both areas while using the mask in the poisoned areas, the message "You see a bar visitor" would appear above my characters head.

    2. In ghosttown in the poisoned sewer area is a note on a corpse/pile of bones, examining the note caused the game to crash. Memory exception error IIRC.

    3. Minor bug, but at Vault 14, the mutant hide-out/Master's Lab, I was able to peacefully gain entrance. When I met Ardenius (name?) he commented about how he couldn't forgive my slaughtering of his brethren, or something to that effect.
    On another note, Ardenius was a nice challenge, if it weren't for the psycho I nicked from cassidy I would have been a gonner :)
    Also he was carrying the wrong ammo for his weapon, a Bozar. He had some .223. The Bozar also disappeared when he died. No matter, I have two.

    4. Vault14 - Marcus' Armour, when he puts it on he changes his appearance briefly then moves one step and some floating red text appears saying:
    "Eh, And why is it that the player hasn't taken advantage of the new animation?"
    He then reverts to his normal self, it does the same thing regardless of whether I have party_armor_graphic on or off.

    5. Two minor bugs that are similar (Might not even be bugs). The doctor that makes marcus' armour will only accept metal armour mk1, it seems the metal used in mk2 armour is not acceptable :) The miner that works on the tunnel between Modoc and the home of the Slags also has the same problem with plastic explosives (Or whatever the white explosive is), he only likes dynamite.

    6. At the EPA, I have already killed all thje spore plants then I met a hologram asking me to kill them, it won't let me tell him they are dead. Perhaps I did something wrong though, although I can't find a damned spore plant left anywhere.

    Earlier I mentioned :
    I have yet to test but I read that this is a known issue, its allegedly caused by taking the car with you so I'll try heading back there without the car soon.


    Good question :) I wish I knew, I always assumed they provided a random effect each time, but everyone I actually try just poisons me.

    Yeah getting the perk is still the same as it always was. You have to rescue smiley the trapper from the toxic caves, after that if you chose the warrior route and you bring him enough golden gecko pelts, the head warrior will teach you how to skin other animals and how to get more than just a skin from a gecko.
    I don't know what watching Jordan does, it might just be an XP gain.
  3. Darek

    Darek is currently unavailable

    Jan 7, 2008
    I haven't played the Megamod in a long time, but this is how it used to be:

  4. Rafaello

    Rafaello First time out of the vault

    Apr 26, 2010

    I encountered a little problem. It's about savegames.

    Apparently, when i come into a map, and do a save(im using quicksaves mostly) i can load it without problems.
    But then, if i load, and save it again - loading makes crash to a desktop. Same if i come into a map and move my character around for a bit - saves can't be loaded.
    I hadn't got this problem with 2.42 version, and i tried downloading "" script which was posted at the first pages of this topic.
    After removing Klint from my team bug seems to be less ocurring. But it's still not fixed.
    Help anybody?

    Thanks for reading my post ;)
  5. savior of the damned

    savior of the damned First time out of the vault

    Feb 11, 2012
    Hi all. I have the same problem as that of Rafaello. When I take Klint, you can not saved with him. If you leave him and move to another location, then everything is OK.
    P.S. Sorry for my bad english:D
  6. tommyd

    tommyd First time out of the vault

    Feb 16, 2012
    Yeah, and I cannot save the game anywhere. I run ProcessDat2.exe before running the game, I've checked if the files in protofolder are set to "read only", I've even tried to change the given in the previous posts and the one from 2.42 version, but I still got the error saving game! message... Any ideas?
  7. Drobovik

    Drobovik Vault Archivarius Modder

    Jun 20, 2011
    Hello, I got an idea, how bout your fallout.cfg. Do u have critter_patch and master_patch pointing to the same folder. Paths have to be identical like DATA for example
  8. Drobovik

    Drobovik Vault Archivarius Modder

    Jun 20, 2011
    Script bug in

    A fixed script file error in dialog for Megamod in script Error appears in Collyweb, conversation with John Grizzly after you kill Humphrey for him. Download and put it into data\scripts of Megamod folder. I changed lines number in dialog, one digit was wrong, pointing to a wrong line in msg file.

    Here is the problem node. Changed 430 to 5430 and 432 to 5432. This line conflicts with line in script.

    Corrected script should look like this.

    procedure Node016 
      variable LVar1 := 0; 
      LVar1 := op_create_object(125, 0, 0, -1); 
      op_add_mult_objs_to_inven(op_dude_obj(), LVar1, 5); 
      LVar1 := op_create_object(236, 0, 0, -1); 
      op_add_mult_objs_to_inven(op_dude_obj(), LVar1, 1); 
      LVar1 := op_create_object(40, 0, 0, -1); 
      op_add_mult_objs_to_inven(op_dude_obj(), LVar1, 2); 
      LVar1 := op_create_object(48, 0, 0, -1); 
      op_add_mult_objs_to_inven(op_dude_obj(), LVar1, 1); 
      LVar1 := op_create_object(109, 0, 0, -1); 
      op_add_mult_objs_to_inven(op_dude_obj(), LVar1, 3); 
      LVar1 := op_create_object(49, 0, 0, -1); 
      op_add_mult_objs_to_inven(op_dude_obj(), LVar1, 1); 
      LVar1 := op_create_object(79, 0, 0, -1); 
      op_add_mult_objs_to_inven(op_dude_obj(), LVar1, 3); 
      LVar1 := op_create_object(86, 0, 0, -1); 
      op_add_mult_objs_to_inven(op_dude_obj(), LVar1, 1); 
      op_set_local_var(8, op_local_var(8) bwor 4096); 
      op_display_msg(op_msg_string(219, 5800)); 
      op_set_global_var(844, 2); 
      op_gsay_reply(219, op_msg_string(219, 5430 + ((op_local_var(8) bwand 2048) != 0)) + op_msg_string(219, 5432)); 
      op_giq_option(4, 219, 5433, @Node999, 50); 
  9. o4fun

    o4fun First time out of the vault

    Feb 27, 2012
    it seems that a new cures the problem with crash including Broken Hills.
  10. diggerzz

    diggerzz First time out of the vault

    Feb 2, 2012
    Bug with two jammed doors in Vault 8 Level2.
    With Strength 7,8,9,10, with and without crowbar in inventory I'm could not open it.

    I'm can join more than four party members with Charisma 8.
    My current party:
    1. Vic
    2. Cassidy
    3. Goris
    4. Sulik
    5. Marcus
    6. Robo-dog from NCR.
    And I can join Lenny.
    But I do not want. :)

    Only Sulik refuses to join again without reducing the number of party members.
  11. Drobovik

    Drobovik Vault Archivarius Modder

    Jun 20, 2011
    Quest log


    These quests in Navarro don't show up in PipBoy.

    • Locate the crashed Vertibird near Klamath. 300xp

      Enter the Toxic Caves warehouse. 1500xp + Advanced Power Armor
  12. Matt Drax

    Matt Drax Smart Ass

    Sep 4, 2010
    Hi. I have the same Problem, and nothing I tried worked. Some help here please.

    Edit: oops, .. thats NOT the Post I wanted to Quote.. my bad.. corrected now!

    Edit²: Things I've already tried:
    • Fiddled with the Edges (At least maybe ti could be that)
    • Entered multiple times even without a car, w/o npcs, etc
    • Extracted the Maps out of the Package and tried again
    • Downloaded it again AND extracted again AND tried it again
    • Runned through all of it with a fresh Second Char, just to stumbling on it again
    • Installed everything completely new and used a third char, the same outcome
    I'm just out of Ideas, and Mapper just won't work on my machine. Driving me nuts and bolts, so checking for a item on ground or entity that causes this is out of order :crazy:

    One thing I noted: There are NO .SAV Files for the Maps in question
  13. Z?

    Z? First time out of the vault

    Jan 5, 2012
    Oh okay. Well where would I get a new Do I download 2.44 again and just take the from it?
  14. Drobovik

    Drobovik Vault Archivarius Modder

    Jun 20, 2011
    Try this link. Ironically, this post is couple posts above yours.
  15. Drobovik

    Drobovik Vault Archivarius Modder

    Jun 20, 2011
    Post here your save file right before entering EPA for THE FIRST TIME. I can check it out for you. Most likely your installation failing one of the steps.
  16. Greel

    Greel First time out of the vault

    Mar 16, 2012
    Hello! First of all, wonderful work on bringing new life to Fallout. Thank you!

    Secondly, I've got a few issues.
    I've installed the GoG version of Fallout2 ( I presume humongous, but there's no version check for their installer)

    Then I've renamed the patch000.dat file to patch0000.bak file, and proceeded to install the Megamod v2.44

    The install went on smoothly, but alas some issues arose after installation. Namely this:

    1) I checked the proto files for read-only, and then I ran the ProcesDat2.exe and nothing happens (Presumably due to the automatic installation, it only throws out an error about a missing file, which was supposedly deleted by the auto-run procesdat2.exe) So this ain't really an issue, however..

    2) I try to run Fallout2.exe and my on-screen color scheme goes banzai, dotted black, and an error message appears saying "Fallout appears to be running in compatibility mode" with a "OK" check to close the window and restore my screen. Here's a link to the screenshot:

    3) After having investigated some into my installation, I compared my folder to the one in the megamod readme, and it is different. Which is also visible from the screenshot. The proto folder is in the first data folder for me.

    If you could be so kind, to help me with this matter, I'd be most grateful!
    Thank you!
  17. Matt Drax

    Matt Drax Smart Ass

    Sep 4, 2010
    You mean Fresh Game, right, not install? If you meant the latter just holler, it can't hurt any more to do it again ^^"

    Savegame Fresh Char * Don't mind the SPECIAL stats *cough*

    Greel: The Sound Folder inside the Main Folder is normal for the GoG Version. 2 things you can do:
    1st: Install Megamod like normal and MOVE the Sound Folder into the 1st Data Folder
    or 2nd: Change ONE of the MUSIC Paths in fallout2.cfg
    Fallout looks in the DATA and MAIN Folders, so music_path2=sound\music\ should be sufficient
  18. Greel

    Greel First time out of the vault

    Mar 16, 2012
    Well, as far as I've seen the sounds in the GoG version of fallout 2 work for me, but when I do what you said (moved sounds into data folder) the game breaks my saves and sounds don't work any more.
  19. Matt Drax

    Matt Drax Smart Ass

    Sep 4, 2010
    Always ensure correct paths. Check both paths.
    I had after the first start of the Game WITH the Mod a corrupt path in the cfg. Had to correct it once again...
    because of that I thought it would be easier to have everything in one folder.
    Well, a better idea is, nice and smooth for multiple Mods.
    For your convinience here the list if you want to restore w/o installing again. But checking your cfg is a must :\

    Index of \sounds\music from GoG

    And for your Problem no 2):
    Set the line SkipCompatModeCheck=0 under [MAIN] to 1. It's a little Workaround if that is really the Problem, and not any wrong path or a error that appears sometimes only. NB: All the ini's are commented ^^
  20. diggerzz

    diggerzz First time out of the vault

    Feb 2, 2012
    I have the same problem.
Thread Status:
Not open for further replies.