Megamod 2.44 Bug Reports and Suggestions

Discussion in 'Fallout General Modding' started by MIB88, Jun 22, 2011.

Thread Status:
Not open for further replies.
  1. Nirran

    Nirran Vault Senior Citizen

    Apr 15, 2007

    cool thanks man

  2. bozar_bullet

    bozar_bullet First time out of the vault

    Jul 20, 2011
    Another bug. In the EPA.

    As soon as I get to EPA for the first time quest n2 (fix the lighting system) gets crossed. Later I talk to one of the holograms about kiling the plants. I already killed them as soon as I got there, but I cannot tell him that no matter what. So I cant finished this quest and I don't get the key from the ground storage.
  3. Pavel

    Pavel First time out of the vault

    Jul 8, 2011
    I have also the same problem with the guest about plants in EPA.

    Another bug:
    I gave Cassidy power armor (the basic type) and since then he cannot use almost any weapon. The only possible I´ve found are shotguns. I tried even energy weapons (pistols, rifles) and gauss pistol but nothing.
    Also he can still carry just 175lbs. Is that normal?
  4. bozar_bullet

    bozar_bullet First time out of the vault

    Jul 20, 2011
    Yet another bug, now a big one with dissapearing car.

    I got to Bunker 21. Went underground, picked up all the stuff, went back up. Now my car was still there, but the grass was actually on top of it (looked very weird). Now when I left the Bunker with the car or without it, as soon as I got anywhere, the car was gone.

    Is there anything that could be done to resolve this? I really don't want to lose the car. Thx
  5. bozar_bullet

    bozar_bullet First time out of the vault

    Jul 20, 2011
    Now all the saves from the Bunker 21 have the same problem with the car. Saves before I got there work correctly.
  6. Nirran

    Nirran Vault Senior Citizen

    Apr 15, 2007
    were those save's from before the map script was installed?

  7. bozar_bullet

    bozar_bullet First time out of the vault

    Jul 20, 2011
    Not sure what you mean... (I'm not a big programmer myself :)
    But I visited B21 just once (yesterday), and saved a few times there. All the saves from there have the same car problem. Saves before B21 work alright.
  8. Nirran

    Nirran Vault Senior Citizen

    Apr 15, 2007
  9. bozar_bullet

    bozar_bullet First time out of the vault

    Jul 20, 2011
    Thanks very much!! Looks like it works now.
  10. VataR

    VataR First time out of the vault

    Aug 4, 2011
    Ok guys, First of all ty for such a great mod.
    I've installed 2.44 version and 've found some bugs listed here.
    [spoiler:fb992d8466]I've already visited:
    1. Arroyo - 've done all quests as shaman with no problems (2nd time played)
    doing quests as warrior (1st time played) caused several bugs:
    1a. i've failed 12 days deadline for warrior's quest and lucas have no option to train melee\unarmed skills just saying: "U've failed the Trail...blah-blah"
    1b. After i've entered Arroyo for the 2nd time and the "Prove that the Trial in the Temple had been passed legitimately"triggered, i've killed Jordan the Sly Fox and the was message that i've "cleared my name" but Arroyo Elder, leader of your village, still had only one option - he was speaking of that i should clear my name by killing enemies - so i couldn't complete "Find a way to save the harvest in Arroyo."
    (!)I've used one of bags with poison (i got 2 from the chest near rat boss in Klamath) on The Elder and that triggered him to speak with me about the harvest.
    1c. It's said in that u have option to increase ur barter skill speaking with Slik but i've got no option to speak with him about the trade. (this was in my 1st and 2nd attemp to play)
    2. Klamath
    (i've done all the quests), but i didn't check the option to "take part in Sajag's "hunting expedition"" (though i've found it by buying drinks to all guys in the bar).
    2a. Bug mb? I've fed dog in the main area and got the Trapper's Town key but it didn't unlock the door to the rat's part of Trapper's Town till i reload the area
    2b. Also didn't check the return of the Jennings's Family (Farm location when u need to defend them against slavers) to Klamath.
    Upd. I've visited Klamath in 3 months' time and there is no Jennings' Family here. Nobody even mentions about them
    2c. Killing Danton Brothers doesn't affect karma at all + for some reasons one of the Brothers when u start attacking him suddenly became "Master Trader". Well that guy from Colly (that occupied Vic' house) also became "Master Trader", when gets attacked and soon dead.
    2d. Why coming with Vic to his house, where this guy from Colly is, doesn't trigger any conversations?
    And where did we lose Vic' girlfriend from the Bathhouse? I didn't see her in Den, never less any messages about her return to Klamath.
    3. Den (all quests done)
    It seems strange that drug dealers in Den Residental Area have their loot renew (each time i enter Den Residental Area) after u did orphanage quests. I've stolen all their stuff before doing orphanage quests.
    3a. Den traders - Tubby and Flint? (the guy in the West side, house with addicts, selling stolen goods) stopped renewing stocks. Last time i was here to ask Karl to return back to Modoc, and ... several months past... but they still have no money
    4. Modoc
    No bugs found in the modoc itself (all quests for original modoc done including ghost farm) though i couldn't break the rock block in the Modoc's Mine area that is connected with the Toilet and location of Rat that stole golden watch.
    As to the Cold Hearts Farm quests. Haven't done them yet but i've already found a bug. There is trapdoor in the shall with ladder leading to dungeon. I've tried several option to open it but nothing worked. Than i tried to blast it with dynamyte - the trapdoor blow up but the ladder still gave me the message about the trapdoor locking the path?! bug! I've opened the trapdoor only using walkthrough telling about oiling the trapdoor and then using "repair skill".
    upd. Jo's shop doesn't renew. I mean no new money (after solve the problem between Modoc and slags, but didn't do the tunnel in well)
    5. Vault City
    I've done all quests except "Deliver Moore's briefcase to Mr. Bishop in New Reno" and "Enter NCR and return to Stark"
    5a.The "Find the raider base" didn't work for me (tried with car only, but still i've knew direct spot where this fuck...'n base is but there is no trigger and i can't find it, though i've spoken with Stark about the Raiders and 've spoken with First Citizen about Raiders and also tried to check ALL THE SPACE between Vault City and Broken Hills
    5b. The trader npc Ed (Vic mention him if u ask about water flask from vault 13) didn't tell you anything about flask asking you to show it to him. I have it in the inventory but he didn't "see" it... My actions: (i used "hand" action on the flask, and i also didn't have flask in my inventory for the first time i ask him about it, so mb that actions caused the glitch)
    6. Gecko
    6a. there is no option to steal from Festus. (i've encountered someone else with same bug earlier... will report if remember)
    6b. I got "supertools box" with me when i spoke with skeeter for the first time - and he offered to change it for the car part without any greetings and so on (...omfg! cheater he sees my inventory). He also didn't mention option to get some kinda thing from reactor stock for free upgrade (as i remember there was such option in original Fallout 2)
    7. Destroyed Lab (Ruined Lab) Encounter. I've found the Destroyed Lab Encounter - that was 6 spots righter than Vault City and 1 down. I've no clue how to enter it though there is message given when you look at the rocks block that u can blast them. Tried it several times with dynamite - no chance
    8.upd.a)Big cockroaches in the random encounter are not aggressive towards anyone. If u encounter some raiders,for example, fighting any critters (skoripions, plants, ...etc) with cockroaches - raiders will kill all the skorpions and plants but won't fight the cockroaches
    9.Followers (tons of bugs if u ask me). My party is Klint (1st), Sulik (2nd), Vic (3d), Cassidy (4th)
    9a. there is bug with followers expecially vic and cassidy, though i give them command burst: BE ABSOLUTELY SURE NOT TO HIT ME, Cassidy uses burst most of the time killing all around himself, he has killed the whole party 3 times already, Vic did same shit with the Assault Rifle, now i gave him Scooped Hunting Rifle (Meanwhile i didn't notice any difference between Scooped and just Original Hunting Rifle except that it weights 2 kilos more) and he miss about 80% of his shots at any range....
    9b. Sulik seems to be brain castrated because he just follow me most of the time instead of atacking anyone.... Vic does same shit sometimes. When i got only Klint and SUlik in the party Sulik didn't atack most of the times, there were lots of glitches all around first towns and encounters when both of them just stand still and atack persons that only walk nearby them....
    9c. upd. Very often Vic walk around with bare hands and do NOTHING in Battle, when u ask him about his gear - there is still option to "put his weapon away"... This is driving me crazy. When i enter combat control - there is no weapon in his hands.
    I'd rather fight alone without this idiots if i have more space for looted items...
    9d. upd. At the begining (first towns) Klint was healing my anytime i was injured and my hp became yellow, and if not i could ask him to heal me. Now this option disappear
    10. Scraptown
    10a. Lex at enter of scrap town gives u the quest to get the rid of both gangs for information about some necropolis and respect of citizens - but this doesn't appear in ya pip boy.
    10b. When u load save in scraptown the message appears: "U've returned in scraptown. Bah, i just load up the game,stfu.
    10.c. Phil's quest. There is a dog that didn't let people in house. I've given her a meat jerky that caused the problem to be solved (message that i helped Phil to get home) and triggered exp bonus and befriending of the dog. The thing is that my meat jerky doesn't disappear. I've didn't try to feed her with any other food... I'm too lazy to do that
    10d. Ah yeah, never coming to the scraptown i've already got karma status Scraptown: Idolized for no reason
    10.e. Blades cheatchat about that "only blades are allowed to wear leather armor", still i saw at least 1 person named "weak melee guard" (who asks to get rid of dog) that wears leather armor. Though both gangs except their leaders are simply named "ganger"
    10.f. the dog follows you (i regret feeding this beast) all over the area (as dog in Klamath, or healed Betsy brahmin do), but if it stacks somewhere on your way u can't move it.
    10.g. And of course joining any band (blades or fool) doesn't work at all. Both bands give u first task to scout the area of the opposite band.
    Playing as Fool i didn't find any option to "scout". I've used binoculars on every piece of the house with generator and nothing happend. As i tried to speak with Blade's leader he called me a Fool and attacked.
    Playing as Blade u even (wow!) can speak up with Fool guys. But most of the answers leads to them attacking you, or u can just leave.
    Didn't i mention that any action u did in scraptown (geting offer to get rid of both bands, joining any band, feeding\killing the dog) doesn't appear in your pipboy?
    10.h. Dog doesn't help u to fight with ganger although it's fed and follows you. It's shown as enemy (red) when u enter battle mod
    10.i. Finally i killed the dog .... and got exp bonus for "helping Phil to get home". So firstly i fed this dog and got (500 exp and quest done) and than i killed it for 200exp more and same quest done. great...
    10.j. I've wiped out Blades without any warning them or causing them to atack me, and nobody in town noticed that the whole gang is dead, even Fools... Don't wanna reload and check this with Fools to be first dead gang... I'm totally sure that DON'T work both ways
    10.k. While clearing Fool's gang, their leader misshot in the brahmin that cause whole town to be agressive and Sulik bursting childs and peasants all around. Doomed city javascript:emoticon(':?') I've reloaded the game and killed all Fools without any innocent to be harmed but still my followers (now Vic) begin to attack peasants. I've just ended battle mod on my turn and no one noticed that we were shootin' peasants... ><
    10.l. Killing Fools (in the building) and Blades (in the building with reactor) didn't solve the problem. So i had to kill that person named in 10e. And also Rock and Skizzer that were guarding the entrance in Scraptown. Only afterwards i got thanks from Lex for wiping out gans. And hell yeah, This 3 dudes that were alive all the time i killed main gangs didn't attack. So i had to attack first to trigger the battle.
    10.m. Ahhah. Finally. I got no karma and no exp boost for helping peasants to get rid of gangs. Yeah and Lex didn't tell me anything about Necropolis. He just thank me for the help. And nobody else in town knew about gang's wipe out. They still think gangers are here.
    10.o. There was also glitch with Klint. First seen in this town (mb i'll see it somewhere else. While killing rest of gangers in town, one of gangers dropped a gun, and Klint wasted 1 turn trying to pick up it. 1st thing to mention - he is melee person, yeah ik he tells about big guns, but that was a pistol.
    2st thing - his capacity was 200\200. How the hell he was going to pick up that weapon anyway? [/spoiler:fb992d8466]

    Just strange things that should be fixed (imo).
    Armor. As u guys are trying to make Fallout more realistic i recommend to look at armor mechanics carefully. It seems rather strange when i burst my enemy in parts with some combat shotgun, his body looks like piece of shit but i still can loot !undamaged! armor from his body if i pass repair check... Em... his arms and legs are 15 foots away of the bloody mess that is called "body". How the hell can i get the armor from it?
    It also tents to be strange that when i got armor from the dead body it's still shown that dead body is in armor. Pardon my english
    Ty, VataR
  11. Vrede

    Vrede It Wandered In From the Wastes

    Mar 11, 2008
    I'll try my hand at a few of those, if I'm wrong feel free to correct me.

    The option is definitely there. It's possible you need to pass a check (INT or Barter) before it's made available.

    [spoiler:ec8991d1b7]You need the map found in Bishops safe. This is not a bug.[/spoiler:ec8991d1b7]

    Pretty sure that's how it was in the original game too.

    [spoiler:ec8991d1b7] Get tons of explosives, drop them around the big pile. As for the exact spots where you need to drop them, can't tell which. Definitely works. Once inside you'll also need a rope and a gas mask. Not much to be found there tho... at least I didn't find anything special but maybe you will. [/spoiler:ec8991d1b7]

    Good luck.
  12. VataR

    VataR First time out of the vault

    Aug 4, 2011
    I has int 7 in both games, so it's possibly the matter of barter skill.
    About Lab and Raiders Base. I got it ty, 'll check
    Anyway it's a glitch.

    @Nirran [spoiler:ff8cebbc45]i'm also interested in ya KOTOR2 MOD, please contact me via Skype @ cuibic or qip: 313-381-366 [/spoiler:ff8cebbc45]
    Bug with the exit grid in toxic caves after saving Smiley's ass still exists. I have solved it several ways:
    1. I've reentered the area (gone to the ladder to caves and back)
    2. Or simply spam left mouse on the red part of exit grid till it relocates me

    I would really want to take part in making Megamod Guide at or at russian variant of it, but i want to know how to make out it properly + i don't know how to check the ... requirements for any quests or exp boost (i mean that some characters and action need ur particular stat/skill to meet the requirments, and i want to include that in wikia section, but without any moding experience and tools it will take eternity to find out it.... i hope u get what i mean)

    Some more bugs:
    [spoiler:ff8cebbc45] 1. Primitive Tribe.
    1a. There is no option to steal anything from fisherman\woman npc-s - the message appear: "Don't do that"
    1b. I've visited the Primitive Tribe at night for the first time, though nobody except warrior should give the quest - i got shaman quests before completing delivery of 10 knives and spears (ah yeah, the warrior accepts any spear/sharpened spear, but i didn't check whether he accepts venomed spears/knives) and as it's said in walkthrough waited till midnight (i was in village at 11 p.m.) but no ghost appeared. After completing weapons quests i've tried to wait for ghost once more, but still there is no ghost ('ve reentered location from 23 p.m. - till 1 a.m. for 2 days)
    1c. There was also the glitch that the car lost car trunk when i reentered Primitive Tribe for the 2nd time (i've gone directly to "Tribe", not the "Woodland"). So when i returned there was no car trunk in the car.

    2. New glitches + updates of already found bugs
    2a. When Sulik is overloaded AND he has no weapon on him - he can't give ur items from the barter menu due to the fact that's there is no space.... I got 85/125 at that moment and wanted to pick 5 kilos from him
    2b. I'm absolutely sure that Car trunk space depends on how much is the charge of car left (checked it several times).... For example: If the charge of the car falls i can't put anything in car trunk, i charge the car and put 100 kilos more of stuff in it
    2c. Klamath. Killing Danton brothers update. After killing danton brothers and returning to Klamath once again some npc became aggressive to me (guys in bar, though barmen still can trade with you), 3 trappers near fire in the Trappers Town, though gardener still sells herbs... Npcs in the house, where Whiskey Bob are not aggressive
    2d. Arroya. Slik seems to renew 1st and second stock, but he does collect all the stuff sold in the 3d stock and doesn't renew it (5 months in game time passed)
    2e. Den. Tubby started to renew stock at last (more than 3 months passed), but the other guy - who is in the house with addicts didn't [/spoiler:ff8cebbc45][/spoiler]
  13. bozar_bullet

    bozar_bullet First time out of the vault

    Jul 20, 2011
    Another strange thing happening - MArcus' armor.

    When I get it, the artwork for marcus changes for a few seconds, but then changes back to the old one and the armor disappears.

    It's exactly the same bug as mac402 pointed out in MM2.43 bugs page (

    There's some fix he wrote:
    if (Complex_Float_Stage == 14) then begin
    Complex_Float_Stage := 0;
    set_global_var(398, 0);
    anim(self_obj, 1000, 3);
    animate_move_obj_to_tile(party_member_obj(16777377), 24326, 0);
    anim(party_member_obj(16777377), 1000, 3);
    float_msg(party_member_obj(16777377), message_str(1594, 210), 7);
    start_gdialog(1594, self_obj, 4, -1, -1);
    call Node043;

    So does this fix it and how do I use it?
  14. bozar_bullet

    bozar_bullet First time out of the vault

    Jul 20, 2011
    Alright, managed to decompile the only to find out that this code has probably already been implemented since the MM2.43. But I still get the same bug. I would be thankful for any help. Thx.
  15. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    I want to thank you for the bug reports and, since I haven't been around, answers to questions people have posted. I appreciate all your efforts. However, things are still busy here for me at least til the end of the month. I will get to these questions and bugs as soon as I can.
  16. bozar_bullet

    bozar_bullet First time out of the vault

    Jul 20, 2011

    BOS bunker is definitely bugged also.

    Siege worked alright, but when I return with a holodisk from Steel to BOS bunker, nothing happens - no enemies come. And then when I leave and return again, I am teleported to the bunker and they are saying something like "we won, must attend to injuries". So theres no battle at all.
  17. bozar_bullet

    bozar_bullet First time out of the vault

    Jul 20, 2011
    Just found out that if I get into the bunker by the "bugged way" metioned above (without the fight), every time I take the elevator from the 1st floor to the Ground, the same thing repeats itself (chitchat about winning and injuries) and I am teleported back into to bunkers' 1st floor.
    So it is impossible to leave the map.
  18. Balgeron

    Balgeron First time out of the vault

    Aug 11, 2011
    Hi, i am new here.

    I gone through most of the the pages and posts on this thread and have`t found mention of this bug yet.


    It started(or at least i notice it) after i finished Toxic Caves(where you looking for the husband of innkeeper). My perception got buffed from 7 to 10, and my agility (8) stopped giving me passive armor bonus.

    Meaning that with the black leather jacket i had 8 armor. Then when i unequipped it, the armor drops to 0, and then when i try to equip it , it stays so.

    Furthermore - my armor seems to go to negative numbers, although its still showing AC 0, because when i did this first time, and try combat and see what bonus i get from action points, it did first +9, then +8, and its constantly decreased every time i switched armor.

    Now i have constantly 0 armor, and when i do "end turn", without any actions, instead of +9 bonus i get +1 only. So my armor is +1. I try loading a previous save, but i only have one just after i finished toxic caves.

    Mind you also , that i have`t being really changing armors during the time i got the leather jacket, as there was`t a reason for it, so it might start earlier.

    I am also using the duke_*** something fix from megaupload, that you upload here earlier, which fixed problems with save corruption. I had no other problems except that, no crashes and no stuckings.
  19. Lynxu

    Lynxu First time out of the vault

    Aug 22, 2011
    Hello! I have problem with car - just after I bought it, when I drive to any location, only trunk remains, the car is gone. I remember having similiar problem with early versions of vanilia game, but I thought that it was taken care of in last official path. Any way to fix it? Playing without car's pretty annoying. I don't put any things in trunk before running it.

    Another thing is a problem with toxic caves - when I tried to do quest evil way, helping to kill Smitty, when I arrived to caves I could saw three trappers, one of them was saying that now I am supposed to kill all remaining geckos and bring him pelts. But there was no geckos at all in cave. I tried to do it several times, re-entered location, loading previous saves - all for nothing. But when I came to RESCUE Smitty, caves were full of geckos and I could kill'em all and the quest was possible to do. No idea why was that - maybe because I entered caves and killed 1 gecko before accepting quest from barman to help kill Smitty?

    I use clean MM, the newest version, Windows 7.
    Sorry for my english.

    Ow, another problem, exackly like that one:
    Is there any way to fix it? Mayby other version of obj_dude? If I check save in FalloutSE, it points that my AC has about -70 bonus, and if I change it to 0 it will be dropping very fast durning game, so after few minutes I will have 0. Any way to change it?
  20. lpz85

    lpz85 First time out of the vault

    Aug 28, 2011

    I've read several comments regarding the BOS bunker quests. I also have a problem with this:

    After I give the item to the major at the door, he grants me the password to the bunker and is interrupted and the conversation end. However, the mutant invasion does not happen and so if I enter the bunker I get attacked immediately. Is there anything I can do to facilitate the invasion/go into the bunker without the BOS turning hostile?

    Also, I've read several posters issues with the toxic caves and other maps (random encounter caves) with no exit grid. I get this error when I go up to the second floor of Salvatores bar. The second floor should have Mason and Salvatore, however, I get transported to the second floor of the shark club with access to the stairs. I changed the settings on the INI file from 0 to 1(or 1 to 0) as described in this thread. Also, moved files into the map folder as well(map edges megamod 2.44 folder). Is there anything else I can do?
Thread Status:
Not open for further replies.