Fallout 2 mod Megamod version 2.46 Bug Reports and Suggestions - Closed

Discussion in 'Fallout General Modding' started by MIB88, Jun 25, 2014.

  1. Blackened

    Blackened I should set a cutom tite

    Jun 29, 2008
    Glad to see this mod is still alive, I played it several years ago and loved it. I really like the idea.

    I'd like to volunteer any programming help if that is needed. But I've never programmed for Fallout before, hopefully tool setup won't be too time-consuming. Can refactor messy code, write tests, document unclear code, fix bugs, implement features, anything really.
  2. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005

    I would greatly appreciate any help you would be willing to give on any aspect of the mod, even if that help is just playing the game and reporting bugs! Actually, that is a pretty big deal, since I tend to always play a certain way and tend to miss bugs. If you want to tackle problems, I'd say just jump in and work on something that you see is broken. I need to make a release before you attempt to work on scripts, as I do not want you to work on things I have fixed. Give me some time on that, though, as getting Internet access at my new place is proving to be problematic.
    Last edited by a moderator: Jan 9, 2016
  3. xsarq

    xsarq First time out of the vault

    Apr 28, 2012

    It's been quite a few months before last time i finished playing Fallout 2. Obviously its time to play it again! I have completed restoration project last time, now it's time for Megamod ;) I Decided to pick up your mod and do total playthrough. This post will be edited as i report my progress and bugs i find (eventually).

    Day 1.

    Installation process was bit complicated. Becuase my game was at 1.00 SFALL didn't let me in. I had to uninstall whole thing, reinstall Fallout then patch it up to 1.02 then remove patch 000. Kinda a lot of work but it's done!

    Character Creation - i made typical do everything char with Gifted and Small Frame. I have 8 AG, 8 LK, 8 INT and 6 of each other special point. I'm a small gun/speech/lockpick user. Forward to Aroyo!

    (to be continued/edited)

    It seems that i bump into something weird. When i try to enter the Temple of Trials im ending up in black map withouth anything at all there instead. I can't save game on that location. I Tried Version 2.44 which i installed from Nirrian site and this one is working for me -> will i miss much if i play with the old version?

    It looks like if you have 1.00 US version the Megamod 2.45.3 won't work. Even after patching to 1.02 i couldn't get into Temple of trials. This worked for me though:

    (careful its all in russian anyway MIB88_MM_2.45.3_US.exe installer worked for me!)

    Pheeeewwww this conclude Day 1. I have menaged to install and play this mod.
    Last edited: Nov 20, 2015
  4. Alexmikli

    Alexmikli First time out of the vault

    Sep 21, 2015
    I'm having an issue with my installation. No matter what I do I can't save in the Temple of Trials(says "Error saving game, unable to save game" and if I get the vault suit I'm sent to Arroyo and the game crashes. Error message is "The instruction at 004af46a referenced memory at 00000028. The Memory could not be read from." I'm using an older steam copy(not the current one availalbe) and it's updated to patch 1.2 and sfall. My original copy and dual jewel are sadly about 5 states away in my mom's basement, but I can probably download it from other sources if the version I have is broken.

    What I did is read the readme, extract to fallout 2's location, delete patch0000, set proto critters and items to read only, ran the Runme batch file, then tried to play the game. Is there something huge I'm missing? I read all the readmes but am at a complete loss.
    Last edited: Nov 20, 2015
  5. Blackened

    Blackened I should set a cutom tite

    Jun 29, 2008

    When you release the next update, just be sure to mention your future plans so I know what to implement.

    It's tempting to give it another play, but my Windows installation has become unbootable in a freak partitioning accident. Might do when I get around to fixing that.
  6. asdfqwer

    asdfqwer First time out of the vault

    Nov 23, 2015
    I am playing Megamode 2.45.3 and my car broke. I get broken alternator from it. Smith (guy who sold me the car) repaired the alternator and now I cannot instal the alternator to the car. Even with 111 repair skill I only get log saying: "You failed to replace damaged alternator". Possible bug? 111 repair skill must be enough or not?
  7. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005

    I am sorry. It is a bug. More specifically, it is a bug I thought I fixed with the last release. I will look at it again and will release a fix along with a number of of other script fixes soon. In the meantime, you may be able to bypass the bug if you have Vic (or possibly Myron) in your group.

    Thank you for the update. I know I need to make an installer for people to make it easier for those not so mod savvy. As for missing out on things, the thing to do is to look at the read me file to see what was changed between versions.

    What operating system are you using? The blank maps are due to missing proto files, usually (critters or items... Most likely items). Either the files got deleted somehow or they are not in the right location. I have heard that some operating systems install the game to different locations than where you think it is.
    Last edited by a moderator: Jan 9, 2016
  8. Alexmikli

    Alexmikli First time out of the vault

    Sep 21, 2015
    Windows 10, but I have Linux installed on a separate drive. I downloaded Fallout 2 to my D drive where my steam library is.

    What about the save bug in Temple of Trials?
  9. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Blank maps and errors saving can have the same cause. But more often missing items leads to blank maps, and missing/corrupt critters leads to errors saving.
    My suggestion is to check the configuration file (fallout2.cfg) and make sure it is pointing to the right location for the game and mod files.
    Last edited: Nov 25, 2015
  10. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    I looked at the car script. There doesn't appear to be a problem with it. It is just VERY hard to repair the car. I may adjust it just a little bit. So, either raise your character's repair skill some more or get Vic into your party. (Myron cannot help with the car.)
    Last edited by a moderator: Jan 9, 2016
  11. Drobovik

    Drobovik Vault Archivarius Modder

    Jun 20, 2011
    @MIB88 asked me to post his newest release which comes in the way of a patch for MM 2.45.3 full repack.

    Here is the download link:
    Last edited by a moderator: Jan 9, 2016
    • [Like] [Like] x 1
  12. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Last edited by a moderator: Jan 9, 2016
  13. lonelyleo58

    lonelyleo58 First time out of the vault

    Sep 29, 2008

    I just started play Fallout 2 again with this mod. However, I have a problem that most of the time when I loot corpses, I don't see any items/weapons inside. Is this normal?

    I also want to report a possible bug? In the Get the book back from Derek in The Den, I cannot find the book in all the 3-4 possible locations like in the vanilla Fallout 2.

    Version 2.45.4
    Last edited: Dec 9, 2015
  14. Dretnoth

    Dretnoth First time out of the vault

    Dec 9, 2015
    Thx. for this mod.
    Hi, I want ask if you patch #.4 fix this bugs that i found in #.3:
    -Skynet in Sentry -
    +The only Dialog whit him is "Give weapon, proceed to surface." And only option is "Bye".
    +But he pop up comments about areas.

    -Canot speak whit Chief Paladin in front of BS Main Bunker.
    +Dialog dont even start
    +And i think i have dialog whit him only when i got job from Abey to visit them.
    Edit> I notice im Enclave Guard my bad.

    -Dont know if has been reported but weapons in my car are reseting to full, creating that infinity ammo reserve.

    -This probably not bug bud cockroach get really on my nerves, is there some way to speed up their movements and decrease assault to one?

    The save if... something...
    Last edited: Dec 11, 2015
  15. lonelyleo58

    lonelyleo58 First time out of the vault

    Sep 29, 2008
    I managed to find out answers for the above, looks like it can be disabled inside the On_death.ini and damage.ini

    Regarding the Derek quest, still could not find the book.

    However, I have a new problem now with the new Bounty Hunter perk as the encounters can get annoying at time, I tried to disable the perk inside the BHPerk.ini but seems it does not affect anything?
  16. Ekventor

    Ekventor First time out of the vault

    Dec 15, 2015
    Hi everyone! Sorry for my bad english. What about russian translate of this greatest mod? I found only for 2.44!
  17. corwin

    corwin First time out of the vault

    Dec 17, 2015
    Hello Guys,

    First of all - thanks for work, for Megamod, having a blast so far and from what I read it will only get better... but.

    I will start from saying - I have looked, and I have tried a lot, but I cannot get out of Toxic Caves.

    I'm using Megamod 2.44+2.45.1 patch + 4.1.8 hi res patch from (I believe) Mash. Playing on Windows 10 x64. GOG FO2 - I heard somewhere Megamod may not like GOG version of FO2? Should I get Steam one? I doubt I will find original CD.

    So, what have I tried is:
    I changed IGNORE_MAP_EDGES to 1 in f2_res.ini (located in main FO2 folder), tried to copy Megamod maps in various places, didn't work. At the moment I'm on clear installation, so file structure is as it should be, original.
    I looked for it, as I said, and found only 2.44 posts - tried everything Nirran suggested, but without an effect it seems.

    Where have I looked is in "official" 2.44 bug/suggestion thread and in topic called Mib88 MegaMod - Cant exit toxic caves (sorry for no links, as I'm new I cannot throw them in).

    My f2_res is attached if you would like to have a look.
    View attachment f2_res.rar

    Sorry for spamming, but since I ended FO4 I got nostalgic and wanted to go through FO2 again - after all it was number one game of my teen years ;)

    EDIT: Downloading 2.45.3 - will make clean install with this and post results. Hope savegame will work ;)

    EDIT2: Sorry for bother - found Drobovik fixes, helped for Toxic Caves. Should probably go to sleep before work tomorrow, but an hour of Fallout 2 can't hurt now, when everything is ready to go! Thanks!
    Last edited: Dec 18, 2015
  18. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Never apologize for not knowing a SECOND (or more) language as well as your first. Besides, your English is fine.
    That said, I am sorry, but I don't know about any later translations for the mod. I can only recommend that you keep searching the internet.

    Sorry, another oversight on my part. I am just too old, I guess. I never play with the high resolution mod. But, I will make sure to add Drobovik's fix to the next patch.

    I will look into the car trunk issue. I thought I already added the fix for that...
    I'm about to start a new game soon, so I will test Skynet. I haven't experienced the bug you mentioned before.
    You can use a prototype editor (like Fallout Utility for Critter tinKering) to modify the cockroaches and remove some of their APs.
    Last edited: Dec 18, 2015
  19. alatari

    alatari First time out of the vault

    Sep 4, 2007
    Thanks andupdated Wikia article

    @MIB88 Thanks for keeping this mod alive. I never played a HtH slayer and only got a little ways into your 2.11 version before I stopped playing FO2. Going to play FO2 one more time for my bucket list. Probably am not going to ever play FO4 and not sure I'll get FO3 finished or start FO3:NV.

    I had save game issues with 2.44 this week. It seemed that 2.44 was the latest as the link to nirran's website on the Wikia article stopped at 2.44.

    I went ahead and updated the Wikia article to your latest version 2.45.3 and a link to the latest patch 2.45.4.

    My broken save games started working again after installing this version. It was so odd that the original save game would work but when saving immediately to another slot, that slot would become permanently corrupted until I deleted it.
  20. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Thank you for updating the wiki.

    I wish I had an idea about the saved game corruptions. I have no idea what could be going on there. And, I don't experience it because, when I am away from home, I mainly just mod the game and don't really play it. And, when I am at home, I use my favorite computer to mod and play F2: an old machine of mine which still runs XP. Now that I am away from home and have a brand new Windows 10 computer, I am guessing that I'll be running into all sorts of problems I've never had before...