Fallout 2 mod Megamod version 2.46 Bug Reports and Suggestions - Closed

Discussion in 'Fallout General Modding' started by MIB88, Jun 25, 2014.

  1. Ekventor

    Ekventor First time out of the vault

    Dec 15, 2015
    Thank you very much.
  2. alatari

    alatari First time out of the vault

    Sep 4, 2007
    Perception and armor class bug

    This machine has a fresh copy of Win 7 SP1 that's not fully patched yet but I'm going to take advantage of the Win X free upgrade after patching
    I moved as many apps as possible (those that can function without registry entries) to a D: drive and use them without their registry entries or install apps from PortableApps. Fallout 2 seems to work fine without any registry entries.

    Found a bug that upped my perception to 9 but haven't been able to recreate. My character has starting PER of 6, was under the effects of one healing powder for 5 PER then smoked a devil weed cig before speaking to Harkunun. I didn't notice the PER then (should have been 6) but after killing the weeds he refused to offer me shaman training (EDIT: that's because I diodn't kill the plants correctly but has nothing to do with the rest of the bug report) so I reloaded. When I did, my PER was 9 and after resting 6 hours it became 10 and stayed after 24 hours of more resting. Went back two save games to when it was 5.
    My guess is maybe the devil weed cig script put the +3 crit% onto the PER but not sure why it happened upon reload.

    OK, I got the perception error again in save games where I traveled to the Shack and then back to the Accusation. The PER ended up +1 at the Shack and then +3 more in Arroyo. Also, my base armor dropped by 2 at the Shack and then dropped to 0 (loss of 9) once I was knife fighting Fox.
    Some clues, I think a sandstorm blew in while in Arroyo, and I smoked one Devil Weed cig and I keep getting this message that my radiation healed 6 and got worse by 6. The save games slots get corrupted and I had to go back to before I left Arroyo for the Shack.

    Maybe this is a corruption when Devil Weed effect happens while the armor/perception mods from a sandstorm are in effect at the same time? How do I disable weather so I can test that hypothesis?
    Last edited: Dec 20, 2015
  3. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    There used to be issues with regards to AC and perception back when the MM still had the weather mod. But, I took those out with the last repack. Did you really see a sandstorm in your game? Is your game a fresh install? By that I mean, did you just install 2.45.3 and then 2.45.4? Check your main folder. Is there a file called weather.ini? Also, check your data/scripts folder. Is there a file called gltsrain.int? Those files should not be there and, if they are, might explain PE and AC issues.
  4. alatari

    alatari First time out of the vault

    Sep 4, 2007
    Installed 2.45.4 over 2.44

    Yeah, weather.ini and gltsrain.int are there. I installed 2.45.3 over the 2.44 game.
    I'll have to to a fresh install.

    EDIT: I updated the Wiki page header to reflect the latest version and that the weather system was removed for causing many issues. Does that reflect the current situation accurately?
    Last edited: Dec 21, 2015
  5. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Yes, that is correct. This is the reason why I said in the 2.45.3 readme file:

    Do NOT - I repeat - do NOT just install this mod over your existing MM location.
    Some files from previous versions have been removed. Those files will still be
    on your computer, and will influence the mod, if you just add this version to
    a previous version. I recommend that you either delete all MM files, and then
    add 2.45.3. Or, you can just install a new instance of Fallout 2, and add this
    version of the MM to that.
  6. Bunio

    Bunio First time out of the vault

    Dec 26, 2015
    Hello, i install 2.45.4, and I think did everything like readme said. But, i can't save game.

    error saving game!
    unable to save game

    Any ideas how fix this?
    Used GOG version of game.
  7. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    So, you installed the game... deleted the patch000.dat, installed 2.45.3, installed 2.45.4 patch, etc... Right?
    Ok, where won't it save the game? Is there anything else wrong with the game? (For example, are you getting a screen that is all black and full of "ghost" images? If so, you may be focusing on the wrong thing.)
  8. Bunio

    Bunio First time out of the vault

    Dec 26, 2015
    Yes I deleted file patch000.dat, installed 2.45.3, then 2.45.4 and run runme.
    Game works, I'v got nice new start screen, new dialog with Kent if I pick women, new temple etc. Everything looks like it is ok.

    Can't save game on front of Arroyo temple, and inside (second room/map of temple, same problem)

    No "ghots" images.

    In data/SAVEGAME

    When I attempt to make save, game create folder with game slot I choose.
    Slot01 -> there is only folder "proto" inside it I got citters and items. Few files in "citters", but no files in "items" folder, and there shoud be something.



    Antivirus make it.
    After distable it, everything work's ok.

    Info for readme, and others.
    Last edited: Dec 27, 2015
    • [Like] [Like] x 1
  9. TheBiggestHyperWeapon

    TheBiggestHyperWeapon First time out of the vault

    Dec 30, 2015
    can you elaborate on that? I dont have any antiviruses to speak of, apart from WinDef (who is not the culprit, it seems).
    to generalize - have same "Error saving game" thing. No saving all throughout the temple, after vault suit video - crash.
    Installed fresh cd-version (so not the version problem, i guess)->patch->2.45.3->2.45.4. Did the processdat2, deleted patch000, runbat, no "proto" folder in the main directory, fallout2.cfg is all correct, no "ghost" imagery or any other problems apart from the saving thing.
    I fell like forgot or messed something, but cant really think of anything. halp.
    Quick Edit: no particular order for all the checks, delete's and stuff, just that i tried most of which you guys spoke of before.
    Last edited: Dec 30, 2015
  10. 3m2oo5

    3m2oo5 First time out of the vault

    Dec 31, 2015
    I also got "save problem"

    ASUS G751JY laptop
    Running on steam.
    windows 10 pro PL

    Antivir Avast Premier
    Malwarebytes Antimalware premium

    for thrird time trying to:

    a) reinstall game
    b) renamed patch000.dat
    c) applied megamod full repack 2.5.3
    d) applied megamod patch 2.5.4

    previously got saves from killap`s RP on steam cloud (RP worked perfectly)

    after reinstall I configured ddraw (tried to add Appearance mod - mod worked)

    cannot save cannot save cannot save :(

    everything else seem to work (excet the screwed graphics - cannot change RES (i think anything..) via game menu - had to do it manualy via ddraw.ini

    help? :/

    disabled antivir and antimalware as well and no result

    edit: what a previous dude said its true - game creates save slot folder each time i "try" to save on slot


    switching off shields in both Avast and Malwarebytes doesnt help
    adding exceptions to both mentioned doesnt help
    the save folders are "read only", but somehow some files and save slot folder are created (steam issue?)
    Last edited: Jan 1, 2016
  11. teskal

    teskal First time out of the vault

    Dec 26, 2015
    same issue:
    'error saving game!
    unable to save game'

    F2 is the gog.com version
    AVG free virus scanner (tried it also deactivated)
    Windows 10 pro 64bit

    - made copy of the F2 game folder
    - check F2 first, saving works fine
    - path of the game: c:\gog games\fallout 2
    - renamed patch000.dat
    - moved all files and folders from the 2.45.3 full repack in the folder
    - started runme.bat
    - put all 2.5.4 files in the F2 folder
    - same issue, can't save games
    - right click and 'start as administrator', same issue
    - choosed in the properties compatibility mode for windows XP SP2 but get error: 'Fallout appears to be running in compatbility mode'

    Tried it with the fallout2.exe and fallout2HR.exe


    Tried it again:
    - deactivated virus scanner
    - made copy of the F2 game folder
    - check F2 first, saving works fine
    - path of the game: c:\gog games\fallout 2
    - renamed patch000.dat
    - moved all files and folders from the 2.45.3 full repack in the folder
    - put all 2.5.4 files in the F2 folder
    - started ProcessDat2.exe
    - started runme.bat

    issue solved.
    Last edited: Jan 2, 2016
  12. TheBiggestHyperWeapon

    TheBiggestHyperWeapon First time out of the vault

    Dec 30, 2015
    Did all that before, rechecked now - no luck.
  13. 3m2oo5

    3m2oo5 First time out of the vault

    Dec 31, 2015
    I`ve solved the issue :D

    as I suspected it was fault of invalid entries of proto files in master.dat

    the program ProcessDat2 posted an error message that I have ignored...

    about missing Msvcr71.dll (some Visual C file by mistake not included in WIN7 and above)

    i`ve puted the Msvcr71.dll in windows\SySWOW64

    repeated MEGAMOD install steps

    applied hero apperance mod

    and it works :)
    • [Like] [Like] x 1
  14. bestfrog

    bestfrog First time out of the vault

    Dec 29, 2015
    Hey, i just started Megamod. I went through the vanilla like 20+ times and probably 6 or 8 times with RP. I am quite fanaticall about fallout and find it hard to accept any changes to the original. Despite that, so far I really enjoy the game. The most difficult for me were the changes to Hakunin and the Elder. Not hearing their voces, which where there with me, through all childehood (in game and in real), was awkward. But thats my personal preference. Apart from that the result so far, seems refreshing and worth playing.

    So far I made it to the Den and I will report any bugs found.

    When creating a character I can't change it's appearance.

    In Klamath, when I unlocked the back door to Golden Gecko, the door shuts after a while and cannot be reopened (game says, the doors are locked). When using Lockpick skill it said I locked the door, used the skill again, same message, an so on....

    I found another thing, in Temple of Trials, there is a quiestion about the Glow. Then when you talk to Jennings on his farm, you say that you never heard of the Glow, but obviosely you did.

    I had problems wit error when saving game, but only when I installed Fallout in different directory then the default path for GOG version.

    (using win7, GOG version of Fallout 2)
  15. teskal

    teskal First time out of the vault

    Dec 26, 2015
    I found 2 issues:
    1. I tried to increase my melee skill, but after speaking to Lucas asking him to train melee, the conversation ended and nothing happened. Same with unarmed combat.
    2. in a random encounter, one with trappers and one with monks (or something like that), in both were caves. While I was in the cave, I couldn't see parts of the cave. Around it was a black area and the case entry, me and some gecko's were in the black area. Leaving was not possible.

    About the installing issue, I have sometimes the problem the problem that I can't open the game. Only if I deactivate the virus scanner again. Sadly I didn't wrote down the error message.

    I think the chosen one would not know most of the answers of the questions. I do not really like the questioning. But this is only my personal opinion.
    Last edited: Jan 3, 2016
  16. teskal

    teskal First time out of the vault

    Dec 26, 2015
    The room in Trapper Town behind the gun shop has a man hole which needs a rope to climb down. If I have 2 ropes in my backpack, both are used. I prevented it dropping one. Don't know if it is a known bug.

    I see no way to remove the rope.
  17. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    Regarding the skill increase, you must do what Lucas says in dialog and in his floats. Do not just skim-read. Actually read the dialog. He would have told you to equip the pole and move closer in order to fight him, or just move closer for melee.

    I don't what the deal is with the random encounter.

    I will look at the Jennings conversation. However, it makes sense that the Chosen One would know some of the more significant details of the Vault Dweller's exploits.

    I will look into the issue with the Trapper Town manhole using 2 ropes. There is no way to remove a rope once used. (Well, I could script it, I suppose. However, ropes are generally seen as single use items in the game. I have no plan on changing that.) Should be an easy fix. Will also look into the issue with the back door of the hotel in Klamath.

    I want to thank all of you for bug reports. Getting your reports helps me to fix the mod to make it better. I am glad to hear that you all have gotten the game to work. So, thank you also for posting exactly what you did to get the game working on your systems. I will be sure to include these helpful hints in the future readme files.
  18. teskal

    teskal First time out of the vault

    Dec 26, 2015
    I was wrong, yes, the Chosen One should know everything about the Vault 13. :-) After reading about Holy 13 again and again even I got it. :-)

    Version 2.45.4
    Yesterday I had the problem that moving or doing anything in Klamath is so slow I couldn't play. In the 'rat infested catacombs' it was normal. I do not know why it is ok again. It is ok, now, but I can't say what was the reason. I removed everything from the autostart I do not need to start (needed to do it anyway). Deinstalled AVG FREE because I can't find how to set the F2 folder as a save or to ignore it. Restarted PC, same issue. Later Klamath was ok again...

    About the random encounter, I will make a picture and upload it as soon I get it again.

    About flares, in F1 I could use them as light source while holding it in the other hand. It is not possible anymore, only if I throw it on the floor. It would be nice if it is possible in F2, too.
    Last edited: Jan 4, 2016
  19. teskal

    teskal First time out of the vault

    Dec 26, 2015
    These are the caves, only with bandits instead of gecko's

    Outside of the cave, only with bandits and not trappers, but in the cave is a similiar issue:
    View attachment 2016-01-04 21.50.35.jpg

    Bottom right side is for me the end of the map, I can't make the part of the cave visible:
    View attachment 2016-01-04 21.49.40.jpg

    Only difference to the gecko caves is that I can see the entry grid:
    View attachment 2016-01-04 21.49.58.jpg

    Top part of the cave I can't make visible. I can go to the right top cave part, but make the head of the guy in the black leather jacket visible:
    View attachment 2016-01-04 21.49.21.jpg

    Interesting part is, I had just few moments ago an encounter with a gecko cave and the issue is solved there.
    I made few changes to the ddraw.ini which could be the reason. Eventually I need other settings for it. But I do not know what I changed. :-( I thought it was the resolution setting from 1920x1080 to 1366x768. First is my native monitor setting. Main reason why I tried to change settings were graphical issues. A friend of mine saw the graphic quality of F2 installation and it is in the moment much worse as a normal 1.02 patched version. I do not know what settings are needed for my win10 pc with 'gog.com F2'. But I got the same graphic quality also on an WinXP version installed from a black isle CD. Sadly I cannot make a screenshot of it.

    Another issue:
    I can walk in Trapper Town from A to B just by clicking with the mouse in the B area.
    The Charakter walks down along the fences and appears at B.

    It was not possible anymore after the rescue of the trapper from the toxic caves (smiley?) or after I got the keys from Trapper Slim in Trapper Town.

    2016-01-04 22.23.32.jpg

    Sorry for the big pictures and the quality.
  20. MIB88

    MIB88 So Old I'm Losing Radiation Signs

    Feb 22, 2005
    The game sometimes lags (randomly slows down). I have no idea what causes it.

    Not sure what is the deal with the placement of the caves. Probably something to do with the hi-resolution mod and the various screen settings. The hi-res mod may even be the cause for being able to go from area A to area B in Trapper Town. I've never experienced anything like that in any of my games (I don't use the hi-res mod). That was not something I worked on. And, to tell you the truth, I don't even know if there are settings that would work for those maps with every possible screen resolution. I just never messed with that aspect of F2. Maybe the developer of the hi-res mod is still around and has an idea...

    I don't know what I can do about the flares. Maybe something is possible through sfall. I really wish I could get that working, too, as it would give a use to the flashlight you can find in the game.
    Last edited: Jan 5, 2016