MIB88 MegaMod - opinions, technical issues, etc.

Discussion in 'Fallout General Modding' started by Lil Mordino, Dec 19, 2005.

Thread Status:
Not open for further replies.
  1. Zzarr1

    Zzarr1 First time out of the vault

    1
    Apr 9, 2007
    A few questions

    Hi, looks like amazing job you've done here with this game mod, I haven't had a chance to try it yet. I used to play it before though with the 1.02 patch. Questions I had were the following:

    1) Can "Fallout 2 graphic update ALPHA1" be safely incorporated into Megamod?

    2) This is probably the wrong place to ask this but: I would love to see the old school Meson Cannon from the Citadel in Wasteland put into this game, with a custom graphic, custom attack animation (blue laser bolt), etc.

    3) Perhaps a Rifle version of the Solar Scorcher =D =)

    4) Question about Skynet, I see that you have updated him in this mod several times. I am really excited that you made him be able to use rockets; my question is, did you change his body graphic to the body type of the Mark II "mech" robots in the Sieraa Army Depot? I had always wanted to have one of those style robots as an NPC in my party, they just looked so kick ass. Kudos to you if you have already done this, it would pwn.

    5) Further question about Skynet: Does he use standard rockets or does he use the mini-rockets that the bots use in SAD? I remember from way back that they used a different rocket graphic (I think), they fired alot faster (did less damage though per shot for balance).

    6) I vaguely remember this so please bare with me: There is a quest involving a town where you have to fix their nuclear reactor or something, and when you fix it, and you come outside, there's a guard or something there waiting for you who threatens you saying he's called in a vertibird (I think), or backup guards or something to come and kill the main character; from what I can recall, nothing ever happened, no reinforcements ever showed up, maybe Im wrong here totally, I dont know, but Im sure you'll tell me.

    As a final note: If some of the better graphic elements from Fallout Tactics can be integrated into this flawlessly, this game would be absolutely incredible. One thing in particular that would rock would be if somehow the visual effect of firing a gauss weapon in Fallut Tactics could be ported over to Fallout 2 (Rings through the air from ultra-rapid air molecule displacement from the tremendous velocity of an electromagnetically propelled projecticle.

    I read some of the read-me's etc, but if I asked anything that was stated already, then just don't respond to it.

    Thank you again for this, this was truly a legendary game, and still is, it is the best RPG I have ever played as far as plot goes, very close to the old Wasteland for the Commodore 64, Apple II back in the day.
     
  2. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Re: A few questions

    Play the mod, then ask all the questions you want and I'll try to answer them or fix any bugs you report. It is a waste of time to address things you will find out about by playing it. I don't answer gameplay questions, but maybe someone else would answer those. I only answer technical questions. But I will address those things above.

    Regarding number 1, it is not compatible as is. The protos from the added mods are different from the ones in the graphics update. This means that if you add the graphics update, you will get the new images for an item, but not the fixes for said item (things relating to weapon characteristics, weights, or anything else that was changed from another mod/patch). Also, initial images for items will be messed up, because none of the maps have been altered. So if you thought that you'd get that version of the Robobrain, you're mistaken. And the image of the 10mm ammo that is on the ground in the Den already will be the same as the original, but when you pick it up then drop it, the new image would be displayed. There would be MANY instances of that sort of thing. Anyway, adding the graphics update is on my 'to do' list.

    (On a side note, this mod contains so many things already. However, don't expect it to work with any other mod.)

    Regarding 2 and 3, if someone were to use the editors and make one and send it to me, I might incorporate it.

    Regarding the last note...maybe, once I have added in/fixed a lot of other things first.
     
  3. RangerKarl

    RangerKarl First time out of the vault

    22
    Apr 7, 2003
    Hey MIB88, have you considered DATting the mod? Might help to control some of the errors.
     
  4. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Yes, I have, and have discussed my reasons for not doing it and the new problems it creates. Look back at page 40.
     
  5. xf69fs

    xf69fs First time out of the vault

    14
    Mar 7, 2007
    Well my game crashed on the last Kaga Encounter. The one with him in power armor and he talks to the character. They just say error back and forth in the bright green floating text.

    I saved the game there and I cant move the screen and if you goto options, then close it, the mouse is gone.

    I also had a few other questions, wheres the bucket for the primitive tribe, the boy for the horton quest. I cant find him.

    Oh, another slight bug I found was with the enclave at the Gecko. If you goto the garage side of town then back toward the exit, there will be twice the enclave. There will be 2 guys standing on the same spot. I almost didnt make it out of that one with a cheated character either. All armed with gauss pisols kicked my ass.

    Ryan
     
  6. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    So you saved during combat and now the game doesn't work? No kidding!? You can't do that in an unmodded game. Playing with the Megamod is no different.

    Interesting. Is this reproducible every time? I shall play with where the Enclave soldiers stand. However, the number that appear is dependent upon level (maybe stats, too). You might have encountered the proper number, just the positions were wrong. Either way, it's not supposed to be easy.
     
  7. xf69fs

    xf69fs First time out of the vault

    14
    Mar 7, 2007
    It was out of combat. After I killed everyone, saved it and went to bed. But the dialog is still messed up.

    I played with the enclave encounter, if you goto the 1st screen of the gecko, you get like 8 soldiers, if you goto the part with skeeter, then back down to the main town part, it will have 16, but they are standing in the same spots.

    The long floor locker in Bunker 21 is listed as hortigan as well.

    Any info on the bucket and the horton quest?

    Ryan
     
  8. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Thanks, but, this occurred with a lot of crates and has already been corrected for all of them for the next release.

    Just a note about how I post things: if I don't answer, it's because a) it is a gameplay question, and I don't answer those, b) it has been addressed already or, c) as is the case this time, something I know is working fine, you just either need to keep playing to find the encounters or look at the screens carefully.

    You get errors because the dialog was never written for the final Kaga encounter. But I don't get this. He should initiate combat after the dialog ends. And if you killed everyone, how can the dialog be messed up? There shouldn't be a Kaga there to talk to.

    Wait a second. This should be an early encounter. Yet, in dealing with Kaga, you mention what happens with a really high level encounter. Also, the Enclave guards show up on an entirely different map, not the Gecko settlement map. Of course. You said you were playing with a cheated character, So...
    I don't care how the mod interacts with anything I didn't add to it. I am not concerned about any bugs as the result of using Falche or some other tool. I don't know how those work, and have no intention of making it compatible in the foreseeable future. I will look into this and make sure the encounter is working right in the mod. In fact, I will check it out right now...

    And it is working mostly fine. For some reason you actually have to talk to the soldiers twice if you don't initiate combat. But the guards are spread out, and the encounter happens on the correct map. So, whatever it is you are encountering is probably the result of whatever cheating tool you are using.
     
  9. jettie

    jettie First time out of the vault

    8
    Aug 3, 2004
    Vault 13 voice module can't be installed

    Hi there, this time I don't want gameplay advice (solved the quest to save arroyo crop by other means than stopping the theft in Sam's garden).

    Instead I have to report a bug which is mentioned also over in the patch 1.05 thread: If I try to install the voice module in the vault 13 terminal, I get nothing else but again the dialogue screen with those lines you can choose from if you don't have the voice module.

    Now I'm not sure wether patch 1.05 is part of Megamod; in fact I only found a 1.04 readme in the appropriate folder, but maybe this patch is the reason for the bug as well.

    Any E.T.A . for the next Megamod patch? Even if it's not possible to give a date, please tell me if 2.1.1 saves will be compatible with the new patch. Since when they won't be usable, I simply gonna steal the GECK from the Deathclaws and play my current game through

    tourist
     
  10. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Re: Vault 13 voice module can't be installed

    :roll:
    Addressed. I even tell how to fix it just a few pages back.

    I don't know when the next will be out. But due to the fixes I made to Skynet, old saved games will not work.
     
  11. xf69fs

    xf69fs First time out of the vault

    14
    Mar 7, 2007
    Ok, I dont think I made myself clear on what happened with the Kaga encounter.

    I got the encounter, and they start talking, saying error back and forth then combat starts. I kill everyone, ended combat and saved the game. I quit the game and came back later. The saved game was dead basicly, couldn't move and after opening the inventory, options or pipboy, the mouse would disappear.

    As for the Gecko. I happened to have saved my game in Vault City. I went to the gecko and to the "settlement" map. It went to the enclave encounter, with like 8 guys, I then got my ass kicked cause I wasnt prepared. I reloaded and equiped myself then went back to the Gecko and instead of going to the settlement, I went to the junkyard part of town, then down to the settlement. There was now 2 times the enclave. 2 soldiers where 1 stood before. Thus 16 soldiers maybe? I want to say I got this to happen 2 times.

    As for the encounter level, I have spent alot of time leveling up my character. Not doing the quests and going around killing everything. I ahvent even touched new reno, broken hills or vault 13. My character is a level 40 or so. lol

    Ryan
     
  12. Unkillable Cat

    Unkillable Cat Mildly Dipped

    562
    Jan 5, 2004
    It's right next to the well.
     
  13. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Ah, ok, then I apologize for those misunderstandings.

    As far as that Kaga counter is concerned, the game probably still assumes that it was a combat encounter that you saved, even though everyone was already killed. That game is lost, I'm afraid.

    As for the Gecko special encounter, I admit I went directly to the settlement, not the junkyard. I think the script assumes that you are going to the settlement instead of the junkyard, and that is why the error occurs. I will go through the script and make sure that the encounter happens correctly regardless of whether you attempt to go to the settlement or the junkyard. Thanks for telling me about this one.

    Edit: Nope. I played this through, and now I see what happens. If you enter the Gecko map, the guards are placed there. The problem is that it adds the guards regardless of what level you enter the map at, and you can only access it by going from the Settlement. So, if you go to the junkyard, it places the guards. And when you leave and then go to the settlement from the worldmap, it places the guards AGAIN. I imagine that this would happen each time you entered the junkyard first. I will tinker with the script to make sure that it activates only once, regardless of the map you enter first.
     
  14. Demonslayer

    Demonslayer Water Chip? Been There, Done That

    968
    Aug 8, 2005
    Always busy, heh MIB88?
    Didn't have much time for fallout lately (some months now) but when i have the time again, i'll come back to see the changes you've made. Bet they're plenty.

    Keep up the good work!

    Btw, just noticed you're from Illinois, now i know how to escape from a prison in that place :D
     
  15. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    No, Demonslayer, it never ends. :D

    In addition to the changes already noted in the readme files, here is the current list of changes so far for the next release:

    -Corrected a bug with the Doctor in the EPA... if you didn't accept one of his quests the first time, you would be unable to complete it later, regardless of your dialog choices
    -It is now possible to enter the storage sheds at the EPA (a scripting error prevented the player from getting the key)
    -Numerous spelling and dialog errors in EPA corrected
    -Patched holes in walls of EPA
    -corrected dialog error regarding gauss pistol with Eldridge
    -Voice from nowhere on level with Ardenius in Vault 14 has been fixed
    -Dangerous Dan Mcgrew no longer says you killed his people if you solved the bar brawl peacefully (actually, all of his responses were messed up and have now been fixed)
    -Klint's name is displayed correctly in combat when he wears advanced power armor
    -Corrected dialog errors regarding the Primitive Tribe
    -Correct Bessie dialog (contains new dialog/options from another mod)
    -Corrected dialog errors with Vault 14
    -Changed the amount of dynamite Megrew needs
    -Player receives positive karma for freeing slaves in random encounters
    -Corrected the bolt weapon that the player is able to use by removing the broken attack option
    -The blacksmith can make a new item. Guess what/who it can be used on/for...
    -Fixed mislabeled maps from save/load screens
    -Sentry Bot Skynet no longer forget combat settings
    -Rockets and 5mm ammo can be added to it (just 'use' them on Skynet)
    -Added a lootable Horrigan

    The other big things still in the works, though, are:
    -Trying to get the marriage to Davin and Miria to work right
    -Adding in Vault 5
    -Getting the final endings to play properly
    -Possible addition of a couple of Russian mods if translations get completed, such as the Colly/Sokil mod and elements of Alternative Life

    As for Prison Break, I never got into it. I hear it is really good, but I have enough television shows to watch without adding any more.
     
  16. Smoke_Jaguar

    Smoke_Jaguar Look, Ma! Two Heads!

    313
    Mar 23, 2006
    Damn, MIB is a nice guy. He works like a bot so we can play this game. Let's give it up for him!
     
  17. brago

    brago First time out of the vault

    3
    Mar 31, 2007
    Well said Smoke_Jaguar! Good on ya MIB88!
     
  18. hackenberg

    hackenberg Heading for Lost Vegas

    33
    Jul 1, 2004
    Voice Module Bug

    I am not sure if this is helpful information for the voice module but in V13, but I did buy the module at New Reno Arms before discovering V13. Is the quest coded on the assumption that the Chosen One shows up without the module in hand? I really prefer not to pop Goris to get the GECK.
     
  19. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    No, I am not a nice guy...always wanted to be one, though. :wink:
    However, I am afraid the real world might be pulling me back soon. Hopefully, anyway. If this happens, I will get one last update out by the middle of next month, hopefully with that big bug you mentioned (i.e. endings) complete. After that...well, it may be a while between large updates. I'll know more by the end of the month.

    @hackenberg: Irrelevant. The error is due to me placing a file in the wrong folder. Do a search for vault13.gam in this thread, and follow the directions. If you don't, your game will not work right...and a kitten somewhere will die.
     
  20. xf69fs

    xf69fs First time out of the vault

    14
    Mar 7, 2007
    Got another bug for you. The Salvadore gun stash mission. I lost my car when I went.

    And I thought it was fixed but going down the well in modoc, going off the map to the right goes to a black screen with the red squares and such. Like the Arroyo temple if you dont install it right.

    Ryan
     
Thread Status:
Not open for further replies.