MIB88 MegaMod - opinions, technical issues, etc.

Discussion in 'Fallout General Modding' started by Lil Mordino, Dec 19, 2005.

Thread Status:
Not open for further replies.
  1. stormcrow

    stormcrow First time out of the vault

    92
    Dec 16, 2006
    Did anyone find a way of resolving the Vault 13 Voice Module bug?
    I tried changing the aforementionned script fille oscomp (or something similar) with one from the master.dat on the CD, but no joy. Or have I missed something?

    I've seen several bugs but I think they've all been brought up (modoc maria/davin, missing forges, etc...). However I'm not sure I've seen the one about the dialogue at Navarro concerning the Vertibird plans. When you have to go pester the guy who has them, you're supposed to accuse Raul, but I had to accuse 'the other guy' which then get the guy started about Raul (simply put the Raul and other guy are inverted).

    Again for modoc, I must be missing something obvious, at the hut with Shawdupp and Gareth, how do I get down the ladder? (PM me if you'd want to avoid spoilers please).
     
  2. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    No Abbey quests have been incorporated yet...I have an idea for one, but not done. There are some fixes. Another Vault may be there as well as an updated Vault 14, and elements from Alternative Life.

    These item don't really exist except for Horrigan. No one has made them, so there are no pictures to bring up.

    There are lots of changes in store for the lootable armor aspect. Not the next version, but later you will not be able to get armor that people are wearing simply by killing them. A later version will take into account luck, repair/science skills, possible new perk/karmic titles, and also factor in how the critter was killed.

    I coded it originally to work only on the player. Your party members for now do not change appearance, but their stats change. However, this is an easy fix.

    Yes, you missed it. I addressed this. Delete the file vault13.gam in the maps folder.

    This was also brought up earlier. I took apart the relevant files, but could not find the problem. It is still on my list.
     
  3. Dude101

    Dude101 Vault Fossil
    Modder

    Aug 3, 2005
    You will kick your self for asking hehe. Will PM the answer.

    edit

    There is a gamplay help thread btw... its not realy a spolier, use the repair skill lol.
     
  4. stormcrow

    stormcrow First time out of the vault

    92
    Dec 16, 2006
    Thanks I think I even tried explosives... thanks for the tip MIB88
     
  5. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    I forgot to mention something Stormcrow:

    In order for that fix to work, you don't need to start over, but you do need to load a game you have that is from before you ever entered Vault 13.
     
  6. WarriorSoul

    WarriorSoul First time out of the vault

    3
    May 22, 2007
    Ah oh well. Missed that I guess! Cheers! haha
     
  7. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    But you read everything else, right? Whatever. Like Oracle pointed out, stuff like that (not reading/researching) doesn't make people anxious to want to help you. I probably won't do so again, anyway.
     
  8. rynie

    rynie First time out of the vault

    20
    May 18, 2007
    Re: Gratitude and question!

    Okay so nothing I can do but wait for the next release? When do you think its coming... no pressure I'm just wondering...

    Oh yea I encountered a minor snag in the EPA...
    *spoiler*

    When the lady hologram gives me the override code, I can initially use it for a few rooms but later my character seems to "forget" it because I don't get it as a choice when I encounter another locked room. And this happened to me twice, both times it wasn't particular rooms that always shut me out, its like the code has charges and once I use it some doors I can't use it any more on others.

    Anyway you can incorporate (or are there even?) mods that alter the landscape accordingly to the ending you get, so that after you finish you have something else to play... ie. the tribal family rising in new reno taking over and deserted towns -> too massive an undertaking?

    Also was anyone else able to get an army to follow them, because when I played 2.0, I got ALL possible NPCs to follow me (save for lenny), so I had 3 dogs, sulik, cassidy, vic, skynet, marcus, myron, klint = 10, a freaking ARMY... utterly destroyed everyone but appearing in small spaces made me crazy since I had to constantly push NPCs out of the way one by one :?

    Hey MIB88 if I can get some suitable artwork for the end boss gun and knife will you put it in?
     
  9. BooN

    BooN First time out of the vault

    1
    May 23, 2007
    rynie ... I've encountered the same problem with the safe.
    CAUTION SPOILER AHEAD:
    Fortunetly there is a way to go around it, dont remember if someone mentioned it earlier. The safe can be blown out by placing dynamite or c4 right under it. Or at least thats how I've delt with the problem, allowing my PC to continue the quests for the cold hearts.
     
  10. Eoz

    Eoz First time out of the vault

    23
    May 21, 2007
    Thanks for the insight. I went back and stepped on every hex just to be sure and it did it.

    And thanks again for your work, I won't stress it enough, your mod is a blessing for replay value. I have the feeling to play a whole new game :D
     
  11. heodien

    heodien It Wandered In From the Wastes

    154
    May 22, 2006
    MIB, i remanaged that Vault13.GAM file and my save files were corrupted (even the ones before i enter v13), then , when i put the archive back to the folder that it wasnt meant to be, the save games started to work again
     
  12. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    Thanks for the kind words everyone and for pointing out the bugs. Now, on to the work. Rynie's quote has been slightly modified to make it easier to answer:

    That doesn't make any sense to me. I mean, a lot of maps have a corresponding .gam file that tracks an extra set of variables. There already exists a vault13.gam file in the maps folder of the master. dat. The one that was in the Megamod 2.0 was the one that belonged in the data/data folder, the one containing ALL of the global variables. If that one is altered, then it does mess up previously saved games. Only the one in the maps folder needed to be deleted to force the game to use the original out of the master.dat.


    1. Look for a file in the data/text folder called modoct31.msg. Change it to rcsafe.msg.

    2. She doesn't give you a code for all the rooms. Try talking to someone else.

    3. Well, keep in mind that those endings you see are the result of your actions years later. When you destroy the oil rig it is like you just got back off the boat. That new world you helped to create hasn't happened yet, and assumes no more interference by the Chosen One in their affairs. You want a mod that takes place say, 10-20 years after Fallout 2. There aren't any completed ones...yet.

    4. Was there a question for me? You should have been able to get Lenny. Also, you didn't mention Goris. The only ones there is still a problem with are Miria and Davin.

    5. Artwork is only part of the problem. I would also need to have the stats for those weapons as well...stats that make sense and don't make those weapons obscenely powerful.
     
  13. stormcrow

    stormcrow First time out of the vault

    92
    Dec 16, 2006
    Ah well too late :( No repairing the Vault for me then, I'm too far ahead. Same for Modoc, I went back to the trapdoor but I had allready blown it up and repairing didnt work.
    Well at least I know what to do next time around ;)

    Or...
    Is it possible to solve my Vault13 and Modoc problems by getting a "working" copy of the map files?
     
  14. rynie

    rynie First time out of the vault

    20
    May 18, 2007
    Oh yea I had goris and miria too, I had 13 NPCs... but I couldn't do the same in the latest patch. Not a request or anything just a statement like my previous post was:shock:

    I noticed klint doesn't level up really, but rather as you get him armor his stats increase accordingly... maybe it was in the readme but I didn't read about klint... with advanced power armor he had 325 hps, 15 AP, 600+ carry load, and energy weapons...some tribal huh?

    About the EPA passcode situation --> I played through EPA twice because of the bug that wouldn't let the character get the 2nd doctor's quest if he refused it the first time (i know its getting fixed in next version, this bug was mentioned alr), the first time with the chick's passcode I could access certain rooms WHICH I could not the 2nd time I played through EPA hence I came to the conclusion of the passcode having "charges". i.e 1st time I went through rooms A, B, C and D, couldn't access E and F... 2nd time it was rooms B, E, F and couldn't go to C... the hero just doesn't have "abre" in his dialouge options when I went back to C...

    @Boon

    Thanks for the help I'll go and play finish those quests
     
  15. Misteryo

    Misteryo Still Mildly Glowing

    258
    Feb 15, 2007
    Re: Another way around safe in Redding problem

     
  16. ceptor

    ceptor First time out of the vault

    10
    Sep 1, 2006
    I have an old computer so in game worldmap is extremely slow and encounters are too frequent. What i need to do with original fallout2.exe v1.02 for make it work correctly with megamod? Or is there unslowed exe?
    Unable to change combat settings of Klint if he not wearing any armor - will this fixed?
     
  17. botia

    botia First time out of the vault

    14
    May 11, 2006
    MegaMod2.1.1 problem

    Hi, I'm sorry for asking, but I really don't know what I did wrong.
    I did a reinstall of fallout (to a system that has never had fallout installed, well on this copy of Windows anyway)
    I then continued to install the offical 1.02 patch
    And then to install the MegaMod 2.0
    Then 2.1
    And then 2.1.1

    At the first attempt, the game would not start at all, claiming something about missing cities. A restart of the system solved this.

    I then continued to play the game again, and I was "YAY" when the game loaded, and I even got into the game itself (and I noticed the mod was working) I then decided to save the game, which sounds great, but all I got was an "unable to save game error"

    I researched a bit, and I found this
    http://appdb.winehq.org/appview.php?iVersionId=319
    There is a note under "fanmade mods and patches, that unless the folders are correctly named, you will recieve the aforementioned error. I tried renaming the folders, and changing their permissions

    In the savegame folder (among others) a grayish check box appears on "read only" attribute. Upon clicking it, I recieve a dialog asking weather I want to apply the "non-read only" attribute to subfolders as well.
    No matter what I choose, no folder permissions are changed.

    Does this have anything to do with the problem I'm facing?
    I did rename the PATCH000 something
    And I tried both, the f2 exe from the patch, mod and the original

    Oh, to any mods who have their ban finger itching, I did try searching the forum, with little or no usable results. Also, 4 or 5 times I recieved strange errors from the search function. One was "Database has gone away" and the other time I got 20 pages of incomprehensible gibberish. A couple times it was OK.
     
  18. stormcrow

    stormcrow First time out of the vault

    92
    Dec 16, 2006
    Did you replace the fallout2.exe in the root by the one in data? (the one in data is the patched one).

    The only folder you need to set to read only is "proto".
     
  19. Markus#

    Markus# It Wandered In From the Wastes

    146
    Nov 9, 2005
    umm.. i got one big broblem with this mod pack.. I can't use any sort type rifle.. only melee and pistols.. :[
     
  20. MIB88

    MIB88 So Old I'm Losing Radiation Signs
    Modder

    Feb 22, 2005
    @ceptor: If you are using a really old computer, then follow these instructions:

    1. Add all items from Megamod 2.0, then 2.1, then 2.1.1 except the .exe file.
    2. Download the city limit patch from this site. Run that patch on your .exe file.

    That's it. The speed should be normal for you. If you still feel that you are getting too many encounters, then:

    1. open up the worldmap.txt file in your data/data folder.
    2. lower the percentages of the frequent, common, uncommon, and rare (I can't tell you what to, just whatever you feel comfortable with)


    Well, I can tell you a number of things you did wrong.

    1. This mod already has the 1.02 patch in it. When you install Fallout 2, don't patch it.
    2. The first time you didn't have the .exe file from the mod in your game folder, but only the original one.
    3. That research you did applies to the windowed mode for this game. Ignore that stuff.
    4. Related to the above, since that is like another patcher, don't use it. The Megamod works fine by itself. You try adding other mods or patches to it, I don't want to hear about it if it doesn't work.
    5. Don't mess with the savegame folder.
    6. Make sure you have all the folders in the right place. Your data folder should have a number of folders: maps, text, data, etc. If you see a folder that has the name of this mod (either MIB88 or megamod or something like that) and it has similar contents inside, take those files out and put them in the main data folder, overwriting the previous contents.

    The next two are notes that I have written into the next readme file that is taken from this thread as helpful hints.
    7. If you are using Winrar, when you check your proto files to see if they are read only, they will say read only. Don't believe them. Uncheck all the read only boxes. Then, check them again.
    8. You should not have any files in any folder that were modified after any other file from the Megamod. Another thing to check is their read-only status. I keep all necessary files on read only. If I see a file and I don't remember if I had intentionally modified it or not, I check this. If it is not read only, I assume it was made by the game and then delete it.

    So, just start over, following the above.

    @Marcus: There is nothing wrong with the weapons. Either you botched something during installation and are getting this weird side effect or your strength isn't high enough.
     
Thread Status:
Not open for further replies.