Noob in need of advice with scripting

Discussion in 'Fallout General Modding' started by WolfWitness, Sep 3, 2010.

  1. WolfWitness

    WolfWitness First time out of the vault

    27
    Jul 20, 2009
    I've been trying my hand at editing NPC scripts and for some reason everytime I try to compile I get:


    TEMP.I(205): Error! Undefined symbol op_party_member_obj
    FSE info --> Compiler reports unknown command or character.

    I tried fixing it until out of curiosity I compile a script I just decompiled without touching it at all and found the same error shows up.

    Can anyone help me out?
     
  2. Ravager69

    Ravager69 Sonny, I Watched the Vault Bein' Built!

    Dec 21, 2007
    There is a lot of redundant stuff in decompiled scripts. If you have the mapper installed, compare the original scripts provided with it with the decompiled one and remove the stuff that ain't in the original or is not added by you (like the Checkpartymembersneardoor procedure etc.). Also, you need to include headers that were there originaly. I advise you to equip yourself with FSE newest version, it can open scripts in .ssl and has a compiler. With it you can use the scripts from the Mapper, add some of your own stuff and if you wrote your procedures right, you won't have to worry about compiling.