[Technical] USB Pen Drive "Security Device" proble

Discussion in 'General Discussion Forum' started by DarkUnderlord, Jan 25, 2004.

  1. DarkUnderlord

    DarkUnderlord Water Chip? Been There, Done That

    Apr 6, 2003
    Here are the facts™ :
    1. Bought a 256 MB USB Pen Drive. Called a "Tiny Disk" on the packaging. Using it between a Win 98 SE and a WinXP Home machine. Worked PERFECTLY.
    2. I was copying data off of the disk today onto the HDD of Win98 when the computer crashed. Froze, probably because of all the shit I had open at the time. I waited a while, nothing came back, so I rebooted.
    3. Windows re-started fine and said it had found new hardware. I had the USB Drive still plugged in (I found that for Win98 to recognise it, I had to have it plugged in when I switch on). However, instead of saying found new hardware "USB Mass Storage Device" which is how it's supposed to recognise it, it instead is recognised as a "Security Device" and wants to look for drivers.
    4. Driver CD has no drivers for a "security device". There is a security feature on the disk, allowing me to password protect an area, but to put it simply, the computer should recognise the device as a "USB Mass Storage" and NOT as a "Security Device".
    5. The same problem now occurs when plugging the device into my WinXP machine, indicating the problem is something that's happened to the disk, not the machine.
    6. The manual has no troubleshooting section for this type of error and google has turned up nothing.
    7. There are no manufacturers markings anywhere giving the name of the manufacturer. In the manual on the CD, on the disk itself, in packaging saying who actually manufactured it. Even the legal mumbo jumbo EULA stuff is "the manufacturer takes no" etc... There is just no name anywhere giving the name of the company who made it. IE: No-one to e-mail.
    8. Obviously, I'd like my disk to work and before I take it back to the place of purchase, I was wondering (hoping) if anyone here could help.
    Suggestions?
     
  2. Myrrdin

    Myrrdin Still Mildly Glowing

    Jan 23, 2004
    Hmm... Have you tried installing it manually (with add/remove hardware)? It rarely works with USB devices but I once got a shitty USB joystick to work like that. Never hurts to try anyway...
     
  3. DarkUnderlord

    DarkUnderlord Water Chip? Been There, Done That

    Apr 6, 2003
    Yar. Even through Add/Remove hardware it comes up as a "Security Device" and because of such won't let me install drivers for a "Mass Storage Device" to it.