UP and RP updates

Discussion in 'Fallout General Modding' started by burn, Jul 9, 2019.

  1. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    49
    Nov 8, 2019

    Kinda fucked up i killed kaga on the 2nd encounter
     
  2. Lexx

    Lexx Background Radiant
    Moderator Modder

    Apr 24, 2005
    Sounds like changes that don't require a new game. Updating the files should be fine I guess.
     
  3. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    49
    Nov 8, 2019
    Backing up just in case, everytime i mess with anything i always end up getting an error one way or another.

    Also, i still can't gain access to the vertibird at navarro, i mean the scripts and text are THERE in the data folder but i cant gain access to it, no hand icon nor does the air traffic control terminal work, burn could you address this issue in the next update please.

    Unless this is an issue with RP itself and this is a common bug?
     
  4. scratch42069

    scratch42069 First time out of the vault

    11
    Apr 11, 2010
    I tried out v9 and there was no music in game. Other sounds seemed to work but no music. I solved it by going into the backup\rpu\ directory and copied and pasted the music .acm files back into data\sounds\music.
     
  5. Cerebro

    Cerebro First time out of the vault

    89
    May 6, 2007
  6. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    49
    Nov 8, 2019
    Just backup everything, install the mod then the fixes and see
     
  7. FalloutBruhMoments

    FalloutBruhMoments First time out of the vault

    49
    Nov 8, 2019
    Again, F2SE isnt compatible with this mod, idk what the fuck i did last time to make it work but now it's not working after the update
     
  8. neptunehs

    neptunehs First time out of the vault

    6
    Nov 1, 2019
    I met game crushed when attacking turret in Navarro,just use RPU V9 and no other mods.What did I do wrong?
     
  9. burn

    burn Mildly Dipped
    Modder

    537
    Apr 22, 2012
    Maybe I should state this one more time, with all clarity:
    This topic is not monitored. Please report bugs to the corresponding github repos: UPU, RPU. The instruction is in the readme.
     
  10. Magnus

    Magnus Water Chip? Been There, Done That
    Modder

    953
    Dec 6, 2007
    Hello all. I'm really looking forward to trying these out, but I'm hesitant because apparently there are a lot of issues with it. Has anyone been able to play it with no problems?

    My plan:
    Install Fallout 2 from steam.
    Install RP 2.3.3, installer version.
    Install this.
    Possibly update sfall and fiddle with ddraw.ini.
    Install F2WR on top.

    Any suggestions?
     
  11. Lexx

    Lexx Background Radiant
    Moderator Modder

    Apr 24, 2005
    I'm pretty sure you don't have to install the old RP files.
     
  12. Arathos

    Arathos First time out of the vault

    47
    Feb 2, 2017
    Is the UP update included in the RP update (as was the original UP included in the original RP)?

    Or should the UP update be installed on top of the RP update?
     
  13. Dux

    Dux First time out of the vault

    53
    Feb 3, 2009
    Can we sticky this topic? I feel like people don't know that reporting bugs for these two gems is not in vain.

    I know burn wants the bug reports to be on github, I am just thinking about how to let people know somehow that they can actually report them and I thought stickying this might bring up the attention.
     
    • [Rad] [Rad] x 1
  14. laclongquan

    laclongquan Boned Hunter of Sister

    422
    Jan 11, 2008
    @burn Recommend a Quest editting: Vault Village in Restoration Project

    Vault village seems to be accessible only AFTER you return from NCR (recon the route from VC to NCR).

    In which case, its xp is a bit out of sync with a post-NCR character. Too little, too late. And 4 Assault Rifle + 1 shotgun would be easy to acquire due to hoarding from that long trip. Let alone its character, JOE, at that time would be, almost always, out on the tomblike field patch instead of inside Cassidy bar (since we most likely acquire that char and close the bar already). Also, its location make it a bit too silly. VC-VV-GECKO

    If it's accessible from start, it would be more useful.

    MOST logically placed would be right after GECKO recon quest, since Vault Village is between GECKO and VC. EVERYTHING would be solved by push it earlier.
     
  15. Yulaw9460

    Yulaw9460 First time out of the vault

    6
    Jun 7, 2018
    Right. I have a completely new and clean Steam installation. I don't need the original 2.2.3. RP installed to use this, right? I don't know if I'm the only one who finds the installation instructions woefully lacking.

    Also, my antivirus had a seizure, when I tried installing UP update.
     
  16. Zorchar

    Zorchar It Wandered In From the Wastes

    108
    Jun 18, 2018
    Just figured out the same..

    I want to tweak YAAM a bit.

    1. I want to bring back DR modifier to the ammo proto, and take out the AC modifer. (so to have DR and DT modifiable in protos). Can someone tell me how?
    EDIT: I think the AC modifier is redundant, especially if u added the DT modifier. This is because the AC armor modifier was included to simulate the deflection of bullets (metal armor doesn't make u be more agile so u can avoid bullets, right?) so adding DT modifier should do(the deflecting capabilities of the armor is represented by DT). Meanwhile, I think DR should be effected by bullet type(a leather armor decreases the energy of a 9mm parabellum much much more than a full 7.62x51 AP rifle round, isn't it?)

    2. I would like to change the damage calculation, but I don't know where this code resides(and which app to use to edit it). How can I reach this code and edit it?

    Please help out.
    Thanks
     
    Last edited: May 26, 2020